unRAID 6 NerdPack - CLI tools (iftop, iotop, screen, kbd, etc.)


jonp

1590 posts in this topic Last Reply

Recommended Posts

Post up your diagnostics file after you select the additional packages to install to ON and click Apply via the NerdPack User Preferences Settings page.

 

In the Syslog you should see something like this when there are no issues:

 

Jan 21 19:02:22 --- emhttp: cmd: /usr/local/emhttp/plugins/NerdPack/scripts/packagemanager --download
Jan 21 19:02:22 --- nerdpack: Processing Packages...
Jan 21 19:02:22 --- nerdpack: cpio-2.12 package up to date, checksum ok.
Jan 21 19:02:22 --- nerdpack: git-2.9.0 package up to date, checksum ok.
Jan 21 19:02:22 --- nerdpack: iftop-1.0pre2 package up to date, checksum ok.
Jan 21 19:02:22 --- nerdpack: inotify-tools-3.14 package up to date, checksum ok.
Jan 21 19:02:23 --- nerdpack: p7zip-16.02 package up to date, checksum ok.
Jan 21 19:02:23 --- nerdpack: screen-4.4.0 package up to date, checksum ok.
Jan 21 19:02:23 --- nerdpack: unrar-5.4.2 package up to date, checksum ok.
Jan 21 19:02:23 --- nerdpack: utempter-1.1.6 package up to date, checksum ok.
Jan 21 19:02:23 --- nerdpack: vim-7.4.1938 package up to date, checksum ok.
Jan 21 19:02:23 --- nerdpack: All packages processed...

Link to post
  • Replies 1.6k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

From discussion that start in this thread, we decided to create a simple plugin that installs a set of additional command line tools onto your unRAID server.   WARNING:  These tools are for

Lol, are we going to petition the willy wonka company to change the name of their candy too?  I guess its not a big deal to change the name, I just have to laugh at the thought of someone honestly bei

I had the same issue... re-linking/aliasing to the existing libraries (libssl.so.1.1 and libcrypto.so.1.1) fixed the issue. A simple `ls -la` helped me figure out what libraries I had... root@Towe

Posted Images

Post up your diagnostics file after you select the additional packages to install to ON and click Apply via the NerdPack User Preferences Settings page.

 

In the Syslog you should see something like this when there are no issues:

 

 

Sadly nothing is posted in the syslog when I do that, it's like it never happened  :-\

Just some earlier unrelated chatter from the network adapter.

 

Seems like the web gui is just an empty shell, unable to interact with the system.

 

Edit:

Here is the syslog from the latest install of NerdPack. ... Not sure what tablesorter is?

 

Jan 21 23:21:41 --- emhttp: cmd: /usr/local/emhttp/plugins/dynamix.plugin.manager/scripts/plugin install https://raw.githubusercontent.com/dmacias72/unRAID-plugins/master/plugins/NerdPack.plg
Jan 21 23:21:41 --- root: plugin: skipping: /boot/config/plugins/tablesorter/tablesorter-2.27.6-x86_64-1.txz already exists
Jan 21 23:21:41 --- root: plugin: running: /boot/config/plugins/tablesorter/tablesorter-2.27.6-x86_64-1.txz
Jan 21 23:21:41 --- root: plugin: creating: /boot/config/plugins/NerdPack/NerdPack.cfg - from INLINE content
Jan 21 23:21:41 --- root: plugin: creating: /boot/config/plugins/NerdPack/NerdPack-2016.10.20-x86_64-1.txz - downloading from URL https://raw.githubusercontent.com/dmacias72/unRAID-plugins/master/archive/NerdPack-2016.10.20-x86_64-1.txz
Jan 21 23:21:42 --- root: plugin: creating: /boot/config/plugins/NerdPack/NerdPack-2016.10.20-x86_64-1.md5 - downloading from URL https://raw.githubusercontent.com/dmacias72/unRAID-plugins/master/archive/NerdPack-2016.10.20-x86_64-1.md5
Jan 21 23:21:42 --- root: plugin: running: anonymous
Jan 21 23:21:42 --- nerdpack: Processing Packages...
Jan 21 23:21:42 --- nerdpack: All packages processed...

 

Edit 2:

 

SOLVED

Tabelsorter seemed to be the problem, removed NerdPack and deleted the tabelsorter files. Reinstalled NerdPack and now it works, thanks ;D

Link to post

Post up your diagnostics file after you select the additional packages to install to ON and click Apply via the NerdPack User Preferences Settings page.

 

In the Syslog you should see something like this when there are no issues:

 

 

Sadly nothing is posted in the syslog when I do that, it's like it never happened  :-\

Just some earlier unrelated chatter from the network adapter.

 

Seems like the web gui is just an empty shell, unable to interact with the system.

 

Edit:

Here is the syslog from the latest install of NerdPack. ... Not sure what tablesorter is?

 

Jan 21 23:21:41 --- emhttp: cmd: /usr/local/emhttp/plugins/dynamix.plugin.manager/scripts/plugin install https://raw.githubusercontent.com/dmacias72/unRAID-plugins/master/plugins/NerdPack.plg
Jan 21 23:21:41 --- root: plugin: skipping: /boot/config/plugins/tablesorter/tablesorter-2.27.6-x86_64-1.txz already exists
Jan 21 23:21:41 --- root: plugin: running: /boot/config/plugins/tablesorter/tablesorter-2.27.6-x86_64-1.txz
Jan 21 23:21:41 --- root: plugin: creating: /boot/config/plugins/NerdPack/NerdPack.cfg - from INLINE content
Jan 21 23:21:41 --- root: plugin: creating: /boot/config/plugins/NerdPack/NerdPack-2016.10.20-x86_64-1.txz - downloading from URL https://raw.githubusercontent.com/dmacias72/unRAID-plugins/master/archive/NerdPack-2016.10.20-x86_64-1.txz
Jan 21 23:21:42 --- root: plugin: creating: /boot/config/plugins/NerdPack/NerdPack-2016.10.20-x86_64-1.md5 - downloading from URL https://raw.githubusercontent.com/dmacias72/unRAID-plugins/master/archive/NerdPack-2016.10.20-x86_64-1.md5
Jan 21 23:21:42 --- root: plugin: running: anonymous
Jan 21 23:21:42 --- nerdpack: Processing Packages...
Jan 21 23:21:42 --- nerdpack: All packages processed...

 

Edit 2:

 

SOLVED

Tabelsorter seemed to be the problem, removed NerdPack and deleted the tabelsorter files. Reinstalled NerdPack and now it works, thanks ;D

Tablesorter is  an updated version of the built in tablesorter that I use for some of my plugins. It has filtering, paging, sort saving and other widgets. I would be interested to know why it was corrupted on the initial install. Do you still have the logs from that? Look for "plugin: checking:" for tablesorter. The unRAID plugin installer is supposed to check the MD5 and delete a bad download.

Link to post

Interesting... I could never figure out how to get my plugins that needed inotifytools to have the NerdPack register that mine was using it.

 

I just search plg files for package name and version with this command

cd /boot/config/plugins ; find *.plg | xargs grep '${pkg_name}-${pkg_version}' -sl

Ah...  I don't include the package in the .plg file to purposely avoid dependency hell so your plugin is forced to install it.  But then you don't notice that I require it.

I didn't think of this before but if you want Nerdpack to see your plugin as using a certain package, you could just include the package name and version like "python-2.7.13" in comments or change log somewhere.

Link to post

Is anyone else having any issues loading the NerdPack plugin? I get the attached screenshot and have all day. Multiple different browsers and I rebooted the server. I'm able to download the packages from the github, but I'm not very familiar with Slackware and I am unable to manually install the screen package. The NerdPack plugin worked for me a few days ago and I was able to install Perl from within it. I also tried removing and reinstalling the plugin multiple times, but that did not help either. Are there any logs that I can look at it to see what is going on?

 

EDIT: It is now working. Not sure what happened, but it is loading quickly now!

NerdPack.png.78d19551c062a8dbeb23881ff973c4d2.png

Link to post

Hi,

quick question - hopefully easy answer!

 

There seem to be old/previous OS variants of NerdPack files under

/boot/config/plugins/NerdPack/packages

 

i.e. 6.1, 6.2

(am now running 6.3 and there is also a 6.3 subdir present)

 

Can I delete the 6.1 and 6.2 folders now? It's about 244MB on my flash drive.

Does that have to be (should it be) done manually?

Any reason it isn't automagically cleaned up on upgrade? Or just for safety?

 

Thanks in advance

Link to post

How can I download updates?

 

kAw7gAQ.jpg

 

It shows that an update is available to the package, but clicking the download symbol doesn't do anything.

 

 

 

Also, there's a typo in the support thread link in "plugins" page. http// isn't a valid address. Missing the colon.

 

AdTlish.jpg

Link to post

How can I download updates?

 

kAw7gAQ.jpg

 

It shows that an update is available to the package, but clicking the download symbol doesn't do anything.

 

 

 

Also, there's a typo in the support thread link in "plugins" page. http// isn't a valid address. Missing the colon.

 

AdTlish.jpg

Thanks for pointing out the typo. Just click apply and the package should update.

Link to post

Thanks for pointing out the typo. Just click apply and the package should update.

Didn't work. The popup window showed "Installing bind-9.9.9.8_P4" but Nerd Pack still shows "update ready".

You still on 6.1.9? The underscore is the problem. You'll need to deselect the package turn on delete then click apply. Then check for updates. I changed the package name. Then select and apply. You may have to manually remove the package from /boot/config/plugins/NerdPack/packages/6.1

Link to post

Hi since upgrading to 6.3.0 and updating to the latest version of vim i am now getting this error

 

vim: error while loading shared libraries: libtinfo.so.6: cannot open shared object file: No such file or directory

 

wondering if this can be looked at.

Sorry. The newer vim requires ncurses 6.0 and unRAID comes with 5.9. I rolled it back to 7.4. I also added the defaults.vim.

 

Link to post

Hi since upgrading to 6.3.0 and updating to the latest version of vim i am now getting this error

 

vim: error while loading shared libraries: libtinfo.so.6: cannot open shared object file: No such file or directory

 

wondering if this can be looked at.

Sorry. The newer vim requires ncurses 6.0 and unRAID comes with 5.9. I rolled it back to 7.4. I also added the defaults.vim.

 

Thats ok thanks for fixing it :)

Link to post

Getting "inotify-tools set to install" as a warning, but NerdPack removed it from their plugin so it can't even be uninstalled anymore.

It's included with 6.3. If you toggle a package on/off and click apply it should remove it from your config.

Link to post

Getting "inotify-tools set to install" as a warning, but NerdPack removed it from their plugin so it can't even be uninstalled anymore.

It's included with 6.3. If you toggle a package on/off and click apply it should remove it from your config.

 

Toggle it on and off from NerdPack plugin? Check the picture links below. inotify is nowhere to be found in the list.

 

http://i.imgur.com/LXL8OIs.png

 

http://i.imgur.com/44WYul1.png

Just toggle any package on/off so the Apply button is not disabled. Then click apply. In the config file the package settings are saved by package-version. The plugin rebuilds the config file every time to get rid of older versions. This should get rid of inotify from the config.

 

I'll add a fix to the plg file to remove inotify from the config on 6.3 installs or at least set it to no.

 

Link to post

 

 

Great plugin--beats having to install all these slackpacks myself!

 

Say, any chance you could include the Lynx text-based browser? Talk about a nerd-only package.

 

Thanks again!

 

I added Lynx text based browser. I tried a couple others but they would require a bunch of other packages.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.