Jump to content
Squid

[Plug-In] Community Applications

2666 posts in this topic Last Reply

Recommended Posts

12 minutes ago, dan15711111 said:

Never had any strange DNS issues.

But on a different note though, on a second glance, it does appear to be downloading a second file fine (the last-updated.json file).  Would have to tear through the code though to confirm.

 

Check for updates and install today's CA release.  I increased the timeout.  If that still doesn't get you anywhere, then as the fail safe, download https://github.com/Squidly271/AppFeed/raw/master/applicationFeed.json and save it on the flash drive /config/plugins/community.applications/applicationFeed.json

 

19 minutes ago, dan15711111 said:

I live in Phoenix Arizona

 

Share this post


Link to post
17 minutes ago, Squid said:

But on a different note though, on a second glance, it does appear to be downloading a second file fine (the last-updated.json file).  Would have to tear through the code though to confirm.

 

Check for updates and install today's CA release.  I increased the timeout.  If that still doesn't get you anywhere, then as the fail safe, download https://github.com/Squidly271/AppFeed/raw/master/applicationFeed.json and save it on the flash drive /config/plugins/community.applications/applicationFeed.json

 

 

Ok so updating the Plugin did nothing.  But transferring over the json from the link you provided worked!  I wonder if it will stay working or fail soon?!  Anyway I owe you a beer!  You are shiz! Thank you so much!

Share this post


Link to post
2 hours ago, dan15711111 said:
Ok so updating the Plugin did nothing.  But transferring over the json from the link you provided worked!  I wonder if it will stay working or fail soon?!  Anyway I owe you a beer!  You are shiz! Thank you so much!

The file will keep it working forever you'll know if the downloads are working if under statistics the last updated time changes from that of the file (Dec 9 @ 7pm - at the time of writing)

Sent via telekinesis
 

Edited by Squid

Share this post


Link to post
On 8/28/2018 at 4:36 PM, Barafu said:

Congrats! You are banned in Russia. tools.linuxserver.io refuses to open without proxy. 

 

On 5/26/2016 at 7:29 AM, tr0910 said:

Hey Squid, do you know that your Community Applications doesn't work in China.

 

It won't populate the list.  Keeps searching and finding nothing.

 

Google is blocked in China.  Is that possibly what is wrong?

If you guys are still having problems with this, look up a couple of posts https://forums.unraid.net/topic/38582-plug-in-community-applications/?page=95&tab=comments#comment-703666

 

Edited by Squid

Share this post


Link to post

image.png.ad50e9a412a93eaab9a3bd2650f2ab0a.png

 

Only real change on this release is that there is now a backup application feed server running (thank you @limetech @eschultz @jonp

In the event that the primary server cannot be reached, the feed will download instead from the secondary server, and failing that a USB stored feed (if present - ask for details) will be utilized instead. 

 

Oh yeah, happy ho-ho. 

image.png.563b66519afefecfb804bdf43bddfaf6.png

Edited by Squid

Share this post


Link to post

Can you add my repository to the Community Applications?

 

https://github.com/dersimn/docker-unraid-templates

Share this post


Link to post

Curious why I am getting this error?  I am in Japan.

 

 

 

plugin: updating: community.applications.plg


Cleaning Up Old Versions


plugin: downloading: https://raw.github.com/Squidly271/community.applications/master/archive/community.applications-2018.12.22-x86_64-1.txz ... failed (Generic error)
plugin: wget: https://raw.github.com/Squidly271/community.applications/master/archive/community.applications-2018.12.22-x86_64-1.txz download failure (Generic error)

Edited by nerbonne

Share this post


Link to post

Sounds like a DNS / gateway error on your network and/or your router/modem needs to be reset.

Share this post


Link to post

I rebooted the router, didn't help.  I can download the file by pasting the link in a browser on my windows PC that is on the same network.  Is there something in unRaid i can test?

Share this post


Link to post
53 minutes ago, nerbonne said:

I rebooted the router, didn't help.  I can download the file by pasting the link in a browser on my windows PC that is on the same network.  Is there something in unRaid i can test?

Can you ping github from your server?

Share this post


Link to post

root@Tower:~# ping -c 3 github.com
PING github.com (192.30.255.113) 56(84) bytes of data.
64 bytes from lb-192-30-255-113-sea.github.com (192.30.255.113): icmp_seq=1 ttl=50 time=136 ms
64 bytes from lb-192-30-255-113-sea.github.com (192.30.255.113): icmp_seq=2 ttl=50 time=135 ms
64 bytes from lb-192-30-255-113-sea.github.com (192.30.255.113): icmp_seq=3 ttl=50 time=133 ms

--- github.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 133.419/135.239/136.578/1.333 ms

 

 

 

Dynamix active streams also fails to update today with the following error:

 

 

plugin: updating: dynamix.active.streams.plg
plugin: run failed: /bin/bash retval: 1

Share this post


Link to post

 

Dec 16 01:42:58 Tower kernel: FAT-fs (sda): error, fat_free_clusters: deleting FAT entry beyond EOF
Dec 16 01:42:58 Tower kernel: FAT-fs (sda): Filesystem has been set read-only

Powerdown, toss the flash drive into a baremetal box and run the filesystem checks on it.

Share this post


Link to post

Quick comment if you're having CA add in a container from the "wild" (docker hub searches).  A few weeks ago the repository pages on dockerHub underwent a subtle (to the user), but drastic change (to CA).  This change now makes it impossible for CA to automatically scrape the dockerHub page for the dockerfile for it to convert to a template for CA.  The change at dockerHub was probably because some programmer got bored and decided to annoy me.

 

I've experimented with various ways to work around this (things like opening an iframe to the page, and having the user copy / paste the dockerfile, etc), but they all wind up being very awkward for the user.  The one approach which I think will work I am not comfortable having CA implement, as it would involve within the Apps tab having it silently execute all of the scripts and code present within the dockerHub page.  (Not a very good idea, security wise)

 

Net result is that going forward all CA conversions from dockerHub will result in basically a blank template being generated and you will have to manually add to the template any applicable volume and path mappings along with the environment variables.

 

Note that this only affects dockerHub searches.  Any template present in CA will always be populated correctly. 

 

For template maintainers, this change at dockerHub also means that the pop-ups on their templates will no longer have the "Base OS" entry.  If you wish to have the Base OS populated on the popup, add in <BaseImage> to the template.

Edited by Squid

Share this post


Link to post

Looks like the thumb drive was going bad.  I plugged it into my Win 10 box, repaired it, but it still had issues when I booted it.  So i backed up the config directory and made a new thumb, restored the config directory and re-downloaded my license key.  Plugins update now.  Thanks so much for your support.

Share this post


Link to post
Posted (edited)

zzz...

 

I added this plugin repo to my install 6.6.6 and now the GUI is broken from a browser  "this site can't be reached" and the console outputs 

 

Tower login: /etc/rc.d/rc.docker: line 30 /boot/config/docker.cfg: Input/output error

/etc/rc.d/rc.libvirt: line 16: /boot/config/domain.cfg: Input/output error

 

Any ideas aside from reinstall unRAID onto the USB?

Edited by dajinn

Share this post


Link to post

Nothing to do with CA at all.  Based on the error, it does appear that you have corruption on the flash drive, or it dropped offline.  I would try the stick in another port, ideally USB2

Share this post


Link to post

Hello.

 

I recently moved my server from Mexico to the US and am having some issues with CA. I get the "Download of appfeed failed" error.  I never had that before.  New ISP and new router...  I am running Unraid 6.4.0.

 

Actually my problem started with Binhex deluge not working when using my vpn (worked in Mexico).  It worked without the VPN  and after much troubleshooting, I decided to try to delete and reload the app.  So, I deleted the app and went to re-install and that is when I discovered CA not working.

 

I set my DNS address to 8.8.8.8 and 8.8.4.4 with no success in solving the problem.  I have rebooted my modem and router.  

 

Thanks in advance for your help!

Share this post


Link to post
14 minutes ago, hoosierdaddy said:

I am running Unraid 6.4.0.

Out-of-date Unraid plus out-of-date plugins is the likely cause.

Share this post


Link to post

I forgot to update the gateway in network settings on my new router.  I found the solution from Squid on another post.  Thanks Squid!

Share this post


Link to post

Having issues trying to download openvpn as in community applications.  There is no download button, just a donate button.  Ive update the community applications plugin to 2019.01.24 and it says its up to date.

openvpn.png

Share this post


Link to post
1 minute ago, icemounty said:

Having issues trying to download openvpn as in community applications.  There is no download button, just a donate button.  Ive update the community applications plugin to 2019.01.24 and it says its up to date.

openvpn.png

Is there a little red note at the top of all the screens saying "docker isn't enabled?"

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.