Upgrading unRaid-5 to unRaid-6


166 posts in this topic Last Reply

Recommended Posts

I upgraded from 5.0.5 straight to 6.1.9 on Sunday. I did it by shutting my server down, backing up the config off the stick, formatting and putting a fresh 6.1.9 on, then copying back my key and config files.

 

It's worked fine so far. With one exception, needing to add sec=sys to my NFS RW exports.

Link to post
  • Replies 165
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

Just upgraded from v5.0.5 to 6.1.9 via 'method 1' and it went like a dream, nothing untoward as yet  :)

 

Now i've got to work out how to get my five disks (3x6TB, 2x4TB) converted from reiserfs to xfs.

 

Fortunately i've got one spare slot with an 8TB drive now pre-clearing (thanks gfjardim!) nicely!

Link to post
  • 3 months later...

Hello

 

Today I tried to upgrade from 5.0 final to latest 6.x (downloaded plg plugin fråm http://lime-technology.com/forum/index.php?topic=41061.0) by method #2. Did two reboots of my Unraid and then it gives me an error message:

 

Error: No configuuration file found

No DEFAULT or UI configuration directive found!

 

Where should I begin looking? Havent done much troubleshooting on Unraid...

 

Regards Jens

Link to post

Hello

 

Today I tried to upgrade from 5.0 final to 6.0.3 by method #2. Did two reboots of my Unraid and then it gives me an error message:

 

Error: No configuuration file found

No DEFAULT or UI configuration directive found!

 

Where should I begin looking? Havent done much troubleshooting on Unraid...

 

Regards Jens

Might have to run makebootable on the flash drive.

 

Where did you get 6.0.3?  The Latest version is 6.1.9

Link to post

Hello!

 

OK, will look into the USB then.

 

Sorry for the typo, I wasnt completely aware of the version number of the Unraid. Downloaded the PLG as described above in my modified post.

 

Regards Jens

 

Describe what is happening as you go through the boot process.  Are you seeing the boot choices screen and the notice that you are unpacking(?) bzimage and bzroot?

 

If it is getting that far, you might want to run chkdsk on your flash drive.

 

Link to post

Hello

 

 

I tried the make_bootable_mac on my MacBook. But got some error messages:

 

cp: /Volumes/UNRAID/syslinux/*: No such file or directory

To continue please enter your admin Password:

sudo: /tmp/UNRAID/syslinux/make_bootable_mac.sh: command not found

 

Leaving me with even more questions... Why isnt it working?

 

Regards Jens

Link to post

 

Describe what is happening as you go through the boot process.  Are you seeing the boot choices screen and the notice that you are unpacking(?) bzimage and bzroot?

 

If it is getting that far, you might want to run chkdsk on your flash drive.

 

1. Computer boots showing bios alternatives (F2 & F10)

2. Computer shows the following message

SYSLINUX 4.03 2010-10-22 EED Copyright © 1994-2010 H. Peter Anvin et al

Error: No configuration file found

No DEFAULT or UI configuration directive found!

boot:

 

Regards Jens

Link to post

 

Describe what is happening as you go through the boot process.  Are you seeing the boot choices screen and the notice that you are unpacking(?) bzimage and bzroot?

 

If it is getting that far, you might want to run chkdsk on your flash drive.

 

1. Computer boots showing bios alternatives (F2 & F10)

2. Computer shows the following message

SYSLINUX 4.03 2010-10-22 EED Copyright © 1994-2010 H. Peter Anvin et al

Error: No configuration file found

No DEFAULT or UI configuration directive found!

boot:

 

Regards Jens

 

IF no one else jumps in you may want to go to this WIKI:

 

        http://lime-technology.com/wiki/index.php/Upgrading_to_UnRAID_v6

 

Be sure to make a backup of your flash drive BEFORE you go any further!!!!!!!  (Hopefully, you also followed LimeTech instructions to make a backup of your flash drive before you started.)

 

There are some trouble shooting hints for the plugin in the third paragraph and you might find some help there.

 

However, I suspect that you might be better served to reformat you flash drive and do an new install of unRAID 6.1.9.  There are instructions on which configuration files you should copy over from the backup that Limetech recommended  However, you will have to look for them if you have to use that backup that I told you to make since the plugin moved things around.   

Link to post
  • 2 weeks later...

I've followed the procedure today on my unraid 5.05 config,but it doesn't seem to work.

I get a problem with the vallidation of the certificate.

In short this is the error message I get after using the wget cmd.:

 

'WARNING cannot verify raw.githubusercontent.com certificate and afterwards I get a HTTP 400 bad request.'"

 

The manual download of the unRAISserver.plg didn't help either. Rebooting the server doesn't result in downloading unraid v6.

 

??

 

 

 

 

 

 

Link to post

I've followed the procedure today on my unraid 5.05 config,but it doesn't seem to work.

I get a problem with the vallidation of the certificate.

In short this is the error message I get after using the wget cmd.:

 

'WARNING cannot verify raw.githubusercontent.com certificate and afterwards I get a HTTP 400 bad request.'"

 

The manual download of the unRAISserver.plg didn't help either. Rebooting the server doesn't result in downloading unraid v6.

 

??

 

You might be better served to do a manual upgrade.  Here is a thread with instructions on how-to-do-it:

 

          http://lime-technology.com/forum/index.php?topic=39032.0

 

At the bottom of the first post, you will find a link to a upgrade WIKI that has even more information including solutions to about every problem which folks encountered in earlier upgrades.  (The simpler your configuration is, the less likely you are to have a problem!)  The most important instruction is make a backup of your current Flash Drive BEFORE you start!!!!!!!

Link to post

Thats what I di now, but now the system doesn't recognize my license key. I've put in the config folder as explained in the wiki, but it doesn't seem to work.

 

What version did you upgrade to?  Version 6.2 beta series requires that the registration be verified on boot by accessing the unRAID server.  (This is is to assure that if they release a beta version that can endanger data, unRAID can stop the system from booting.)  You seem to having some issues with access the Internet from your unRAID server.    Post up a diagnostics file if you can get to 'Tools', 'Diagnostics' icon. 

Link to post
  • 4 months later...

The upgrade didn't go well I had to revert back to 5.0-beta14.

I ran method 2. First I got error "Could not find kernel image: linux". So I copied "syslinux" from "unRAIDServer-6.2.4-x86_64.zip" onto the USB stick.

Upon rebooting again the first error was gone and I was getting "SYSLINUX 3.7.2 2008-09-25 EBIOS Copyright © 1994-2008 H. Peter Anvin". It was just stuck there never moving.

 

Has anyone had similar issues and do they have any suggestions?

Link to post

The upgrade didn't go well I had to revert back to 5.0-beta14.

I ran method 2. First I got error "Could not find kernel image: linux". So I copied "syslinux" from "unRAIDServer-6.2.4-x86_64.zip" onto the USB stick.

Upon rebooting again the first error was gone and I was getting "SYSLINUX 3.7.2 2008-09-25 EBIOS Copyright © 1994-2008 H. Peter Anvin". It was just stuck there never moving.

 

Has anyone had similar issues and do they have any suggestions?

 

Here is an introductory thread that will point you to several other resources to assist you through this problem.  You are probably one of the folks who had to reformat their Flash Drives and install the new version.  DON'T PANIC.  If you follow the directions, you will not lose your configuration settings. 

 

          https://lime-technology.com/forum/index.php?topic=41003.0

 

I will tell you right now, none of your plugins will work so be prepared for that. 

Link to post

The upgrade didn't go well I had to revert back to 5.0-beta14.

I ran method 2. First I got error "Could not find kernel image: linux". So I copied "syslinux" from "unRAIDServer-6.2.4-x86_64.zip" onto the USB stick.

Upon rebooting again the first error was gone and I was getting "SYSLINUX 3.7.2 2008-09-25 EBIOS Copyright © 1994-2008 H. Peter Anvin". It was just stuck there never moving.

 

Has anyone had similar issues and do they have any suggestions?

For a version that old, there were extra instructions, and I strongly recommend reading the Upgrading to UnRAID v6 guide, even if you wish to use the plugin to upgrade.  You copied syslinux, but I can't tell if you cleaned out the old syslinux files, and you don't mention running make_bootable, something you HAVE to do if you switch syslinux files.

 

For your old version, you are also going to have to run New Permissions.  I believe the instructions for the upgrade plugin assume that the user has kept up to date, at least running v5.0, and you were still on an old beta.

Link to post

I do have one question.

I set a share to private, created a user set read/write permissions to that share.

But on my windows 7 pc when i try to navigate to that share it's saying I don't have access when i put the user name and password. Did I miss anything?

I'm going to suggest starting a new support topic in the General Support board.  Permissions issues with Windows are somewhat common, and I'm sure someone will have the answer you need.  Be sure to add your diagnostics, see ->  Need help? Read me first!

Link to post

I do have one question.

I set a share to private, created a user set read/write permissions to that share.

But on my windows 7 pc when i try to navigate to that share it's saying I don't have access when i put the user name and password. Did I miss anything?

 

I'm pretty sure this is what you are looking for.

https://lime-technology.com/forum/index.php?topic=26412.msg231122#msg231122

Link to post

I do have one question.

I set a share to private, created a user set read/write permissions to that share.

But on my windows 7 pc when i try to navigate to that share it's saying I don't have access when i put the user name and password. Did I miss anything?

 

I'm pretty sure this is what you are looking for.

https://lime-technology.com/forum/index.php?topic=26412.msg231122#msg231122

 

Perhaps LimeTech should put this information into the user manual(s) so that it is more easily found.  The explanation in the link explains the problem, the why-and-how, and the solution in a few lines.  The way Samba handles this whole user name/password thing is extremely convoluted and I have never seen a clearer explanation about it in any place else!

Link to post
  • 2 months later...

I used method 1 on a 5.0.4 that was running for a long time. I uninstalled my Dynamix plugins just in case. Everything went perfectly. I now have 6.2.4 with all my shares and user logins.

It decided to do a parity check after the first boot. Only 7 hours remaining. :)

It booted a lot faster than 5.0.4. There used to be one area it would get stuck at during boot for about 1 minute.

 

One question about the "build-in" Dynamix? It doesn't seem to be live updating anything. The dashboard works and shows live CPU usage, but the Main page doesn't update. I have to keep pressing F5 to refresh the screen and show the current progress/stats. I liked the old Dynamix in 5.0.4, everything updated in realtime.

 

Something strange I've noticed about the update. I've opened two browsers to the Main page, IE and Firefox. During a parity check they both have the same status, nothing changes. But if I press F5 in either of my browsers to refresh the page, not only does that browser page update, but the other browser page also updates. It's like me pressing F5 forces unRAID to spit out a page update. Anyone seen anything like this?

 

Thanks a lot for everyone's hard work.

Link to post

One question about the "build-in" Dynamix? It doesn't seem to be live updating anything. The dashboard works and shows live CPU usage, but the Main page doesn't update. I have to keep pressing F5 to refresh the screen and show the current progress/stats. I liked the old Dynamix in 5.0.4, everything updated in realtime.

 

By this method, you've done the mechanics of the upgrade, but you haven't been introduced to all the changes and settings.  For that, I still recommend reading the Upgrading to UnRAID v6 guide.  You can skip down to the Boot and test section for some notes, but I'd still skim through the first parts, as there are some helpful notes scattered through it.  Then read the following sections, especially about the Display settings.

 

And turn on Notifications.

 

I personally think that users that shortcutted the upgrade are left a bit high and dry, as there's a lot to learn about the new stuff in v6.  The upgrade guide is a little dated though, written for v6.0, and we're now at v6.2, beta testing v6.3.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.