Jump to content
linuxserver.io

[Support] Linuxserver.io - Rutorrent

489 posts in this topic Last Reply

Recommended Posts

If I update it from 'docker exec -t -i rutorrent /bin/bash'- would it be changed just for rutorrent or for all dockers? Just curious.

Anything you do from the command line within a docker only affects the current installation of that docker.

Thank you. Now just to figure out how to get gcc installed on the docker lol

Note I said the "current installation". If you ever have to reinstall for any reason anything you did from docker exec would have to be reapplied. Making your own docker with the changes already applied is the way to make them stick for a reinstall.

Oh got it :)

It's very strange that I'm the first one that encounters problems with https trackers on this container :o

Take a look here, this might be of interest https://github.com/binhex/arch-rtorrentvpn/issues/10

 

Issue solved (i think) by altering the tTorrent config.

 

Sent from my SM-G900F using Tapatalk

 

 

Share this post


Link to post

If I update it from 'docker exec -t -i rutorrent /bin/bash'- would it be changed just for rutorrent or for all dockers? Just curious.

Anything you do from the command line within a docker only affects the current installation of that docker.

Thank you. Now just to figure out how to get gcc installed on the docker lol

Note I said the "current installation". If you ever have to reinstall for any reason anything you did from docker exec would have to be reapplied. Making your own docker with the changes already applied is the way to make them stick for a reinstall.

Oh got it :)

It's very strange that I'm the first one that encounters problems with https trackers on this container :o

Take a look here, this might be of interest https://github.com/binhex/arch-rtorrentvpn/issues/10

 

Issue solved (i think) by altering the tTorrent config.

 

Sent from my SM-G900F using Tapatalk

 

How did you fix it finally? Having the same issue. It was working fine with https trackers up to a couple days ago  but since then all I got are timeouts.

Share this post


Link to post

 

Thank you. Now just to figure out how to get gcc installed on the docker lol

Note I said the "current installation". If you ever have to reinstall for any reason anything you did from docker exec would have to be reapplied. Making your own docker with the changes already applied is the way to make them stick for a reinstall.

Oh got it :)

It's very strange that I'm the first one that encounters problems with https trackers on this container :o

Take a look here, this might be of interest https://github.com/binhex/arch-rtorrentvpn/issues/10

 

Issue solved (i think) by altering the tTorrent config.

 

Sent from my SM-G900F using Tapatalk

 

How did you fix it finally? Having the same issue. It was working fine with https trackers up to a couple days ago  but since then all I got are timeouts.

 

ok so assuming your issue is this, if it isn't then please ignore this fix (shown in rutorrent):-

 

Tracker Status: Tracker: [Peer certificate cannot be authenticated with given CA certificates]

 

If this is the issue then one way of fixing this is to edit rtorrent.rc file (rtorrent configuration file) and add the line:-

 

network.http.ssl_verify_peer.set = 0

 

This basically tells rtorrent to ignore ssl verification for all trackers.

 

Just to be clear this works for the docker image i created, so im not talking specifically about the LSIO version here, but i see no reason why this shouldn't also work for the LSIO docker image.

Share this post


Link to post

 

Thank you. Now just to figure out how to get gcc installed on the docker lol

Note I said the "current installation". If you ever have to reinstall for any reason anything you did from docker exec would have to be reapplied. Making your own docker with the changes already applied is the way to make them stick for a reinstall.

Oh got it :)

It's very strange that I'm the first one that encounters problems with https trackers on this container :o

Take a look here, this might be of interest https://github.com/binhex/arch-rtorrentvpn/issues/10

 

Issue solved (i think) by altering the tTorrent config.

 

Sent from my SM-G900F using Tapatalk

 

How did you fix it finally? Having the same issue. It was working fine with https trackers up to a couple days ago  but since then all I got are timeouts.

 

ok so assuming your issue is this, if it isn't then please ignore this fix (shown in rutorrent):-

 

Tracker Status: Tracker: [Peer certificate cannot be authenticated with given CA certificates]

 

If this is the issue then one way of fixing this is to edit rtorrent.rc file (rtorrent configuration file) and add the line:-

 

network.http.ssl_verify_peer.set = 0

 

This basically tells rtorrent to ignore ssl verification for all trackers.

 

Just to be clear this works for the docker image i created, so im not talking specifically about the LSIO version here, but i see no reason why this shouldn't also work for the LSIO docker image.

 

Yeah I already tried that but it didn't fix the problem. The error I have is:

 

Tracker: [Timeout was reached]

 

 

Share this post


Link to post

I've got the "Tracker: [Timeout was reached]" error also, but only for 2 trackers out of 5. This has appeared after last docker update, which also coordinates with a modem/router replacement (new model). Port forwarding seems fine, as reported by rutorrent. rtorrent version is not blacklisted on any of those trackers. Any ideas where this issue could come from?

Share this post


Link to post

I've got the "Tracker: [Timeout was reached]" error also, but only for 2 trackers out of 5. This has appeared after last docker update, which also coordinates with a modem/router replacement (new model). Port forwarding seems fine, as reported by rutorrent. rtorrent version is not blacklisted on any of those trackers. Any ideas where this issue could come from?

 

This seems to be related to curl. See notes for version 7.52.1_1 : https://www.freshports.org/ftp/curl and https://github.com/rakshasa/rtorrent/issues/538

 

I flagged the curl package out of date here so we can upgrade from apk as soon as possible : https://pkgs.alpinelinux.org/package/edge/main/x86/libcurl

 

Edit: Also if we can get an update for the container with an upgraded curl, that would be awesome :D

Share this post


Link to post

Thank you binhex but as the others said it was not the issue. The error message does not include 'CA cert' inside it, only timeout.

As I said earlier (https://lime-technology.com/forum/index.php?topic=47299.msg530444#msg530444) and as 3psus said, this seems like an issue with the curl package, and the next scheduled release is in February.

If someone can find a solution before the next release of curl it would be awesome! :)

Share this post


Link to post

Thank you binhex but as the others said it was not the issue. The error message does not include 'CA cert' inside it, only timeout.

As I said earlier (https://lime-technology.com/forum/index.php?topic=47299.msg530444#msg530444) and as 3psus said, this seems like an issue with the curl package, and the next scheduled release is in February.

If someone can find a solution before the next release of curl it would be awesome! :)

 

ok assuming it is curl that is the problem and earlier versions of curl were ok then you could either bug LSIO to roll back to a earlier version of curl and rebuild the image (dunno how easy it is to install a particular version of a package with the current base image) or you could roll back to a earlier tagged version on docker hub (assuming the images are tagged and go back far enough) and wait for the fix in feb.

Share this post


Link to post

I've got the "Tracker: [Timeout was reached]" error also, but only for 2 trackers out of 5. This has appeared after last docker update, which also coordinates with a modem/router replacement (new model). Port forwarding seems fine, as reported by rutorrent. rtorrent version is not blacklisted on any of those trackers. Any ideas where this issue could come from?

 

This seems to be related to curl. See notes for version 7.52.1_1 : https://www.freshports.org/ftp/curl and https://github.com/rakshasa/rtorrent/issues/538

 

I flagged the curl package out of date here so we can upgrade from apk as soon as possible : https://pkgs.alpinelinux.org/package/edge/main/x86/libcurl

 

Edit: Also if we can get an update for the container with an upgraded curl, that would be awesome :D

 

 

you flagged a package that is up to date with the latest release, as out of date ?

 

you're going to be popular with alpine, lol.

Share this post


Link to post

I've got the "Tracker: [Timeout was reached]" error also, but only for 2 trackers out of 5. This has appeared after last docker update, which also coordinates with a modem/router replacement (new model). Port forwarding seems fine, as reported by rutorrent. rtorrent version is not blacklisted on any of those trackers. Any ideas where this issue could come from?

 

This seems to be related to curl. See notes for version 7.52.1_1 : https://www.freshports.org/ftp/curl and https://github.com/rakshasa/rtorrent/issues/538

 

I flagged the curl package out of date here so we can upgrade from apk as soon as possible : https://pkgs.alpinelinux.org/package/edge/main/x86/libcurl

 

Edit: Also if we can get an update for the container with an upgraded curl, that would be awesome :D

 

 

you flagged a package that is up to date with the latest release, as out of date ?

 

you're going to be popular with alpine, lol.

 

Yeah, you might be right. I actually thought there was a newer release of curl, but that is not the case. Anyways, it is done now, at least the maintainer will be notified about the issue and can apply the patch in a sub-release, like has been done on many other distros  ;). I understand he might wait to the next stable release of curl though. I must say I find it surprising that libcurl hasn't had a new stable release after this but whatever.

 

Thanks binhex for the suggestions. Seems like a roll back is the solution here.     

 

ref.   

https://github.com/curl/curl/issues/1174

https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/curl&id=bae58314ffe16b0642811fdb0187a9b8eba8d362

https://www.freshports.org/ftp/curl

Share this post


Link to post

I've got the "Tracker: [Timeout was reached]" error also, but only for 2 trackers out of 5. This has appeared after last docker update, which also coordinates with a modem/router replacement (new model). Port forwarding seems fine, as reported by rutorrent. rtorrent version is not blacklisted on any of those trackers. Any ideas where this issue could come from?

 

This seems to be related to curl. See notes for version 7.52.1_1 : https://www.freshports.org/ftp/curl and https://github.com/rakshasa/rtorrent/issues/538

 

I flagged the curl package out of date here so we can upgrade from apk as soon as possible : https://pkgs.alpinelinux.org/package/edge/main/x86/libcurl

 

Edit: Also if we can get an update for the container with an upgraded curl, that would be awesome :D

 

 

you flagged a package that is up to date with the latest release, as out of date ?

 

you're going to be popular with alpine, lol.

 

Yeah, you might be right. I actually thought there was a newer release of curl, but that is not the case. Anyways, it is done now, at least the maintainer will be notified about the issue and can apply the patch in a sub-release, like has been done on many other distros  ;). I understand he might wait to the next stable release of curl though. I must say I find it surprising that libcurl hasn't had a new stable release after this but whatever.

 

Thanks binhex for the suggestions. Seems like a roll back is the solution here.     

 

ref.   

https://github.com/curl/curl/issues/1174

https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/curl&id=bae58314ffe16b0642811fdb0187a9b8eba8d362

https://www.freshports.org/ftp/curl

 

thanks for the links above, tracked it back via github and arch already have the patch in place, i wondered why i wasnt seeing the issue  8)

Share this post


Link to post

 

Yeah, you might be right. I actually thought there was a newer release of curl, but that is not the case. Anyways, it is done now, at least the maintainer will be notified about the issue and can apply the patch in a sub-release, like has been done on many other distros  ;). I understand he might wait to the next stable release of curl though. I must say I find it surprising that libcurl hasn't had a new stable release after this but whatever.

 

Thanks binhex for the suggestions. Seems like a roll back is the solution here.     

 

ref.   

https://github.com/curl/curl/issues/1174

https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/curl&id=bae58314ffe16b0642811fdb0187a9b8eba8d362

https://www.freshports.org/ftp/curl

 

thanks for the links above, tracked it back via github and arch already have the patch in place, i wondered why i wasnt seeing the issue  8)

 

Np! By the way, for anybody wanting to roll back, it is as easy as appending ":52" to the "Repository" field and update the container.

Screen_Shot_2017-01-18_at_11_51_46.png.6df62ea9350b3466dd987b8b1c145fd0.png

Share this post


Link to post

 

Yeah, you might be right. I actually thought there was a newer release of curl, but that is not the case. Anyways, it is done now, at least the maintainer will be notified about the issue and can apply the patch in a sub-release, like has been done on many other distros  ;). I understand he might wait to the next stable release of curl though. I must say I find it surprising that libcurl hasn't had a new stable release after this but whatever.

 

Thanks binhex for the suggestions. Seems like a roll back is the solution here.     

 

ref.   

https://github.com/curl/curl/issues/1174

https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/curl&id=bae58314ffe16b0642811fdb0187a9b8eba8d362

https://www.freshports.org/ftp/curl

 

thanks for the links above, tracked it back via github and arch already have the patch in place, i wondered why i wasnt seeing the issue  8)

 

Np! By the way, for anybody wanting to roll back, it is as easy as appending ":52" to the "Repository" field and update the container.

Thanks a lot :)

Finally a fix / workaround to the underlying problem.

I got it working by adding this suffix.

Share this post


Link to post

 

Yeah, you might be right. I actually thought there was a newer release of curl, but that is not the case. Anyways, it is done now, at least the maintainer will be notified about the issue and can apply the patch in a sub-release, like has been done on many other distros  ;). I understand he might wait to the next stable release of curl though. I must say I find it surprising that libcurl hasn't had a new stable release after this but whatever.

 

Thanks binhex for the suggestions. Seems like a roll back is the solution here.     

 

ref.   

https://github.com/curl/curl/issues/1174

https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/curl&id=bae58314ffe16b0642811fdb0187a9b8eba8d362

https://www.freshports.org/ftp/curl

 

thanks for the links above, tracked it back via github and arch already have the patch in place, i wondered why i wasnt seeing the issue  8)

 

Np! By the way, for anybody wanting to roll back, it is as easy as appending ":52" to the "Repository" field and update the container.

Thanks a lot :)

Finally a fix / workaround to the underlying problem.

I got it working by adding this suffix.

Working for me too. Thanks!

 

Sent from my SM-G935W8 using Tapatalk

 

 

Share this post


Link to post

I just started using this ruTorrent docker and I'm confused on a few things, mainly how do I connect it to CouchPotato / SickBeard and how do I set authentication?

 

After a few hours of tinkering I ended up using nginx basic auth and a virtual server. So far ruTorrent works amazingly!

Share this post


Link to post

I have tried to incorporate autodl-irssi into this unsuccessfully for a couple months now.  Has anyone else tried doing this?

Share this post


Link to post

Torrent downloads as normal and this happens about 15 mins after rTorrent is started from unRAID.

 

Getting this error in the log which results in the GUI not connecting to rtorrent:

 

-
tail: cannot open '' for reading: No such file or directory

 

This is what the GUI reports:

 

[01.02.2017 15:00:48] WebUI started.
[01.02.2017 15:00:48] No connection to rTorrent. Check if it is really running. Check $scgi_port and $scgi_host settings in config.php and scgi_port in rTorrent configuration file.

 

Share this post


Link to post

I have tried to incorporate autodl-irssi into this unsuccessfully for a couple months now.  Has anyone else tried doing this?

 

I'd like it as well. What have you tried? It would be nice if it were included.

 

Edit: I've requested it on the Linuxserver forum here:

https://forum.linuxserver.io/thread-440.html

 

There is also a fork of the linuxserver docker with it included but I cannot get it to work for me:

https://hub.docker.com/r/xeroxmalf/rutorrent-autodl-irssi/

 

I also found this one:

https://hub.docker.com/r/sethgregory/docker-rutorrent-autodl/

 

I tried that one on Windows earlier and it works but I haven't tried it on UnRAID yet.

Share this post


Link to post

Torrent downloads as normal and this happens about 15 mins after rTorrent is started from unRAID.

 

Getting this error in the log which results in the GUI not connecting to rtorrent:

 

-
tail: cannot open '' for reading: No such file or directory

 

This is what the GUI reports:

 

[01.02.2017 15:00:48] WebUI started.
[01.02.2017 15:00:48] No connection to rTorrent. Check if it is really running. Check $scgi_port and $scgi_host settings in config.php and scgi_port in rTorrent configuration file.

 

I have the same problem  :'(

Share this post


Link to post

Getting a different error with the latest update:

 

[05.02.2017 19:07:28] Bad response from server: (500 [error,list]) Link to XMLRPC failed. May be, rTorrent is down?

 

Just removed and reinstalled. Still giving that error.

Share this post


Link to post

Also getting this error as before:

 

[05.02.2017 20:11:24] No connection to rTorrent. Check if it is really running. Check $scgi_port and $scgi_host settings in config.php and scgi_port in rTorrent configuration file.

 

Share this post


Link to post

I have tried to incorporate autodl-irssi into this unsuccessfully for a couple months now.  Has anyone else tried doing this?

 

I'd like it as well. What have you tried? It would be nice if it were included.

 

Edit: I've requested it on the Linuxserver forum here:

https://forum.linuxserver.io/thread-440.html

 

There is also a fork of the linuxserver docker with it included but I cannot get it to work for me:

https://hub.docker.com/r/xeroxmalf/rutorrent-autodl-irssi/

 

I also found this one:

https://hub.docker.com/r/sethgregory/docker-rutorrent-autodl/

 

I tried that one on Windows earlier and it works but I haven't tried it on UnRAID yet.

 

LOL I have tried the same ones except the sethgregory one I did not try windows, as I don't have the resources for another VM.  I really wish this was included, the RSS https feeds don't work on my private tracker due to server volume, and they are not upgrading their hardware anytime soon.  The IRC however is always up and what was recommended from some of the experienced members there.

Share this post


Link to post

I have tried to incorporate autodl-irssi into this unsuccessfully for a couple months now.  Has anyone else tried doing this?

 

I'd like it as well. What have you tried? It would be nice if it were included.

 

Edit: I've requested it on the Linuxserver forum here:

https://forum.linuxserver.io/thread-440.html

 

There is also a fork of the linuxserver docker with it included but I cannot get it to work for me:

https://hub.docker.com/r/xeroxmalf/rutorrent-autodl-irssi/

 

I also found this one:

https://hub.docker.com/r/sethgregory/docker-rutorrent-autodl/

 

I tried that one on Windows earlier and it works but I haven't tried it on UnRAID yet.

 

LOL I have tried the same ones except the sethgregory one I did not try windows, as I don't have the resources for another VM.  I really wish this was included, the RSS https feeds don't work on my private tracker due to server volume, and they are not upgrading their hardware anytime soon.  The IRC however is always up and what was recommended from some of the experienced members there.

 

Done got it working. How I did it.

1.)  SSH into your machine

 

2.)  Enter the following command replacing your file structure.  Note I could not get it to work if I changed the 443 port.

docker create --name=rutorrent-autodl-irssi -v /mnt/user/Docker/rutorrent-autodl-irssi:/config -v /mnt/user/Docker/Torrents:/downloads -e PGID=100 -e PUID=99 -e TZ=-5 -p 443:443 -p 45566-45576:45566-45576 xeroxmalf/rutorrent-autodl-irssi

 

3.)  Then in the Docker Tab on the Unraid Gui Start the container.

 

Here is the link for additional info

https://hub.docker.com/r/xeroxmalf/rutorrent-autodl-irssi/

 

Done.

 

I spent about 6 hours today trying different combinations but xeroxmalf did it based off of LinuxServer.IO's docker.

 

Edit - Spelling and hyperlink

  • Like 1
  • Upvote 1

Share this post


Link to post

May I make a suggestion that you change the container path /download to /data to aid compatiblity with sonarr and radarr?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now