Jump to content
jbrodriguez

ControlR (Android/iOS app for unRAID)

1009 posts in this topic Last Reply

Recommended Posts

Cache pool - 2nd (and beyond I assume only have 2 drives) comes up "NaN undefinesdNaN %NaN" etc

 

Myk

 

Thanks MyKroFt, I will look into this.

Share this post


Link to post

Would also be nice if the 1st page server name/ip would have the background like you do when selected and are viewing drives.

 

Just a suggestion

 

Otherwise nice app

 

Myk

 

Sent from my SM-G920V using Tapatalk

 

Thanks !

 

Yes that should be possible, I'll see if I can make it optional.

Share this post


Link to post

I've published v1.1.3 (should be available in the Play Store soon), with the following changes:

 

- Fix display of disk info (second cache, unmountable, etc.)

- Validate input for ip and port

- Display app version in Libraries page

- Bug fixes and improvements

 

Additionally, I set up a page to receive feature requests and feedback: https://feedback.userreport.com/b5864402-1922-4c3e-810c-0e427f4d204a/

 

I've started the list with docker support, add any others.

Share this post


Link to post

Thanks for the continued improvements!

I've added some requests, feel free to comment or ignore them entirely..  ;)

Share this post


Link to post

Going to hold off on this for a bit till VM management is fully implemented, as that is where the bulk of my unRAID use is. I would also be very interested if the ability to simultaneously/securely/remotely access multiple unRAID servers running on different networks via the app ever came to fruition. Might be asking for way too much, but it would surely be a selling point for me.

 

That being said, I will definitely be keeping my eye on this one.

Good job, looking good so far!

Share this post


Link to post

Thanks for the continued improvements!

I've added some requests, feel free to comment or ignore them entirely..  ;)

 

Thanks bungee91, I'll check them over the weekend.

Share this post


Link to post

Going to hold off on this for a bit till VM management is fully implemented, as that is where the bulk of my unRAID use is. I would also be very interested if the ability to simultaneously/securely/remotely access multiple unRAID servers running on different networks via the app ever came to fruition. Might be asking for way too much, but it would surely be a selling point for me.

 

That being said, I will definitely be keeping my eye on this one.

Good job, looking good so far!

 

Thanks ryoko227 !

 

VM management is one of the top feature requests.

 

Remote access has been also requested.

 

I'll look into it.

Share this post


Link to post

These are the features currently requested for ControlR (Requests Forum)

 

ZnV4l9f.png

 

I'm working on the docker and vm support right now, I hope to release a new version soon.

Share this post


Link to post

I bought this today. I can't seem to get it to connect to my unraid box. First tried automatic and it couldn't find anything. I tried with user/password and without. Then I tried manual and put my server's ip address and same result. No server added. Any advice? My phone is connected to my network, I can get to my box through a browser.

 

Edit: forgot to add, my server is running 6.1.9

 

Sent from my HTC One using Tapatalk

 

Share this post


Link to post

After the last update I can no longer search for server with automatic. A message saying: Check your input. IP address and/or port are invalid.

 

I cleared both data and cache, but still the same message.

Share this post


Link to post

I bought this today. I can't seem to get it to connect to my unraid box. First tried automatic and it couldn't find anything. I tried with user/password and without. Then I tried manual and put my server's ip address and same result. No server added. Any advice? My phone is connected to my network, I can get to my box through a browser.

 

Edit: forgot to add, my server is running 6.1.9

 

Sent from my HTC One using Tapatalk

 

Hi Kewjoe,

 

Currently, it's supposed to work from inside the lan network (internal wifi).

 

One question .. when you go to the manual tab, does it show an ip address or the field appears blank ?

 

Let me know.

Share this post


Link to post

After the last update I can no longer search for server with automatic. A message saying: Check your input. IP address and/or port are invalid.

 

I cleared both data and cache, but still the same message.

 

saarg, the same question ... you are on your internal wifi right ?

 

In the manual tab, is an ip address pre-populated or is it blank ?

Share this post


Link to post

After the last update I can no longer search for server with automatic. A message saying: Check your input. IP address and/or port are invalid.

 

I cleared both data and cache, but still the same message.

 

saarg, the same question ... you are on your internal wifi right ?

 

In the manual tab, is an ip address pre-populated or is it blank ?

 

Yes internal Wifi.

The IP is populated with the address of the tablet, and also in the correct IP range. Sent you a PM with more info and screenshot.

Share this post


Link to post

Yes, internal Wifi for me too. It shows the IP address of my phone (internal network IP)

Share this post


Link to post

I get the same thing when trying with my Samsung tablet on lan wifi

 

Even when I manually enter everything - check your input

 

Myk

 

Share this post


Link to post

Hi, I just pushed 1.1.4 (takes a while to roll out on the Play store)

 

I made a fix to the ip/port validation routine (when adding servers).

 

The ip should be entered without http://, just the ip number.

 

Kewjoe, do you have bridge enabled on your server ?

 

 

Share this post


Link to post

No, not using bridge on my router. Have it set to Wireless Router (the other options are Repeater, Access Point and Media Bridge).

 

I updated the app. Tried auto, it went through all the ip address on my subnet. Didn't find my server. Tried manual, added my server's IP (with no http) and it didn't find it either.

 

My router is an Asus RT-AC66U running AsusWRT-Merlin 380.57.

Share this post


Link to post

No, not using bridge on my router. Have it set to Wireless Router (the other options are Repeater, Access Point and Media Bridge).

 

I updated the app. Tried auto, it went through all the ip address on my subnet. Didn't find my server. Tried manual, added my server's IP (with no http) and it didn't find it either.

 

My router is an Asus RT-AC66U running AsusWRT-Merlin 380.57.

I think he meant on you unraid server in network settings  :)

Share this post


Link to post

Whoops. Definitely not using bridge on the server

 

Sent from my HTC One using Tapatalk

 

 

Share this post


Link to post

Kewjoe,

 

I've been discussing with saarg an issue he had adding one of his servers.

 

We seem to agree that it's due to the timeout I've set to wait for a server's answer.

 

It's currently set at half a second.

 

If the server doesn't answer before that half a second, then the app thinks it's down.

 

I believe this is what happening to you too.

 

I've been thinking about how to manage this and what I'll do is increase the timeout for Manual mode (I'll set it to 10 seconds) and leave the timeout at half a second for Automatic mode, but it will be customizable in the Settings.

 

I'll release an update soon.

Share this post


Link to post

Kewjoe,

 

I've been discussing with saarg an issue he had adding one of his servers.

 

We seem to agree that it's due to the timeout I've set to wait for a server's answer.

 

It's currently set at half a second.

 

If the server doesn't answer before that half a second, then the app thinks it's down.

 

I believe this is what happening to you too.

 

I've been thinking about how to manage this and what I'll do is increase the timeout for Manual mode (I'll set it to 10 seconds) and leave the timeout at half a second for Automatic mode, but it will be customizable in the Settings.

 

I'll release an update soon.

Sounds good. Thanks!

 

Sent from my HTC One using Tapatalk

 

 

Share this post


Link to post

Hi, I've released v1.1.5 on the Play Store (normal roll out times apply)

 

I've set the following default timeouts, when detecting a new server:

Manual mode: 10 seconds (10000 ms)

Automatic mode: 0.5 seconds (500 ms)

 

Both values are configurable and should be expressed in milliseconds.

Share this post


Link to post

Bingo! You hit the jackpot  ;)

Server was added without problem. Thanks for the fix.

 

Share this post


Link to post

Woohoo, it works now! Did manual, left it as your new default of 10 seconds and that did the trick. Thanks!

 

Sent from my HTC One using Tapatalk

 

 

Share this post


Link to post

Hi I am interested in getting this app. I would like it if it was also compatible with android tv so i can also run on my shield in the bedroom.

 

Just one thing can you explain the app permissions

 

This app has access to:

Photos / Media / Files
Uses one or more of: files on the device such as images, videos or audio, the device's external storage

 

I guess this is if the app needs to be moved to sd card?

 

Wi-Fi connection information
Allows the app to view information about Wi-Fi networking, such as whether Wi-Fi is enabled and names of connected Wi-Fi devices

 

This is self explanitory !

 

Device ID & call information
Allows the app to determine the phone number and device IDs, whether a call is active and the remote number connected by a call

 

This is the permission i am not sure can you explain why this is necessary.  I am sorry i hope this question doesn't sound rude but having just read about mobile device app security and the recent Runkeeper data privacy leak I just wanted to ask  :)

 

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.