Jump to content
linuxserver.io

[Support] Linuxserver.io - TVHeadend

1069 posts in this topic Last Reply

Recommended Posts

See my above post  ;)

 

OK, what DVB card are you using?  Seems like there are no drivers for it in RC3....  Might be a problem with the Unraid DVB build...

 

What version Unraid were you using before?

 

And can you post a screenshot of the same screen from the working version?

Share this post


Link to post

August DVB-T210 - HD Freeview USB TV Tuner - External DVB-T2 Digital Television Receiver and PVR Style Recorder

 

It worked on this dvb build before the tvheadend docker image updated a few days ago.

Share this post


Link to post

August DVB-T210 - HD Freeview USB TV Tuner - External DVB-T2 Digital Television Receiver and PVR Style Recorder

 

It worked on this dvb build before the tvheadend docker image updated a few days ago.

 

The DVB build screen is showing no DVB adapters found in your system.  Only other thing is to try a reboot.

 

Just to clarify, what you're saying is that you have had TVHeadEnd working on LibreELEC V6.3 RC3?  If so the only thing I can think of is to reboot.

 

If you're saying that you've had it working on LibreELEC V6.3 RC2 or RC1 or any other version of LibreELEC like V6.23 or v6.22 then it may be an error with the DVB build.

 

EDIT:  /dev/dvb/ is a system thing, unrelated to docker, so it can't be the TVH update that caused it.  /dev/dvb/ is your DVB adapter, TVH can't find it so wasn't starting.  So we need to look at why TVH can't find it.  The possibilities are:

 

1.  Something went wrong with the DVB Build creation when I did it.

2.  Your DVB adapter has died.

3.  Something (No idea what) has caused your DVB adapter to drop off the face of the earth, a reboot may fix this.

Share this post


Link to post

Thanks for your help, I'll get a chance to troubleshoot more later.

 

OK, first of all try a reboot to the previous version of Unraid you were using, if that works, then try RC3 again.  If that doesn't work, then it's an issue with the DVB build I'm guessing.

 

If you could get DVB plugin screenshots from a working version that would be helpful.

Share this post


Link to post

OK now working.

 

Had to remove tvheadend docker completely and reboot.

Install tvheadend docker and reboot again.

 

All the things I should have done first I guess.  ::)

Share this post


Link to post

OK now working.

 

Had to remove tvheadend docker completely and reboot.

Install tvheadend docker and reboot again.

 

All the things I should have done first I guess.  ::)

It's good that it's working again  :)

Next time, no need to remove the tvheadend container, just reboot.

Share this post


Link to post

OK now working.

 

Had to remove tvheadend docker completely and reboot.

Install tvheadend docker and reboot again.

 

All the things I should have done first I guess.  ::)

 

I think that means that your USB tuner tripped up somewhere.....

If it happens again check the DVB plugin page and see if it can see the tuner before messing around with the TVH docker.

Share this post


Link to post

The funny thing is we had a power cut last night (I have a ups connected) so the server did reboot. 

 

Thanks for helping. 

Share this post


Link to post

Interesting, maybe when the UPS kicked in, the USB dropped or something?!  Guess we'll never know....

Share this post


Link to post

Can get this installed, sure it is something basic, can anyone help??

 

Just want to use it for IPTV

 

You haven't filled in the host path for recordings.

Share this post


Link to post

Can get this installed, sure it is something basic, can anyone help??

 

Just want to use it for IPTV

 

And I'm pretty sure if you're using IPTV you need to switch it to host mode so multicast works.

Share this post


Link to post

Can get this installed, sure it is something basic, can anyone help??

 

Just want to use it for IPTV

 

And I'm pretty sure if you're using IPTV you need to switch it to host mode so multicast works.

 

A pair of good eyes you have, my friend  8)

Share this post


Link to post

Thank you for the replys, so just to confirm i need host mode?

 

It did install once i set the recording dir, however now when i try to add IPTV channels when it scans them it come up with FAIL. is this because i didn't choose host mode or something else?

Share this post


Link to post

Thank you for the replys, so just to confirm i need host mode?

 

It did install once i set the recording dir, however now when i try to add IPTV channels when it scans them it come up with FAIL. is this because i didn't choose host mode or something else?

 

Yes, you need to set it to host for multicast Iptv to work.

Share this post


Link to post

Hi guys, I'm having an issue with recordings and though I'd ask here if anyone knows what I'm doing wrong. 

 

I have several auto-records scheduled but they always seem to end up as failed recordings with a status of 'time missed'.  The odd thing is that the .mkv files are saved to disk and play fine if I use VLC.  For some reason they are not showing as completed recordings in TVHeadend or any of it's clients (Kodi).  One other thing I noticed is that some times the error while trying to record is 'no input source available', but if I start a recording of the same show manually at the same time, the manual recording will complete as it should.

 

The tuner is a HDHomerun on the network.

 

Also, what's the best way to attach a log from unRAID dockers?  I've just zipped the HTML file but is there a preferred method?

 

Thanks.

 

Log_for__tvheadend.zip

failed.png.c72313180261461c7ff307ff2f993b1e.png

saved_files.png.90434c354f7af8cfb7087ad55492a0f9.png

Share this post


Link to post

Hi guys, I'm having an issue with recordings and though I'd ask here if anyone knows what I'm doing wrong. 

 

I have several auto-records scheduled but they always seem to end up as failed recordings with a status of 'time missed'.  The odd thing is that the .mkv files are saved to disk and play fine if I use VLC.  For some reason they are not showing as completed recordings in TVHeadend or any of it's clients (Kodi).  One other thing I noticed is that some times the error while trying to record is 'no input source available', but if I start a recording of the same show manually at the same time, the manual recording will complete as it should.

 

The tuner is a HDHomerun on the network.

 

Also, what's the best way to attach a log from unRAID dockers?  I've just zipped the HTML file but is there a preferred method?

 

Thanks.

 

Could you click the two arrows in the bottom right of the tvheadend webgui before the scheduled recording starts and paste the output here?

It might be that it takes too long to tune the channel and time missed comes, but it still manage to start the recording as tvheadend doesn't give up until the scheduled recordings end time.

Share this post


Link to post

This is from a failed recording earlier today.

 

Is it also odd that every time it scrapes for new guide data it is adding over 5000 'new' items.  I thought it was just doing an incremental update of new or changed programs  every day.

log.txt

Share this post


Link to post

This is from a failed recording earlier today.

 

Is it also odd that every time it scrapes for new guide data it is adding over 5000 'new' items.  I thought it was just doing an incremental update of new or changed programs  every day.

 

You have two scheduled recordings of the same show. Is there a reason why?

General hospital is not recorded as the days of our life is not finished and that means you have no free tuners.

Share this post


Link to post

So, it looks like things can work correctly as I had added an auto record and it seems to have completed correctly with a minor issue of not being able to change permissions.  I suggested to my wife that she just watch the news instead of soaps since this recording is working but that didn't go over too well...

 

Loglevel debug: enabled
2016-11-15 17:03:22.766 dvr: entry 2ad58a5679263d3cf2d476f41635a9dd "ABC6 News at 5:30pm" on "WLNE HDTV (ABC)" starting at 2016-11-15 17:29:30, scheduled for recording by "htpcserver"
2016-11-15 17:03:22.766 dvr: entry bbc8514c0321675e794fdb5e22aa0afb "ABC6 News at 5:30pm" on "WLNE HDTV (ABC)" starting at 2016-11-16 17:29:30, scheduled for recording by "htpcserver"
2016-11-15 17:03:22.766 dvr: entry 129f18c6d26a487063f579423d69d631 "ABC6 News at 5:30pm" on "WLNE HDTV (ABC)" starting at 2016-11-17 17:29:30, scheduled for recording by "htpcserver"
2016-11-15 17:03:22.766 dvr: entry 3a58fdcb629ee271272e00cf7bd2e939 "ABC6 News at 5:30pm" on "WLNE HDTV (ABC)" starting at 2016-11-18 17:29:30, scheduled for recording by "htpcserver"
2016-11-15 17:03:22.767 dvr: entry 325c53bf5d00630a37122b0e75f1b07e "ABC6 News at 5:30pm" on "WLNE HDTV (ABC)" starting at 2016-11-21 17:29:30, scheduled for recording by "htpcserver"
2016-11-15 17:03:22.767 dvr: entry 6512b1467c59802cd9c3ce1cbdcb9874 "ABC6 News at 5:30pm" on "WLNE HDTV (ABC)" starting at 2016-11-22 17:29:30, scheduled for recording by "htpcserver"
2016-11-15 17:29:30.000 dvr: "ABC6 News at 5:30pm" on "WLNE HDTV (ABC)" recorder starting
2016-11-15 17:29:30.000 mpegts: 683.028MHz in ATSC-T Network - tuning on HDHomeRun ATSC-T Tuner #0 (192.168.0.103)
2016-11-15 17:29:30.000 tvhdhomerun: tuning to auto:683028615
2016-11-15 17:29:30.105 subscription: 0002: "DVR: ABC6 News at 5:30pm" subscribing on channel "WLNE HDTV (ABC)", weight: 300, adapter: "HDHomeRun ATSC-T Tuner #0 (192.168.0.103)", network: "ATSC-T Network", mux: "683.028MHz", service: "WLNE-TV", profile="matroska"
2016-11-15 17:30:00.007 dvr: Unable to change directory permissions to "775" for "/recordings/ABC6 News at 5_30pm" (keeping "755")
2016-11-15 17:30:00.008 dvr: /recordings/ABC6 News at 5_30pm/ABC6 News at 5_30pm - -.mkv from adapter: "HDHomeRun ATSC-T Tuner #0 (192.168.0.103)", network: "ATSC-T Network", mux: "683.028MHz", provider: "", service: "WLNE-TV"
2016-11-15 17:30:00.008 dvr:  #  type              lang  resolution  aspect ratio  sample rate  channels
2016-11-15 17:30:00.008 dvr:  1  MPEG2VIDEO              1280x720    16:9                                 
2016-11-15 17:30:00.008 dvr:  2  AC3               eng                             48000        5.1       
2016-11-15 17:30:00.008 dvr:  3  AC3               spa                             48000        2         
2016-11-15 18:00:00.010 subscription: 0002: "DVR: ABC6 News at 5:30pm" unsubscribing from "WLNE HDTV (ABC)"
2016-11-15 18:00:00.012 dvr: "ABC6 News at 5:30pm" on "WLNE HDTV (ABC)": End of program: Completed OK

 

As for the dual recordings, I have no clue why that happened.  They should all be created from the auto-record settings.  It only shows double recordings for some days and not others.  I'll try deleting all auto recordings and scheduled recordings and re-create them and see what happens going forward.

 

Thanks for taking a look at this. 

Tvheadend_4.png.b5e0eed9d80156eb3c374ea6b30e416b.png

Tvheadend_3.png.cba8ff2f2989764f1ed9be1477757ac1.png

Share this post


Link to post

 

As for the dual recordings, I have no clue why that happened.  They should all be created from the auto-record settings.  It only shows double recordings for some days and not others.  I'll try deleting all auto recordings and scheduled recordings and re-create them and see what happens going forward.

 

Thanks for taking a look at this.

 

If in doubt, blame the wife.....  ;D

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.