[Support] Linuxserver.io - LazyLibrarian


221 posts in this topic Last Reply

Recommended Posts

Hi.  I tried installing this again, deleting the old container.  Can someone help troubleshoot?  It says Lazylibrarian is running, but I don't see anything.  

Screen Shot 2017-06-21 at 6.11.23 PM.png

Screen Shot 2017-06-21 at 6.15.54 PM.png

Screen Shot 2017-06-21 at 6.15.41 PM.png

Screen Shot 2017-06-21 at 6.12.11 PM.png

Edited by jang430
added more info
Link to post
  • Replies 220
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Application Name: LazyLibrarian Application Site:  https://github.com/DobyTang/LazyLibrarian Docker: https://hub.docker.com/r/linuxserver/lazylibrarian/ Github: https://github.com/linux

Why are you putting /config on a drive mounted outside the array?

This forum is only for unRAID support. Linuxserver.io has its own forum for supporting their dockers on other platforms.

Posted Images

1 hour ago, jang430 said:

 It says Lazylibrarian is running, but I don't see anything.

Change host port 1 to something other than 5299 or any other port currently in use. You didn't expand the "show deployed ports" entry so I can't make a more specific recommendation. If you expand it you will see the currently set list that unraid knows about, definitely don't use any of those numbers.

Link to post
2 hours ago, jang430 said:

Hi, see attached.  But before posting here, I've tried using another port already, and result is the same.

I don't know how you managed it, but you have your unraid's IP set inside the container, which isn't going to work.

 

The line in the log should be Starting LazyLibrarian web server on http://0.0.0.0:5299/ instead of showing your unraid's IP.

Link to post

Hi, all my docker containers are accessed via http://192.168.1.103:8081, 8989, etc.  Is this wrong?  In this case, I try to access http://192.168.1.103:8085.

 

This is what I see now that I set it to 8085.

 

I install the app by searching through the app tab in Unraid. 

Screen Shot 2017-06-22 at 10.37.00 AM.png

Edited by jang430
Link to post
1 minute ago, jang430 said:

Hi, all my docker containers are accessed via http://192.168.1.103:8081, 8989, etc.  Is this wrong?  In this case, I try to access http://192.168.1.103:8085.

No, the IP is correct to access it, but the port is 5299, not 8085. What I'm saying is that somehow you entered that address into the wrong spot, inside the container setup. It's supposed to listen on any IP, which is designated by all zeros, because the docker itself doesn't have your unraid IP, it has its own IP that is different.

 

When you get the internal address for the app set back to all zeroes, you should be able to access it at http://192.168.1.103:5299/

 

Link to post

Oh, I see.  So what steps can I do to fix this?  I've already deleted the container, even deleted the previous config when adding the same container.  I also made sure there are no Orphaned containers.  Any ideas?

Link to post
9 hours ago, jang430 said:

Oh, I see.  So what steps can I do to fix this?  I've already deleted the container, even deleted the previous config when adding the same container.  I also made sure there are no Orphaned containers.  Any ideas?

Remove the container again, and this time before you add it back delete the /mnt/cache/appdata/lazylibrarian folder.

Link to post

follow-up question.  I have a category in sabnzbd ebooks, which downloads to /downloads/complete/ebooks

 

I have configure the 2 paths I can find inside lazylibrarian as such (seen on attachment).  All downloads stay at /downloads/complete/ebooks.  It doesn't go into /downloads/complete/ebooks/_Magazines.  It also doesn't move to /books/ebooks (Media/ebooks).  

 

Maybe you can help me check which path am I missing?  Are there any other parts worth taking care of?

downloaders.png

post.png

Untitled.png

Link to post
  • 2 weeks later...

@jang430

Try this:

 

LL Container

change Host Path 2 to: /mnt/cache/downloads/complete/ebooks

change Host Path 3 to: /mnt/user/Media/ebooks/

 

LL Settings

change Download Directory: /downloads

change Book Library Folder: /books

 

 

Edited by fergalc
updated LL Settings, forgot /downloads
Link to post
  • 2 weeks later...

Anyone have this successfully setup using magazines? I can't get the post-processing to work. It won't move them to a magazines share I created.

 

EDIT:

I think I figured it out but post-processing won't work. It tries to create directory and says permissions denied. PUID is set to 99 and PGID 100 in the docker container.

 

2017-07-16 12:07:29	ERROR	Postprocessing for 2016-11-01 - Magpi has failed: Unable to create directory Magazines/Magpi/2016-11-01: Permission denied

 

596bbe7e28db2_ScreenShot2017-07-16at12_27_14PM.thumb.png.b061e2be4847064fcd0d9ceaaf48e390.png

Edited by jrdnlc
Link to post
10 minutes ago, CHBMB said:

Well I dunno, as the text underneath says /books, you may have changed it to /Magazines as I'm not sure that text in yellow gets updated.

 

I changed it now to  /Magazines and same error. Permissions denied and won't create the folder

Link to post
9 minutes ago, CHBMB said:

Tried changing the Magazine Foldername Pattern to /magazines/$Title/$IssueDate or /Magazines/$Title/$IssueDate depending on whether you're using /magazines or /Magazines

 

Share is magazines so I changed it to /magazines. No luck same error

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.