[Plugin] ControlR


535 posts in this topic Last Reply

Recommended Posts

1 hour ago, jbrodriguez said:

Ok, repeat the steps above, only this time change to port 2379 in the browser address bar/url, not in the plugin settings (I wasn't clear on that).

Let me know how it goes.


Sent from my iPhone using Tapatalk

Unable to connect

Firefox can’t establish a connection to the server at d7b7dd5f31171a775e28111b7128e5ddc8c08b3c.unraid.net:2379.

    The site could be temporarily unavailable or too busy. Try again in a few moments.
    If you are unable to load any pages, check your computer’s network connection.
    If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

 

On the settings page it shows the ControlR Status as Stopped. It wont start on port 2379

Link to post
  • Replies 534
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

ControlR is a companion plugin for the ControlR app.   Screenshot   Introduction This plugin allows you to set up user permissions for the ControlR app.   Oper

If 6.7 was imminent they wouldn't have bothered with 6.6.7.  Just sayin'  

Hi, yes, I'm tracking the issue in the app thread. I don't have a solution yet, because I'm unable to replicate the issue. Can you follow the steps in https://github.com/jbrodriguez/controlr

Posted Images

7 hours ago, darrenyorston said:

On the settings page it shows the ControlR Status as Stopped. It wont start on port 2379

Right, on the settings page set the port to 2378.

 

It's the default port and generally it shouldn't be changed.

 

Then make sure the plugin is running, click on the green Open webui.. link, then change the url port to 2379.

 

It should work now.

 

I've already fixed this in dev.

 

I'm waiting for 6.7.x stable to release a new plugin and app, but if there's an rc5, I'll probably go ahead and publish anyway.

Link to post
22 hours ago, jbrodriguez said:

Right, on the settings page set the port to 2378.

 

It's the default port and generally it shouldn't be changed.

 

Then make sure the plugin is running, click on the green Open webui.. link, then change the url port to 2379.

 

It should work now.

 

I've already fixed this in dev.

 

I'm waiting for 6.7.x stable to release a new plugin and app, but if there's an rc5, I'll probably go ahead and publish anyway.

That worked. I presume each time I want to edit the plugin Ill just need to change the port?

 

Thanks for the help. Much appreciated.

Link to post
12 hours ago, darrenyorston said:

I presume each time I want to edit the plugin Ill just need to change the port?

Yes, until I release a new version of the plugin.

 

Now that RC5 is out I guess I'll have to make true on my promise and release a new plugin/app, but I'll wait 'til Tuesday for Stable 😁

Edited by jbrodriguez
Link to post
1 hour ago, jbrodriguez said:

Now that RC5 is out I guess I'll have to make true on my promise and release a new plugin/app, but I'll wait 'til Tuesday for Stable 😁

If 6.7 was imminent they wouldn't have bothered with 6.6.7.  Just sayin' :) 

Link to post
  • 4 weeks later...

Trying to get the plugin working, when I login I get the following message:

 

Unable to connect to serverx

(1001) - Unable to get unRAID state (dockers): Get https://127.0.0.1/plugins/dynamix.docker.manager/include/DockerContainers.php: dial tcp 127.0.0.1:443: connect: connection refused

 

No users are shown, no dockers etc.

 

The IOS app refuses to show any logs and just tells me I need to install the plugin.

 

What am I missing here?

Link to post
  • 2 weeks later...
On 3/21/2019 at 11:49 AM, jbrodriguez said:

It has been reported a couple of times, but I haven't been able to reproduce it.

 

Are you running a reverse proxy on the server, letsencrypt docker or similar ?

 

Let me know, based on that let's dm to troubleshoot.

I'm also seeing this issue, but running 6.7.0-rc6 (which I'm guessing might be the cause?)

Link to post
On 3/21/2019 at 8:49 PM, jbrodriguez said:

It has been reported a couple of times, but I haven't been able to reproduce it.

 

Are you running a reverse proxy on the server, letsencrypt docker or similar ?

 

Let me know, based on that let's dm to troubleshoot.

Same issue,

its been like this since I buy the app, 

It's definitely because the NGINX , If I use port fowording only its not happaing.

 

my config:

port 443 handler:

################################################################################
#### PORT 80  
################################################################################
# listening on port 80 disabled by default, remove the "#" signs to enable
#redirect all traffic to https
server {
	listen 80 default_server;
	listen [::]:80;
	server_name _;
	return 301 https://$host$request_uri;
}
################################################################################
# main server block
################################################################################
server {
	listen 443 ssl http2 default_server;
	listen [::]:443 ssl http2 default_server;

	root /config/www;
	index index.html index.htm index.php;

	server_name _;

	# all ssl related config moved to ssl.conf
	include /config/nginx/ssl.conf;


	client_max_body_size 0;

	location / {
		try_files $uri $uri/ /index.html /index.php?$args =404;
	}

	location ~ \.php$ {
		fastcgi_split_path_info ^(.+\.php)(/.+)$;
		fastcgi_pass 127.0.0.1:9000;
		fastcgi_index index.php;
		include /etc/nginx/fastcgi_params;
	}
	
}	

 

UNRAID SUBDOMAIN (V1) - currently in use

##############################################################
### SUBDOMAIN 4 - Server UNRAID
##############################################################

server {
    listen 443 ssl http2;
    server_name UNRAID.MYDOMAIN.COM;
    
    include /config/nginx/ssl.conf;

    location / {
        include /config/nginx/proxy.conf;
        proxy_pass https://XXXXXXX.unraid.net;
        
        # unraid logs do not work if buffering is enabled
        proxy_buffering off;
        
        # If you are proxying unRAID 6.4+, uncomment the following lines to support WebSockets
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection "upgrade";
      }
}

UNRAID SUBDOMAIN (V2) - not in use - but the same problem:

server {
	listen 443 ssl http2;
	server_name UNRAID.MYDOMAIN.COM;

	include /config/nginx/ssl.conf;
	
	client_max_body_size 0;
	
	location / {
		proxy_set_header	Host $host;
		proxy_set_header	X-Real-IP $remote_addr;
		proxy_set_header	X-Forwarded-For $proxy_add_x_forwarded_for;
		proxy_set_header	X-Forwarded-Proto $scheme;
		proxy_pass https://XXXXXXXX.unraid.net;
    	proxy_set_header Upgrade $http_upgrade;
    	proxy_set_header Connection "Upgrade";
	}
}

 

Link to post
  • 2 weeks later...
  • 1 month later...
On 3/21/2019 at 12:55 PM, Fizzyade said:

Trying to get the plugin working, when I login I get the following message:

 

Unable to connect to serverx

(1001) - Unable to get unRAID state (dockers): Get https://127.0.0.1/plugins/dynamix.docker.manager/include/DockerContainers.php: dial tcp 127.0.0.1:443: connect: connection refused

 

No users are shown, no dockers etc.

 

The IOS app refuses to show any logs and just tells me I need to install the plugin.

 

What am I missing here?

I'm having this same issue. What can I do to get this working?  UnRAID 6.7.0 and ControlR v2019.03.28.

Edited by scb147
Link to post

This is my list of dockers:

PlexMediaServer, Sabnzbd, Sonarr, Radarr, Lidarr, qBittorrentvpn, CrashPlanPRO, Google-MusicManager, Speedtest (disabled)

 

I'm not sure if any of these have a reverse proxy associated with them.

Edited by scb147
Link to post

I'm not accessing UnRAID via SSL.  But it looks like ControlR is accessing via SSL, but I don't see any settings on the ControlR page to disable SSL, just a text entry for the location of the certificates.  So when I select the link to open the Web UI, it navigates to:

https://<IP_ADDRESS>:2379/#/

The port in ControlR settings is 2378.  Cert dir is the default: /boot/config/ssl/certs

Link to post

The plugin looks at the Unraid settings to connect via either SSL or not.

 

You have SSL set to 'yes' or 'auto'.

 

Could you try setting Unraid SSL to no, then stop/start the plugin ?

 

It should work this way.

Link to post

I am trying to add my server manually, using the external url I have set up with nginx.

 

I can see in the log it is trying to connect, but it always try to auth as "root" and that isn't what I am putting into the username field.

Link to post
26 minutes ago, mikeydk said:

I am trying to add my server manually, using the external url I have set up with nginx.

 

I can see in the log it is trying to connect, but it always try to auth as "root" and that isn't what I am putting into the username field.

As far as I know you HAVE to authenticate with the root username/password.   No other user can control Unraid.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.