SSH Not Running?


Recommended Posts

Hi all,


I have trouble logging into terminal using SSH, message in terminal is "connection refused". Somehow i do not seem to be able to connect anymore. The SSH plugin from Docgyver (nice work btw) indicates SSH is not running. How do I find out why this is happening?


Cheers, Deeks!

Link to comment

By looking at your diagnostics (Tools -> Diagnostics) or by posting them here.


EDIT: if you can log in at the console or telnet it try this:


ps aux | grep sshd


If it returns something like this


root      1558  0.0  0.0  24492  3216 ?        Ss  Jan03  0:00 /usr/sbin/sshd


then the ssh daemon is running.


Link to comment

You don't need a plugin to make ssh work. Try removing the plugin and see if that fixes it.


The ssh daemon might be getting disabled here:


Jan 30 17:17:11 unRaid emhttp: cmd: /usr/local/emhttp/plugins/ssh/scripts/rc.ssh disable 22 -1 no 6 yes no no

Jan 30 17:17:30 unRaid emhttp: cmd: /usr/local/emhttp/plugins/ssh/scripts/rc.ssh enable 22 -1 no 6 yes no no

Jan 30 17:17:42 unRaid emhttp: cmd: /usr/local/emhttp/plugins/ssh/scripts/rc.ssh buttonstart

Jan 30 17:22:19 unRaid emhttp: cmd: /usr/local/emhttp/plugins/ssh/scripts/rc.ssh enable 22 -1 yes 6 yes no no

Jan 30 17:22:31 unRaid emhttp: cmd: /usr/local/emhttp/plugins/ssh/scripts/rc.ssh enable 22 -1 no 6 yes no no

Jan 30 17:22:42 unRaid emhttp: cmd: /usr/local/emhttp/plugins/ssh/scripts/rc.ssh buttonstart

Jan 30 17:30:01 unRaid emhttp: cmd: /usr/local/emhttp/plugins/ssh/scripts/rc.ssh buttonstart

Jan 30 17:30:01 unRaid speedtest: Internet bandwidth test started

Link to comment
  • 1 month later...

After reboot the deamon was running again. All I had to do was edit known_hosts on my macbook from which I usually connect and throw away the lines referring to my unraid box. Now I can connect to SSH again.


Happy as Larry! Thanks heaps Gubbgnutten!!:D


ps. The reason why this thread was an the SSH community plugins not working, of course the are now working beautifully as well

Link to comment
  • 4 months later...

Hi experts,


I have a similar problem regarding SSH access. After I installed "DenyHosts" und "SSH Config Tool" plugins and uninstalled them again I'm not able to login to SSH anymore. Pytty says "Access denied".


Telnet is still working and this is the output from ps aux | grep sshd:

root      1739  0.0  0.0  24500  3204 ?        Ss   Jul14   0:00 /usr/sbin/sshd
root     26054  0.0  0.0   9656  1868 pts/4    S+   18:52   0:00 grep sshd


If there are some changed SSH settings is it possible to reset them to default values?


Can someone advice please?



I've tried to reinstall the SSH Config Tool, but the installation script returned an error:

plugin: installing:
plugin: downloading
plugin: downloading: ... done
plugin: downloading: ... done
plugin: run failed: /bin/bash retval: 1

Link to comment
1 hour ago, deeks said:



Not sure if my ssh issue had abrelations to the plug-ins. Try editing the known hosts as suggested by Gubbhnutten. It worked for me.



Hi Deeks,


I got it! Had to modify /boot/config/ssh/sshd_config and set PermitRootLogin to yes and then restart SSHD with /etc/rc.d/rc.sshd restart.



Link to comment
  • 1 year later...

Very similar issue here although this thread is already six months old.


I get "Permission Denied" when I try to ssh in. Using telnet I moved /boot/config/ssh to a new name and restarted ssh as above. It recreated the ssh directory with new keys. The old directory had a sshd_config file of 0 bytes.


After rebooting, I can't get sshd to run. Looking at sshd_config, I see that there is a new one there but it's all default values--read: broken. 


Would someone be able to send me working sshd_config so I can compare and get one running on my end?



Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.