Jump to content
linuxserver.io

[Support] Linuxserver.io - airsonic

99 posts in this topic Last Reply

Recommended Posts

14 hours ago, tjb_altf4 said:

The template still needs an update, I installed Airsonic for the first time and ran into the 'too small initial heap' error.

Updating the JAVA_OPTS values with m after numbers as noted earlier resolved the issue.

 

I thought we fixed that a long time ago... Apparently we didn't. 

  • Upvote 1

Share this post


Link to post

Really liking Airsonic, seems very solid.


I've changed over the back end from the internal hsqldb to MariaDB.

Probably not needed in terms of performance, but a nice to have for backing up library and user profiles etc as part of a centralised db.

 

Share this post


Link to post
On 9/22/2018 at 7:26 PM, saarg said:

 

I thought we fixed that a long time ago... Apparently we didn't. 

just tried for the first time also and same issue

Share this post


Link to post
just tried for the first time also and same issue
It's definitely been fixed now, probably an issue with your locally cached template

Sent from my Mi A1 using Tapatalk

Share this post


Link to post
It's definitely been fixed now, probably an issue with your locally cached template

Sent from my Mi A1 using Tapatalk


First time installing it. Adding the m fix it


Sent from my iPhone using Tapatalk Pro

Share this post


Link to post
3 hours ago, saarg said:

 

My bad. Didn't think about that one at all. 

Neither did I..... @tjb_altf4 did though.... :D

Share this post


Link to post
12 minutes ago, CHBMB said:

Neither did I..... @tjb_altf4 did though.... :D

Good we have some users that quality check our work 😁

Share this post


Link to post
1 minute ago, saarg said:

Good we have some users that quality check our work 😁

I dunno, I think we do alright for a mishmash of amateurs..... lol

Share this post


Link to post
Just now, CHBMB said:

I dunno, I think we do alright for a mishmash of amateurs..... lol

Absolutely agree! Which kind of place would the world have been without us? 😂

Share this post


Link to post
19 minutes ago, saarg said:

Which kind of place would the world have been without us? 

Peaceful and serene

Share this post


Link to post
2 hours ago, Squid said:

Peaceful and serene

😱

Share this post


Link to post

I'm not having luck streaming music with the Airsonic DLNA media server.  The media server does not appear to any devices (receiver, tv, etc).  I have the PLEX media server docker installed and my devices can see that. 

 

I have restarted the Arisonic server each time after saving the DLNA setting.  Any suggestions?  Thanks!

 

Enable DLNA server: Box checked

Use this option to turn on the DLNA/UPnP media server in Airsonic, and stream your media to compatible DLNA players. Requires restart.

 

Media Server name: Airsonic

Name of the media server, as shown on DLNA players.

 

LAN Server address: Slightly confused about this setting.  I'm not sure exactly what I need to put here.  I have tried http://UNRAID-IP/, http://UNRAID-IP/airsonic/, http://UNRAID-IP:4040/, http://UNRAID-IP:4040/airsonic/

The base LAN address to be used for DLNA resources, for example http://192.168.0.2/airsonic/

 

Log shows the server is enabled or at least started to enable.

2018-11-24 10:37:49.047 INFO --- o.a.player.service.UPnPService : Enabling UPnP/DLNA media server 

 

Version10.1.1-RELEASE – December 16, 2017

Serverjetty/9.3.14.v20161028, java 1.8.0_151, Linux (120.3 MB / 442.0 MB)

Share this post


Link to post
27 minutes ago, dboonthego said:

I'm not having luck streaming music with the Airsonic DLNA media server.  The media server does not appear to any devices (receiver, tv, etc).  I have the PLEX media server docker installed and my devices can see that. 

 

I have restarted the Arisonic server each time after saving the DLNA setting.  Any suggestions?  Thanks!

 

Enable DLNA server: Box checked

Use this option to turn on the DLNA/UPnP media server in Airsonic, and stream your media to compatible DLNA players. Requires restart.

 

Media Server name: Airsonic

Name of the media server, as shown on DLNA players.

 

LAN Server address: Slightly confused about this setting.  I'm not sure exactly what I need to put here.  I have tried http://UNRAID-IP/, http://UNRAID-IP/airsonic/, http://UNRAID-IP:4040/, http://UNRAID-IP:4040/airsonic/

The base LAN address to be used for DLNA resources, for example http://192.168.0.2/airsonic/

 

Log shows the server is enabled or at least started to enable.

2018-11-24 10:37:49.047 INFO --- o.a.player.service.UPnPService : Enabling UPnP/DLNA media server 

 

Version10.1.1-RELEASE – December 16, 2017

Serverjetty/9.3.14.v20161028, java 1.8.0_151, Linux (120.3 MB / 442.0 MB)

You need to map port 1900, but not sure if it works as plex already use it. 

Another solution is to give the airsonic its own IP. 

Edited by saarg
  • Like 1

Share this post


Link to post
On 11/24/2018 at 11:32 AM, saarg said:

You need to map port 1900, but not sure if it works as plex already use it. 

Another solution is to give the airsonic its own IP. 

Thanks.  I turned off PLEX and added added the following port config to the docker container.  I also tried setting Network Type=Host; Privileged=On.  Still no luck. 

  • Config Type: Port
  • Name: DLNA Port
  • Container Port: 1900
  • Host Port: 1900
  • Connection Type: UDP
  • Description: DLNA Port

 

Still confused about the proper usage of "LAN Server address" in the Airsonic web console.  Any other suggestions?

 

Share this post


Link to post
6 hours ago, dboonthego said:

Thanks.  I turned off PLEX and added added the following port config to the docker container.  I also tried setting Network Type=Host; Privileged=On.  Still no luck. 

  • Config Type: Port
  • Name: DLNA Port
  • Container Port: 1900
  • Host Port: 1900
  • Connection Type: UDP
  • Description: DLNA Port

 

Still confused about the proper usage of "LAN Server address" in the Airsonic web console.  Any other suggestions?

 

 

I have never tried it myself, so not sure about the Lan server address. Try setting it to the IP:port/airsonic. It's should be the same address as you use for accessing airsonic in a browser. 

 

Edit: Just tested here. You need to give airsonic its own IP for it to work. Edit the template, change network to br0, give it an IP of your local network in the IP field. 

Be sure to set the Lan server in airsonic settings to how you access the server. Should be the above I mentioned earlier. 

Edited by saarg

Share this post


Link to post
10 hours ago, saarg said:

Try setting it to the IP:port/airsonic. It's should be the same address as you use for accessing airsonic in a browser. 

Thanks for the clarification.  That is how I am setting; with a trailing '/' slash.

10 hours ago, saarg said:

You need to give airsonic its own IP for it to work. Edit the template, change network to br0, give it an IP of your local network in the IP field. 

Network type is set to Bridge, but the template does not have an IP field.  Not sure how to assign this.

Share this post


Link to post
2 hours ago, dboonthego said:

Thanks for the clarification.  That is how I am setting; with a trailing '/' slash.

Network type is set to Bridge, but the template does not have an IP field.  Not sure how to assign this.

You need to enable it in docker settings in unraid first i think. 

Share this post


Link to post
On 11/27/2018 at 3:37 AM, saarg said:

 

If you are still pre 6.4 it's about time to update 😲

Truth.  Upgraded to 6.6.5 last week and found the time to play with Airsonic again tonight.  DLNA is finally working!  ... but I feel like it should have also worked without the OS update.  Thanks for the help.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now