Jump to content
binhex

[Support] binhex - NZBHydra2

26 posts in this topic Last Reply

Recommended Posts

Overview: Support for Docker image arch-nzbhydra2 in the binhex repo.

Application: NZBHydra2 - https://github.com/theotherp/nzbhydra2

Docker Hub: https://hub.docker.com/r/binhex/arch-nzbhydra2/

GitHub: https://github.com/binhex/arch-nzbhydra2

Documentationhttps://github.com/binhex/documentation

 

For other Docker support threads and requests, news and Docker template support for the binhex repository please use the "General" thread here


If you appreciate my work, then please consider buying me a beer  :D

 

btn_donate_SM.gif

Edited by binhex

Share this post


Link to post

Please note the template is not uploaded yet and thus won't be visible in CA, please check back in approx 8 hours from this post and it should be there.

 

Please also note this application is currently marked as "alpha" and thus is still under heavy development, it may or may not have bugs.

Edited by binhex

Share this post


Link to post

The docker is now available in CA, just an FYI.

 

This isn't loading for me, this just keeps going in the log over and over:


e":"No such container: f08423aa0af6"}
 

Edited by Dimtar

Share this post


Link to post
The docker is now available in CA, just an FYI.
 
This isn't loading for me, this just keeps going in the log over and over:

e":"No such container: f08423aa0af6"}
 
Try latest image just built

Sent from my SM-G935F using Tapatalk

Share this post


Link to post

Hey @binhex Is upgrade automatic with the newest releases of nzbhydra2 or do you have to upgrade the docker manually for us to get the new version?

Share this post


Link to post
47 minutes ago, woble said:

Hey @binhex Is upgrade automatic with the newest releases of nzbhydra2 or do you have to upgrade the docker manually for us to get the new version?

 

I believe its the latter.

 

Share this post


Link to post
 

I believe its the latter.

 

It is the latter, I have automation scripts in place that monitor and auto build on new release, this will then once built show up in unraid for you as an update.

 

Sent from my SM-G935F using Tapatalk

 

 

 

Share this post


Link to post

Looking for an update if possible:

"An update is available. Your version: 1.4.0. Latest version: 1.4.1. You seem to be running Hydra inside docker. Please update your container."

Thanks for your work binhex!

Share this post


Link to post
6 hours ago, dstanley said:

Looking for an update if possible:

"An update is available. Your version: 1.4.0. Latest version: 1.4.1. You seem to be running Hydra inside docker. Please update your container."

Thanks for your work binhex!

 

it's fully automated, it will happen.

Share this post


Link to post

just pulled latest build

 

___.   .__       .__                   
\_ |__ |__| ____ |  |__   ____ ___  ___
 | __ \|  |/    \|  |  \_/ __ \\  \/  /
 | \_\ \  |   |  \   Y  \  ___/ >    < 
 |___  /__|___|  /___|  /\___  >__/\_ \
     \/        \/     \/     \/      \/
   https://hub.docker.com/u/binhex/

2018-03-16 23:44:38.486664 [info] System information Linux ec1dc240d262 4.9.0-0.bpo.3-amd64 #1 SMP Debian 4.9.30-2~bpo8+1 (2017-06-14) x86_64 GNU/Linux
2018-03-16 23:44:38.574209 [info] PUID defined as '1000'
2018-03-16 23:44:38.667035 [warn] PGID not defined (via -e PGID), defaulting to '100'
2018-03-16 23:44:38.857990 [warn] UMASK not defined (via -e UMASK), defaulting to '000'
2018-03-16 23:44:38.947159 [info] Permissions already set for volume mappings
2018-03-16 23:44:39.030368 [info] Setting permissions on files/folders inside container...
chown: cannot access '/var/lib/nzbhydra2': No such file or directory

binhex/arch-nzbhydra2: 1.4.7-1-01 works

Edited by saitoh183

Share this post


Link to post

You can roll back to `1.4.7-1-01` by changing the repo to `binhex/arch-nzbhydra2:1.4.7-1-01`.

 

Anyone else experiencing v2 crashing and needing to restart the docker? Happens to me every few days or so. Unsure if it's related to the beta state of hydra or the docker itself.

Share this post


Link to post

i posted this in the plexpass support as well as its same problem with binehex's more recent update to plexpass. i think binhex is playing with new code and its not playing well with unraid 6.x ;)

Share this post


Link to post

check the docker hub see a 4hr old version 1.4.8-1-01 maybe its fixed now.   I test and post

Share this post


Link to post
On 18/03/2018 at 7:51 AM, Can0nfan said:

i think binhex is playing with new code and its not playing well with unraid 6.x ;)

 

its a change in install location in the AUR package, which is maintained by somebody else and thus out of my control, ive put some newer code (need to spam it around to all builds ugg) to cope with this and blow up during build to prevent an image being produced that won't then run, so at least i now be alerted to the fact something is wrong before users start getting vocal :-). 

Share this post


Link to post

Installed, configured, worked first time and used it all day but......

 

After stopping all dockers to do an appdata save, and then restarting again, this docker cant be accessed (says started ok)  Logs suggest a tomcat error - as if the port is in use but I have changed it on the startup and it does not matter what port I use - same error on diff ports each start.

 

org.apache.catalina.LifecycleException: Failed to start component [Connector[HTTP/1.1-5076]]
    at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:167)
    at org.apache.catalina.core.StandardService.addConnector(StandardService.java:225)
    at org.springframework.boot.web.embedded.tomcat.TomcatWebServer.addPreviouslyRemovedConnectors(TomcatWebServer.java:256)
    at org.springframework.boot.web.embedded.tomcat.TomcatWebServer.start(TomcatWebServer.java:198)
    at org.springframework.boot.web.servlet.context.ServletWebServerApplicationContext.startWebServer(ServletWebServerApplicationContext.java:300)
    at org.springframework.boot.web.servlet.context.ServletWebServerApplicationContext.finishRefresh(ServletWebServerApplicationContext.java:162)
    at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:553)
    at org.springframework.boot.web.servlet.context.ServletWebServerApplicationContext.refresh(ServletWebServerApplicationContext.java:140)
    at org.springframework.boot.SpringApplication.refresh(SpringApplication.java:762)
    at org.springframework.boot.SpringApplication.refreshContext(SpringApplication.java:398)
    at org.springframework.boot.SpringApplication.run(SpringApplication.java:330)
    at org.nzbhydra.NzbHydra.startup(NzbHydra.java:160)
    at org.nzbhydra.NzbHydra.main(NzbHydra.java:114)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.springframework.boot.loader.MainMethodRunner.run(MainMethodRunner.java:48)
    at org.springframework.boot.loader.Launcher.launch(Launcher.java:87)
    at org.springframework.boot.loader.Launcher.launch(Launcher.java:50)
    at org.springframework.boot.loader.JarLauncher.main(JarLauncher.java:51)
Caused by: org.apache.catalina.LifecycleException: Protocol handler start failed
    at org.apache.catalina.connector.Connector.startInternal(Connector.java:1020)
    at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
    ... 20 common frames omitted
Caused by: java.net.BindException: Cannot assign requested address
    at sun.nio.ch.Net.bind0(Native Method)
    at sun.nio.ch.Net.bind(Net.java:433)
    at sun.nio.ch.Net.bind(Net.java:425)
    at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223)
    at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)
    at org.apache.tomcat.util.net.NioEndpoint.bind(NioEndpoint.java:210)
    at org.apache.tomcat.util.net.AbstractEndpoint.start(AbstractEndpoint.java:1150)
    at org.apache.coyote.AbstractProtocol.start(AbstractProtocol.java:591)
    at org.apache.catalina.connector.Connector.startInternal(Connector.java:1018)
    ... 21 common frames omitted

 

2018-09-16 12:09:53.312 ERROR --- [           main] o.s.b.d.LoggingFailureAnalysisReporter   : 

***************************
APPLICATION FAILED TO START
***************************

Description:

The Tomcat connector configured to listen on port 5076 failed to start. The port may already be in use or the connector may be misconfigured.

Action:

Verify the connector's configuration, identify and stop any process that's listening on port 5076, or configure this application to listen on another port.

Share this post


Link to post

It looks like this container is still out of date. It's running v2.2.0, but the latest is v.2.3.0. Is there something wrong on my end, or has it simply not been updated yet?

Share this post


Link to post
53 minutes ago, seannymurrs said:

It looks like this container is still out of date. It's running v2.2.0, but the latest is v.2.3.0. Is there something wrong on my end, or has it simply not been updated yet?

its fully up to date, current ver is 2.3.3 built image.

https://github.com/binhex/arch-nzbhydra2/releases

Share this post


Link to post

I'm looking for help with this, when for example when radarr is running a search for John Wick Hydra sends back titles for john wick but also other random film titles, what setting would i need to change for this issue, thanks in advance.  

Share this post


Link to post

I have the same question...  Are there any options on the search?  I use both Radar, Sonar and then the Jacket Search.   When I search for a movie with the Jacket Search, it returns pages of results that I have to sift through.

 

Thanks. 

Share this post


Link to post

Hi All, I'm coming across an issue when searching from Sonarr to Hydra where for example I search for a series it shows me results for it but also shows results from a completely different series, added a pic to show it, how do I stop this happening? 

Screenshot 2019-05-19 at 12.50.11.png

Share this post


Link to post

First of all thank you for all your hard work.

 

I can setup the docker and use the search in the web interface and even send from the web UI to a downloader.

the issue i am having is getting an external app to call to the api. i have tried giving the docker privileged and without. i have changed network from bridged to host and back again. i have changed the ip to the server ip and back to 0.0.0.0 andi have tried local ip ignoring and going through the proxie. i am lost of what i am doing wrong.  

Share this post


Link to post

hmmm... 

 

I'm unable to access the webgui and my other dockers are unable to communicate with my Hydra2 instance.   It shows running in Unraid, however the log shows...
 

�[2m2019-09-12 20:52:39.950�[0;39m �[31mERROR�[0;39m �[2m---�[0;39m �[2m[ main]�[0;39m �[36morg.nzbhydra.NzbHydra �[0;39m �[2m:�[0;39m�[35m �[0;39m�[34m�[0;39mAn unexpected error occurred during startup

org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'entityManagerFactory' defined in class path resource [org/springframework/boot/autoconfigure/orm/jpa/HibernateJpaConfiguration.class]: Invocation of init method failed; nested exception is org.hibernate.boot.archive.spi.ArchiveException: Unable to extract bytes from InputStream
Caused by: java.io.IOException: Input/output error

 

Suggestions?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.