Jump to content
Djoss

[Support] Djoss - FileBot

167 posts in this topic Last Reply

Recommended Posts

I'm also having the Grey Box issue, I guess from timeouts/rate limiting by the DB provider (I get it with all providers but at different stages).

 

I figured I'd see if I could get any more sensible debug out of the cli, but my container doesn't appear to have /usr/bin/filebot.sh and find / filebot* doesn't give any results.

 

I'm using the latest docker image on 6.5.3. The logs seem to only make reference to the UI connection.

Share this post


Link to post
13 hours ago, jebk said:

I'm also having the Grey Box issue, I guess from timeouts/rate limiting by the DB provider (I get it with all providers but at different stages).

 

I figured I'd see if I could get any more sensible debug out of the cli, but my container doesn't appear to have /usr/bin/filebot.sh and find / filebot* doesn't give any results.

 

I'm using the latest docker image on 6.5.3. The logs seem to only make reference to the UI connection.

 

Do you have/see a way to reproduce ?  I've never be able to see this issue...

Share this post


Link to post
18 hours ago, Djoss said:

 

Do you have/see a way to reproduce ?  I've never be able to see this issue...

Basically run it, but I can't. I left it running and it actually did start moving stuff so obviously a GUI hang. Unfortunately I hadn't set the format so I had to stop it, and haaven't had chance to restart yet.

Share this post


Link to post

Unfortunately updating the docker to the latest version of the app now make it not-so-useful as in the past, because now Filebot need a license to rename the files :(

Edited by M4st3r

Share this post


Link to post
6 hours ago, M4st3r said:

Unfortunately updating the docker to the latest version of the app now make it not-so-useful as in the past, because now Filebot need a license to rename the files :(

 

Yes but the license is very cheap (6$/year).  However, you can still use the old version, see:

 

https://github.com/jlesage/docker-filebot/blob/master/README.md#donation-supported-version

Share this post


Link to post
On 8/25/2018 at 4:04 PM, cybrnook said:

------------------- UPDATE AVAILABLE: FileBot 4.8.2 (r5789) --------------------

 

Thanks for reporting.  A new image build is in progress!

Share this post


Link to post
On 8/25/2018 at 4:06 PM, cybrnook said:

Also getting the grey box:

image.thumb.png.a758a0f5f933d67154e91e109144899a.png

 


******************************************************************************
Have you tried the x11vnc '-ncache' VNC client-side pixel caching feature yet?

The scheme stores pixel data offscreen on the VNC viewer side for faster
retrieval. It should work with any VNC viewer. Try it by running:

x11vnc -ncache 10 ...

One can also add -ncache_cr for smooth 'copyrect' window motion.
More info: http://www.karlrunge.com/x11vnc/faq.html#faq-client-caching

FileBot 4.8.2 (r5768)
JNA Native: 5.2.0
MediaInfo: 18.05
Apache Commons VFS: [zip, rar]
Chromaprint: 1.4.3
Extended Attributes: OK
Unicode Filesystem: OK
Script Bundle: 2018-08-14 (r534)
Groovy: 2.5.0
JRE: OpenJDK Runtime Environment 1.8.0_171
JVM: 64-bit OpenJDK 64-Bit Server VM
CPU/MEM: 28 Core / 13 GB Max Memory / 40 MB Used Memory
OS: Linux (amd64)
HW: Linux 09bde228b294 4.14.49-unRAID #1 SMP Mon Jun 11 16:21:07 PDT 2018 x86_64 Linux
DATA: /config
Package: DOCKER

------------------- UPDATE AVAILABLE: FileBot 4.8.2 (r5789) --------------------

Done ヾ(@⌒ー⌒@)ノ
25/08/2018 16:02:30 Got connection from client 127.0.0.1
25/08/2018 16:02:30 other clients:
25/08/2018 16:02:30 Got 'ws' WebSockets handshake
25/08/2018 16:02:30 Got protocol: binary
25/08/2018 16:02:30 - webSocketsHandshake: using binary/raw encoding
25/08/2018 16:02:30 - WebSockets client version hybi-13

25/08/2018 16:02:30 Disabled X server key autorepeat.
25/08/2018 16:02:30 to force back on run: 'xset r on' (3 times)
25/08/2018 16:02:30 incr accepted_client=1 for 127.0.0.1:37248 sock=10
25/08/2018 16:02:30 Client Protocol Version 3.8

25/08/2018 16:02:30 Protocol version sent 3.8, using 3.8

25/08/2018 16:02:30 rfbProcessClientSecurityType: executing handler for type 1
25/08/2018 16:02:30 rfbProcessClientSecurityType: returning securityResult for client rfb version >= 3.8

25/08/2018 16:02:30 Pixel format for client 127.0.0.1:
25/08/2018 16:02:30 32 bpp, depth 24, little endian
25/08/2018 16:02:30 true colour: max r 255 g 255 b 255, shift r 16 g 8 b 0
25/08/2018 16:02:30 no translation needed
25/08/2018 16:02:30 Enabling NewFBSize protocol extension for client 127.0.0.1
25/08/2018 16:02:30 Enabling full-color cursor updates for client 127.0.0.1
25/08/2018 16:02:30 Using image quality level 6 for client 127.0.0.1
25/08/2018 16:02:30 Using JPEG subsampling 0, Q79 for client 127.0.0.1
25/08/2018 16:02:30 Using compression level 9 for client 127.0.0.1
25/08/2018 16:02:30 Enabling LastRect protocol extension for client 127.0.0.1
25/08/2018 16:02:30 rfbProcessClientNormalMessage: ignoring unsupported encoding type Enc(0xFFFFFECC)
25/08/2018 16:02:30 Using tight encoding for client 127.0.0.1
Prism pipeline init order: sw
Using java-based Pisces rasterizer
Using dirty region optimizations
Not using texture mask for primitives
Not forcing power of 2 sizes for textures
Using hardware CLAMP_TO_ZERO mode
Opting in for HiDPI pixel scaling
*** Fallback to Prism SW pipeline
Prism pipeline name = com.sun.prism.sw.SWPipeline
(X) Got class = class com.sun.prism.sw.SWPipeline
Initialized prism pipeline: com.sun.prism.sw.SWPipeline
vsync: true vpipe: false
25/08/2018 16:02:30 client_set_net: 127.0.0.1 0.0000
25/08/2018 16:02:30 created xdamage object: 0x40002c
25/08/2018 16:02:30 client 1 network rate 914.1 KB/sec (102632.7 eff KB/sec)
25/08/2018 16:02:30 client 1 latency: 0.6 ms
25/08/2018 16:02:30 dt1: 0.0074, dt2: 0.0312 dt3: 0.0006 bytes: 35027
25/08/2018 16:02:30 link_rate: LR_LAN - 1 ms, 914 KB/s
25/08/2018 16:02:30 copy_tiles: allocating first_line at size 41
25/08/2018 16:02:40 created selwin: 0x40002d
25/08/2018 16:02:40 called initialize_xfixes()

 

 

I will contact the author of FileBot to see if there is something to do about this.

Share this post


Link to post

There is now an update to the container image that should fix the grey box issue.

Share this post


Link to post
On 4/18/2018 at 7:35 PM, Djoss said:

Yes it's definitely possible to have a "watch" folder and I'm planning to do it.  I'm just not sure yet what is the best way: simply call a user-defined script periodically (where the user will have the ability to call the AMC script) or have something more targeted toward the AMC script (where its behaviour is configurable via container settings (environment variables)).

 

Did a "watch folder" ever get implemented? 

Share this post


Link to post
19 hours ago, FireFtw said:

Did a "watch folder" ever get implemented? 

No yet, but this feature is still planned.

Share this post


Link to post

I am having a hard time finding a few things you referenced before with kizer, mainly how to run it from command line (/usr/bin/filebot.sh does not exist) and being able to have a folder run a script automatically after some time. Anywhere you can point me for those?

Share this post


Link to post

Hey Djoss,

it's me again 🙂

 

I have two things that would be really awesome with this and also with your other containers.

 

The first thing/suggestion is:

I have two locations where i need to specify my files. This is due to heavy storage and the storage is split

between two volumes. (Now it's about 60TB of data - split to two RAID volumes) Could you please add the possibility to specify two /output folders ? ...that would be awesome. I think it would be totally fine if FileBot or any other container app will show all of the two outputs all together in the container app.

 

The second thing/suggestion is:

Is there a way to disable right click in the web gui sessions?   ...i mean i have two right click menus the one from the app and the one from my operating system. Would be really nice to have the os right click menu disabled.

 

And additionally i want to note that the copy/paste function in the web gui seems to be broken as it will not insert the written text into the container app dialog. (Clipboard function not working)

I noticed this while i tried to paste my template for renaming to the web gui. I have a very, very long template which i not really want to enter /update manually :-)

Edited by dockerstarter

Share this post


Link to post
12 hours ago, FireFtw said:

I am having a hard time finding a few things you referenced before with kizer, mainly how to run it from command line (/usr/bin/filebot.sh does not exist) and being able to have a folder run a script automatically after some time. Anywhere you can point me for those?

The executable is at "/opt/filebot/filebot".

As for the watch folder, it is not available yet.

Share this post


Link to post
7 hours ago, dockerstarter said:

The first thing/suggestion is:

I have two locations where i need to specify my files. This is due to heavy storage and the storage is split

between two volumes. (Now it's about 60TB of data - split to two RAID volumes) Could you please add the possibility to specify two /output folders ? ...that would be awesome. I think it would be totally fine if FileBot or any other container app will show all of the two outputs all together in the container app.

You can map as many folders as you want.  The template juste gives some defaults that are useful for most common scenario.  If you want an additional output folder, juste edit the container settings and add a new "path" by clicking the "Add another Path, Port, Variable, Label or Device" link.

 

7 hours ago, dockerstarter said:

The second thing/suggestion is:

Is there a way to disable right click in the web gui sessions?   ...i mean i have two right click menus the one from the app and the one from my operating system. Would be really nice to have the os right click menu disabled.

Which operating system and browser are you using?  This should works well, a right click being handled only by the app.

 

7 hours ago, dockerstarter said:

And additionally i want to note that the copy/paste function in the web gui seems to be broken as it will not insert the written text into the container app dialog. (Clipboard function not working)

I noticed this while i tried to paste my template for renaming to the web gui. I have a very, very long template which i not really want to enter /update manually :-)

Again, this should also work.

Share this post


Link to post
4 hours ago, Djoss said:

Again, this should also work.

 

Aha,

oh okay then let us try to solve the issue.

I am using Linux Mint 19 (Ubuntu 18.04 LTS) as my main operatings systems together with Firefox as my browser.

Edited by dockerstarter

Share this post


Link to post
5 minutes ago, dockerstarter said:

 

Aha,

oh okay then let us try to solve the issue.

I am using Linux Mint 19 (Ubuntu 18.04 LTS) as my main operatings systems together with Firefox as my browser.

Ok I also have this setup and both the right click et clipboard works.  Did you tried Chrome to see if you have the same issues?

Share this post


Link to post

Will check that now and get back to you with the results 🙂

 

 

Edit: Wow with Chromium it did work and then i retried it with Firefox and it worked, too again. Kinda weird because yesterday it didn't work. I did some updates on my operating system and i remember that the graphics from the top bars of windows on the apps look a bit different (more modern) now. Im not sure what or who fixed it 🙈

Did you update anything? (i have watchtower running which automatically pulls and updates my containers)

 

 

Edit: The integrated clipboard function is not working. But copy and paste with ctrl+c and ctrl+v works great.

Edited by dockerstarter

Share this post


Link to post

hi, may an idea about Filebot error, i guess since 664 (happened last nite, updated today to 665, same behavior)

 

from log

 

Use excludes: /config/amc-exclude-list.txt (1)
Ignore hidden: /media/Temp/.keep
#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x000014d6dad1aa72, pid=243, tid=0x000014d712366700
#
# JRE version: Java(TM) SE Runtime Environment (8.0_161-b12) (build 1.8.0_161-b12)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (25.161-b12 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C [libmediainfo.so.0+0x3c3a72]
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /tmp/hs_err_pid243.log

 

i attached the error log in case its useful, i use filebot without GUI as note (config GUI no)

 

for an tip, thanks ahead ;)

hs_err_pid243.log

Edited by alturismo

Share this post


Link to post
4 hours ago, alturismo said:

hi, may an idea about Filebot error, i guess since 664 (happened last nite, updated today to 665, same behavior)

 

from log

 

Use excludes: /config/amc-exclude-list.txt (1)
Ignore hidden: /media/Temp/.keep
#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x000014d6dad1aa72, pid=243, tid=0x000014d712366700
#
# JRE version: Java(TM) SE Runtime Environment (8.0_161-b12) (build 1.8.0_161-b12)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (25.161-b12 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C [libmediainfo.so.0+0x3c3a72]
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /tmp/hs_err_pid243.log

 

i attached the error log in case its useful, i use filebot without GUI as note (config GUI no)

 

for an tip, thanks ahead ;)

hs_err_pid243.log

I think you are in the wrong thread.  Are you using coppit's container?

Share this post


Link to post
7 hours ago, Djoss said:

I think you are in the wrong thread.  Are you using coppit's container?

urgs, sorry, yes i do ...

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.