[Support] ich777 - Application Dockers


ich777

Recommended Posts

Also isn't ComicRack a GUI application for Windows? 
==> Yes it's that I have build a docker with wine and winetricks because, to be precise, it's doesn't work with mono-gecko we need to install wintricks and dotnet45 (and other tools wmi corefonts wsh57 all installable in the container) in this case I can launch the application without error. In the docker I share a directory (where the comics are stocked) with the wine explorer application I don't have any problem to read the directory. 

But Comicrack can't read the same directory (she don't launch the files parser) it's for that I suppose it's a problem between the dotnet45 and the directory shared by unraid because estrangely it's work when i deploy the same docker locally.   

 

How would you display it through Unraid?
==> Like an application in a light desktop (it's work) the target it's to use comicrack like comics file manager (it's really advanced for that)  and ubooquity for readings (it's one of tools which have the particularity to read the comicrack metadata). And you a very cool result for example :

 

Comixology.thumb.jpg.4b8865f3e003ee05c15b2db9ccea3296.jpg

Edited by Gunnm
Link to comment

Hello, I just installed PhotoPrism, I didnt change anything except add a password that is asks for. It starts, however when I go to the webgui it isnt working. I get "this site cant be reached" page

 

 

Is there something in my Unraid that is causing this? The docker template network type is still set to the default Bridge. I'm not having a issue like this with any other apps.

Edited by SPOautos
Link to comment
58 minutes ago, SPOautos said:

Hello, I just installed PhotoPrism, I didnt change anything except add a password that is asks for. It starts, however when I go to the webgui it isnt working. I get "this site cant be reached" page

 

 

Is there something in my Unraid that is causing this? The docker template network type is still set to the default Bridge. I'm not having a issue like this with any other apps.

I also tried it here and no problem so far (I also changed only the password), can you try to change the network to host?

Eventually something in the network settings is messed up...

Bildschirmfoto_2020-10-19_18-04-39.thumb.png.d594c48d4aeef073f78f02dab33e369b.png

Link to comment
32 minutes ago, ich777 said:

I also tried it here and no problem so far (I also changed only the password), can you try to change the network to host?

Eventually something in the network settings is messed up...

Bildschirmfoto_2020-10-19_18-04-39.thumb.png.d594c48d4aeef073f78f02dab33e369b.png

 

Changed to host, but its still doing the same.  I'm not sure what it could be except Swag reverse proxy but typically when I install apps Swag doesnt have any affect on them unless I assign them to the custom network type that is related to the reverse proxy. 

 

Do you have any ideas where I should start looking? I tried stopping Swag and that didn't make any difference either.

Edited by SPOautos
Link to comment
18 minutes ago, SPOautos said:

Changed to host, but its still doing the same.  I'm not sure what it could be except Swag reverse proxy but typically when I install apps Swag doesnt have any affect on them unless I assign them to the custom network type that is related to the reverse proxy. 

How do you connect to it? YOURSERVERIP:PORT or did you just reverse proxy anything yet?

Can you give me the log output?

 

Have you configured something in your Unraid Network configuration? Have you installed a Cache drive? Can you provide a screenshot from the template?

Link to comment
19 hours ago, Gunnm said:

I want to create a fork of your project debian-buster-nvidia to add lutris.

Go in the Docker template and change the 'Repository' from 'ich777/debian-buster:nvidia-steam' to 'ich777/debian-buster:nvidia-steam-lutris' and you have Lutris fully installed.

Link to comment
45 minutes ago, ich777 said:

How do you connect to it? YOURSERVERIP:PORT or did you just reverse proxy anything yet?

Can you give me the log output?

 

Have you configured something in your Unraid Network configuration? Have you installed a Cache drive? Can you provide a screenshot from the template?

 

I just went to PhotoPrism in the docker tab, clicked and went to webgui.  It tried to open it up in the brower using the serverip:2342 but says that it cant for some reason. However I can open other apps just fine. Just late last night I installed DiskSpeed which also installs in Bridge type and its webui opens in the browser using the serverip:port and it opens fine. I dont see what going be going on that would cause two apps both using Bridge type and the same ip with just different port numbers to open one and not the other. 

 

Here is the log info.....

panic: attempt to write a readonly database

goroutine 1 [running]:
github.com/photoprism/photoprism/internal/entity.Types.Migrate(0xc0157209c0)
/go/src/github.com/photoprism/photoprism/internal/entity/entity.go:106 +0x234
github.com/photoprism/photoprism/internal/entity.MigrateDb()
/go/src/github.com/photoprism/photoprism/internal/entity/entity.go:134 +0x2d
github.com/photoprism/photoprism/internal/config.(*Config).InitDb(0xc013803700)
/go/src/github.com/photoprism/photoprism/internal/config/db.go:110 +0x49
github.com/photoprism/photoprism/internal/commands.startAction(0xc01380c2c0, 0x0, 0xc013803560)
/go/src/github.com/photoprism/photoprism/internal/commands/start.go:71 +0x20a
github.com/urfave/cli.HandleAction(0xf4c6a0, 0x111a570, 0xc01380c2c0, 0xc01380c2c0, 0x0)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/app.go:526 +0xfd
github.com/urfave/cli.Command.Run(0x10a065f, 0x5, 0x0, 0x0, 0x17d78f0, 0x1, 0x1, 0x10b5d47, 0x11, 0x0, ...)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/command.go:174 +0x58e
github.com/urfave/cli.(*App).Run(0xc013816000, 0xc00012c000, 0x2, 0x2, 0x0, 0x0)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/app.go:279 +0x7e8
main.main()
/go/src/github.com/photoprism/photoprism/cmd/photoprism/photoprism.go:71 +0x529
usermod: no changes
panic: attempt to write a readonly database

goroutine 1 [running]:
github.com/photoprism/photoprism/internal/entity.Types.Migrate(0xc0034c78f0)
/go/src/github.com/photoprism/photoprism/internal/entity/entity.go:106 +0x234
github.com/photoprism/photoprism/internal/entity.MigrateDb()
/go/src/github.com/photoprism/photoprism/internal/entity/entity.go:134 +0x2d
github.com/photoprism/photoprism/internal/config.(*Config).InitDb(0xc01b6916c0)
/go/src/github.com/photoprism/photoprism/internal/config/db.go:110 +0x49
github.com/photoprism/photoprism/internal/commands.startAction(0xc01b69a2c0, 0x0, 0xc01b691520)
/go/src/github.com/photoprism/photoprism/internal/commands/start.go:71 +0x20a
github.com/urfave/cli.HandleAction(0xf4c6a0, 0x111a570, 0xc01b69a2c0, 0xc01b69a2c0, 0x0)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/app.go:526 +0xfd
github.com/urfave/cli.Command.Run(0x10a065f, 0x5, 0x0, 0x0, 0x17d78f0, 0x1, 0x1, 0x10b5d47, 0x11, 0x0, ...)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/command.go:174 +0x58e
github.com/urfave/cli.(*App).Run(0xc01b6a4000, 0xc00012c000, 0x2, 0x2, 0x0, 0x0)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/app.go:279 +0x7e8
main.main()
/go/src/github.com/photoprism/photoprism/cmd/photoprism/photoprism.go:71 +0x529
usermod: no changes
panic: attempt to write a readonly database

goroutine 1 [running]:
github.com/photoprism/photoprism/internal/entity.Types.Migrate(0xc0119e5b60)
/go/src/github.com/photoprism/photoprism/internal/entity/entity.go:106 +0x234
github.com/photoprism/photoprism/internal/entity.MigrateDb()
/go/src/github.com/photoprism/photoprism/internal/entity/entity.go:134 +0x2d
github.com/photoprism/photoprism/internal/config.(*Config).InitDb(0xc0005af640)
/go/src/github.com/photoprism/photoprism/internal/config/db.go:110 +0x49
github.com/photoprism/photoprism/internal/commands.startAction(0xc0005b62c0, 0x0, 0xc0005af4a0)
/go/src/github.com/photoprism/photoprism/internal/commands/start.go:71 +0x20a
github.com/urfave/cli.HandleAction(0xf4c6a0, 0x111a570, 0xc0005b62c0, 0xc0005b62c0, 0x0)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/app.go:526 +0xfd
github.com/urfave/cli.Command.Run(0x10a065f, 0x5, 0x0, 0x0, 0x17d78f0, 0x1, 0x1, 0x10b5d47, 0x11, 0x0, ...)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/command.go:174 +0x58e
github.com/urfave/cli.(*App).Run(0xc0005be000, 0xc00012c000, 0x2, 0x2, 0x0, 0x0)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/app.go:279 +0x7e8
main.main()
/go/src/github.com/photoprism/photoprism/cmd/photoprism/photoprism.go:71 +0x529
usermod: no changes
panic: attempt to write a readonly database

goroutine 1 [running]:
github.com/photoprism/photoprism/internal/entity.Types.Migrate(0xc011971ef0)
/go/src/github.com/photoprism/photoprism/internal/entity/entity.go:106 +0x234
github.com/photoprism/photoprism/internal/entity.MigrateDb()
/go/src/github.com/photoprism/photoprism/internal/entity/entity.go:134 +0x2d
github.com/photoprism/photoprism/internal/config.(*Config).InitDb(0xc0007a3640)
/go/src/github.com/photoprism/photoprism/internal/config/db.go:110 +0x49
github.com/photoprism/photoprism/internal/commands.startAction(0xc0007ac2c0, 0x0, 0xc0007a34a0)
/go/src/github.com/photoprism/photoprism/internal/commands/start.go:71 +0x20a
github.com/urfave/cli.HandleAction(0xf4c6a0, 0x111a570, 0xc0007ac2c0, 0xc0007ac2c0, 0x0)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/app.go:526 +0xfd
github.com/urfave/cli.Command.Run(0x10a065f, 0x5, 0x0, 0x0, 0x17d78f0, 0x1, 0x1, 0x10b5d47, 0x11, 0x0, ...)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/command.go:174 +0x58e
github.com/urfave/cli.(*App).Run(0xc0007b4000, 0xc000132000, 0x2, 0x2, 0x0, 0x0)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/app.go:279 +0x7e8
main.main()
/go/src/github.com/photoprism/photoprism/cmd/photoprism/photoprism.go:71 +0x529
usermod: no changes
panic: attempt to write a readonly database

goroutine 1 [running]:
github.com/photoprism/photoprism/internal/entity.Types.Migrate(0xc0001d1d10)
/go/src/github.com/photoprism/photoprism/internal/entity/entity.go:106 +0x234
github.com/photoprism/photoprism/internal/entity.MigrateDb()
/go/src/github.com/photoprism/photoprism/internal/entity/entity.go:134 +0x2d
github.com/photoprism/photoprism/internal/config.(*Config).InitDb(0xc0135e2300)
/go/src/github.com/photoprism/photoprism/internal/config/db.go:110 +0x49
github.com/photoprism/photoprism/internal/commands.startAction(0xc0046e8580, 0x0, 0xc0135e2160)
/go/src/github.com/photoprism/photoprism/internal/commands/start.go:71 +0x20a
github.com/urfave/cli.HandleAction(0xf4c6a0, 0x111a570, 0xc0046e8580, 0xc0046e8580, 0x0)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/app.go:526 +0xfd
github.com/urfave/cli.Command.Run(0x10a065f, 0x5, 0x0, 0x0, 0x17d78f0, 0x1, 0x1, 0x10b5d47, 0x11, 0x0, ...)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/command.go:174 +0x58e
github.com/urfave/cli.(*App).Run(0xc010454380, 0xc000132000, 0x2, 0x2, 0x0, 0x0)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/app.go:279 +0x7e8
main.main()
/go/src/github.com/photoprism/photoprism/cmd/photoprism/photoprism.go:71 +0x529
usermod: no changes
panic: attempt to write a readonly database

goroutine 1 [running]:
github.com/photoprism/photoprism/internal/entity.Types.Migrate(0xc01367c9c0)
/go/src/github.com/photoprism/photoprism/internal/entity/entity.go:106 +0x234
github.com/photoprism/photoprism/internal/entity.MigrateDb()
/go/src/github.com/photoprism/photoprism/internal/entity/entity.go:134 +0x2d
github.com/photoprism/photoprism/internal/config.(*Config).InitDb(0xc01c5e1680)
/go/src/github.com/photoprism/photoprism/internal/config/db.go:110 +0x49
github.com/photoprism/photoprism/internal/commands.startAction(0xc01c5ea2c0, 0x0, 0xc01c5e14e0)
/go/src/github.com/photoprism/photoprism/internal/commands/start.go:71 +0x20a
github.com/urfave/cli.HandleAction(0xf4c6a0, 0x111a570, 0xc01c5ea2c0, 0xc01c5ea2c0, 0x0)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/app.go:526 +0xfd
github.com/urfave/cli.Command.Run(0x10a065f, 0x5, 0x0, 0x0, 0x17d78f0, 0x1, 0x1, 0x10b5d47, 0x11, 0x0, ...)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/command.go:174 +0x58e
github.com/urfave/cli.(*App).Run(0xc01c5f4000, 0xc00000e060, 0x2, 0x2, 0x0, 0x0)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/app.go:279 +0x7e8
main.main()
/go/src/github.com/photoprism/photoprism/cmd/photoprism/photoprism.go:71 +0x529
usermod: no changes
panic: attempt to write a readonly database

goroutine 1 [running]:
github.com/photoprism/photoprism/internal/entity.Types.Migrate(0xc0136d49c0)
/go/src/github.com/photoprism/photoprism/internal/entity/entity.go:106 +0x234
github.com/photoprism/photoprism/internal/entity.MigrateDb()
/go/src/github.com/photoprism/photoprism/internal/entity/entity.go:134 +0x2d
github.com/photoprism/photoprism/internal/config.(*Config).InitDb(0xc0137601c0)
/go/src/github.com/photoprism/photoprism/internal/config/db.go:110 +0x49
github.com/photoprism/photoprism/internal/commands.startAction(0xc0136506e0, 0x0, 0xc013760020)
/go/src/github.com/photoprism/photoprism/internal/commands/start.go:71 +0x20a
github.com/urfave/cli.HandleAction(0xf4c6a0, 0x111a570, 0xc0136506e0, 0xc0136506e0, 0x0)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/app.go:526 +0xfd
github.com/urfave/cli.Command.Run(0x10a065f, 0x5, 0x0, 0x0, 0x17d78f0, 0x1, 0x1, 0x10b5d47, 0x11, 0x0, ...)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/command.go:174 +0x58e
github.com/urfave/cli.(*App).Run(0xc00013c380, 0xc00000e060, 0x2, 0x2, 0x0, 0x0)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/app.go:279 +0x7e8
main.main()
/go/src/github.com/photoprism/photoprism/cmd/photoprism/photoprism.go:71 +0x529
usermod: no changes
panic: attempt to write a readonly database

goroutine 1 [running]:
github.com/photoprism/photoprism/internal/entity.Types.Migrate(0xc0136da9c0)
/go/src/github.com/photoprism/photoprism/internal/entity/entity.go:106 +0x234
github.com/photoprism/photoprism/internal/entity.MigrateDb()
/go/src/github.com/photoprism/photoprism/internal/entity/entity.go:134 +0x2d
github.com/photoprism/photoprism/internal/config.(*Config).InitDb(0xc0001317c0)
/go/src/github.com/photoprism/photoprism/internal/config/db.go:110 +0x49
github.com/photoprism/photoprism/internal/commands.startAction(0xc00013c2c0, 0x0, 0xc000131620)
/go/src/github.com/photoprism/photoprism/internal/commands/start.go:71 +0x20a
github.com/urfave/cli.HandleAction(0xf4c6a0, 0x111a570, 0xc00013c2c0, 0xc00013c2c0, 0x0)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/app.go:526 +0xfd
github.com/urfave/cli.Command.Run(0x10a065f, 0x5, 0x0, 0x0, 0x17d78f0, 0x1, 0x1, 0x10b5d47, 0x11, 0x0, ...)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/command.go:174 +0x58e
github.com/urfave/cli.(*App).Run(0xc000146000, 0xc0001a6000, 0x2, 0x2, 0x0, 0x0)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/app.go:279 +0x7e8
main.main()
/go/src/github.com/photoprism/photoprism/cmd/photoprism/photoprism.go:71 +0x529
usermod: no changes
panic: attempt to write a readonly database

goroutine 1 [running]:
github.com/photoprism/photoprism/internal/entity.Types.Migrate(0xc0128b7e00)
/go/src/github.com/photoprism/photoprism/internal/entity/entity.go:106 +0x234
github.com/photoprism/photoprism/internal/entity.MigrateDb()
/go/src/github.com/photoprism/photoprism/internal/entity/entity.go:134 +0x2d
github.com/photoprism/photoprism/internal/config.(*Config).InitDb(0xc01c5c37c0)
/go/src/github.com/photoprism/photoprism/internal/config/db.go:110 +0x49
github.com/photoprism/photoprism/internal/commands.startAction(0xc01c5ce2c0, 0x0, 0xc01c5c3620)
/go/src/github.com/photoprism/photoprism/internal/commands/start.go:71 +0x20a
github.com/urfave/cli.HandleAction(0xf4c6a0, 0x111a570, 0xc01c5ce2c0, 0xc01c5ce2c0, 0x0)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/app.go:526 +0xfd
github.com/urfave/cli.Command.Run(0x10a065f, 0x5, 0x0, 0x0, 0x17d78f0, 0x1, 0x1, 0x10b5d47, 0x11, 0x0, ...)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/command.go:174 +0x58e
github.com/urfave/cli.(*App).Run(0xc01c5d6000, 0xc00000e060, 0x2, 0x2, 0x0, 0x0)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/app.go:279 +0x7e8
main.main()
/go/src/github.com/photoprism/photoprism/cmd/photoprism/photoprism.go:71 +0x529
usermod: no changes
panic: attempt to write a readonly database

goroutine 1 [running]:
github.com/photoprism/photoprism/internal/entity.Types.Migrate(0xc013db5b30)
/go/src/github.com/photoprism/photoprism/internal/entity/entity.go:106 +0x234
github.com/photoprism/photoprism/internal/entity.MigrateDb()
/go/src/github.com/photoprism/photoprism/internal/entity/entity.go:134 +0x2d
github.com/photoprism/photoprism/internal/config.(*Config).InitDb(0xc0136c41c0)
/go/src/github.com/photoprism/photoprism/internal/config/db.go:110 +0x49
github.com/photoprism/photoprism/internal/commands.startAction(0xc00052a840, 0x0, 0xc0136c4020)
/go/src/github.com/photoprism/photoprism/internal/commands/start.go:71 +0x20a
github.com/urfave/cli.HandleAction(0xf4c6a0, 0x111a570, 0xc00052a840, 0xc00052a840, 0x0)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/app.go:526 +0xfd
github.com/urfave/cli.Command.Run(0x10a065f, 0x5, 0x0, 0x0, 0x17d78f0, 0x1, 0x1, 0x10b5d47, 0x11, 0x0, ...)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/command.go:174 +0x58e
github.com/urfave/cli.(*App).Run(0xc019964380, 0xc00000e060, 0x2, 0x2, 0x0, 0x0)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/app.go:279 +0x7e8
main.main()
/go/src/github.com/photoprism/photoprism/cmd/photoprism/photoprism.go:71 +0x529
usermod: no changes
panic: attempt to write a readonly database

goroutine 1 [running]:
github.com/photoprism/photoprism/internal/entity.Types.Migrate(0xc00fb149f0)
/go/src/github.com/photoprism/photoprism/internal/entity/entity.go:106 +0x234
github.com/photoprism/photoprism/internal/entity.MigrateDb()
/go/src/github.com/photoprism/photoprism/internal/entity/entity.go:134 +0x2d
github.com/photoprism/photoprism/internal/config.(*Config).InitDb(0xc00059d740)
/go/src/github.com/photoprism/photoprism/internal/config/db.go:110 +0x49
github.com/photoprism/photoprism/internal/commands.startAction(0xc0005a62c0, 0x0, 0xc00059d5a0)
/go/src/github.com/photoprism/photoprism/internal/commands/start.go:71 +0x20a
github.com/urfave/cli.HandleAction(0xf4c6a0, 0x111a570, 0xc0005a62c0, 0xc0005a62c0, 0x0)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/app.go:526 +0xfd
github.com/urfave/cli.Command.Run(0x10a065f, 0x5, 0x0, 0x0, 0x17d78f0, 0x1, 0x1, 0x10b5d47, 0x11, 0x0, ...)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/command.go:174 +0x58e
github.com/urfave/cli.(*App).Run(0xc0005b0000, 0xc00012c000, 0x2, 0x2, 0x0, 0x0)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/app.go:279 +0x7e8
main.main()
/go/src/github.com/photoprism/photoprism/cmd/photoprism/photoprism.go:71 +0x529
usermod: no changes
panic: attempt to write a readonly database

goroutine 1 [running]:
github.com/photoprism/photoprism/internal/entity.Types.Migrate(0xc0136529c0)
/go/src/github.com/photoprism/photoprism/internal/entity/entity.go:106 +0x234
github.com/photoprism/photoprism/internal/entity.MigrateDb()
/go/src/github.com/photoprism/photoprism/internal/entity/entity.go:134 +0x2d
github.com/photoprism/photoprism/internal/config.(*Config).InitDb(0xc01c5b9740)
/go/src/github.com/photoprism/photoprism/internal/config/db.go:110 +0x49
github.com/photoprism/photoprism/internal/commands.startAction(0xc01c5c82c0, 0x0, 0xc01c5b95a0)
/go/src/github.com/photoprism/photoprism/internal/commands/start.go:71 +0x20a
github.com/urfave/cli.HandleAction(0xf4c6a0, 0x111a570, 0xc01c5c82c0, 0xc01c5c82c0, 0x0)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/app.go:526 +0xfd
github.com/urfave/cli.Command.Run(0x10a065f, 0x5, 0x0, 0x0, 0x17d78f0, 0x1, 0x1, 0x10b5d47, 0x11, 0x0, ...)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/command.go:174 +0x58e
github.com/urfave/cli.(*App).Run(0xc01c5d2000, 0xc000132000, 0x2, 0x2, 0x0, 0x0)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/app.go:279 +0x7e8
main.main()
/go/src/github.com/photoprism/photoprism/cmd/photoprism/photoprism.go:71 +0x529
usermod: no changes
panic: attempt to write a readonly database

goroutine 1 [running]:
github.com/photoprism/photoprism/internal/entity.Types.Migrate(0xc01146d020)
/go/src/github.com/photoprism/photoprism/internal/entity/entity.go:106 +0x234
github.com/photoprism/photoprism/internal/entity.MigrateDb()
/go/src/github.com/photoprism/photoprism/internal/entity/entity.go:134 +0x2d
github.com/photoprism/photoprism/internal/config.(*Config).InitDb(0xc01c5b3740)
/go/src/github.com/photoprism/photoprism/internal/config/db.go:110 +0x49
github.com/photoprism/photoprism/internal/commands.startAction(0xc01c5c42c0, 0x0, 0xc01c5b35a0)
/go/src/github.com/photoprism/photoprism/internal/commands/start.go:71 +0x20a
github.com/urfave/cli.HandleAction(0xf4c6a0, 0x111a570, 0xc01c5c42c0, 0xc01c5c42c0, 0x0)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/app.go:526 +0xfd
github.com/urfave/cli.Command.Run(0x10a065f, 0x5, 0x0, 0x0, 0x17d78f0, 0x1, 0x1, 0x10b5d47, 0x11, 0x0, ...)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/command.go:174 +0x58e
github.com/urfave/cli.(*App).Run(0xc01c5ce000, 0xc000132000, 0x2, 0x2, 0x0, 0x0)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/app.go:279 +0x7e8
main.main()
/go/src/github.com/photoprism/photoprism/cmd/photoprism/photoprism.go:71 +0x529
usermod: no changes
panic: attempt to write a readonly database

goroutine 1 [running]:
github.com/photoprism/photoprism/internal/entity.Types.Migrate(0xc00016d8f0)
/go/src/github.com/photoprism/photoprism/internal/entity/entity.go:106 +0x234
github.com/photoprism/photoprism/internal/entity.MigrateDb()
/go/src/github.com/photoprism/photoprism/internal/entity/entity.go:134 +0x2d
github.com/photoprism/photoprism/internal/config.(*Config).InitDb(0xc0135d2140)
/go/src/github.com/photoprism/photoprism/internal/config/db.go:110 +0x49
github.com/photoprism/photoprism/internal/commands.startAction(0xc0001686e0, 0x0, 0xc0130fdfa0)
/go/src/github.com/photoprism/photoprism/internal/commands/start.go:71 +0x20a
github.com/urfave/cli.HandleAction(0xf4c6a0, 0x111a570, 0xc0001686e0, 0xc0001686e0, 0x0)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/app.go:526 +0xfd
github.com/urfave/cli.Command.Run(0x10a065f, 0x5, 0x0, 0x0, 0x17d78f0, 0x1, 0x1, 0x10b5d47, 0x11, 0x0, ...)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/command.go:174 +0x58e
github.com/urfave/cli.(*App).Run(0xc01b4ec380, 0xc00012c000, 0x2, 0x2, 0x0, 0x0)
/go/pkg/mod/github.com/urfave/cli@v1.22.4/app.go:279 +0x7e8
main.main()
/go/src/github.com/photoprism/photoprism/cmd/photoprism/photoprism.go:71 +0x529

Edited by SPOautos
Link to comment
1 minute ago, SPOautos said:

I just went to PhotoPrism in the docker tab, clicked and went to webgui.  It tried to open it up in the brower using the serverip:2342 but says that it cant for some reason. However I can open other apps just fine. Just late last night I installed DiskSpeed which also installs in Bridge type and its webui opens in the browser using the serverip:port and it opens fine. I dont see what going be going on that would cause two apps both using Bridge type and the same ip with just different port numbers to open one and not the other. 

That's fine because the port is routed from the internal Docker network to the hosts network and so you can reach two different Docker containers on different ports from the hosts IP:PORT.

If you are using two Docker containers with the same Port Unraid will throw an error.

 

I can't help when you don't answer the other question.

I need the log (the little sheet icon on the right side or the blue text that states how long the container is running), the template page itsef and all the other questions answered above to look into this to eventually help you out.

Link to comment
5 minutes ago, ich777 said:

That's fine because the port is routed from the internal Docker network to the hosts network and so you can reach two different Docker containers on different ports from the hosts IP:PORT.

If you are using two Docker containers with the same Port Unraid will throw an error.

 

I can't help when you don't answer the other question.

I need the log (the little sheet icon on the right side or the blue text that states how long the container is running), the template page itsef and all the other questions answered above to look into this to eventually help you out.

 

I had gone back and edited the post to include the log file...just took me a minute....I pasted it into my last post (is that what you wanted me to do or to attach the log file as an attachment?)

 

image.thumb.png.ce6b58378329a0e7e377f7f2b9706ace.png

 

image.thumb.png.d88a4e2e4364b254dd793dbd6d1691e4.png

Edited by SPOautos
Link to comment
6 minutes ago, SPOautos said:

I had gone back and edited the post to include the log file...just took me a minute....I pasted it into my last post (is that what you wanted me to do or to attach the log file as an attachment?)

The log tells the problem. It simply can't start the container and is now looping.

  1. Stop the container
  2. Remove the container completely
  3. Remove the folder 'photoprism' from your appdata folder
  4. Redownload the container from the CA App
  5. Fill in the password and also try to define a import folder

The log should only be ~3 lines that tell you that the webserver and app startet.

Link to comment
46 minutes ago, ich777 said:

The log tells the problem. It simply can't start the container and is now looping.

  1. Stop the container
  2. Remove the container completely
  3. Remove the folder 'photoprism' from your appdata folder
  4. Redownload the container from the CA App
  5. Fill in the password and also try to define a import folder

The log should only be ~3 lines that tell you that the webserver and app startet.

 

Its working. I had actually deleted and reinstalled before posting here but I didn't know to delete the appdata folder. That fixed it.

THANK YOU

 

You also had me define a import folder as well. Which brings up a question you may can answer....do you happen to know a way that I can have multiple folders in Unraid that house images, all show up in one large gallery in Photoprism?  I have 4 users with their own picture folder that comes into Unraid from their phone using Nextcloud. I would like to then bring those 4 folders into a single gallery.  Well, that isnt really a question for you since you just do docker side of things....i just thought you might know, this is why I installed Photoprism to see if I could do this.

Edited by SPOautos
  • Like 1
Link to comment
33 minutes ago, SPOautos said:

Well, that isnt really a question for you since you just do docker side of things....i just thought you might know, this is why I installed Photoprism to see if I could do this.

You could do this with the external storage plugin.

Just use the external storage folder as the synchronisation folder for all 4 phones and use the external storage folder as input folder in photoprism. ;)

Link to comment
4 minutes ago, ich777 said:

You could do this with the external storage plugin.

Just use the external storage folder as the synchronisation folder for all 4 phones and use the external storage folder as input folder in photoprism. ;)

 

Are you refering to a plug in for Photoprism, Unraid, or Nextcloud? I couldnt find one in the CA called "external storage"

I use the Nextcloud as phone backup as well so I have them all separate so if a device dies or gets lost I can restore it. But I wonder if there is a app that will copy those 4 folders into a different folder and then use that one for Photoprism

Link to comment
4 minutes ago, SPOautos said:

Are you refering to a plug in for Photoprism, Unraid, or Nextcloud?

Nextcloud

 

5 minutes ago, SPOautos said:

But I wonder if there is a app that will copy those 4 folders into a different folder and then use that one for Photoprism

You can select which folder I think within nextcloud and photoprism should scan all files recursively I think.

Link to comment
1 hour ago, ich777 said:

Nextcloud

 

You can select which folder I think within nextcloud and photoprism should scan all files recursively I think.

 

I'll have to check that out some more, I didnt think the external storage plugin was going to work. I looked a while back at Nextcloud apps and didnt think anything was going to work, but I'll look closer since you mentioned it.

 

I was thinking of looking at the Unraid app DirSyncPro (which I just realized when I just now looked to get the name that it is also your app). I have it on my 'to do' list to install and see if I can use it to duplicate the folders. Basically have the 4 folders with pictures that all point to the one folder and copy everything into that one folder. But my concern was that it probably 'syncs' the folders instead of just duplicating everything over. I figured it would just make a image of the 4 folders rather than allowing me to combine them into 1.

Link to comment

In your Chrome app can dockers like Plex be opened up in it instead of Firefox and can Chrome extensions be added?  Chrome has much better ability to play videos and I am thinking I may could open Plex in Chrome on my Unraid machine and play videos (something I cant do in Firefox).

Edited by SPOautos
Link to comment
8 hours ago, Gunnm said:

Thank you very much :)

Hope everything is working as expected.

 

8 hours ago, SPOautos said:

I'll have to check that out some more, I didnt think the external storage plugin was going to work. I looked a while back at Nextcloud apps and didnt think anything was going to work, but I'll look closer since you mentioned it.

Should work just fine, tested this with this exact configuratione but only with one phone. ;)

 

6 hours ago, SPOautos said:

In your Chrome app can dockers like Plex be opened up in it instead of Firefox and can Chrome extensions be added?

This should work, but keep in mind that Chrome isn't hardware accelerated because of the missing GPU inside the Container and also you get no sound through the WebGUI but if you stream it it might just work, but that's a thing that you have to try out...

Link to comment
9 hours ago, ich777 said:

Hope everything is working as expected.

 

Should work just fine, tested this with this exact configuratione but only with one phone. ;)

 

 

Seems to be working well! I'm trying to get those image folders connected. Hope you dont mind me asking some more detail about how you set that up with your phone in Nextcloud.....So I am trying to setup the external storage and for it to point to a folder in Unraid (the folder that I will get PhotoPrism to look at). In Nextcloud, in the settings to create the external storage, did you select it to be "local" and then what did you use for "configuration" in my mind it would be the path to the folder so I put "mnt/user/media/family content" but that doesn't seem to work. 

 

 

Link to comment
34 minutes ago, SPOautos said:

Seems to be working well!

Nice.

 

First of all I would configure Nextcloud and Photoprism so that they share a directory and then set all up in the Nextcloud instance itself and lastly point the autoupload to the external folder:

  1. Go into your Nextcloud template and create a new path Container: '/mnt/external_photoprism_storage' and for the host path you have to select the photoprism import folder on your Unraid box.
  2. Then go into your Nextcloud instance and go to the settings and create the external storage pointing to '/mnt/external_photoprism_storage'
  3. On the phones you have to set the autoupload of the pictures to the external storege folder that you created above.

It could happen that you have not enough permissions to use the '/mnt' folder then I would suggest that you use /external_photoprism_storage' without '/mnt' but at least I would try it works with '/mnt/external_photoprism_storage' (you don't have to change any of the settings within Photoprism if you already added a import folder).

 

Hope that makes sense to you.

Link to comment
7 hours ago, cyleper said:

Hello, I just installed Firefox, and I found a problem is that the Chinese cannot be displayed correctly。How can i fix it?

 

I will look into this, should be a quick fix, I will update the container as soon as possible. I will edit this post if the new version is online, please report back if everything works.

 

EDIT: Please update the container (force update):

Bildschirmfoto_2020-10-20_17-57-48.thumb.png.7ed77082cd9fa87cc4f06abf47f9d801.png

Link to comment

For the PhotoPrism docker you should add in options for using mysql isntead of sqlite since the built in sqlite is horrible with performance and getting itself "locked" causing issues.

 

Here's what I've added on mine to get it working.

 

Name: Database Driver

Key: PHOTOPRISM_DATABASE_DRIVER

Value: sqlite (default) or mysql

Description: Change my mysql instead of sqlite to use a MariaDB or MySQL database.

 

Name: MySQL Data Source Name

Key: PHOTOPRISM_DATABASE_DSN

value: user:pass@tcp(IP.OF.DATABASE.SERVER:3306)/photoprism?charset=utf8mb4,utf8&parseTime=true

Description: MySQL database connection information. Leave alone if using SQLite

 

NOTE. Would just need to test actually leaving DSN blank/unchanged for sqlite, it shouldn't use it at all if sqlite is in use, but I haven't actually tested this.

 

All info from here: https://dl.photoprism.org/docker/docker-compose.yml

 

I have this up and working on the MariaDB container with this information above.

 

  • Like 2
Link to comment
4 minutes ago, CorneliousJD said:

For the PhotoPrism docker you should add in options for using mysql isntead of sqlite since the built in sqlite is horrible with performance and getting itself "locked" causing issues.

 

Here's what I've added on mine to get it working.

 

Name: Database Driver

Key: PHOTOPRISM_DATABASE_DRIVER

Value: sqlite (default) or mysql

Description: Change my mysql instead of sqlite to use a MariaDB or MySQL database.

 

Name: MySQL Data Source Name

Key: PHOTOPRISM_DATABASE_DSN

value: user:pass@tcp(IP.OF.DATABASE.SERVER:3306)/photoprism?charset=utf8mb4,utf8&parseTime=true

Description: MySQL database connection information. Leave alone if using SQLite

 

NOTE. Would just need to test actually leaving DSN blank/unchanged for sqlite, it shouldn't use it at all if sqlite is in use, but I haven't actually tested this.

 

All info from here: https://dl.photoprism.org/docker/docker-compose.yml

 

I have this up and working on the MariaDB container with this information above.

 

Yep I know that and the informations are all on the previous page I think but most of the people are not configuring photoprism with MariaDB or MySQL.

I cann add the options but don't think that anybody uses it, I'm also thinking about pulling the container from the CA app because the reals devs don't take Unraid serious and don't understand how Unraid permissions work (or most consumer grade NAS are working).

 

EDIT: btw I thank you for researching this yourself since most people doesn't do that.

  • Like 1
Link to comment
5 hours ago, ich777 said:

Nice.

 

First of all I would configure Nextcloud and Photoprism so that they share a directory and then set all up in the Nextcloud instance itself and lastly point the autoupload to the external folder:

  1. Go into your Nextcloud template and create a new path Container: '/mnt/external_photoprism_storage' and for the host path you have to select the photoprism import folder on your Unraid box.
  2. Then go into your Nextcloud instance and go to the settings and create the external storage pointing to '/mnt/external_photoprism_storage'
  3. On the phones you have to set the autoupload of the pictures to the external storege folder that you created above.

It could happen that you have not enough permissions to use the '/mnt' folder then I would suggest that you use /external_photoprism_storage' without '/mnt' but at least I would try it works with '/mnt/external_photoprism_storage' (you don't have to change any of the settings within Photoprism if you already added a import folder).

 

Hope that makes sense to you.

 

Thank you for this info...I am going to work on this tonight! Quick question, just to make sure I understand you....when you say put them in the same directory do you mean instead of having /mnt/user/nextcloud and /mnt/user/media/pictures to instead do something like /mnt/user/device content/nextcloud and /mnt/user/device content/pictures so that Nextcloud and the Photoprism picture database on both under the same parent folder?

 

Or do you just mean to have a shared folder (presumably the external storage folder) for all pictures that both applications are using....Nextcloud is dumping into and Photoprism is reading?

 

I just want to make sure I'm clear on how you mean that before I start moving stuff around.  BTW, your help is greatly appreciated. Its pretty hard for someone like me to figure all this stuff out  lol.  I've not done a whole lot more than using a Windows pc to browse the internet, email, MS Word, Quickbooks accounting.....maybe a few very basic networking functions, not much more with a router than just plugging it in. This is my first time to actually build a computer all by myself and get it all set up.....so when I say I appreciate you and others on the forum who help out, I really mean that....I do appreciate it and absolutly could not do this without the help.  Thank You

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.