[Support] ich777 - Application Dockers


ich777

Recommended Posts

After installation of MagicMirror2 plugin MMM-CalendarExt2 I get just this loop after restart of the app:

---Checking if UID: 99 matches user---
usermod: no changes
---Checking if GID: 100 matches user---
usermod: no changes
---Setting umask to 000---
---Checking for optional scripts---
---No optional script found, continuing---
---Starting...---
---Checking if UID: 99 matches user---
usermod: no changes
---Checking if GID: 100 matches user---
usermod: no changes
---Setting umask to 000---
---Checking for optional scripts---
---No optional script found, continuing---
---Starting...---
---MagicMirror² up-to-date---
---Looking for new modules to install---
---Preparing Server---
---Configuration file found!---
---Please wait, permissions are set, this can take some time...---
---Starting Server---

> magicmirror@2.17.1 server /magicmirror2
> node ./serveronly

[25.10.2021 15:09.02.673] [LOG] Starting MagicMirror: v2.17.1
[25.10.2021 15:09.02.676] [LOG] Loading config ...
[25.10.2021 15:09.02.686] [LOG] Loading module helpers ...
[25.10.2021 15:09.02.688] [LOG] No helper found for module: alert.
[25.10.2021 15:09.02.705] [LOG] Initializing new module helper ...
[25.10.2021 15:09.02.706] [LOG] Module helper loaded: updatenotification
[25.10.2021 15:09.02.726] [ERROR] WARNING! Could not load config file. Starting with default configuration. Error found: Error: Cannot find module 'request'

Require stack:
- /magicmirror2/modules/MMM-CalendarExt2/node_helper.js
- /magicmirror2/js/app.js
- /magicmirror2/serveronly/index.js
[25.10.2021 15:09.02.726] [LOG] Loading module helpers ...
[25.10.2021 15:09.02.730] [LOG] No helper found for module: alert.
[25.10.2021 15:09.02.731] [LOG] Initializing new module helper ...
[25.10.2021 15:09.02.731] [LOG] Module helper loaded: updatenotification
[25.10.2021 15:09.02.735] [ERROR] Whoops! There was an uncaught exception...

[25.10.2021 15:09.02.740] [ERROR] Error: Cannot find module 'request'

Require stack:
- /magicmirror2/modules/MMM-CalendarExt2/node_helper.js
- /magicmirror2/js/app.js
- /magicmirror2/serveronly/index.js
at Function.Module._resolveFilename (internal/modules/cjs/loader.js:815:15)
at Function.Module._resolveFilename (/magicmirror2/node_modules/module-alias/index.js:49:29)
at Function.Module._load (internal/modules/cjs/loader.js:667:27)
at Module.require (internal/modules/cjs/loader.js:887:19)
at require (internal/modules/cjs/helpers.js:74:18)
at Object.<anonymous> (/magicmirror2/modules/MMM-CalendarExt2/node_helper.js:4:17)
at Module._compile (internal/modules/cjs/loader.js:999:30)
at Object.Module._extensions..js (internal/modules/cjs/loader.js:1027:10)
at Module.load (internal/modules/cjs/loader.js:863:32)
at Function.Module._load (internal/modules/cjs/loader.js:708:14) {
code: 'MODULE_NOT_FOUND',
requireStack: [
'/magicmirror2/modules/MMM-CalendarExt2/node_helper.js',
'/magicmirror2/js/app.js',
'/magicmirror2/serveronly/index.js'
]
}
[25.10.2021 15:09.02.741] [ERROR] MagicMirror will not quit, but it might be a good idea to check why this happened. Maybe no internet connection?

[25.10.2021 15:09.02.742] [ERROR] If you think this really is an issue, please open an issue on GitHub: https://github.com/MichMich/MagicMirror/issues

---Checking if UID: 99 matches user---
usermod: no changes
---Checking if GID: 100 matches user---
usermod: no changes
---Setting umask to 000---
---Checking for optional scripts---
---No optional script found, continuing---
---Starting...---
---Checking if UID: 99 matches user---
usermod: no changes
---Checking if GID: 100 matches user---
usermod: no changes
---Setting umask to 000---
---Checking for optional scripts---
---No optional script found, continuing---
---Starting...---
---MagicMirror² up-to-date---
---Looking for new modules to install---
---Preparing Server---
---Configuration file found!---
---Please wait, permissions are set, this can take some time...---

 

Link to comment
After installation of MagicMirror2 plugin MMM-CalendarExt2 I get just this loop after restart of the app:
---Checking if UID: 99 matches user---usermod: no changes---Checking if GID: 100 matches user---usermod: no changes---Setting umask to 000------Checking for optional scripts------No optional script found, continuing------Starting...------Checking if UID: 99 matches user---usermod: no changes---Checking if GID: 100 matches user---usermod: no changes---Setting umask to 000------Checking for optional scripts------No optional script found, continuing------Starting...------MagicMirror² up-to-date------Looking for new modules to install------Preparing Server------Configuration file found!------Please wait, permissions are set, this can take some time...------Starting Server---> magicmirror@2.17.1 server /magicmirror2> node ./serveronly[25.10.2021 15:09.02.673] [LOG] Starting MagicMirror: v2.17.1[25.10.2021 15:09.02.676] [LOG] Loading config ...[25.10.2021 15:09.02.686] [LOG] Loading module helpers ...[25.10.2021 15:09.02.688] [LOG] No helper found for module: alert.[25.10.2021 15:09.02.705] [LOG] Initializing new module helper ...[25.10.2021 15:09.02.706] [LOG] Module helper loaded: updatenotification[25.10.2021 15:09.02.726] [ERROR] WARNING! Could not load config file. Starting with default configuration. Error found: Error: Cannot find module 'request'Require stack:- /magicmirror2/modules/MMM-CalendarExt2/node_helper.js- /magicmirror2/js/app.js- /magicmirror2/serveronly/index.js[25.10.2021 15:09.02.726] [LOG] Loading module helpers ...[25.10.2021 15:09.02.730] [LOG] No helper found for module: alert.[25.10.2021 15:09.02.731] [LOG] Initializing new module helper ...[25.10.2021 15:09.02.731] [LOG] Module helper loaded: updatenotification[25.10.2021 15:09.02.735] [ERROR] Whoops! There was an uncaught exception...[25.10.2021 15:09.02.740] [ERROR] Error: Cannot find module 'request'Require stack:- /magicmirror2/modules/MMM-CalendarExt2/node_helper.js- /magicmirror2/js/app.js- /magicmirror2/serveronly/index.jsat Function.Module._resolveFilename (internal/modules/cjs/loader.js:815:15)at Function.Module._resolveFilename (/magicmirror2/node_modules/module-alias/index.js:49:29)at Function.Module._load (internal/modules/cjs/loader.js:667:27)at Module.require (internal/modules/cjs/loader.js:887:19)at require (internal/modules/cjs/helpers.js:74:18)at Object. (/magicmirror2/modules/MMM-CalendarExt2/node_helper.js:4:17)at Module._compile (internal/modules/cjs/loader.js:999:30)at Object.Module._extensions..js (internal/modules/cjs/loader.js:1027:10)at Module.load (internal/modules/cjs/loader.js:863:32)at Function.Module._load (internal/modules/cjs/loader.js:708:14) {code: 'MODULE_NOT_FOUND',requireStack: ['/magicmirror2/modules/MMM-CalendarExt2/node_helper.js','/magicmirror2/js/app.js','/magicmirror2/serveronly/index.js']}[25.10.2021 15:09.02.741] [ERROR] MagicMirror will not quit, but it might be a good idea to check why this happened. Maybe no internet connection?[25.10.2021 15:09.02.742] [ERROR] If you think this really is an issue, please open an issue on GitHub: https://github.com/MichMich/MagicMirror/issues---Checking if UID: 99 matches user---usermod: no changes---Checking if GID: 100 matches user---usermod: no changes---Setting umask to 000------Checking for optional scripts------No optional script found, continuing------Starting...------Checking if UID: 99 matches user---usermod: no changes---Checking if GID: 100 matches user---usermod: no changes---Setting umask to 000------Checking for optional scripts------No optional script found, continuing------Starting...------MagicMirror² up-to-date------Looking for new modules to install------Preparing Server------Configuration file found!------Please wait, permissions are set, this can take some time...---

 

This is a common issue and I haven't got time to fix this yet, MagicMirror2 changed some dependencies and that's causing this errors on some plugins.
I will fix that ASAP but can take a few days/weeks.

Sent from my C64


  • Like 1
Link to comment

 

How come lucky backup is using 3gbs of data on the docker img? not sure how or why. I have set lucky backup to backup to google drive folder that is mounted using the rclone plug-in and to a local drive that is mounted using unassigned devices. but that is it.

 

any thoughts on whats using the 3gb of space? if cache or temp files, then is there a way to cache and temp files get stored in the ram?image.thumb.png.84e25d88a4398d9398e04e371a7707d3.png

Link to comment
6 minutes ago, Goldmaster said:

@alturismo this is what I have set in the docker folder.

The more interesting thing would be how you set up the synchronizations, since if you set it up to the wrong path you are basically writing into the Docker image and not in the share itself, I think that is what happened here.

 

My luckyBackup container on my Backup machine only has about ~750MB and never changes the size and I sync about 20TB.

Link to comment

@alturismo just sorted it. What it was, I had a folder called /Destination which was the old mount point for my external drives, before moving to /destination and luckybackup would create the folder if it doesn't exist, so lucky backup had backed up some stuff to the docker and not the hard drive. so now my docker size has gone from 98% full to 80% full.

 

 

Link to comment
2 minutes ago, Goldmaster said:

@alturismo just sorted it. What it was, I had a folder called /Destination which was the old mount point for my external drives, before moving to /destination and luckybackup would create the folder if it doesn't exist, so lucky backup had backed up some stuff to the docker and not the hard drive. so now my docker size has gone from 98% full to 80% full.

So it is working now?

I really don't understand what you've did here but if it works I'm ok with that... :D

 

I'm really curious since you have defined paths in your Docker template that you don't use in the container itself so it has written into the container I think.

Link to comment
36 minutes ago, ich777 said:

So it is working now?

I really don't understand what you've did here but if it works I'm ok with that... :D

 

I had /Destination instead /destination so when the folder was not found, it would have been recreated inside the docker. not sure how to turn that off in lucky backup.

  • Like 1
Link to comment
13 minutes ago, Goldmaster said:

I had /Destination instead /destination so when the folder was not found, it would have been recreated inside the docker. not sure how to turn that off in lucky backup.

exactly .. case sensitive ;) and no, this is the expected behaviour, wrong setup somewhere is sometimes just a little pain ;)

 

glad you sorted it

  • Like 1
Link to comment

Hi @ich777
I

 really like your job and thanks for all your dockers/apps.

 

I just have a small request (maybe someone already asked), but in your MagicMirror container, is it possible to not autoreplace the file custom.css on css folder?
Because I loose my CSS everytime I update the container.

 

Thanks and keep the good work

Link to comment
On 10/30/2021 at 5:42 PM, Denkyem said:

Because I loose my CSS everytime I update the container.

Can you send me a screenshot from your Docker template?

Have you enabled the Force Update option?

 

This should not happen if MagicMirror2 is started without Force Update since it only starts the application.

  • Like 1
Link to comment
1 hour ago, ich777 said:

Can you send me a screenshot from your Docker template?

Have you enabled the Force Update option?

 

This should not happen if MagicMirror2 is started without Force Update since it only starts the application.

 

Yes, it only happens with the force update option, but without the force update, the MagicMirror is still updated?
I don't have the force update always enabled

 

Thanks

Link to comment

Hello, I am new here.
 

I come to share with you some information about the VPN configuration after several searches to connect this client to my OpenVPN create with pivpn.
 

For the latter the user name is useless therefore it suffices in the file "vpn.ovpn" to add the line

 

askpass /vpn/vpn.pass

 

and create a text vpn.pass file with only the user password, I only say


this comment is therefore not a search for a solution but seeing that I have been looking for I said to myself that I could give my solution if ever someone was looking for the same info, see you can add it to your documentation :)


Sorry for my pitiful English I'm French x)

  • Thanks 1
Link to comment

If not, I'm still trying to figure out how to get all access to my unraid (all ports and all protocols) through my VPN while keeping the same properties on my local network.

If I put it in host I can no longer access it via my local network (192.168.1.203) and in bridge I do not have access to VPN (192.168.10.3) I will surely find the solution but if you have it :) I am taker

Link to comment
1 minute ago, PhiKirax said:

how to get all access to my unraid (all ports and all protocols) through my VPN while keeping the same properties on my local network.

The container is designed to let other containers access the internet through a VPN not your whole server. That's not what that container is for.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.