Help!!! (I cannot get windows vm to run)


Rovivrus

72 posts in this topic Last Reply

Recommended Posts

Sorry to call on you guys again.

but I having trouble with setting up a windows VM.

the farthest I got so far is I got to the windows installer choose a C : drive location and entering a licence key then it rebooted a few mins after and then I got to a UEFI shell text screen that doesn't seem to go any where

 

yesterday I didn't even get to the ms installer 

my 1st issue was a blank screen which I found out was down to I thought I switched the onboard graphics as primary. So when I went to the bios that said it was set to PCIe so i switched that back.

 

So, that fixed the blank/black screen, phew.

This is when I 1st encountered the UEFI shell text screen after you hit any key to boot from cd

and it responded by putting up a text screen which doesn't seem to respond to the keyboard i tried hitting ESCAPE and typing exit to no luck there?

 

this is when I thought I will totally start again today:

checked the graphics in the bios that the onboard is primary and the virtual settings are enabled, which they are still.

redone the VIFO config tool.

graphics selected

graphics sound card selected

M.2 drives selected

and the USB3 card selected.

 

all in there own iommu groups thanks to the override in the vm manager set to downstream it separated out what was required.

 

I even used a freshly downloaded win 10 iso file from the microsoft site media creation tool.

 

and today got as far a couple of minutes after entering the licence key.

 

Please if anyone can point me to what i am doing wrong? or away to fix this, PLEASE, Please I would very much like to hear from you.......

 

PS: I have enclosed the VM log and the two screens one being the progress made and the other is that UEFI screen!  :(

UEFI shell v2 text SCREEN.JPG

progress.JPG

vm log.rtf

Link to post
  • Replies 71
  • Created
  • Last Reply

Top Posters In This Topic

Since you started this new thread I have locked your other thread and linked this one.

 

Please don't post in multiple threads about the same thing. It makes it impossible to coordinate responses.

 

"Crossposting" has been considered bad form on message boards since before the World Wide Web.

Link to post

Sorry about that. I have a bit of an update I had to start with making a virtual drive which the video later copies over to the m.2.

I got passed the windows installer and when I got to the drivers the display driver started updating and then it crashed!

so I am going to reattempt this later on this eve.

Link to post

I am well and truly stuck, please help.

 

Something is not right, this is now the 2nd time this has happened I installed the windows on virtual disk in the automatic location (auto). 

installed the missing drivers when I got onto the desktop and the graphics driver from AMD gets to downloading packages and then the screen goes black in this instance I can not do the normal fix of remove the card and use the onboard since that is in use by unread being the host system. to go back in and remove /roll back the driver.

 

What could I be doing wrong or missing to get installing a display driver that knocks out the display???

 

PLEASE, PLEASE any suggestions are more than welcome to get a true AMD driver to work rather than the microsoft's basic display driver.

 

the card is correctly in the slot since I was getting a display before installing the the amd driver.

the power cable are plugged in one 8pin connector using 6pin+2pin.

 

the model of the gpu sapphire amd Radeon RX 580 8gb.

Link to post

I have looked and the top result of that suggested search as the guy managed to solve his but I do not get how???

 

I have heard about the VFIO-PCI plugging installed this is how I was able to select the NVME drive and the USB3 card for the VM. I knew to get each item into it's own IOMMU Group which the Ovride option I found in the VM Manger set to downstream achieved the desired groupings. I had not realised that you need to select the GPU+GPUsound as well! due to unread saw the graphics card in the drop down menu. (I think I will try this next).

 

other info:

the primary video device is the onboard in the bios

the card is in the 1st 16x on the board.

power supply is a 1000watt PSU this is what helped me get the system to become stable and it also identified the one of the drives had failed, so that is now replaced.

the 8pin is being supplied by a 6-2pin power cable nothing else connected to the cable.

 

 

I really hope it is that simple to fix.

 

where the topic goes to syslinux and a XML from the VM and the diagnostics file from the host this is where I get completely lost. Sorry.

 

If this is the problem I am only to need help.

 

Also, this seems slightly to be different, as I got into a completely fresh installed desktop screen.

but the networking drivers, and a system device where missing

so I installed the drivers from E: virtio-win-0.1.173-2

which looks like there are working fine.

but the display driver is Microsofts own basic display driver.

So as you would on a pc you would install AMD or Nvidia driver, I thought the same applied to a virtual Machine?

so I downloaded the application AMD's adrenalin 2020edition (auto detect from their website).

https://www.amd.com/en/support

and let it run it downloaded what it needed but just after that stage the screen goes black, and doesn't return.

 

the annoying thing is that this is the only video source to fall back on because the onboard is taken by the host the unraid system.

 

I have also look at:

 

 

 

I Have not to the stage in this suggested video to use the PCIE to M.2 NVME SSD as the VM's Hard drive yet.

from what I gather:

!: clone the virtual disk to the m.2 (due to the screen going black on me when installing the AMD display driver).

2: edited some thing so when the VM is off the m.2 drive become a share? (I would not mind if this didn't happen).

3: edit a boot loader a clover image (?).

4: should be done and dusted for windows (but I would like to repeat this for a linux mint vm with another NVME drive. (I have not got a clue on this point)).

 

As I said I will try again with the VFIO PCI config pluggin with the gpu&gpu sound selected there.

SO, PLEASE PLEASE anything else to try, or that i have over looked?

Or if comes to syslinux and a XML from the VM and the diagnostics file from the host, please bare with me as I am still new to this.

 

But Please I would be grateful for any help

 

Link to post

Please, Please, Help I tried again yesterday, and it seems like the vm is unstable the windows installer is no problem once I get into it most of the time I keep ending up at the mkII UEFI text screen that doesn't progress anywhere. I think i am nearly at my wits end! :( 

 

I will admit I am new to doing vm work, I had trouble getting unraid to work!

thanks to the help with that from the community, for all their help getting the NAS side up and running.

 

I asked in that post if anyone knew of a very basic step by step guide, and there was no more information forthcoming.

 

So, I had to look for a guide myself and found invader one's guides.

found his basic checks  

How to set up a windows 10 VM pt1

How to set up a windows 10 VM pt2

quick and easy for any PCIe devices

So: ISO & Domains are exported.

VT-D & VT-X are enabled in bios and is shown in the info 

The Primary video device is set to onboard in the bios.

I had to use the PCIe ACS override and this is set for downstream.

to get the USB3 card and the Samsungs SSD's to show in the other PCIe devices box.

I went and got the VFIO-PCI Plugin mentioned in another video and selected the IMMOU groups for the USB3 Card and the two samsung SSD's.

 

I selected the hardware i wanted to pass through and got the UEFI shell mk II screen and couldn't progress so had to force quit the vm.

 

then Rachid596 pointed out that the vm can not boot from a SSD and to use a clover image.

via watching the how to pass through an name controller.

and I am unable to get passed step one, since when I installed the AMD display driver the vm screen went black and never returned?!

and last nights attempt got me back on to the windows desktop, and got the network driver than system devices installed but I hesitated to install the and driver and so I shutdown the vm via the windows desktop.

When I rebooted the screened locked and went black like before so retried to boot the machine and it locked up at the white ring booting screen.

 

I tried the plugin with the GPU+its sound ticked and just got the mkII shell screen.

when the gpu and sound was unticked I got to the windows installer.

 

the video is of the attempts last night. I really am getting stumped...

 

SO, PLEASE PLEASE Help I am a new to this the terminal/dos like screens I have the very, very basic knowledge of. Just to throw in a curve ball my vision is not all that good.

 

The background I have with computers is adapting them so I can see them.

(switch from windows in 2007/-10 due to I could see the original OSX (10 lion) just with the font size increase (i now know that is scaling).

now both windows native and mac native are getting hard to see and linux is not quite there to move to compliantly due to I have not got photoshop to run or microsoft office working in linux mint but the OS is a lot easier to see.

In this I have got into building computers recently. the most resent is the NAS. I have managed to get working a water cooled gaming rig

and the test rig trying without much luck the photo editing and ms office on linux rig with a copy of adapted windows mainly a lot more scaling with the high contrast and speech out put enabled.

 

to help as a quick way to getting to the unraid web interface via getting the ip address from the router. Also to help me out with the terminal I have just setup a raspberry pi 

I do want to set this up as a static ip but I do not know how?

 

but I really need some help with setting up the windows VM at this point in time.

 

Please any help welcome

Screenshot 2020-11-24 at 15.17.17.png

MONOLITH:SysDevs.pdf vm form veiw.rtf monolith-diagnostics-20201124-1613.zip

Link to post
  • 2 weeks later...

Hello, I am getting really stuck here I have got a VNC vm to work and when i pass the graphics card through with its sound counter part. it boots the windows basic driver due to amds driver has yet to be installed I clicked on the auto detect and install the recommended version. system still showing it downloads everything it needs and then when it installs the screen goes black and doesn't return?

 

PLEASE HELP!!! I am stuck I do not know how to fix this problem.

 

Link to post

Big update I got the graphics card installed and working correctly :) !!!!!!

Why is there not more info or a note on unraid. around graphics passthroughs if you have the VM crash after installing the graphics card's driver. on i440fx try setting up the same VM on Q35? this little note would be great next to the Machine:'s drop drown box.

(I only found out this little gem on a reddit post).

 

(turns out Q35 has native PCI/PCIe support which I440fx dose not).

 

so the only issue remains and that is to get a work around for booting of an m.2.

That is a job for tomorrow :)

Link to post

PLease, please help!!!

I think i am loosing my mind!

I followed the steps taken to get a VNC vm to work which goes with no problem, even with the additional USB controller and the M.2 SSD (in an unformatted state).

Then, when I passthrough the graphics and sound the I440fx gives up when the new driver is being installed.

thus making the screen go black and the display never returns.

So, as suggested to run the machine as Q35 and the display flickers but returns back to a typical display.

This only last for a few days at most for some unknown reason....

 

but i have also tried the work around for trying to use a m.2 ssd and I took the steps in the video 

but the the outcome of switching out the virtual drive for the clover image just seems to turn the screen black no mkII shell no splash screen nothing just black.

like what ever linked and got it go has been removed.

Please, please help....

Monolith logs 08122020.zip

Edited by Rovivrus
Link to post
  • 3 weeks later...

Hello, can some one please help! I am new to unraid since October. I have not got a Windows VM to work with passed through hardware (which is why I chosen unraid to setup a NAS and still be able to run a PC from the same machine)! 

I struggled to get the NAS side up and running (thank you for help me out there). The computer side (the windows 10 VM) is beyond me.

 

I have managed to get a vm to work via VNC but this is also proven to be temperamental it works fine on the day of setting it up and the day after but when I come back after a week it doesn't work.

usually ending up with a blank screen or no guest agent installed (which I knew it was) or guest has not started the graphics yet or I get is the empty EFI shell MKII screen (yes even i have installed windows to a vdisk).

 

when I pass through the gpu, it is fine when I install the drivers to a Q35 VM but as soon as I power down the nas and return to the VM the next day I end up with a black blank screen on the odd time either the guest agent is not installed or the efi shell mkII screen.

If I dare try and use the default machine type I440FX type as soon as a new display driver is starting to install the display disappears and doesn't return.

 

it is similar to the amd rest bug that I have come across on the web but I do not get an error message from unraid when I start the VM up.

and there is the oddity that when I powered the vm after installing the display driver (as I installed windows and got the display right so I can at least be able read the screen to a degree on a when the VM was on VNC before hand). Then later on power down the NAS when I come back to use it the next time it will not display but on the browser the VM is working.

 

If I try sort out the M.2 I got to the point of switching the original vdisk for the adapted clover image and when I try to return to the vm I get a blank screen or the guess agent is not installed! I am getting to the point to abandon the M,2 drive if I can get a stable/reliable Windows VM

with a USB and graphic card.

 

I have even gone to the lengths of adding another graphics card two the 1st PCIe x16 slot on the motherboard and placed the graphics card I am after on the next slot down. All this time the bios was setting to onboard graphics as the primary graphics device.

 

I do not what I am missing here I am not confident at all with editing the scripts/codes on the nas.

 

The Goal was to have a computer that I could use since the interface on my current PC has changed to the point that I am really having trouble accessing it (that OS seemed to of gone backwards in accessibility from 2009/10) I didn't want to add another PC physically to the house and it was perfect if the computer to run both the storage and the desktop in one unit.  But alas the VM particular has been a royal pain! Which I need to get this problem sorted out because the hardware is sitting there waiting to be used but I am unable to sort it out.

I have been struggling with this since October and I am still stuck!

 

PlEASE, PLEASE HELP!!!!

 

Link to post

Hi there,

 

I can almost guarantee you the issue is related to the GPU you are trying to use.  AMD has been notoriously bad for supporting virtualization on their GPUs and the community has gone through great lengths to make quirks and workarounds to accommodate this.  The easiest solution to your problem would be to purchase an EVGA GTX-series (or RTX-series) GPU and use that instead.  I really wish we had a solution for the GPU you're using, but it's a hardware-specific problem that doesn't offer a simple solution for us to implement within Unraid.  All the guides you've tried are the same ones I would normally have suggested, so if you've gone through all those and still don't have a working solution, I think you're going to need to try a different card.

 

One thing worth noting is if you get stuck on the UEFI BIOS screen, you can navigate into the FS devices:

 

fs0:

cd boot/efi

bootx64.efi

 

Those three commands usually work but you can also type 'dir' or 'ls' to list out the directory contents of those FS devices to find that .efi boot file you need to launch the OS.  Not sure why VMs get stuck their at random.

Link to post

Jonp Thank you ever so much for replying! :) 

 

I thought no one was reading this post since the last piece of advice was posted on the 23rd of November, and that i have be deemed a pest, since the suggestions seem to help get me so far long but seemed not solve the issue or issues, that are not allowing a VM to become a stable, so I can run the vm as desktop PC.

 

Following that line of research (Search google Radeon RX 580 site:unraid.net)

completely lost me when they discussing scripts and the behaviour I have been seeing with the VM's on this setup seemed to be similar but also different like they where able to run the vm if they restarted the whole server, with mine it lost and never to return after a server power down and when I came to power on the vm the next day to be faced with a blank black screen. But the person having the issue with their card seemed to be resloved, and mine is so clear not having the same success.

 

On this note I have even tried putting in another low power graphics card in the 1st PCIe x16 slot to see if that will help things along.

which resulted in the same result blank black screen or uefi interactive shell or no guest agent installed :(

 

the m.2 drive when I try and move to the clover image after cloning the vdisk to the m.2 I just seem to get a guest agent not installed screen which I know there was on the m.2 or it is back to the UEFI interactive shellv2.2 screen.

which seemed to be frustrating because I couldn't see any guides as how the shell  apart from a post in this site which describes as the fall back interface if the vm is deemed to be empty. Thank you again with the there command lines for me to try when I next come across this screen because since this is new to me when I hit that screen any command I tried from old dos commands or the very, very basic linux terminal commands I know just seemed to add a new blank line what always started as "Shell>".

Which the only option for me at the time was to delete the vm and start again.

So I will try the:

 

fs0:

cd boot/efi

bootx64.efi

 

commands thank you again.

 

It is driving me up the wall! with not being able to get a stable VM with passthroughs (graphics + sound and A USB3 Card at least the ultimate goal is the to get the m.2 to work as the vms hard drive). I am sorry to hear that others with the rx 580 card have been have the same/similar problems with trying to get VMs to work, but I am glad I am not the only one with such a problem.

 

I have even made a check list from the videos mentioned of things to watch out for (enclosed)

I have been going stirr crazy with "have I screwed this up?"

"What I am not doing here that I should be doing?"

"Have I done something wrong?"

"What am I missing here?"

"Is it something visually that I have not seen?" (this is a question that I have asked myself because really, really struggle to red blue and green, yellow text on white anything red is not seen since I lack the red spectrum and this is only my colour vision! (oh boy!)

 

The stupid thing is I have tried the same card in another bare metal machine it works fine. I have recently passed the rx 580 to a friend to try out and they came back with it works absolutely fine. Now I get the impression they are now after the same card for their PC.

as the 1st thing for seeing if it is a bad card is try it in another machine. so annoyingly we know the card itself works fine on a standard windows machine.

 

So I will certainly be trying to get my hands on a EVGA GTX card I am looking for a model with 6GB minimum 8GB perferable

so I know I be able to run zoom text (accessibility software) and a photo editor and the odd video.

 

(Rational) I seem to be a odd visually impaired person.

I have had to learn computers so I am able to adapt the appearance of an operating system so I am able to use it*

hence my knowledge of parts and putting them together (hoping they work, with fair success, until now and with the VM's :) )

What my hobby is photography, which helps me train my eyes to keep them focused for longer than 3 seconds), and working on the pictures back at home, hence the photo editor and the odd video editing the odd video from my other interest canoeing.

and the zoom text  well this is a newy!

I struggled with windows when I was going through school and I had a friend who went on to do graphics and he introduced me to apple mac back in 2007 which with their hi contrast interface and their screen reader and speech recognition being great as well as their implantation of usual large text and choice of highlighted text colour was great then but now it is really a disappointment how accessibility options are implemented.

Hence the return to windows since there is now a lot more accessibility programs and support for these programs and even with high contrast white on black increased text size and improved scaling, are easier to see than the newer mac osx releases.

I would even swap to linux if I could easily install and run MS office, photoshop, lightroom, abby finereader pro (for OCR) the only apple application I have not found a similar program that is so easy to use like Imovie.

and if I can get the houses stroage (the NAS Side of things) and me still being able to use it as a pc, seemed to me to be a no brainer! :)

So it is not really going to be used for gaming the a dedicated graphics card is going to help no end.

 

So any recommendations for an EVGA GTX 6-8GB Graphics cards that are more compatible with unraid ?

if the RX cards are a head ache at least :)

the reason I went with RX580 was the price for an 8gb card at the time..

 

What would you recommend for me to focus on 10,16,20,30 series?

Any suggestions are more than welcome.

as it is clear I need the help! :)

 

it is going to take me a little while to acquire a graphics card. I will keep this post updated as I can.

 

Really thanks again for your information it has really, really helped, I can stop tormenting myself with trying to get a VM to work with the RX580. :)

 

 

 

 

Vm checks.txt

Link to post

Hello, I have manged to order an EVGA GTX 1070TI SC that ticks my box of 8GB and the Suggestion of the EVGA and GTX/RTX series.

The only thing that I need to double check is SC = Super Clocked is okay or is this going to be a problem?

Link to post
  • 2 weeks later...

Hello 

I thought I was doing well, I got the clover image to work for the 1st time ever!!! :)

but the trouble still seems to be gpu.

AMD with its problems Q35 didn't work, but after the system physical computer power down it won't display a picture.

Nvidia went back to i440fx as it was the standard selection.

the 1070it shows up so it is getting power since it been detected. 

the card works since the other person sold to upgrade their's.

i passed through the bios since it is nvidia.

i even checked that the sound and graphics where on the same slot as they would be but still a black screen.

the motherboard is around the same as the EVGA 1070ti sc was around.

 

I am really coming close to losing my mind here. Please Please Help!!!

 

 

 

 

Monolith.zip

Link to post

Hi again,

 

Part of the reason you're probably not getting more feedback here is that your posts are kind of all over the place.  What you need to try and do is simply set up a VM using virtual storage (no M.2 pass through).  If you can get that to work, then you know the issue is with the m.2 device.  So much of what you're writing just doesn't make sense.  If English isn't your first language, that could be part of the problem.

 

Please try again to set up a Windows VM with just the NVIDIA GPU, Audio device, and the USB controller passed through.  If you get stuck at the UEFI shell, try the commands I previously mentioned (you never indicated if that worked for you or not).  Take pics/screenshots of anywhere you get stuck and post them back in a reply.  Keep your reply as short as possible with just the factual information regarding your setup.  This will let us quickly analyze and provide next steps.  Your longer written posts, while well-intentioned, just take us down too many confusing paths for us to properly analyze where you're getting stuck.

 

Just know that we have a plethora of users (myself included) that have zero problems with this setup on our hardware.  So something is definitely amiss or you just have a really unfortunate motherboard that doesn't want to cooperate.

Link to post

Hello.

Thanks for getting back to me. Sorry the post seem to be all over the place. It is just been a case I though I had got some somewhere with trying to solve the VM issue, but then over a short period of time what I thought was progress was not. Hence going back a step.

 

English is my 1st language, but reading is hard when small and inverted (albinoism and nystagmus, etc...). 

 

System:

intel I7 7700K, ASROCK Z270 Taichi (which I picked out for the ten SATA Ports),  48Gb DDR4 Ram 2666mhz but set 2444mhz. storage x2 14tb ironwolf x2 2tb samsung Qvo Sata SSDs, x6 10tb ironwolf, x1 1tb m.2 samsung 970 (for Windows vm) xi 500gb m.2 same unit (hoping to get a linux mint vm running off here) and a Corsair 1000watts RMI.

 

Had originally for GPU AMD Raideon Sapphire pulse RX580 8GB.

(thinking here must be simpler to pass through as didn't need to mess with Bios Roms, Plus the 8GB for photo editor plus zoom text and the OS). 

But now have installed Nvidia EVGA GTX 1070it SC 8Gb.

( as you mentioned go for EVGA GTX/RTX, I also had to find a card that was 8Gb).

 

Please bare in mind that networking and servers are new ground for me.

my knowledge for NAS's where a four bay buffalo unit that its fan failed and took out most of the electrics.

and I had a month of trying to get freeness up and running and that was bad, i didn't know what most of the choices where, I understood the basics ie volumes, pools, shares, users in that order. but there was not the user friendly side that is present here in unraid. It was a friend who said they trying unraid out and they where impressed by the VM side to unraid and they didn't have the issues I was seeing. 

Hence looking at you tube guides and turning to you guys. I have put together bare metal pc's together without problems. but this is new and I am not really happy about editing the code.

 

so unraid vm's to date.

 

AMD: my 1st try I installed the OS on to the m2 with GPU and the USB Card all passed through the windows installer ran but when it rebooted (into windows) it failed. then I found out that I cannot do that and got pointed towards a youtube guide which is where the clover image comes in.

 

this is after working out the was only secs to press a key to boot the the OS installer and this was my 1st sight of eufi shell screen which did seems to respond to commands like escape. I am thankful for those commands you gave to me, but I still have not had to use them.

 

So then I looked for other guides to setup VM's I must admit spacesaver one is really good and helpful.

But I can't find his guides where things do not work, and follow the plan he demonstrating in the video, apart from slow VNC response and odd sound but he went through some fixes. The problems I had where not touched upon.

 

So each vm I try I start with just the VNC and the USB card and nothing else. this seemed to work (which I am still not sure about).

but I got windows installed and made the changes that was pointed out in the spacesaver one's two part guide to windows VM's, still on VNC. so I added the amd GPU into the mix, and the the VM booted into windows as it should 

then two things I found it would fail

1) when I tried to install AMD latest Driver or the windows checked Driver it seemed to be a difference in the version of the driver. Each time being a fresh VM and I repeated and got the same errors. it would be fine downloading the driver as soon as it started to install it would freeze, blink on then off, then the screen would go black and will never return even I restarted the VM!

or

2) around the time 20mins of the vm booting and with me just moving the mouse around the VM would lock, crash and reboot to a black screen 90% of the time other outcomes being a eufi shell screen or QMU agent not installed, which is silly because that is the 1st thing I install on a new VM.  

 

So, this was frustrating as hell, as all outcomes ended with black screen mostly, the shell screen or the rare QMU Agent not installed screens.

 

So, at this point I was tearing the walls down looking for an answer.

then I found people saying q35 fixed their issues, I spent weeks what q35 was and where to locate it!

The Answer came in an redit article. machine type: default set to I440fx 4.2 and there was Q35 and a load of versions so stuck with 4.2.

 

using this machine type the Q35. it booted installed the driver and would boot after a shutdown of the VM so thought fixed! After the the physical server shutdown and rebooted it would go back to black screen that also will not return. but there was that one system device that was unknown to the system and no drivers could be found for it as well???

 

then I heard if is the only gpu and the system wouldn't let go of it, that this might be the cause. So I put in a cheap passive cooled gpu in the 1st slot and moved the AMD card down to the next. still no joy,

This is when I noticed that the VNC VM's after a few days a few server usual power down and start ups there would fail to.

 

This now the point I think I start to loose my mind trying to get a vm to a start and keep going.

even if i can't have a physical drive for the vm to use as it's hard drive at this point if it stable I would be overjoyed.

but I had a go with doing the clover image on a Q35 VM and I got a QMU agent not installed screen and when the server rebooted

it was in windows on the onboard graphics.

 

I have also found people saying about changing a code around BZROOT?? and I am not confident to try and most of the guides go really technical and loose me. I am not sure if this would solve the issue with the GPU?

 

Then A new error ouccred I used to be able to switch back to VNC graphics but this seemed to be no longer an option.

 

at this point you said that I was not going crazy and there is a issue with unraid and this card.

Hence when We went for an Nvidia card by EVGA and the my requirement of 8GB of video memory.

 

So, I went tried out what if I go VNC to clover and M.2 on an 1330fx VM and the 1st time it worked for the 1st time ever.

so I was hopeful about the graphics and booted the VM with the new nvidia gpu and hex edited rom file, I was not happy about creating scripts on the unraid server. but opening up a rom in an editor to loose the reflashing header I can do that with a guide.

but got an error over 'on' /> and so changed that to 'on'/> an the VM booted but it was a black screen.

Even when I found a bit more info spacesaver one always checks the vm slot where it put the card which unraid normal splits the GPU into video device and sound device and puts them into differing slots!

So I amended the code which was simple as it turned out hence 'on'/> issue.

I looked at the GPU physically and i noticed the fans where not spinning. so I checked my connection at the card this seemed right.

but RMI are modular (sorry I guess you know this) so yesterday I planned to move the desk back but I had to take the screen off so put it face down on the bed, to move the desk to move a water cooled system from the top of the tower that is the unraid server

and got in side to the PSU and that also seems fine? 

 

So is it a power draw issue? I checked a online power supply calculator and seems to be around 50% draw so I hope the 100watt PSU is enough because at the moment you can not seem to find new GPUs or high wattage power supplies. 

I feel like i am adding to this issue by having the AMD GPU with no use for it.

 

 

So I put everything back and redone the wiring and only to find the screen has got cracked from a soft bed???!!!!

So Fingers crossed a friends spare will be here sometime over the weekend :(

 

So as soon as I get a monitor I will do VNC + USB to GPU + USB and let you guys know.

one question Q35 or the default???

Link to post

Hello.

I have taken on board what you said but I was still unsure on the correct machine type to use.

So I have set up one of each machine type to a VNC VM and a VM with the new GPU passed through, but all have the USB card passed through.

 

I have set up the 4 vm's they are:

  • 1 an i440fx vm with vnc+usb Win10.
  • 2 an Q35 vm with vnc+usb Win10.
  • 3 an i440fx vm with vnc+usb win10 (when I have a monitor I will passthrough the EVGA 1070ti gpu).
  • 4 an Q35 vm with vnc+usb win10 (when I have a monitor I will passthrough the EVGA 1070ti gpu).
  • CONSTRUCT is the attempt to move the disk to the 1tb m.2 which booted with the VNC graphics when I added the GPU to the Vm after the code error. (multifunction= 'on' /> so found and corrected to 'on'/> ). Then when i booted the VM with the EVGA 1070ti gpu the outcome was a blank black screen. The GPU rom file was the one I edited via a hex editor to remove a refreshing header from the rom that I  download from tech powerup site that spacesaver's one video guided the viewer to.

 

The Q35 vm's had an unknown device that windows could not ID and nor is there a driver on the virtio iso for it either, (Please see attached images)???

 

  • All the VM's were set with cores 2 and 3 (0 and 1 left for unraid).
  • Ram is set to 16GB.
  • Machine type 1&3 = i440fx 4.2, 2&4 = Q35 4.2.
  • All VM's used the same Windows 10 Iso and virtio iso.
  • All set to VNC graphics and no audio (3&4 will have the EVGA 1070ti GPU passed through).
  • VNC keyboard set UK.
  • Vdisk location set to auto and the auto Vdisk size also the defult value of 30Gb.
  • All had the USB card Passed through via PCFIO plugin creating that profile,
  • Which, the profile is also added the m.2s to list within  the passthrough box but as requested these remain unselected.
  • Also I did not select the auto start.

 

When the OS was installed.

I installed the Qmu agent (v AMD64x83).

Then made the mouse easier to work with for my self (extra large pointer, short mouse trail, ctrl key locator and untick hide mouse whilst typing).

I would also set the high contrast setting (black on white) but left it out this time,  and opted to use the Accessing PC  magnifier to enlarge the text and increased contrast and a colour filter to remove colour (mainly reds) from the display image on screen thankfully it doesn't affect the screen grabs.

Then I moved through the device manger on the VM (networking device, system devices, display driver in that order).

I also reset the basic 600x800 screen resolution, to ease the work load on the system and keeps the text larger too.

Then went through the power options 

  • Power scheme = profromance.
  • Disable the drive hibernation.
  • Disable USB hibernation.
  • Disable fast boot.
  • Disable the power button and sleep button.
  • Disabled windows search via service.msg.
  • Ran CMD as admin to turn hibernation off (command used power cfg -h off).
  • Disabled the C : defragmenter.

This is when I powered down the particular vm.

 

Now I am playing a waiting game for the monitor to arrive over the pending weekend, to enable the GPU passthrough on VM's 3 and 4.

I will ensure that the GPU video and audio are assigned to the same slot (know I know how and the problem it causes) in both of the GPU passed through VM's, which I yet to add to the VM check list (enclosed). I have enclosed a screen grab of the device manager in each vm and the Q35 unknown device error. 

I have also attached the list on current vm's on the unraid server.

 

I also have rewatched the spacesaver one video on advanced gpu passthourghs and I did not catch before is there a real difference having the the server boot in Legacy over EUFI? and if so how do you go about applying that switch, as the video guide only highlighted this but has not really covered how???

 

I created the four VM's, so, we can see which is more problematic or the more fixable and stable in the long term. because I intend to have the VM become my PC in the long term. The pervious update I tried to hopefully put down the previous experiences with the AMD card i hope in way that is more streamlined.

I am starting to wonder if the amd issue was the card being divided up over two virtual PCIe slots?

I also forgot to attach an animated Gif image to get across the reading issue with the nystagmus.

 

As I have said previously, I am really truthfully grateful for any information, advice here, this has really been driving me around the bend.

 

I will endeavour to get the template and code for each vm uploaded tomorrow, to see if that can provide any insight that you guys would pick up on straight away and I would just totally, plainly miss completely.

 

 

 

 

 

 

 

1.png

2.png

2 device unkown.png

3.png

4.png

4 device unkown.png

Vm List.png

Reading (Nystagmus&Eye Strain).gif

Vm checks.doc.txt

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.