Jump to content

JustinAiken

Members
  • Content Count

    451
  • Joined

  • Last visited

Everything posted by JustinAiken

  1. Right now on the current docker image, I'm seeing this error on startup: /usr/lib/python3.8/site-packages/sickchill/locale /usr/lib/python3.8/site-packages/sickchill/locale Traceback (most recent call last): File "/usr/bin/SickChill.py", line 14, in <module> import sickchill.start File "/usr/lib/python3.8/site-packages/sickchill/__init__.py", line 1, in <module> from .show.indexers import indexer, ShowIndexer File "/usr/lib/python3.8/site-packages/sickchill/show/indexers/__init__.py", line 1, in <module> from .handler import ShowIndexer File "/usr/lib/python3.8/site-packages/sickchill/show/indexers/handler.py", line 5, in <module> from sickchill.tv import Show, TVEpisode File "/usr/lib/python3.8/site-packages/sickchill/tv.py", line 15, in <module> import imdb ModuleNotFoundError: No module named 'imdb' EDIT: Opened issue on github at https://github.com/linuxserver/docker-sickchill/issues/25
  2. Favorite thing is a tie between mix-n-match drive sizes, and just how easy it makes Docker apps. What I want is a full featured API so I can integrate it into HA more.
  3. ..it was bad ram. Ran memtest and the amount of corruption that spewed out would be right at home in the Trump administration.
  4. ..you got me interested in a dark theme, I just gave it a try. ``` # Run this while Node Red is up and running: $ docker exec -it NodeRed-OfficialDocker /bin/bash # Then you'll be inside the running container # Now run: $ npm install node-red-contrib-theme-midnight-red # And exit the container: $ exit # Now from unraid, edit settings.js: $ vim /path/to/nodered/settings.js ``` You'll want it to look like: ``` .... editorTheme: { page: { css: "/usr/src/node-red/node_modules/node-red-contrib-theme-midnight-red/midnight.css" } } ``` Then restart nodered docker from the unraid docker GUI.
  5. NOT the toplevel appdata folder !- the path to your nodered appdata folder. Something like `/mnt/user/appdata/nodered` https://github.com/bonanitech/node-red-contrib-theme-midnight-red#install Looks like you have to manually do some `npm`'ing
  6. To update to v1.0 that came out today: - Edit your docker template's repository field from `nodered/node-red-docker` to just `nodered/node-red` - I needed to `chown -R 1000 /path/to/appdir` to update it to the new uid used by the container
  7. Last night my unRaid became unresponse - no webUI, no ssh, and attaching I monitor I see this Kernel Panic, attached. Unfortunately no log; had to hard power it off and back on. I just turned on the syslog server, so if it happens again I'll hopefully have more info... But anyone see anything actionable in the tail end of the panic? But
  8. I almost feel bad about getting one of these and putting it on my ancient beat up Norco 4220! (Cover doesn't fit since I jammed in the 120mm fanplate :p )
  9. Same problem on 6.7.0 here, and confirmed that gist fixed it for me. Thanks @ljm42 !
  10. Love unRaid... started as a way to just hold lots of movies for XMBC to play, now it's an automated downloading behemoth that's also running backups and home automation.
  11. I'd love RSS for both blog posts, and new unRaid stable/beta releases
  12. Hahaha I'm dumb. I swear it used to be that little play/stop icon, but clicking the logo works.
  13. I've seen this on 6.7.0, at least both rc5 and rc6, and I believe one of the earlier rc's, but 5 and 6 for sure. If I go to the docker page, and hover over the icon that shows state, instead of popping up the menu of options, it shows the "rearrange tool" - Tried with white theme, black theme, and azure theme - Tried with Chrome, Safari, and Firefox - Tried in both basic and advanced view
  14. https://github.com/JustinAiken/unRaid-Youtube-DL The meat of it is this command, then some wrappers around it to make it easy to list out vids/channels/playlists you want docker run -it --rm \ --name=youtube-dl \ -v "$YOUTUBE_DIR:/src" \ wernight/youtube-dl \ -v \ --all-subs \ --embed-subs \ --add-metadata \ --ignore-errors \ --playlist-start 1 \ -f bestvideo+bestaudio \ -o "$path" \ --download-archive /src/archive.txt \ "$youtube_url" || echo "Download failed :/"
  15. Just had the same problem, and deleting the server.key/server.cert in `appdata/sabnzbd/admin` worked for me too 👍
  16. 8 seconds to finish running `xfs_repair -v /dev/md2` and I'm back to all green.. thanks @johnnie.black!
  17. Today when I started the array (rebooted to try the 6.7.0rc2 from 6.6.6; think if anything is wrong it was the reboot, not the new version that caused this) I see this: If I do `ls /mnt/` I see all my discs except for `disk2` which is just missing. - Does this mean my array is emulating disc2 via parity, or is it out and I'm going to find out once I go to watch a movie to find it's randomly not there? - Is this a disc issue, or filesystem issue? ... I used to deal with things like this all the time when I was on reiserfs, but in the last few years I've forgotten what this is like! 😛 From my syslog: Jan 29 08:46:12 Tower emhttpd: shcmd (4051): mkdir -p /mnt/disk2 Jan 29 08:46:12 Tower emhttpd: shcmd (4052): mount -t xfs -o noatime,nodiratime /dev/md2 /mnt/disk2 Jan 29 08:46:12 Tower kernel: XFS (md2): Mounting V5 Filesystem Jan 29 08:46:13 Tower kernel: XFS (md2): Corruption warning: Metadata has LSN (1:741158) ahead of current LSN (1:741150). Please unmount and run xfs_repair (>= v4.3) to resolve. Jan 29 08:46:13 Tower kernel: XFS (md2): log mount/recovery failed: error -22 Jan 29 08:46:13 Tower kernel: XFS (md2): log mount failed Jan 29 08:46:13 Tower root: mount: /mnt/disk2: wrong fs type, bad option, bad superblock on /dev/md2, missing codepage or helper program, or other error. Jan 29 08:46:13 Tower emhttpd: shcmd (4052): exit status: 32 Jan 29 08:46:13 Tower emhttpd: /mnt/disk2 mount error: No file system Jan 29 08:46:13 Tower emhttpd: shcmd (4053): umount /mnt/disk2 Jan 29 08:46:13 Tower root: umount: /mnt/disk2: not mounted. Jan 29 08:46:13 Tower emhttpd: shcmd (4053): exit status: 32 Jan 29 08:46:13 Tower emhttpd: shcmd (4054): rmdir /mnt/disk2 Seems likely that I should do what it says and run `xfs_repair`, but before I mess with 8TB of data thought I'd better check here....
  18. > When connecting from a Mac to a public share with enhanced OS X support enabled Ahha... that's been plaguing me for months, didn't know it was related to the "enhanced OS X" option. Thanks for posting!
  19. I'm more or less indifferent to the new look, except on the Docker page - it was better before the update, a lot more information fit and was readable at once. Adjusting the zoom on the new doesn't bring it back - something about padding or the like.
  20. I've been getting "unable to write to..." errors since upgrading to 6.6.1, from my Mac to a my cache share. I've tried running `newperms /mnt/cache/<folder that complains>` then ejecting and remounting the SMB share, same error...
  21. @TexasAg - if you do that, then does the query log show the host instead of the IP under "Client"? Or is that just to make local DNS queries resolve?