UHD 750 - Rocket Lake IGP support.


22 posts in this topic Last Reply

Recommended Posts

I know i915 is supported so is there any way we could get the new UHD 750 i915 drivers supported in Unraid? Specifically the new Rocket Lake line of processors and the new UHD 750 IGP.

 

Maybe I'm just doing it wrong, but trying to load the i915 drivers i get this error message:

[  636.077251] i915 0000:00:02.0: Your graphics device 4c8a is not properly supported by the driver in this
               kernel version. To force driver probe anyway, use i915.force_probe=4c8a
               module parameter or CONFIG_DRM_I915_FORCE_PROBE=4c8a configuration option,
               or (recommended) check for kernel updates.

Edited by alex711
Link to post

Is there an available driver ?

 

I think I read earlier that Intel did not yet provide that. I might have skimmed through the article too quick and be wrong.

(plus it was an article in french, so not too much use here :D )

Link to post

Yo también estoy esperando. (UHD 730-I5 11400)

 

[8086: 4c8b] 00: 02.0 Controlador compatible con VGA: Dispositivo Intel Corporation 4c8b (rev 04)

 

 

Captura.PNG

Edited by xXx
Link to post
17 hours ago, fahmietalife said:

desperate for UHD750 to be supported by unraid..... 

@xXxFound this, looks like support is already there, but needs to be triggered at present. You should be able to add to the i915 conf file in modprobe.d 

 

With Rocket Lake, the Linux support is all in order once again. But there is one sort of exception: the Gen12 Xe Graphics might not be working out-of-the-box depending upon your kernel. When I first booted up the Rocket Lake test system with Linux 5.12 + Mesa Git previously already installed, I was startled to find accelerated graphics not working... LLVMpipe was at play. This was a big surprise given Intel's track record and Gen12 Linux graphics support being out for a while now. Checking dmesg though quickly revealed that the PCI ID was still hidden behind the early support flag.

 

Re-booting the system while having "i915.force_probe=4c8a" avoided the issue and accelerated graphics were quickly working. All was well on both the i5-11600K and i9-11900K processors when booting the stable Linux kernel with the force_probe option. While the patch to remove Rocket Lake from requiring the force probe has been on the mailing list for several months, as of writing it hasn't landed in the stable upstream Linux kernel. At the moment that is queued into DRM-Next ahead of Linux 5.13... We'll see if one of the "fixes" pull request soon removes this restriction. Some distribution kernels including the likes of Ubuntu are already carrying the patch for providing the Rocket Lake support out-of-the-box.

 

I am not 100% sure if this is correct. But I think you should be able to add the following to i915.conf

 

options i915 force_probe=4c8a

 

Removal of support flag not in kernel as yet.

 

 

Edited by SimonF
Link to post
9 minutes ago, xXx said:

Thanks, but the ones I need are the ones from unRAID.

 

 

Have you tried adding 

 

options i915 force_probe=4c8a to file /boot/config/modprobe.d/i915.conf and rebooting?

Link to post
5 hours ago, SimonF said:

 

 

Have you tried adding 

 

options i915 force_probe=4c8a to file /boot/config/modprobe.d/i915.conf and rebooting?

 

IMG_20210408_153112__01.jpg

Link to post
46 minutes ago, xXx said:

 

IMG_20210408_153112__01.jpg

Just to confirm you have the following

 

root@computenode:~# cat /boot/config/modprobe.d/i915.conf 
options i915 force_probe=4c8a
root@computenode:~# 

 

I dont have a new gen cpu, but dont get any errors.

 

root@computenode:~# modprobe -c | grep 4c8a
options i915 force_probe=4c8a

Edited by SimonF
Link to post
On 4/4/2021 at 9:17 PM, xXx said:

[8086: 4c8b] 00: 02.0 Controlador compatible con VGA: Dispositivo Intel Corporation 4c8b (rev 04)

Sorry just noticed looks like you have 4c8b, update to this. I was using the OP vers and didnt notice yours was different.

Link to post
24 minutes ago, xXx said:

I realized just when I made the capture, it is changed to 4c8b, but it keeps giving me the same error

Please try to append 'force_probe=4c8a' to your syslinux.config and reboot (if you do it like that then please remove the contents of the i915.conf file).

Please don't double post, you also can mention me here. ;)

 

Your i915.conf file has to be empty or at least have only the middle line in it, the first and the last line are wrong.

  • Like 1
  • Thanks 1
Link to post
30 minutes ago, ich777 said:

Intente agregar 'force_probe = 4c8a' a su syslinux.config y reinicie (si lo hace así, elimine el contenido del archivo i915.conf).

Por favor, no publiques dos veces, también puedes mencionarme aquí. ;)

 

Su archivo i915.conf debe estar vacío o al menos tener solo la línea media, la primera y la última línea son incorrectas.

yes, I have added only one line: options i915 force_probe = 4c8b
Sorry to mention in two,

Link to post

What output to you get from lspci -v for your gpu.

 

Example:


00:02.0 VGA compatible controller: Intel Corporation Device 9ba8 (rev 03) (prog-if 00 [VGA controller])
        DeviceName: Onboard - Video
        Subsystem: Micro-Star International Co., Ltd. [MSI] Device 7c88
        Flags: bus master, fast devsel, latency 0, IRQ 127, IOMMU group 2
        Memory at c2000000 (64-bit, non-prefetchable) [size=16M]
        Memory at a0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 5000 [size=64]
        Expansion ROM at 000c0000 [virtual] [disabled] [size=128K]
        Capabilities: [40] Vendor Specific Information: Len=0c <?>
        Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [ac] MSI: Enable+ Count=1/1 Maskable- 64bit-
        Capabilities: [d0] Power Management version 2
        Capabilities: [100] Process Address Space ID (PASID)
        Capabilities: [200] Address Translation Service (ATS)
        Capabilities: [300] Page Request Interface (PRI)
        Kernel driver in use: i915
        Kernel modules: i915
 

Link to post
Hace 5 minutos, SimonF dijo:

00:02.0 VGA compatible controller: Intel Corporation Device 4c8b (rev 04) (prog-if 00 [VGA controller])
        Subsystem: ASRock Incorporation Device 4c8b
        Flags: bus master, fast devsel, latency 0, IRQ 159, IOMMU group 1
        Memory at 6000000000 (64-bit, non-prefetchable) [size=16M]
        Memory at 4000000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 5000 [size=64]
        Expansion ROM at 000c0000 [virtual] [disabled] [size=128K]
        Capabilities: [40] Vendor Specific Information: Len=0c <?>
        Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [ac] MSI: Enable+ Count=1/1 Maskable+ 64bit-
        Capabilities: [d0] Power Management version 2
        Capabilities: [100] Process Address Space ID (PASID)
        Capabilities: [200] Address Translation Service (ATS)
        Capabilities: [300] Page Request Interface (PRI)
        Kernel driver in use: i915
        Kernel modules: i915

 

 

Link to post

Yes now. Thanks a lot :)

yes!!.PNG

intel GPU.PNG

Edited by xXx
It already works albeit half, when I use plex pass, it only transcodes H264 the integrated igpu, but if I run H265 it does not transcode the igpu
Link to post
55 minutes ago, xXx said:

Yes now. Thanks a lot :)

yes!!.PNG

intel GPU.PNG

 

1 hour ago, xXx said:

force_probe = 4c8b

You can also add this as said to your syslinux.conf file so that you don't have to do anything or create a file if you installed the Intel-GPU-TOP plugin.

But I was wrong above you have to do it in this format:

i915.force_probe=4c8b

Simply append this to your syslinux.conf file and this is appended when the Intel-GPU-TOP plugin loads the drivers, so no need to create the file with the contents (Main -> Click on 'Flash' and append it like that and click Apply at the bottom):

grafik.thumb.png.aad9d9542c4ab9425e84802da2210050.png

 

 

57 minutes ago, xXx said:

It already works albeit half, when I use plex pass, it only transcodes H264 the integrated igpu, but if I run H265 it does not transcode the igpu

From what I know this is a problem with Plex and you can only solve this if you run a custom script but you have to run it on every update of the container otherwise it will stop working again.

 

I would post an issue an the Plex Forums about that. ;)

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.