every reboot caues unraid to do parity check and says unsafe shutdown


Recommended Posts

how do i know if its old or new? i dunno anything about errors  all i know is the history  tab   and i showed no parity errors

 

so what does the scrub do?  and how do i know if i fixed the error?  

 

and is BTRFS  a good system  i choose it because when i first installed unraid and gave me options i googled it and they said btrfs  was good over xfs  but i really dont know and if i should stay with btrfs  or go with xfs  etc

 

but  ya i not sure how to know if i fixed the error????

Link to comment
  • Replies 95
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

Posted (edited)

i clicked disk 3  and it says 

 

UUID: 610be969-2e97-4e51-adeb-39267e01779c no stats available Total to scrub: 1.47TiB Rate: 0.00B/s Error summary: no errors found

 

didnt click the scrub button

 

and i dont know how to clear the btrfs scrub stats??

Edited by comet424
Link to comment
Posted (edited)

ah ok.. so whats the next test? i doing a scrub i dunno what i really does

 

and i was asking a question  i should have added ?

so it was a question    "stay with btrfs or go with xfs?"

 

so what next test i do  before i do a reboot?

and how you clear that stat that the other guy said

 

Edited by comet424
Link to comment
Posted (edited)

so i ran that scrub  on disk 3  no errors... i running a balance  on disk 3 whatever that does

 


UUID:             610be969-2e97-4e51-adeb-39267e01779c
Scrub started:    Wed Apr 14 16:07:03 2021
Status:           finished
Duration:         3:22:51
Total to scrub:   1.47TiB
Rate:             126.91MiB/s
Error summary:    no errors found

 

Edited by comet424
Link to comment
1 hour ago, comet424 said:

so here is the log before the reboot and a diagnostic after the reboot

Those don't help to diagnosing an unclean shutdown, the only ones that can help are the diags saved by Unraid in the logs folder.

Link to comment
Posted (edited)

ok here are the logs from yesterday and today if i have to go further back let me know

from the flash\logs folder... if you need me to go further back  more dates  i can attach them too

tower-diagnostics-20210415-0817.zip tower-diagnostics-20210415-0819.zip unbalance.log tower-diagnostics-20210415-1252.zip tower-diagnostics-20210414-1359.zip tower-diagnostics-20210414-1405.zip

Edited by comet424
Link to comment
Posted (edited)

heck if i know whats automaticlly created..  you guess is good as mine  i guess 

it be 

 

ubalance.log

and the 8am file

you guys are smarter then me at log files.

if i took a guess it be

 

8:19am file 

its confusing  as tower-diagnostics-xxxx is labled the same as a manual download

so you cant even tell between the 2 either

 

be nice if the Flash logs wrote   

tower-diaganostics(flash)-xxxx

and manual

tower-diaganostics(manual)-xxxx

 

but you guys are the experts.  hopefully you can figure it 

 

but whats confusing these are really noy Flash logs they are "diagnostic" download files 

it seems there is no difference from  "flash logs" and "manual down"

 

 

maybe log files should be saved as  

tower-diagnostic(Reboot)  

 

somethiong to show  whats a pre reboot and whats and after reboot file in flash logs

 

unless there is something i can change  so it makes it easier for me to distinguish

 

 

reason i said i gave the last 2 days diag nostics is to look in there what keeps causing this bug that other people are having and that the 100 second from 90 seconds trick didnt fix it... as i also make sure to check  fix common issues too to try to solve those too

 

 

Edited by comet424
Link to comment

just the 90 seconds to the 100 seconds  that was from the other forum that fixed the issue for other people  

i havent tried different numbers as trul  was giving me other tests to do...  

 

i dunno how high to go?  or what number is too high

Link to comment

ok the 150 seconds fixed it.. it didnt take a new log file

 

did the log files tell you what caused the timeout from not being honored?

is it the VMS?  more so Windows VMs?

does it say like windows does

 

These Files are still open do you wish to force closer...  does the diagnostics tell ya  what was still open at the time of the timeout?

Link to comment
2 hours ago, comet424 said:

did the log files tell you what caused the timeout from not being honored?

It appears to be an Unraid bug, it's not respecting the set timeout, you had the timeout set to 100 secs, and Unraid was forcing the shutdown after less than 30 secs had elapsed, changing the setting usually makes it stick, same thing happened to a handful of users after upgrading to v6.9.

Link to comment

oh ok.. as its was set to 90secs i guess thats the default.. and then i set it to 100  and  i just in the earlier post set it to 150

 

so i figured it was a Windows VM thing you know how it hangs

ro how you cant shut down Windows VMS  using Stop  you always gootta use the Force Stop  as it wont shut downin the VM section.. be nice if they could fix that too  that the STOP would shut it down.. or i had to click STOP 2-4 times  to get ot to shut down  ..

 

so least i not going crazy.. so then  will this  happen again in the next reboot or will it stick..  i didnt try a 2nd reboot 

i was also thinking maybe my hard drives are failing and unraid knows something

Link to comment
7 minutes ago, comet424 said:

ro how you cant shut down Windows VMS  using Stop  you always gootta use the Force Stop  as it wont shut downin the VM section.

You can try hibernating the VMs instead, that's what I do, much faster.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.