[Support] Josh5 - Steam (Headless)


Recommended Posts

No luck on my side, but I'm on 6.9.2.  I'll upgrade to 6.10 tomorrow.  

 

No luck there either, but found a problem of some sort in dmesg- 
 

[26167.409463] pcieport 0000:00:03.0: AER: Uncorrected (Non-Fatal) error received: 0000:02:00.0
[26167.409473] pcieport 0000:02:00.0: PCIe Bus Error: severity=Uncorrected (Non-Fatal), type=Transaction Layer, (Requester ID)
[26167.409476] pcieport 0000:02:00.0:   device [1022:1471] error status/mask=00100000/00000000
[26167.409478] pcieport 0000:02:00.0:    [20] UnsupReq               (First)
[26167.409480] pcieport 0000:02:00.0: AER:   TLP Header: 34000000 03000010 00000000 84288428
[26167.409489] [drm] PCI error: detected callback, state(1)!!
[26167.409503] pci 0000:03:00.1: AER: can't recover (no error_detected callback)
[26167.409511] pcieport 0000:02:00.0: AER: device recovery failed

 

Repeats ~1000 times per second.

Edited by bmfrosty
To not doublepost
Link to comment
On 8/31/2022 at 11:42 PM, Ouadie BAKI SENHAJI said:

Hello,

Thank you for this great project

How can I start steam collapsed (hidden in sys tray). I googled and found that -silent do the job..

tried to add it in the Applications > Settings > Session and Startup :

from /usr/game/steam %U to /usr/game/steam %U -silent

for some reason after reboot the command is back to initial value (/usr/game/steam %U)

any idea !

The command that was installing the home directory template on boot was overriding these files every time. 
I have updated the rsync command with `--ignore-existing` so that your changes will not be over written again on boot.

I also like this change that you are making so I have made it the default for new installations moving forward. Thanks

  • Like 1
Link to comment
On 8/30/2022 at 1:03 AM, dopeytree said:

How would one control the desktop size?

You can set this in the Display settings. These should persist on restart and update of the container.

 

Note that the NVIDIA X server settings control panel will not persist as these are stored elsewhere and are generated from scratch on startup. If you want to set the resolution from the desktop, the Display settings control panel is the one to use.
image.thumb.png.7b8c16e55e498ea48271135139e5a6b7.png

 

If you want another way, you can also set these in the container environment variables:

    DISPLAY_CDEPTH="24"
    DISPLAY_DPI="96"
    DISPLAY_REFRESH="60"
    DISPLAY_SIZEH="900"
    DISPLAY_SIZEW="1600"

 

Link to comment
On 8/29/2022 at 10:08 AM, Spectral Force said:

I keep getting this error:

 

2022-08-28 22:04:49,170 INFO success: x11vnc entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
2022-08-28 22:04:49,171 INFO exited: x11vnc (exit status 1; not expected)

 

Does anyone have any insight?

This is likely caused by a conflict. Are you running any other X11 servers on this PC?

The log `/var/log/Xorg.55.log` (inside the container) may be useful also.

Link to comment
On 7/27/2022 at 1:47 AM, pinion said:

 

For this esync issue you need to edit the Docker Container for Steam-Headless and enable the Advanced view (default is Basic just check the slider). Then in the Extra Parameters: add

 --ulimit nofile=1024:524288

 

Restart the container and you should be good to go. Worked for me with Disco Elysium from GOG.

Thanks for this. I have added this to the default template. This is also a requirement to get Epic working.

  • Like 1
Link to comment

Got everything working yesterday.  Had to change a kernel parameter and had some conflict that I had to solve between this container and a VM - (I didn't fix it, I reinstalled the chart, which caused the problem to go away), and I updated this AM, but now in noVNC I get a popup that I didn't have yesterday:

noVNC encountered an error:



The play() request was interrupted because the media was removed from the document. https://goo.gl/LdLk22

I saw this occasionally before when I was testing and got the VNC for my container, so I don't know if it's a regression here or elsewhere.

Link to comment

A bunch of things are now working.  The container definitely works, I can VNC in and it definitely works, and I can play games that are DX9 and they work.  I was able to launch Saints Row IV and Portal 2.  What's not working is anything past DX9.

 

I'm running a Vega 56, which does have DX12 support, so I'm expecting it to be a drivers problem.  I've tried GTAV and Darksiders (Warmastered Edition), and GTAV complains that my hardware doesn't support DX10/11, and Darksiders complains that the hardware doesn't support DX10.

 

I'm not sure how to troubleshoot this.  Older games *tend* to work as long as I'm running them through Proton and not relying on the Linux version.

 

Can anyone point me in the right direction?

Link to comment

I followed the instructions in the first post of this thread and was able to get Stardew Valley working without any additional tinkering or playing with settings.  At first the steam link did not recognize this as a computer but after restarting the container the problem seemed to fix itself.  This is an awesome container, and thanks to the creator for the work they've put in.

  • Like 1
Link to comment
  • 2 weeks later...

Thank you for this amazing project!!

 

I have noticed that there is a huge audio lag when accessing Steam via noVNC. Is there any way to resolve this?

 

I've also noticed a number of games do not launch. Some without an error, or in the case of Portal:

 

Any ideas why this might be?

 

firefox_wohOJdFrTJ.png

Edited by Xenu
Link to comment
2022-09-24 16:58:35,420 INFO exited: pulseaudio (exit status 1; not expected)
2022-09-24 16:58:38,009 INFO spawned: 'pulseaudio' with pid 615
2022-09-24 16:58:38,024 INFO exited: pulseaudio (exit status 1; not expected)
2022-09-24 16:58:41,059 INFO spawned: 'pulseaudio' with pid 616
2022-09-24 16:58:41,075 INFO exited: pulseaudio (exit status 1; not expected)
2022-09-24 16:58:41,104 INFO gave up: pulseaudio entered FATAL state, too many start retries too quickly
2022-09-24 16:58:43,171 INFO reaped unknown pid 619 (exit status 0)
2022-09-24 16:58:43,438 INFO exited: desktop (exit status 1; not expected)
2022-09-24 16:58:44,441 INFO spawned: 'desktop' with pid 674
2022-09-24 16:58:44,470 INFO reaped unknown pid 679 (exit status 0)
2022-09-24 16:58:44,569 INFO exited: desktop (exit status 1; not expected)
2022-09-24 16:58:45,572 INFO spawned: 'desktop' with pid 702
2022-09-24 16:58:45,603 INFO reaped unknown pid 707 (exit status 0)
2022-09-24 16:58:45,698 INFO exited: desktop (exit status 1; not expected)
2022-09-24 16:58:47,702 INFO spawned: 'desktop' with pid 730
2022-09-24 16:58:47,732 INFO reaped unknown pid 735 (exit status 0)
2022-09-24 16:58:47,825 INFO exited: desktop (exit status 1; not expected)
2022-09-24 16:58:50,830 INFO spawned: 'desktop' with pid 758
2022-09-24 16:58:50,860 INFO reaped unknown pid 763 (exit status 0)
2022-09-24 16:58:50,954 INFO exited: desktop (exit status 1; not expected)
2022-09-24 16:58:51,956 INFO gave up: desktop entered FATAL state, too many start retries too quickly

 

Getting these errors on launch..

 

Upgraded to 6.11 so maybe that's it?

Edited by dopeytree
Link to comment
6 hours ago, dopeytree said:
2022-09-24 16:58:35,420 INFO exited: pulseaudio (exit status 1; not expected)
2022-09-24 16:58:38,009 INFO spawned: 'pulseaudio' with pid 615
2022-09-24 16:58:38,024 INFO exited: pulseaudio (exit status 1; not expected)
2022-09-24 16:58:41,059 INFO spawned: 'pulseaudio' with pid 616
2022-09-24 16:58:41,075 INFO exited: pulseaudio (exit status 1; not expected)
2022-09-24 16:58:41,104 INFO gave up: pulseaudio entered FATAL state, too many start retries too quickly
2022-09-24 16:58:43,171 INFO reaped unknown pid 619 (exit status 0)
2022-09-24 16:58:43,438 INFO exited: desktop (exit status 1; not expected)
2022-09-24 16:58:44,441 INFO spawned: 'desktop' with pid 674
2022-09-24 16:58:44,470 INFO reaped unknown pid 679 (exit status 0)
2022-09-24 16:58:44,569 INFO exited: desktop (exit status 1; not expected)
2022-09-24 16:58:45,572 INFO spawned: 'desktop' with pid 702
2022-09-24 16:58:45,603 INFO reaped unknown pid 707 (exit status 0)
2022-09-24 16:58:45,698 INFO exited: desktop (exit status 1; not expected)
2022-09-24 16:58:47,702 INFO spawned: 'desktop' with pid 730
2022-09-24 16:58:47,732 INFO reaped unknown pid 735 (exit status 0)
2022-09-24 16:58:47,825 INFO exited: desktop (exit status 1; not expected)
2022-09-24 16:58:50,830 INFO spawned: 'desktop' with pid 758
2022-09-24 16:58:50,860 INFO reaped unknown pid 763 (exit status 0)
2022-09-24 16:58:50,954 INFO exited: desktop (exit status 1; not expected)
2022-09-24 16:58:51,956 INFO gave up: desktop entered FATAL state, too many start retries too quickly

 

Getting these errors on launch..

 

Upgraded to 6.11 so maybe that's it?

I have not upgraded yet... I'll take a look when I can

  • Like 1
Link to comment
On 4/3/2022 at 8:58 PM, Spectral Force said:

Yeah can't do that and access it from work.  Was hoping for a reverse proxy solution.  Thanks.

This is a bit old, however, I'm able to access the webui it behind Swag with Authelia for authentication. I have Swag configured to only forward the webUI port the rest of the ports are accessible without modification via steam link by default 
 

## Version 2022/09/08

# "set $upstream_app <HOSTIP>;" for host mode, HOSTIP being the IP address of steam



server {

    listen 443 ssl;

    listen [::]:443 ssl;



    server_name steam.*;



    include /config/nginx/ssl.conf;



    client_max_body_size 0;



    # enable for ldap auth (requires ldap-location.conf in the location block)

    #include /config/nginx/ldap-server.conf;



    # enable for Authelia (requires authelia-location.conf in the location block)

    include /config/nginx/authelia-server.conf;



    location / {

        # enable the next two lines for http auth

        #auth_basic "Restricted";

        #auth_basic_user_file /config/nginx/.htpasswd;



        # enable for ldap auth (requires ldap-server.conf in the server block)

        #include /config/nginx/ldap-location.conf;



        # enable for Authelia (requires authelia-server.conf in the server block)

        include /config/nginx/authelia-location.conf;



        include /config/nginx/proxy.conf;

        include /config/nginx/resolver.conf;

        set $upstream_app <HOSTIP>;

        set $upstream_port 8083;

        set $upstream_proto http;

        proxy_pass $upstream_proto://$upstream_app:$upstream_port;



    }



}

 

Update: Just saw this post, I'm not currently passing this above, but I was only passing the webUI to set stuff up not play games.

Edited by jxjelly
formatting / update
Link to comment

Trying to utilize this with 1660 Super & Ryzen 1600AF - it's super slow... AC Origins 25 mins and it's still launching - games are on SSD share, shaders are done, using 5 GHz wifi. Should I pin some cores for this container exclusively? Memory is not an issue as I have 30 GB free...

Edited by cpu
Link to comment
On 9/24/2022 at 10:54 PM, Xenu said:

Thank you for this amazing project!!

 

I have noticed that there is a huge audio lag when accessing Steam via noVNC. Is there any way to resolve this?

 

I've also noticed a number of games do not launch. Some without an error, or in the case of Portal:

 

Any ideas why this might be?

 

firefox_wohOJdFrTJ.png

 

I think this is the issue you're having - https://github.com/ValveSoftware/Source-1-Games/issues/1685

 

Seems that some steam games dont like XFS file systems. I'm unsure as best way to fix it, I have just given up on some of those games. Maybe use an unassigned drive for the game storage?

Link to comment
8 hours ago, eatoff said:

 

I think this is the issue you're having - https://github.com/ValveSoftware/Source-1-Games/issues/1685

 

Seems that some steam games dont like XFS file systems. I'm unsure as best way to fix it, I have just given up on some of those games. Maybe use an unassigned drive for the game storage?

But once you create share with cache set to only games will sit on SSD which have btrfs

Link to comment
On 9/25/2022 at 3:54 AM, Xenu said:

Thank you for this amazing project!!

 

I have noticed that there is a huge audio lag when accessing Steam via noVNC. Is there any way to resolve this?

 

I've also noticed a number of games do not launch. Some without an error, or in the case of Portal:

 

Any ideas why this might be?

 

firefox_wohOJdFrTJ.png

I have noticed on lower end hardware that there are massive delays in audio sync. Even on my PC where it has poo loads of CPU to spare, the audio for noVNC is lagging by about half a second.

I suspect that this is all to do with the encoding being used. There is nothing about this that is really low latency.

That all being said, I would recommend leaving the VNC web UI only for tinkering and never playing games. When you want to stream the desktop with low latency, ther are better options available. I'll post an update here shortly with some if the newly added and upcoming changes to Steam Headless.

Link to comment

Over the past month I have been slowly improving various aspects of Steam Headless. Here are some of the recently added updates:

- Added neko as an optional alternative to noVNC (This must ne configured through environment variables).
- Improved container start times.
- Made all VNC and audio transport ports dynamicly configured on startup. You no longer need to specify them all to avoid conflicts, Steam Headless will find and use a random available port on startup (You can still configure them if you really want).
- Added docker compose templates for other non-unraid OS.
- Various bug fixes.
- Updated Unraid template in CA.


What I'm working on this week:
- Adding sunshine to init. This will be optional to run and configured through env variables, but if enabled it will provide a really nice low latency way of accessing the desktop.
- Adding keyboard and mouse pass-through support. The container already supports video out through your GPU. Now it will also support USB attached kb and mouse if you configure it to.

  • Like 4
  • Thanks 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.