[Plug-In] Community Applications


Recommended Posts

9 minutes ago, Chester said:

posted in the General Support forum, but realized it may be more useful here.

Probably more useful to keep it to that other thread, or at least have included a link to it:

 

I suspect you still haven't prepared your flash correctly as indicated by the problems you were still having on the other thread.

Link to comment
  • 2 weeks later...

Today's update along with some fixes and enhancements brings the ability to update the applications directly within CA (installed apps), rather than the previous method of simply linking back to either the Docker or Plugins tab.

 

Keeping in line with how the rest of the world works, there is a new option within CA's Settings that will have CA check for updates when entering in the Apps tab (defaults to check for updates).  This is outside of your regularly scheduled update checks done via Settings - Notification Settings (and if updates are found via CA, then a notification will not get sent until your scheduled check happens)

 

Because this check runs in the background, depending upon how many applications you have installed, if an update is found it may not show up as being available if you immediately jump into Installed Apps.  In practice however this shouldn't be an issue.

Link to comment

i'm not sure if this a question i should under this thread or under the "Fix Common Problem" app thread, or maybe even a new thread.

i'm trying to fix permission for folders created by my qBittorrent docker container. For whatever reason, whenever i download a torrent, the permission sets it to "Nobody", instead of my user. I could move the files to a different folder in the share, but i can't seem to delete (weird).

 

i want to run the Fix Common Problem plugin to fix the permission issue, but it chose the share i want to move my downloaded files  to as the CA backup destination and since the plugin exclude scanning that folder, i unable to use the plugin to fix my downloads.

 

I guess this is a 2 part question:

1. how would i fix download permission problem with qBittorrent?

2. how do i change my CA Backup Destination?

 

i just started using UNraid for few weeks, so if anyone can point me the to direction needed to fix this, i would very much appreciate it.

 

Here is my permission setup for my qBittorrent docker container.

image.png.190410b883a2ca6863d948e72c8ba22c.png

Link to comment
32 minutes ago, gantoz said:

maybe even a new thread

Ideally under the qBittorent support thread

32 minutes ago, gantoz said:

how would i fix download permission problem with qBittorrent?

Barring playing around with the PUID / PGID variables (which AFAIK should be good), most download clients have options as to what to set the permissions on new downloads (advanced settings?).  You'd want 0777 and not worry about the ownership

33 minutes ago, gantoz said:

how do i change my CA Backup Destination?

By clicking in it.  Will bring up a directory listing.

Link to comment
  • 2 weeks later...

Hey Guys,

 

I'm trying to get librephotos from dockerhub, https://hub.docker.com/r/reallibrephotos/librephotos/ unfortunately it won't download it.

TOTAL DATA PULLED: 0 B

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='librephotos-frontend' --net='bridge' -e TZ="Europe/Berlin" -e HOST_OS="Unraid" 'reallibrephotos/librephotos-frontend'
Unable to find image 'reallibrephotos/librephotos-frontend:latest' locally
docker: Error response from daemon: manifest for reallibrephotos/librephotos-frontend:latest not found: manifest unknown: manifest unknown.
See 'docker run --help'.

The command failed.

 

I don't know why it won't find the image locally, so it would expect it to download it but somehow doesn't.

 

Any ideas what I need to change?

 

thank you in advance,

Autchi

Link to comment

Trying to install Vaultwarden through CA, it lets me select a branch but just goes back to the main page after I select a branch. It won't take me to the template page.

 

image.png.bb1ab9bdb48306897efc260cd91e1b30.png

 

Tried installing other apps and I'm able to get to the template pages fine. I've tried multiple different browsers, on different devices and restarted my unraid server.

 

Any help would be appreciated, thanks!

Link to comment

Issue:  CA App version 2021.08.08 - Search only returns results of Application titles and ignores the descriptions.

 

 

What occurred:  I wanted to find a Minecraft server manager that I previously used.  I searched for Minecraft and only had ~10ish titles show up.  I knew there were more so I searched for Crafty and discovered there were indeed packages being left out.   If you search for Minecraft, the results show red highlights for the word Minecraft in titles and descriptions.  For applications that do not have the word Minecraft in the title but have it in the description, their results will be omitted and not shown.

 

Steps to reproduce:

 

1.  Go in the CA and search for Minecraft

2. Notice that Minecraft is highlighted in the titles and description of the applications.

3. Search for Crafty

3. Notice that Minecraft is in the description of the crafty application and yet was not displayed in the search results in Step 1. 

 

I hope this is clear.

 

 

 

Link to comment

Having an issue that I noticed after last update.

If an installer gives me a popup window for which branch to install none of the branches work.
I can click any of the branches, but nothing at all will happen, the popup even stays open.

Steps I did when issue appeared
- Installed overseerr - linuxserver docker
- Removed overseerr - linuxserver docker

- Updated CA to last version (2021.08.08) as per CA's request

- Tried installing overseerr - linuxserver docker but my above issue started appearing

 

Any that don't give this popup work completely normal and instantly bring me to the template.

It doesn't matter if it's one I've had/have installed before or if it's a completely new one.

 

Restarting UNRAID did not solve the issue.

 


As an example I put a picture of emby - linuxserver (one of the ones I've tried) to show what popup I mean.

 

image.png.d520fcc75a023357fbeecb2de318dccb.png

Edited by ErikRedbeard
Link to comment

CA is great. Thank you for the work. Curious, is there a way to look at the statistics outside of CA? Example. I find it interesting to see what's trending to learn about new/upcoming packages I might want to try, but it may be more convenient to look at that outside of unraid's management interface. 

Link to comment
3 minutes ago, stevilg said:

CA is great. Thank you for the work. Curious, is there a way to look at the statistics outside of CA? Example. I find it interesting to see what's trending to learn about new/upcoming packages I might want to try, but it may be more convenient to look at that outside of unraid's management interface. 

The stats reflect everything.  Not just Unraid / Community Applications

Link to comment
19 hours ago, stevilg said:

Ok great, any place other than in unraid to see that?

Not really.  The pull counts are kept track of month to month by CA and then the graphs are generated.  Closest you can get is that current pull count from dockerHub

image.png.22093e44aec8fcb3eee7bfd8a68ce2a1.png

Link to comment

Just FYI, the appfeed is (as of today) incompatible with 6.0 / 6.1 versions of the OS.  Even if you haven't upgraded the OS and are running a version of CA which operates on those versions.  This saves a rather significant amount of bandwidth on the feed.  (The uncompressed size of the feed is roughly 38% smaller)

Link to comment
On 7/13/2021 at 10:13 PM, Chester said:

UPDATE - solved with new flash drive.

 

Folks:

I posted in the General Support forum, but realized it may be more useful here.

 

Long story short, after a upgrade to 6.9.2, I ended up doing a fresh install.  Trying to reinstall CA, I am receiving the following error.  Anyone help?

 

image.png.b30137b6455994aa6b470ce8a9f2add6.png

 

I also have several errors showing in the docker section of the dashboard.

 

Warning: parse_ini_file(/boot/config/docker.cfg): failed to open stream: No such file or directory in /usr/local/emhttp/plugins/dynamix.docker.manager/include/DockerClient.php on line 50

Warning: array_replace_recursive(): Expected parameter 2 to be an array, bool given in /usr/local/emhttp/plugins/dynamix.docker.manager/include/DockerClient.php on line 50

Warning: parse_ini_file(/boot/config/domain.cfg): failed to open stream: No such file or directory in /usr/local/emhttp/plugins/dynamix.vm.manager/include/libvirt_helpers.php on line 478

I've started getting lots of similar today as well, but in the plugins tab. 

Not found a solution yet...

Link to comment
5 hours ago, Squid said:

The problem is the flash drive (assuming that the messages are similar).  Try a different port (and reboot) or replace.

Its not the flash drive.

No errors elseware on the system, and its been functioning fine in the same port for over a year.  

 

Strangely, installing a different dynamix plugin seems to have resolved it, will keep an eye on it though.

Link to comment

Hello, I'm having a funny issue where the WordPress docker container always wants to update even though there is no update available. This happens when I'm looking under Apps -> Installed Apps but not when I'm looking under Docker in Unraid.

 

image.png.978f442be71c53b2ffdbab363ba3fc55.png

 

image.png.86b25aba79233a2d071d0d1dc6760b9f.png

 

image.thumb.png.3de3ba2a317706d3840d37b383b9a256.png

Link to comment
18 hours ago, mrkvchm said:

Hello, I'm having a funny issue where the WordPress docker container always wants to update even though there is no update available. This happens when I'm looking under Apps -> Installed Apps but not when I'm looking under Docker in Unraid.

Thanks.  Official containers always displaying an update available fixed next release.

  • Thanks 1
Link to comment

@Squid  have an idea for the community apps plugin,  a page where all installed plugins are displayed in a list format, with a checkbox beside each to quickly enable/disable the plugin for diagnostics/testing purposes.
unchecking the plugin temporarily remvoes the plugin / refreshes unraid without the plugin

Edited by TRusselo
Link to comment
21 minutes ago, TRusselo said:

unchecking the plugin renames the plugin/extension and refreshes unraid without the plugin

Not quite the way it works. The .plg files are used to load the plugins at boot. Simply renaming the .plg after boot won't unload anything.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.