Jump to content
linuxserver.io

[Support] Linuxserver.io - Kodi-Headless

584 posts in this topic Last Reply

Recommended Posts

I've not tested that as a possible solution, so I'd be grateful if you try it if you could post the results here...

 

Sent from my LG-H815 using Tapatalk

 

Just to clarify you mean for me to try to delete the docker.img or leaping out of the nearest window?

 

Well I can rule out the docker.img stuff here....  ;D

Share this post


Link to post

I've not tested that as a possible solution, so I'd be grateful if you try it if you could post the results here...

 

Sent from my LG-H815 using Tapatalk

 

Just to clarify you mean for me to try to delete the docker.img or leaping out of the nearest window?

 

Well I can rule out the docker.img stuff here....  ;D

 

If you need me to try, I can. However, since you mentioned that you were able reproduce the error, I have not tried. I have quite a few dockers to recreate, if you can quickly rule the docker.img that'll be swell.

Share this post


Link to post

I've not tested that as a possible solution, so I'd be grateful if you try it if you could post the results here...

 

Sent from my LG-H815 using Tapatalk

 

Just to clarify you mean for me to try to delete the docker.img or leaping out of the nearest window?

 

Well I can rule out the docker.img stuff here....  ;D

 

If you need me to try, I can. However, since you mentioned that you were able reproduce the error, I have not tried. I have quite a few dockers to recreate, if you can quickly rule the docker.img that'll be swell.

 

It was a joke man, it's not the docker.img.....

Share this post


Link to post

my best bet is one of the default kodi addons is broken and is crashing the container.

 

 

that's only a guess, but whatever it is, it seems to be something fairly universal and related to jarvis, a fresh pull of the alpine test container for Jarvis does the same, so do two of the competition (ie, not LSIO containers).

 

 

Share this post


Link to post

thanks for the update sparklyballs, hopefully this widespread an issue gets remedied quickly. is this bug being tracked, can't seem to find reference to this particular segfault?

Share this post


Link to post

Rebooted the server and I started getting this segfault error in my syslog. I've tried removing the docker completely and reinstalling but still get the error. Any ideas?

 

Aug 28 01:06:29 Tower kernel: JobWorker[12434]: segfault at 4c0 ip 00000000009c0cc7 sp 00002b02f0a02730 error 4 in kodi.bin[400000+1da6000]
Aug 28 01:06:49 Tower kernel: JobWorker[12723]: segfault at 4c0 ip 00000000009c0cc7 sp 00002b77623db730 error 4 in kodi.bin[400000+1da6000]
Aug 28 01:07:09 Tower kernel: JobWorker[12997]: segfault at 4c0 ip 00000000009c0cc7 sp 00002b8ff9d1b730 error 4 in kodi.bin[400000+1da6000]
Aug 28 01:07:29 Tower kernel: JobWorker[13202]: segfault at 4c0 ip 00000000009c0cc7 sp 00002b226d412730 error 4 in kodi.bin[400000+1da6000]
Aug 28 01:07:48 Tower kernel: JobWorker[13476]: segfault at 4c0 ip 00000000009c0cc7 sp 00002b9537901730 error 4 in kodi.bin[400000+1da6000]

Share this post


Link to post

Rebooted the server and I started getting this segfault error in my syslog. I've tried removing the docker completely and reinstalling but still get the error. Any ideas?

 

Aug 28 01:06:29 Tower kernel: JobWorker[12434]: segfault at 4c0 ip 00000000009c0cc7 sp 00002b02f0a02730 error 4 in kodi.bin[400000+1da6000]
Aug 28 01:06:49 Tower kernel: JobWorker[12723]: segfault at 4c0 ip 00000000009c0cc7 sp 00002b77623db730 error 4 in kodi.bin[400000+1da6000]
Aug 28 01:07:09 Tower kernel: JobWorker[12997]: segfault at 4c0 ip 00000000009c0cc7 sp 00002b8ff9d1b730 error 4 in kodi.bin[400000+1da6000]
Aug 28 01:07:29 Tower kernel: JobWorker[13202]: segfault at 4c0 ip 00000000009c0cc7 sp 00002b226d412730 error 4 in kodi.bin[400000+1da6000]
Aug 28 01:07:48 Tower kernel: JobWorker[13476]: segfault at 4c0 ip 00000000009c0cc7 sp 00002b9537901730 error 4 in kodi.bin[400000+1da6000]

 

Yep.  Read the posts above.

Share this post


Link to post

Same segfaults here using this docker. Tested  celedhrim/kodi-server on a arch server and that works fine. Hope you can figure this one out :)

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post

We can't figure it out as the posts above say. 

 

This is a kodi issue, completely separate to our container.  It is affecting all kodi headless installs including docker containers not made by us.

 

Sent from my LG-H815 using Tapatalk

 

 

Share this post


Link to post

We can't figure it out as the posts above say. 

 

This is a kodi issue, completely separate to our container.  It is affecting all kodi headless installs including docker containers not made by us.

 

Sent from my LG-H815 using Tapatalk

 

 

it should also be noted it's something that is intermittent. my current container over the last couple of days has bombed out about 3 times, and i've had mixed success at different times with with starting a new container on my test server from several different authors of kodi headless dockers, the only constant being that they're jarvis variants.

Share this post


Link to post

CONTAINER ID        IMAGE                   COMMAND                  CREATED             STATUS              PORTS               NAMES
7fe23da3da5b        celedhrim/kodi-server   "/opt/kodi-server/lib"   2 minutes ago       Up 18 seconds                           tender_meitner
sparklyballs@Docker-Slave1:~$ docker ps -a
CONTAINER ID        IMAGE                   COMMAND                  CREATED             STATUS                                    PORTS               NAMES
7fe23da3da5b        celedhrim/kodi-server   "/opt/kodi-server/lib"   2 minutes ago       Restarting (139) Less than a second ago                       tender_meitner
sparklyballs@Docker-Slave1:~$ docker ps -a
CONTAINER ID        IMAGE                   COMMAND                  CREATED             STATUS              PORTS               NAMES
7fe23da3da5b        celedhrim/kodi-server   "/opt/kodi-server/lib"   2 minutes ago       Up 1 seconds                            tender_meitner

 

 

the only thing keeping that particular docker alive is the --restart=always flag , other than that it is having exactly the same issue as the linuxserver docker.

 

 

Share this post


Link to post

Using the Alpine Jarvis container

 

If you redirect "mirrors.kodi.tv" to "0.0.0.0" so that it's unreachable then the container will boot without crashing; removing the redirection after the initial boot, it will still continue to boot without crashing.

 

By removing Addons20.db, the crashing behavior returns and requires the initial redirection again.

 

I've posted this on the Kodi forums and awaiting a response.

 

Share this post


Link to post

Using the Alpine Jarvis container

 

If you redirect "mirrors.kodi.tv" to "0.0.0.0" so that it's unreachable then the container will boot without crashing; removing the redirection after the initial boot, it will still continue to boot without crashing.

 

By removing Addons20.db, the crashing behavior returns and requires the initial redirection again.

 

I've posted this on the Kodi forums and awaiting a response.

 

I added mirrors.kodi.tv to the hosts file and reinstalled the docker, appears to still be crashing on my end

 

./run: line 2:   299 Segmentation fault      /sbin/setuser abc /usr/local/lib/kodi/kodi.bin --headless

 

Oh it seems to still be grabbing addons.xml.gz from different mirrors.

 

09:14:27 T:47314506884864   DEBUG: CurlFile::Open(0x2b0844601460) http://mirrors.kodi.tv/addons/jarvis/addons.xml.gz
09:14:28 T:47314506884864   DEBUG: CCurlFile::Open - effective URL: <http://ftp.halifax.rwth-aachen.de/xbmc/addons/jarvis/addons.xml.gz>
09:14:29 T:47314506884864   DEBUG: CRepository 'http://mirrors.kodi.tv/addons/jarvis/addons.xml.gz' is gzip. decompressing

 

EDIT: I got it to finally stop crashing by copying Addons20.db from my 16.1 Mac OS X box. Not pretty, but for now it'll do.

 

EDIT 2: Guess I was wrong, was up for a couple of hours and it appears to still want to download addons.xml.gz

 

EDIT 3: I set the below to 2 in guisettings.xml to prevent addon updates, better now

<addonupdates>2</addonupdates>

Share this post


Link to post

Installed the update today.  Now I get the following in the log file over and over, but it seems to be runningfine.

 

mkdir failed on directory /var/cache/samba: Permission denied

Share this post


Link to post

This docker has been rebased to alpine/xenial (dependant on branch) with s6 overlay, please make sure you backup your appdata first before you update to this latest image.

 

The following branches are available (see first post for more information)

Helix

Isengard

Jarvis

Krypton - at time of post , is in beta.

 

For more information, please read : http://lime-technology.com/forum/index.php?topic=50793.0

Share this post


Link to post

So the segmentation fault big with the addons file is fixed ?

As far as i know, it's still a problem.

Share this post


Link to post

can confirm, still seeing seg faults as of last night (Jarvis)... looking back at my kodi.log the last entry was:

 

12:00:59 T:47607460599552   DEBUG: CurlFile::Open(0x2b4c79c70460) http://mirrors.kodi.tv/addons/jarvis/addons.xml.gz
12:01:00 T:47607460599552   DEBUG: CCurlFile::Open - effective URL: <http://mirror.jmu.edu/pub/xbmc/addons/jarvis/addons.xml.gz>
12:01:00 T:47607460599552   DEBUG: CRepository 'http://mirrors.kodi.tv/addons/jarvis/addons.xml.gz' is gzip. decompressing

 

and previous days when it hasn't crashed, I do see stuff like:

12:01:34 T:47812767586048   ERROR: CCurlFile::FillBuffer - Failed: Timeout was reached(28)
12:01:34 T:47812767586048   DEBUG: CCurlFile::Open - effective URL: <http://mirror.umd.edu/xbmc/addons/jarvis/addons.xml.gz>
12:01:34 T:47812767586048   DEBUG: CRepository 'http://mirrors.kodi.tv/addons/jarvis/addons.xml.gz' is gzip. decompressing
12:01:34 T:47812767586048   ERROR: CRepository: Failed to parse addons.xml. Malformated.

 

 

going to disable addon updates, per: https://lime-technology.com/forum/index.php?topic=42439.msg494193#msg494193

 

[*]shut down kodi docker...

[*]block mirrors lookup

[*]disable addon updates

[*]remove mirrors block

 

block mirrors lookup:



root@tower:/etc# echo "0.0.0.0  mirrors.kodi.tv" >> /etc/hosts

 

block addonupdates:

sed -i 's#0</addonupdates>#2</addonupdates>#' /mnt/cache/.kodi/userdata/guisettings.xml 

 

remove block:



sed -i '/kodi/!p' /etc/hosts

 

(will have to re-write the file, cant redirect output without it truncating the file... )

Share this post


Link to post

So the segmentation fault big with the addons file is fixed ?

As far as i know, it's still a problem.

 

I'm seeing them in my syslog...

 

Sep 6 15:20:17 unRAID kernel: kodi.bin[28741]: segfault at 7a8 ip 0000559813729277 sp 00002af6d5fe6750 error 4 in kodi.bin[559812fad000+201c000]
Sep 6 15:20:37 unRAID kernel: kodi.bin[28934]: segfault at 7a8 ip 000055a329bf9277 sp 00002b4328f1a750 error 4 in kodi.bin[55a32947d000+201c000]
Sep 6 15:20:56 unRAID kernel: kodi.bin[29126]: segfault at 7a8 ip 0000562c97a31277 sp 00002b538675e750 error 4 in kodi.bin[562c972b5000+201c000]
Sep 6 15:21:16 unRAID kernel: kodi.bin[29365]: segfault at 7a8 ip 000055e625682277 sp 00002b0d26c43750 error 4 in kodi.bin[55e624f06000+201c000]
Sep 6 15:21:35 unRAID kernel: kodi.bin[29580]: segfault at 7a8 ip 0000562499c55277 sp 00002b61cb2d8750 error 4 in kodi.bin[5624994d9000+201c000]

Share this post


Link to post

So the segmentation fault big with the addons file is fixed ?

As far as i know, it's still a problem.

 

I'm seeing them in my syslog...

 

Sep 6 15:20:17 unRAID kernel: kodi.bin[28741]: segfault at 7a8 ip 0000559813729277 sp 00002af6d5fe6750 error 4 in kodi.bin[559812fad000+201c000]
Sep 6 15:20:37 unRAID kernel: kodi.bin[28934]: segfault at 7a8 ip 000055a329bf9277 sp 00002b4328f1a750 error 4 in kodi.bin[55a32947d000+201c000]
Sep 6 15:20:56 unRAID kernel: kodi.bin[29126]: segfault at 7a8 ip 0000562c97a31277 sp 00002b538675e750 error 4 in kodi.bin[562c972b5000+201c000]
Sep 6 15:21:16 unRAID kernel: kodi.bin[29365]: segfault at 7a8 ip 000055e625682277 sp 00002b0d26c43750 error 4 in kodi.bin[55e624f06000+201c000]
Sep 6 15:21:35 unRAID kernel: kodi.bin[29580]: segfault at 7a8 ip 0000562499c55277 sp 00002b61cb2d8750 error 4 in kodi.bin[5624994d9000+201c000]

 

We know it's an ongoing intermittent problem that we don't really have any control over, it's affecting all kodi headless containers, not just ours and I think currently we believe it needs an upstream fix.

Share this post


Link to post

 

I'm seeing them in my syslog...

 

Sep 6 15:20:17 unRAID kernel: kodi.bin[28741]: segfault at 7a8 ip 0000559813729277 sp 00002af6d5fe6750 error 4 in kodi.bin[559812fad000+201c000]
Sep 6 15:20:37 unRAID kernel: kodi.bin[28934]: segfault at 7a8 ip 000055a329bf9277 sp 00002b4328f1a750 error 4 in kodi.bin[55a32947d000+201c000]
Sep 6 15:20:56 unRAID kernel: kodi.bin[29126]: segfault at 7a8 ip 0000562c97a31277 sp 00002b538675e750 error 4 in kodi.bin[562c972b5000+201c000]
Sep 6 15:21:16 unRAID kernel: kodi.bin[29365]: segfault at 7a8 ip 000055e625682277 sp 00002b0d26c43750 error 4 in kodi.bin[55e624f06000+201c000]
Sep 6 15:21:35 unRAID kernel: kodi.bin[29580]: segfault at 7a8 ip 0000562499c55277 sp 00002b61cb2d8750 error 4 in kodi.bin[5624994d9000+201c000]

 

You could try my workaround in the meantime, it's been solid for me.

 

https://lime-technology.com/forum/index.php?topic=42439.msg494193#msg494193

Share this post


Link to post

fix had work, saw it seg fault again kodi just restarts over and over and crashing..  really annoying as I used this as my main instance to update media..

 

looking at the kodi forums I see they posted about this:

 

http://forum.kodi.tv/showthread.php?tid=290259&pid=2411449#pid2411449

Looks like alpine linux(new default docker image) in that docker, which uses the musl libc.

Musl is not supported for kodi, so I suggest rebuilding that docker container against an ubuntu image or switch to glib

Share this post


Link to post

fix had work, saw it seg fault again kodi just restarts over and over and crashing..  really annoying as I used this as my main instance to update media..

 

looking at the kodi forums I see they posted about this:

 

http://forum.kodi.tv/showthread.php?tid=290259&pid=2411449#pid2411449

Looks like alpine linux(new default docker image) in that docker, which uses the musl libc.

Musl is not supported for kodi, so I suggest rebuilding that docker container against an ubuntu image or switch to glib

 

 

that doesn't explain exactly the same issue on an ubuntu based image of kodi-headless Jarvis.

 

http://lime-technology.com/forum/index.php?topic=42439.msg493789#msg493789

 

^^^ that image is ubuntu based, the only thing keeping it up is the --restart=always option in the run command.

take that out and the whole container crashes with the same problem.

Share this post


Link to post

I updated this today and still get the following in the log:

 

-------------------------------------
_ _ _
| |___| (_) ___
| / __| | |/ _ \
| \__ \ | | (_) |
|_|___/ |_|\___/
|_|

Brought to you by linuxserver.io
We gratefully accept donations at:
https://www.linuxserver.io/index.php/donations/
-------------------------------------
GID/UID
-------------------------------------
User uid: 99
User gid: 100
-------------------------------------

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 30-config: executing...
[cont-init.d] 30-config: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
mkdir failed on directory /var/cache/samba: Permission denied

mkdir failed on directory /var/cache/samba: Permission denied

 

That permission denied error keeps going on and on and on...

 

Anyone else seeing this or is it just my system ?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.