Recycle Bin (vfs recycle) for SMB Shares


dlandon

794 posts in this topic Last Reply

Recommended Posts

This no longer seems to be moving things to the recycle bin. I have upgraded to 6.3, uninstalled the plugin, removed all .Recycle.Bin folders and reinstalled it from community applications. However when I create a text file and delete it it does not create a .Recycle.Bin folder.

 

Is there any other information I can provide? I'd love to get this working again.

 

Thanks!

 

I need more information.  You have the recycle bin enabled?  You are doing the delete through a smb share?

 

Check the shares tab of the recycle bin to be sure the share is enabled.  Look at the deleted files log and see if it has logged the deleted file.

 

A zero length file will not be put in the recycle bin.  You did enter something into the text file?

 

I do have the recycle bin enabled. I am using SMB. All my shares are listed under the Shares portion of that page. I have tested with a text file with text in it as well as duplicating one of the other larger files. Deleting these files does not create the recycle folder. The deleted files log on the recycle bin settings page is blank, I do have logging enabled.

 

Copy and post the /etc/samba/smb-shares.conf file.  Tell me which share you are trying to delete the file from.

 

Have you tried another share?

 

Here is the requested file http://pastebin.com/wJLkj5ak

 

I have tried on the TV - Shows share and the Downloads share.

 

Everything looks right.

 

Go to the Settings->SMB and look at the 'SMB Extras'.  It should look like this:

#vfs_recycle_start

#Recycle bin configuration

[global]

  syslog only = No

  log level = 0 vfs:0

#vfs_recycle_end

 

Try a 'Restart' on the recycle bin.

Link to post
  • Replies 793
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

This is a plugin that will create a per share .Recycle.Bin folder on each smb share for files deleted on that share.  Built into samba is a module called "vfs recycle" that handles the deletion of fil

Shares were not displaying when "Log Deleted Files" was set to "No".  This has been fixed in the latest version.

No longer true.  I'm releasing a new version that will not show any remote mounted shares and the local recycle bin will not remove any files from the remote share recycle bins.  Only the local server

Posted Images

Everything looks right.

 

Go to the Settings->SMB and look at the 'SMB Extras'.  It should look like this:

#vfs_recycle_start

#Recycle bin configuration

[global]

  syslog only = No

  log level = 0 vfs:0

#vfs_recycle_end

 

It does look like that, copy and paste below in case I can't read.

#vfs_recycle_start

#Recycle bin configuration

[global]

  syslog only = No

  log level = 0 vfs:0

#vfs_recycle_end

 

Link to post

Everything looks right.

 

Go to the Settings->SMB and look at the 'SMB Extras'.  It should look like this:

#vfs_recycle_start

#Recycle bin configuration

[global]

  syslog only = No

  log level = 0 vfs:0

#vfs_recycle_end

 

It does look like that, copy and paste below in case I can't read.

#vfs_recycle_start

#Recycle bin configuration

[global]

  syslog only = No

  log level = 0 vfs:0

#vfs_recycle_end

 

Restart the recycle bin.

Link to post

Everything looks right.

 

Go to the Settings->SMB and look at the 'SMB Extras'.  It should look like this:

#vfs_recycle_start

#Recycle bin configuration

[global]

  syslog only = No

  log level = 0 vfs:0

#vfs_recycle_end

 

It does look like that, copy and paste below in case I can't read.

#vfs_recycle_start

#Recycle bin configuration

[global]

  syslog only = No

  log level = 0 vfs:0

#vfs_recycle_end

 

Restart the recycle bin.

 

Tried that, it did not work

Link to post

Everything looks right.

 

Go to the Settings->SMB and look at the 'SMB Extras'.  It should look like this:

#vfs_recycle_start

#Recycle bin configuration

[global]

  syslog only = No

  log level = 0 vfs:0

#vfs_recycle_end

 

It does look like that, copy and paste below in case I can't read.

#vfs_recycle_start

#Recycle bin configuration

[global]

  syslog only = No

  log level = 0 vfs:0

#vfs_recycle_end

 

Restart the recycle bin.

 

Tried that, it did not work

 

Ok.  One last thing.  Do this command:

/etc/rc.d/rc.samba restart

 

Link to post

Everything looks right.

 

Go to the Settings->SMB and look at the 'SMB Extras'.  It should look like this:

#vfs_recycle_start

#Recycle bin configuration

[global]

  syslog only = No

  log level = 0 vfs:0

#vfs_recycle_end

 

It does look like that, copy and paste below in case I can't read.

#vfs_recycle_start

#Recycle bin configuration

[global]

  syslog only = No

  log level = 0 vfs:0

#vfs_recycle_end

 

Restart the recycle bin.

 

Tried that, it did not work

 

Ok.  One last thing.  Do this command:

/etc/rc.d/rc.samba restart

 

Tried rebooting server didn't work (RIP uptime).

 

But the command you provided DID work!! Thank you much, glad to have this working again!

Link to post

Everything looks right.

 

Go to the Settings->SMB and look at the 'SMB Extras'.  It should look like this:

#vfs_recycle_start

#Recycle bin configuration

[global]

  syslog only = No

  log level = 0 vfs:0

#vfs_recycle_end

 

It does look like that, copy and paste below in case I can't read.

#vfs_recycle_start

#Recycle bin configuration

[global]

  syslog only = No

  log level = 0 vfs:0

#vfs_recycle_end

 

Restart the recycle bin.

 

Tried that, it did not work

 

Ok.  One last thing.  Do this command:

/etc/rc.d/rc.samba restart

 

Tried rebooting server didn't work (RIP uptime).

 

But the command you provided DID work!! Thank you much, glad to have this working again!

 

I thought it would.  Can you post your diagnostics?  I know what the problem is, but I want to see what I need to do to fix it.

Link to post

Everything looks right.

 

Go to the Settings->SMB and look at the 'SMB Extras'.  It should look like this:

#vfs_recycle_start

#Recycle bin configuration

[global]

  syslog only = No

  log level = 0 vfs:0

#vfs_recycle_end

 

It does look like that, copy and paste below in case I can't read.

#vfs_recycle_start

#Recycle bin configuration

[global]

  syslog only = No

  log level = 0 vfs:0

#vfs_recycle_end

 

Restart the recycle bin.

 

Tried that, it did not work

 

Ok.  One last thing.  Do this command:

/etc/rc.d/rc.samba restart

 

Tried rebooting server didn't work (RIP uptime).

 

But the command you provided DID work!! Thank you much, glad to have this working again!

 

I thought it would.  Can you post your diagnostics?  I know what the problem is, but I want to see what I need to do to fix it.

 

Here you go

diagnostics-20170207-1548.zip

Link to post

I don't understand. Isn't that the GUI plugin?

 

It's the beta version from a while back.

 

Oh, I removed that a long time ago. Hmmm, so just delete the dynamix.plg and reboot?

 

Yes.  See if it doesn't fix the recycle bin without restarting samba.

Link to post

I don't understand. Isn't that the GUI plugin?

 

It's the beta version from a while back.

 

Oh, I removed that a long time ago. Hmmm, so just delete the dynamix.plg and reboot?

 

Yes.  See if it doesn't fix the recycle bin without restarting samba.

 

Well I didn't test if rebooting after restarting samba without removing that plugin would have been fine but I can confirm it works fine after removing that plugin and restarting so that is enough for me! Thanks again

Link to post

I really like the new "Exclude Shares" option. However the entry field seems to be limited. I was trying the exclude all Ransom Ware shares but it seems that they are too many. Is is possible to exclude all shares of these share with one single entry e.g. Squidbait* ?

 

I can expand the entry field, but entering all the shares that way seems tedious.  Let me do some research and try to find a way to exclude all the shares of the Ransom Ware plugin.  I'd be surprised if there were that many individual shares.

 

Can you post a screen shot of the Recycle Bin->Shares page so I can see how the Ransom Ware plugin sets up its shares?  Scroll the page to show the Ransom Ware shares.

Link to post

I really like the new "Exclude Shares" option. However the entry field seems to be limited. I was trying the exclude all Ransom Ware shares but it seems that they are too many. Is is possible to exclude all shares of these share with one single entry e.g. Squidbait* ?

 

I can expand the entry field, but entering all the shares that way seems tedious.  Let me do some research and try to find a way to exclude all the shares of the Ransom Ware plugin.  I'd be surprised if there were that many individual shares.

 

Can you post a screen shot of the Recycle Bin->Shares page so I can see how the Ransom Ware plugin sets up its shares?  Scroll the page to show the Ransom Ware shares.

Best way to exclude is to allow a regex / wildcard to be in the field (or a drop down).  Depending upon options, the folder names can be regenerated every boot and are completely random.  But I don't see how recyclebin would affect the moniitoring
Link to post

Here you are ... I have already excluded as much as possible.

 

Thank you very much for looking into this.

 

I am changing the exclude share to act more like a wildcard exclude.  For example:

'Squidbait' will exclude all shares with the 'Squidbait' in the share name.  The comparison will be like the wild card 'Squidbait*'.

Link to post

Update 2017.02.08 released.  You can now specify the excluded shares in a wild card fashion.  For example with the Ransom Ware plugin, you specify the excluded share as Squidbait.  All shares with the text Squidbait will be excluded.  There is additional write up on the OP.

Link to post

Can you PLEASE... add an option to not remove the recycle bin folder when it's empty.. This is causing issues with programs such as Sonarr that are not smart enough to just 'delete' , looks like it's doing more of a move function thus causing lots of errors when unraid recycle bin purges.. things only work well again when I delete a manual file so the ./recycle bin folder comes back..

Link to post

Can you PLEASE... add an option to not remove the recycle bin folder when it's empty.. This is causing issues with programs such as Sonarr that are not smart enough to just 'delete' , looks like it's doing more of a move function thus causing lots of errors when unraid recycle bin purges.. things only work well again when I delete a manual file so the ./recycle bin folder comes back..

 

Please provide more information.  I do not understand why this is a problem.  Samba handles the delete function.  Why is Sonarr managing the .Recycle.Bin?  How does it even know of its existence?

Link to post

I love this plug in dlandon!  When I delete items from my Linux machine it puts them in  . Trash-1000 in the root of the active share.    Would it be possible to have this plug-in also monitor  .Trash-1000 when it comes to Empty &  purge functions?  Thanks :)

Link to post

I love this plug in dlandon!  When I delete items from my Linux machine it puts them in  . Trash-1000 in the root of the active share.    Would it be possible to have this plug-in also monitor  .Trash-1000 when it comes to Empty &  purge functions?  Thanks :)

 

Perhaps a simple user script run by cron that periodically moves the folders into the Recycle Bin folders?

Link to post
  • dlandon changed the title to Recycle Bin (vfs recycle) for SMB Shares

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.