Jump to content
linuxserver.io

[Plugin] Linuxserver.io - Unraid DVB

1681 posts in this topic Last Reply

Recommended Posts

I have tried RC9 6.2.4 and it would work and reboot OK but tvheadend kept going laggy then my DVB cards would disappear for a bit and not tune but after other issues I gave up and have gone back to stock. I also tried just one card, The DVB cards would not list for VM pass through but I think I may have been able to add them manually.

 

I installed the cards in another AMD based motherboard with RC6 Trial DVB edition and they seem to work fine so I am going to conclude that my motherboard is the issue here. Its a Gigabyte 970A-DS3P with a video and sata controller card installed.

 

I will wait for Stable 6.3 but if the Motherboard is faulty I will never get it to work. I did have a VM running with a PCTV card working before but they are not supported under Linux. I will have to go back to running a spare PC just for live TV which is what I was trying to get rid of.

Share this post


Link to post

V6.3.0 LibreELEC, Digital Devices, TBS Opensource uploaded.

 

Note that there are security vulnerabilities in ANY version prior to V6.3 RC9 so I've pulled these builds.

 

I have left the v6.2.4 TBS Official DVB-S/T, DVB-C and CrazyCat builds as there are no equivalent 6.3.0 builds with the caveat that I am not responsible for any issues with these.  These vulnerabilities are in the Unraid builds themselves not limited to the DVB builds.  You may find if you were using the CrazyCat build that the TBS Opensource build works as I've added the LibreELEC firmware to this image.

 

RUN V6.2.4 BUILDS AT YOUR OWN RISK

 

See here.

 

TBS Official Closed Source drivers are not compiling on the latest Linux kernel so no builds there.  I've let TBS know.

 

 

Share this post


Link to post

V6.3.0 LibreELEC, Digital Devices, TBS Opensource uploaded.

 

Note that there are security vulnerabilities in ANY version prior to V6.3 RC9 so I've pulled these builds.

 

I have left the v6.2.4 TBS Official DVB-S/T, DVB-C and CrazyCat builds as there are no equivalent 6.3.0 builds with the caveat that I am not responsible for any issues with these.  These vulnerabilities are in the Unraid builds themselves not limited to the DVB builds.  You may find if you were using the CrazyCat build that the TBS Opensource build works as I've added the LibreELEC firmware to this image.

 

RUN V6.2.4 BUILDS AT YOUR OWN RISK

 

See here.

 

TBS Official Closed Source drivers are not compiling on the latest Linux kernel so no builds there.  I've let TBS know.

Thanks! Works well here.

Share this post


Link to post

Thanks! Works well here.

 

V6.3 TBS Offficial DVB-S/T & DVB-C builds uploaded now.  Only leaves CrazyCat on v6.2.4....

 

RUN CRAZYCAT V6.2.4 BUILD AT YOUR OWN RISK

 

Share this post


Link to post

CrazyCat build done.

 

OK, all builds are now updated and I've pulled all the builds prior to V6.3.0

 

If you do wish to use an older build then let me know, as I do still have them, I'm just not publishing them anymore.

Share this post


Link to post

Any chance in getting FireWire support added to the DVB edition?  I need the DVB version to support Hauppauge HD-PVR tuners for SageTV. I would like to be able to use FireWire to change channels on my STB but it doesn't appear that the kernel supports FireWire.

Share this post


Link to post

Any chance in getting FireWire support added to the DVB edition?  I need the DVB version to support Hauppauge HD-PVR tuners for SageTV. I would like to be able to use FireWire to change channels on my STB but it doesn't appear that the kernel supports FireWire.

 

I don't have a firewire device and spoke to someone in IRC about this yesterday.  (CraziFuzzy)

 

If it's not in kernel then my first inclination is to say no, CraziFuzzy was going to speak to some of the SageTV devs and let me know some more details.  If someone tells me what's involved and what's required then I'm happy to help, this may not be me making more builds, but if there's call for it and someone wants to make them, then we could host them for the SageTV community. 

Share this post


Link to post

Thanks - Fuzzy contacting you came out of some discussions he and I were having on the SageTV forums.  This will likely have benefit beyond SageTV as it will give other folks using other TV recording software with Set Top Boxes the possibility of using firewire as a method to change channels.  This is more reliable than using IR which is the main standard and getting IR working with lirc can be a bit difficult.  Firewire can also be daisy-chained so it is trivial to get multiple boxes working on one system.

Share this post


Link to post

udated too fast to 6.3.1 without checking new dvb available ;)

 

possible to boot with 6.3.0 dvb kernel ?

 

thanks ahead ?

Share this post


Link to post

udated too fast to 6.3.1 without checking new dvb available ;)

 

possible to boot with 6.3.0 dvb kernel ?

 

thanks ahead ?

 

Boot? Yes. But you won't be able to run DVB-specific stuff, like a Tvheadend docker (mine gave a "no such container" error). 6.3.1 DVB build should be out in the next couple days, I'd guess. If you need DVB funtionality before then, you can safely downgrade to 6.3.0 DVB build.

Share this post


Link to post

udated too fast to 6.3.1 without checking new dvb available ;)

 

possible to boot with 6.3.0 dvb kernel ?

 

thanks ahead ?

 

Yes, if you're using the DVB Edition from this plugin then you need to wait to upgrade until I've created the builds, I try and do so as soon as possible after the release.  You can downgrade at anytime from the plugin too.

 

Thanks - Fuzzy contacting you came out of some discussions he and I were having on the SageTV forums.  This will likely have benefit beyond SageTV as it will give other folks using other TV recording software with Set Top Boxes the possibility of using firewire as a method to change channels.  This is more reliable than using IR which is the main standard and getting IR working with lirc can be a bit difficult.  Firewire can also be daisy-chained so it is trivial to get multiple boxes working on one system.

 

For the V6.3.1 builds I've enabled Firewire support in kernel, dunno if that'll work or not.

 

Boot? Yes. But you won't be able to run DVB-specific stuff, like a Tvheadend docker (mine gave a "no such container" error). 6.3.1 DVB build should be out in the next couple days, I'd guess. If you need DVB funtionality before then, you can safely downgrade to 6.3.0 DVB build.

 

Good advice here.  Thanks  ;)

 

 

V6.3.1 TBS DVB-ST, DVB-C, TBS OpenSource, TBS CrazyCat, LibreELEC & DigitalDevices all uploaded.

Share this post


Link to post

Hi

 

 

I'm considering adding some tuners - has anyone managed to get either of these to work? If not, which USB (cheap!) tuners are recommended?  Thanks

 

 

http://www.hauppauge.co.uk/site/products/data_dualhd.html

 

 

http://www.hauppauge.co.uk/site/products/data_quadhd.html

 

Best place to look for this kind of thing is here or here.

Share this post


Link to post

It looks like firewire is now working in this kernel as I can see firewire devices in the SageTV docker.  I haven't got them properly set up for tuning yet that won't be a kernel or OS problem, it is more of a cable box / application configuration.

 

Thanks you very much CHBMB!

Share this post


Link to post

Hi

 

 

I'm considering adding some tuners - has anyone managed to get either of these to work? If not, which USB (cheap!) tuners are recommended?  Thanks

 

 

http://www.hauppauge.co.uk/site/products/data_dualhd.html

 

 

http://www.hauppauge.co.uk/site/products/data_quadhd.html

 

Best place to look for this kind of thing is here or here.

 

 

Thanks as always!

No problem, having a quick look at those it looks like the quad tuner is the one that would be your best bet.  Dual tumer kernel support looks a bit more flakey, Unraid is already on kernel 4.9 so that works for the quad tuner according to that link.

 

Sent from my LG-H815 using Tapatalk

 

 

Share this post


Link to post

It looks like firewire is now working in this kernel as I can see firewire devices in the SageTV docker.  I haven't got them properly set up for tuning yet that won't be a kernel or OS problem, it is more of a cable box / application configuration.

 

Thanks you very much CHBMB!

Great, let me know if you manage to get it working ok and I can make Firewire inclusion standard going forward.

 

Sent from my LG-H815 using Tapatalk

 

 

Share this post


Link to post

Hi

 

 

I'm considering adding some tuners - has anyone managed to get either of these to work? If not, which USB (cheap!) tuners are recommended?  Thanks

 

 

http://www.hauppauge.co.uk/site/products/data_dualhd.html

 

 

http://www.hauppauge.co.uk/site/products/data_quadhd.html

 

Best place to look for this kind of thing is here or here.

 

 

Thanks as always!

No problem, having a quick look at those it looks like the quad tuner is the one that would be your best bet.  Dual tumer kernel support looks a bit more flakey, Unraid is already on kernel 4.9 so that works for the quad tuner according to that link.

 

Sent from my LG-H815 using Tapatalk

 

 

I came to the same conclusion and the quad arrives tomorrow - my thinking also was the pcie probably has better components than the USB as they don't have to worry so much about space, and I don't have to worry about running two cables to my PC - although I'm worried that the 4 way split that the card does might mean each tuner won't get a v.strong signal.  WIll see tomorrow.

 

 

Now I need to decide today if I use DVBlink which I used a few years ago or try TVheadend which seems to have more users on unRAID

Share this post


Link to post

Hi, I upgraded to 6.3.0 and 6.3.1 but neither registered my DVB-T USB tuners (working finer prior to 6.3.0 upgrade).  MediaTreeCheck confirms that Media tree is detected but no DVB adaptors.  When I hot plug one of them, I see:

 

New device PCTV Systems 290e

chip ID is em28174

Identified as PCTV nanoStick T2 290e (card=78)

 

Any suggestions how to get tuners working again?

 

00000235.png

Share this post


Link to post

Hi, I upgraded to 6.3.0 and 6.3.1 but neither registered my DVB-T USB tuners (working finer prior to 6.3.0 upgrade).  MediaTreeCheck confirms that Media tree is detected but no DVB adaptors.  When I hot plug one of them, I see:

 

New device PCTV Systems 290e

chip ID is em28174

Identified as PCTV nanoStick T2 290e (card=78)

 

Any suggestions how to get tuners working again?

 

Can you try the CrazyCat build and let me know?

Share this post


Link to post

Success! Thanks :)  So I guess I should stick to the CrazyCat build from now on?  I also tried the Github build previously without success - I should have persevered, sorry.

Share this post


Link to post

Success! Thanks :)  So I guess I should stick to the CrazyCat build from now on?  I also tried the Github build previously without success - I should have persevered, sorry.

 

I can only assume that it's something to do with the LibreELEC build updating their firmware package.  In theory nowadays CrazyCat should cover 99% of tuners that have Linux support.

Share this post


Link to post

Hi

 

Great plugin, saved me so much time not having to build from source.Thanks

 

This question may have been answered before but i have not come across the answer in the unraid dvb guides i have found.

 

I remember reading somewhere that moving from 6.1 to 6.2 that you needed to install the stock version do the upgrade and then re enable the dvb kernel.

 

Is this still the case, i am running 6.2.4, can i just select the TBS 6.3.1 image in unraid dvb or do i need to go back to the stock build do the upgrade and then select the TBS version.##Thanks for any response.

Share this post


Link to post

Hi

 

Great plugin, saved me so much time not having to build from source.Thanks

 

This question may have been answered before but i have not come across the answer in the unraid dvb guides i have found.

 

I remember reading somewhere that moving from 6.1 to 6.2 that you needed to install the stock version do the upgrade and then re enable the dvb kernel.

 

Is this still the case, i am running 6.2.4, can i just select the TBS 6.3.1 image in unraid dvb or do i need to go back to the stock build do the upgrade and then select the TBS version.##Thanks for any response.

 

It was just for the V6.1.9 => V6.2.0 upgrade as that bought about some changes to syslinux.cfg, so required updating to stock to facilitate that. 

 

I've since removed support for any version prior to V6.2.0

 

You should be good to just upgrade straight to V6.3.1

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.