Jump to content
linuxserver.io

[Support] Linuxserver.io - SWAG - Secure Web Application Gateway (Nginx/PHP/Certbot/Fail2ban)

5134 posts in this topic Last Reply

Recommended Posts

No!
443 external to 442 internal.
 
I believe you reference his router settings and he asked about his router so I replied yes.

Caught up on the the thread seems user doesn't get understand port forwarding.
Hopefully he gets it.

Sent from my SM-N960U using Tapatalk

Share this post


Link to post
1 minute ago, ijuarez said:

I believe you reference his router settings and he asked about his router so I replied yes.

Caught up on the the thread seems user doesn't get understand port forwarding.
Hopefully he gets it.

Sent from my SM-N960U using Tapatalk
 

I even managed to type wrong also 😁

Share this post


Link to post
2 minutes ago, Tucubanito07 said:

 

This is what i get when I port forwarding how you said. @saarg

 

image.png.91d2a28c8d1301a048527976583a00c2.png

 

image.thumb.png.b106a873ed17d23dea529c11828512e8.png

 

Did you restart letsencrypt after you corrected the port forward?

 

 

Share this post


Link to post
1 minute ago, saarg said:

 

Did you restart letsencrypt after you corrected the port forward?

 

 

Yes i did. I restarted Letsencrypt and also Nextcloud just to see. I am getting this error still though.

 

 

nginx: [emerg] PEM_read_bio_DHparams("/config/nginx/dhparams.pem") failed (SSL: error:0909006C:PEM routines:get_name:no start line:Expecting: DH PARAMETERS)

Share this post


Link to post
Just now, Tucubanito07 said:

Yes i did. I restarted Letsencrypt and also Nextcloud just to see. I am getting this error still though.

 

 

nginx: [emerg] PEM_read_bio_DHparams("/config/nginx/dhparams.pem") failed (SSL: error:0909006C:PEM routines:get_name:no start line:Expecting: DH PARAMETERS)

 

You also set up letsencrypt wrong. Your domain is not ddns.net, it's nextcloud-eleanor.ddns.net. That goes in the domain variable in the letsencrypt template.

Not sure if you need to add www as subdomain or if you can leave it empty. Try empty first.

Share this post


Link to post
 
This is what i get when I port forwarding how you said. [mention=63089]saarg[/mention]
 
image.png.91d2a28c8d1301a048527976583a00c2.png
 
image.thumb.png.b106a873ed17d23dea529c11828512e8.png
So what client are using to update your ddns.net name?

Sent from my SM-N960U using Tapatalk

Share this post


Link to post
 
Did you restart letsencrypt after you corrected the port forward?
 
 
Now it looks like it's hitting let's encrypt but you are missing the certificate

Sent from my Pixel 2 XL using Tapatalk

Share this post


Link to post
5 minutes ago, saarg said:

 

You also set up letsencrypt wrong. Your domain is not ddns.net, it's nextcloud-eleanor.ddns.net. That goes in the domain variable in the letsencrypt template.

Not sure if you need to add www as subdomain or if you can leave it empty. Try empty first.

Not working either. However, i dont have control over the Domain Name since ddns.net is from No-IP. 

 

image.thumb.png.cb9edbb7559a30870ad3c7895decb6da.png

 

Share this post


Link to post
2 minutes ago, Tucubanito07 said:

Not working either. However, i dont have control over the Domain Name since ddns.net is from No-IP. 

 

image.thumb.png.cb9edbb7559a30870ad3c7895decb6da.png

 

What exactly is not working?

Share this post


Link to post
Just now, saarg said:

What exactly is not working?

Nextcloud. When i go to unraid and click on the nextcloud container to click on WebUI it takes me here. Then i cannot connect to nextcloud. It does not even work inside my network. @saarg

 

image.thumb.png.a1026cafb0afca4d4b24a6912de0cb7b.png

Share this post


Link to post
Nextcloud. When i go to unraid and click on the nextcloud container to click on WebUI it takes me here. Then i cannot connect to nextcloud. It does not even work inside my network. [mention=63089]saarg[/mention]
 
image.thumb.png.a1026cafb0afca4d4b24a6912de0cb7b.png
It's doing that because of the redirect inside the nextcloud configuration set previously during configuration. But its okay, hit continue and it should go through even if you don't have the certificate valid yet

Sent from my Pixel 2 XL using Tapatalk

Share this post


Link to post

I am getting this now. 

 

ERROR: Cert does not exist! Please see the validation error above. The issue may be due to incorrect dns or port forwarding settings. Please fix your settings and recreate the container

Share this post


Link to post
1 minute ago, blaine07 said:

What happens at bottom if you hit proceed anyways?

Sent from my SM-G975U using Tapatalk
 

I have and it does not do anything.

Share this post


Link to post
1 minute ago, gacpac said:

It's doing that because of the redirect inside the nextcloud configuration set previously during configuration. But its okay, hit continue and it should go through even if you don't have the certificate valid yet

Sent from my Pixel 2 XL using Tapatalk
 

I have and it does not do anything.

Share this post


Link to post
1 minute ago, Tucubanito07 said:

Nextcloud. When i go to unraid and click on the nextcloud container to click on WebUI it takes me here. Then i cannot connect to nextcloud. It does not even work inside my network. @saarg

 

image.thumb.png.a1026cafb0afca4d4b24a6912de0cb7b.png

 

Let's concentrate on one thing at a time.

We want to get letsencrypt working before we try nextcloud.

What does the container log of letsencrypt say?

Share this post


Link to post
1 minute ago, saarg said:

 

Let's concentrate on one thing at a time.

We want to get letsencrypt working before we try nextcloud.

What does the container log of letsencrypt say?

 

Ok i am very sorry. I was just letting you know. @saarg See below on what i am getting.

 

image.thumb.png.77729b207b29f306e122391c7b3afc9d.png

Share this post


Link to post
6 minutes ago, Tucubanito07 said:

 

Ok i am very sorry. I was just letting you know. @saarg See below on what i am getting.

 

image.thumb.png.77729b207b29f306e122391c7b3afc9d.png

 

Is your IP correct on the noip site?

and you are sure your ISP doesn't block port 80?

Share this post


Link to post
2 minutes ago, saarg said:

 

Is your IP correct on the noip site?

and you are sure your ISP doesn't block port 80?

When i look at the address in the No-IP website, it is the correct to my wan ip. My isp does not block port 80. @saarg

Share this post


Link to post
When i look at the address in the No-IP website, it is the correct to my wan ip. My isp does not block port 80. [mention=63089]saarg[/mention]
Let's try to confirm

Go to canyouseeme.org and check for port 80 also the 443 just in case

Sent from my Pixel 2 XL using Tapatalk

Share this post


Link to post
4 minutes ago, Tucubanito07 said:

When i look at the address in the No-IP website, it is the correct to my wan ip. My isp does not block port 80. @saarg

You might have to set www as a subdomain on the noip page. I never used it, so don't know how it works.

also change the ONLY_SUBDOMAINS variable in the template to false so you also get a certificate for your top domain.

Share this post


Link to post
3 minutes ago, gacpac said:

Let's try to confirm

Go to canyouseeme.org and check for port 80 also the 443 just in case

Sent from my Pixel 2 XL using Tapatalk
 

I am getting connection refused. This is my firewall on the router.

 

image.png.0cdd477f9ebb50e451b5cabbf46ddce6.png

Share this post


Link to post
I am getting connection refused. This is my firewall on the router.
 
image.png.0cdd477f9ebb50e451b5cabbf46ddce6.png
If you get connection refused. You likely have the port closed. Check in your firewall settings what could be.

Sent from my Pixel 2 XL using Tapatalk

Share this post


Link to post
2 minutes ago, saarg said:

You might have to set www as a subdomain on the noip page. I never used it, so don't know how it works.

also change the ONLY_SUBDOMAINS variable in the template to false so you also get a certificate for your top domain.

I have change the variable to false. I still keep getting this.

 

ERROR: Cert does not exist! Please see the validation error above. The issue may be due to incorrect dns or port forwarding settings. Please fix your settings and recreate the container

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.