[Support] Linuxserver.io - Ombi


571 posts in this topic Last Reply

Recommended Posts

  • Replies 570
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

That 'asshole' would be me.        Please keep in mind that I have a full time demanding job, a child, a 10 month old and a wife outside of what I do in ombi. All of my free time i

Ran into this too and it looks like this is the issue. Look at my post there (currently the last one) for a fix you can do without having to install anything into your container. It looks like they ad

Application Name: Ombi Application Site: https://ombi.io Docker Hub: https://hub.docker.com/r/linuxserver/ombi/ Github: https://github.com/linuxserver/docker-ombi   Please

Posted Images

Anyone seeing very high disk IO with this container?  I have an issue with constant writes to the cache drive. In 13 days my cache drive has over 81 million writes..  I'm afraid my cache disk will die on me long before it's supposed to if this keeps going on. I used the file activity plugin to log whats happening and I've included the output in the txt file. Keep in mind this is just 1 hour worth. So Imagine this all day, every day, 24/7...

 

This started when I replaced my cache disk one month ago, at least that's when I started noticing the very high write count. Before I nuke my docker Image and try again I thought I ask here if anyone else is seeing this?

ombi.txt

Link to post

@aptalca - I noticed that none of the configs that contained the following line would work:

 

 resolver 127.0.0.11 valid=30s;

 

I realized I never created the custom network fr Docker.  So I did that and set all the containers to use it an now the built-in Ombi config works.  But the Android app still won't connect.

Link to post
38 minutes ago, strike said:

Anyone seeing very high disk IO with this container?  I have an issue with constant writes to the cache drive. In 13 days my cache drive has over 81 million writes..  I'm afraid my cache disk will die on me long before it's supposed to if this keeps going on. I used the file activity plugin to log whats happening and I've included the output in the txt file. Keep in mind this is just 1 hour worth. So Imagine this all day, every day, 24/7...

 

This started when I replaced my cache disk one month ago, at least that's when I started noticing the very high write count. Before I nuke my docker Image and try again I thought I ask here if anyone else is seeing this?

ombi.txt

 

 

Looking at your log the container is messed up and the scheduler cannot properly create the db file.  that's me trying to say it plainly. I personally would nuke the container and rebuild it.

Link to post

Just a quick question. I have recently changed my plex password and with that the plex authorization token has changed. Now ive gone to ombi to try update this but for some reason it just wont work. When i go through the motion of changing it and then pressing the load servers and select my server it automatically put the old auth token back in. I have tried deleting the server in full and starting that from scratch but no joy. As a result i keep getting an error when trying to load the libraries and testing the connectivity. 

Link to post
5 minutes ago, tazire said:

Just a quick question. I have recently changed my plex password and with that the plex authorization token has changed. Now ive gone to ombi to try update this but for some reason it just wont work. When i go through the motion of changing it and then pressing the load servers and select my server it automatically put the old auth token back in. I have tried deleting the server in full and starting that from scratch but no joy. As a result i keep getting an error when trying to load the libraries and testing the connectivity. 

 

I have found it best to input the username and password and press get token.  pasting the token and then trying anything tends to use a cached version from itself or the browser.

Link to post
4 hours ago, fmp4m said:

 

I have found it best to input the username and password and press get token.  pasting the token and then trying anything tends to use a cached version from itself or the browser.

 

I dont see a get token option on my list for plex anyway. And no matter what i do it just always reverts to the cached token atm. 

Link to post

pretty wayne anyway.

 

Ive set this now 3 or 4 times up.

 

Even when you are able to get all tokens and so on, at some timm this docker stops working (some sort of unlimited circle) and or is incredible slow.

 

I guess we have to wait some updates... but looks so promising... 

Edited by nuhll
Link to post

So I recently had to re add ombi and now I can't get nginx to work whereas it worked previously. My default file for site-confs is:

 

upstream backend {
	server 192.168.42.9:19999;
	keepalive 64;
}

server {
	listen 443 ssl default_server;
	listen 80 default_server;
	root /config/www;
	index index.html index.htm index.php;

	server_name _;

	ssl_certificate /config/keys/letsencrypt/fullchain.pem;
	ssl_certificate_key /config/keys/letsencrypt/privkey.pem;
	ssl_dhparam /config/nginx/dhparams.pem;
	ssl_ciphers 'ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:DHE-DSS-AES128-GCM-SHA256:kEDH+AESGCM:ECDHE-RSA-AES128-SHA256:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA:ECDHE-ECDSA-AES128-SHA:ECDHE-RSA-AES256-SHA384:ECDHE-ECDSA-AES256-SHA384:ECDHE-RSA-AES256-SHA:ECDHE-ECDSA-AES256-SHA:DHE-RSA-AES128-SHA256:DHE-RSA-AES128-SHA:DHE-DSS-AES128-SHA256:DHE-RSA-AES256-SHA256:DHE-DSS-AES256-SHA:DHE-RSA-AES256-SHA:AES128-GCM-SHA256:AES256-GCM-SHA384:AES128-SHA256:AES256-SHA256:AES128-SHA:AES256-SHA:AES:CAMELLIA:DES-CBC3-SHA:!aNULL:!eNULL:!EXPORT:!DES:!RC4:!MD5:!PSK:!aECDH:!EDH-DSS-DES-CBC3-SHA:!EDH-RSA-DES-CBC3-SHA:!KRB5-DES-CBC3-SHA';
	ssl_prefer_server_ciphers on;

	client_max_body_size 0;

	location = / {
		return 301 /;
	}

	location /tautulli {
		include /config/nginx/proxy.conf;
		proxy_pass http://192.168.42.9:8181/tautulli;
	}

	location /ombi {
		include /config/nginx/proxy.conf;
		proxy_pass http://192.168.42.9:3579/ombi;
	}
	
	if ($http_referer ~* /ombi/) {
        rewrite ^/dist/(.*) $scheme://$host/ombi/dist/$1 permanent;
    }
	
}

I have ombi's base url set to /ombi. I was told to add the line if ($http_referer...)  when ombi got updated a while back since they had some issues. I have with and without this block of code. I know nginx is working because tautulli is working. Any ideas if there is a step I am missing?

 

EDIT: Error message is 

This site can’t be reached
The connection was reset.
Try:

Checking the connection
Checking the proxy and the firewall
Running Windows Network Diagnostics
ERR_CONNECTION_RESET

 

Edited by brianbrifri
Link to post

is there any way for me to delete the cached token and re add the new one???

 

EDIT

 

Managed to fix this. had to change the port number for the server as well for some reason. but all sorted

Edited by tazire
Link to post
On 7/23/2018 at 12:49 AM, strike said:

Anyone seeing very high disk IO with this container?  I have an issue with constant writes to the cache drive. In 13 days my cache drive has over 81 million writes..  I'm afraid my cache disk will die on me long before it's supposed to if this keeps going on. I used the file activity plugin to log whats happening and I've included the output in the txt file. Keep in mind this is just 1 hour worth. So Imagine this all day, every day, 24/7...

 

This started when I replaced my cache disk one month ago, at least that's when I started noticing the very high write count. Before I nuke my docker Image and try again I thought I ask here if anyone else is seeing this?

ombi.txt

 

On 7/23/2018 at 1:29 AM, fmp4m said:

 

 

Looking at your log the container is messed up and the scheduler cannot properly create the db file.  that's me trying to say it plainly. I personally would nuke the container and rebuild it.

 

Ok, so I deleted the appdata for this container, nuked my docker image and downloaded all my containers again, still the same issue with a fresh container. Nobody else is having this issue?

Link to post

Any chance the appsettings.json can be included in appdata? I have little understanding if this is possible, but it would solve configuration issues for many of us. For example, you are unable to customize the landing/login pages because the file re-pulls each update. I hope this is something that can be modified without reverting back each time. Thanks!

 

Customize Landing/Login Pages: https://github.com/tidusjar/Ombi/wiki/Customize-the-Landing-and-Login-background

Link to post

Only problem with this docker i have is that it from time to time dont respond, cant login, cant reach, and it hangs while connecting to other services because it seems to throw out 19891831298391231309182391318923 requests at the same time. And i did atleast 3-4 reinstalls from scratch with the same results after some days... (but the weekly mail works fine)

Edited by nuhll
Link to post
On 3/11/2018 at 1:38 AM, CHBMB said:

 


	location /ombi {		
     		return 301 $scheme://$host/ombi/;		
	}
	
	location /ombi/ {
    		proxy_pass http://192.168.0.1:3579;
    		proxy_set_header Host $host;
    		proxy_set_header X-Forwarded-Host $server_name;
    		proxy_set_header X-Real-IP $remote_addr;
    		proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
    		proxy_set_header X-Forwarded-Ssl on;
    		proxy_set_header X-Forwarded-Proto $scheme;
    		proxy_read_timeout  90;
    		proxy_redirect http://192.168.0.1:3579 https://$host;
	}

	if ($http_referer ~* /ombi/) {
	        rewrite ^/dist/(.*) $scheme://$host/ombi/dist/$1 permanent;
	}

Works for me, make sure you change the IP and port to suit and also don't forget to add /ombi as the root url in the ombi webui settings

 

I have been following this guide to setup reverse proxy: 

From here i have used their default.txt file for nginx: https://pastebin.com/vs2Dxgb3

 

and it has worked for radarr perfectly.

 

I'm now trying to add ombi and clearly this config is different.

 

I have set in ombi -> configuration -> customisation -> application URL to /ombi

I have changed the ip addresses and ports to my docker config like so:

 

location /ombi {		
     		return 301 $scheme://$host/ombi/;		
	}
	
	location /ombi/ {
    		proxy_pass http://192.168.0.3:3000;
    		proxy_set_header Host $host;
    		proxy_set_header X-Forwarded-Host $server_name;
    		proxy_set_header X-Real-IP $remote_addr;
    		proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
    		proxy_set_header X-Forwarded-Ssl on;
    		proxy_set_header X-Forwarded-Proto $scheme;
    		proxy_read_timeout  90;
    		proxy_redirect http://192.168.0.3:3000 https://$host;
	}

Do i simply copy and paste that into the default.txt file and that's it? As i have tried this and all i get is "loading...." on a white screen why i try to launch the site.

Link to post
31 minutes ago, CHBMB said:

Honestly, that guide is outdated.  Our container and config has changed, start with a fresh config and paste what I put into the default file.

 

Thanks, i've done that and re-added radarr and ombi.

 

radarr works and ombi is still getting white screen with loading

ombi.jpg

 

what's this part, as it's not in tidusjar example on their GitHub:

 

	if ($http_referer ~* /ombi/) {
	        rewrite ^/dist/(.*) $scheme://$host/ombi/dist/$1 permanent;
	}

 

Edited by Ockingshay
Link to post

I have this:

 

	client_max_body_size 0;

	location / {
		try_files $uri $uri/ /index.html /index.php?$args =404;
	}

	location ~ \.php$ {
		fastcgi_split_path_info ^(.+\.php)(/.+)$;
		# With php7-cgi alone:
		fastcgi_pass 127.0.0.1:9000;
		# With php7-fpm:
		#fastcgi_pass unix:/var/run/php7-fpm.sock;
		fastcgi_index index.php;
		include /etc/nginx/fastcgi_params;
	}
	
	location /ombi {		
     		return 301 $scheme://$host/ombi/;		
	}
	
	location /ombi/ {
    		proxy_pass http://192.168.0.3:3579;
    		proxy_set_header Host $host;
    		proxy_set_header X-Forwarded-Host $server_name;
    		proxy_set_header X-Real-IP $remote_addr;
    		proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
    		proxy_set_header X-Forwarded-Ssl on;
    		proxy_set_header X-Forwarded-Proto $scheme;
    		proxy_read_timeout  90;
    		proxy_redirect http://192.168.0.3:3579 https://$host;
	}

	if ($http_referer ~* /ombi/) {
	        rewrite ^/dist/(.*) $scheme://$host/ombi/dist/$1 permanent;
	}
	
	location /radarr {
		include /config/nginx/proxy.conf;
		proxy_pass http://192.168.0.3:7878/radarr;
	}

and in Ombi GUI i have /ombi in "Application URL"

Edited by Ockingshay
Link to post
Just now, CHBMB said:

Post your Ombi docker run command and also can you access Ombi on http://192.168.0.3:3579/ombi

 

yes, i can access it on http://192.168.0.3:3579/ombi

 

how do i know what the rn command is? i installed ombi from CA

 

log starts off like this:

 

-------------------------------------
_ ()
| | ___ _ __
| | / __| | | / \
| | \__ \ | | | () |
|_| |___/ |_| \__/


Brought to you by linuxserver.io
We gratefully accept donations at:
https://www.linuxserver.io/donations/
-------------------------------------
GID/UID
-------------------------------------

User uid: 99
User gid: 100
-------------------------------------

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 30-config: executing...
[cont-init.d] 30-config: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
Hello, welcome to Ombi
Valid options are:
Ombi 3.0.3477-master
Copyright (C) 2018 Ombi

--host (Default: http://*:5000) Set to a semicolon-separated (;) list
of URL prefixes to which the server should respond. For example,
http://localhost:123. Use "*" to indicate that the server should
listen for requests on any IP address or hostname using the
specified port and protocol (for example, http://*:5000). The
protocol (http:// or https://) must be included with each URL.
Supported formats vary between servers.

--storage Storage path, where we save the logs and database

--baseurl The base URL for reverse proxy scenarios

--help Display this help screen.

--version Display version information.




We are running on

i
Hosting environment: Production
Content root path: /opt/ombi
Now listening on: http://[::]:3579
Application started. Press Ctrl+C to shut down.

 

Link to post

aha, many thanks for your patience!

 

Command:
root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='Ombi' --net='bridge' -e TZ="Europe/London" -e HOST_OS="unRAID" -e 'PUID'='99' -e 'PGID'='100' -p '3579:3579/tcp' -v '/mnt/user/dockerapps/Ombi/':'/config':'rw' 'linuxserver/ombi' 
3de6882b9be619ce644195869f09d5613b6fb296a2f2507e2f53deef37493f52

The command finished successfully!

 

Link to post

oh you little beauty!

 

i thought i just had to put it in your 2nd screenshot, and that it just had to be /ombi

i didn't even see the ombi tab (1st screenshot)

 

thank you again for your time and patience ?

 

There doesn't seem to be any standardisation between apps! very confusing for my old brain...

Edited by Ockingshay
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.