Jump to content
limetech

LimeTech Release Process: How Do I Install Prereleases?

28 posts in this topic Last Reply

Recommended Posts

Here at Lime Technology we manage two release branches: stable and next.  The stable branch is for those users who want better tested, though less frequent releases.  The next branch is where all new development takes place.

 

If you are running a 6.4 stable release, go to the Tools/UpdateOS page and select the Next branch.  If you are running an earlier stable release, to get on the next release branch, install this plugin:

https://s3.amazonaws.com/dnld.lime-technology.com/next/unRAIDServer.plg

New next releases may be installed using the usual plugin Check for updates mechanism.

 

Stable Releases

Stable releases are numbered <major>.<minor>.<patch> as in:

6.2.0

6.2.1

6.2.2

6.3.0

6.3.1

etc.

 

Completion of a new feature or improvement set typically increments the <minor> number.

 

Patch releases are reserved primarily for CVE (security) and other critical bug fixes.

 

A server reboot is required to update to a new stable release.

 

At this time, whenever a new stable release is published, all previous stable releases are deemed EOS (End of Support).

 

Next Releases

Next releases are numbered <major>.<minor>.<patch>-rc<n> as in:

6.4.1-rc1

6.4.2-rc2

etc.

 

It must be assumed that lurking bugs may exist in incremental next releases that can cause instability.

 

If an incremental release carries a risk of data loss, that will be separately noted in the release notes.  Our intent however, is that each incremental next release is fully functional.

 

An incremental next release requires a server reboot.

Share this post


Link to post

Replace all bz* files on your flash drive with the ones from the stable release zip and reboot.

 

Edit: I forgot to mention that you can also do it from the GUI:

 

Tools -> Update OS -> Change "Branch" from "next" to "stable" and click install.

Edited by johnnie.black

Share this post


Link to post
Replace all bz* files on your flash drive with the ones from the stable release zip and reboot.
 
Edit: I forgot to mention that you can also do it from the GUI:
 
Tools -> Update OS -> Change "Branch" from "next" to "stable" and click install.
I don't see the update os in the tools section? I'm using Version 6.3.5 I wanna go to 6.4?

Sent from my LG-H901 using Tapatalk

Share this post


Link to post
10 minutes ago, Gary489 said:

I don't see the update os in the tools section? I'm using Version 6.3.5 I wanna go to 6.4?

That is to downgrade from v6.4 to v6.3.5, to upgrade from 6.3.5 see the 1st post.

Share this post


Link to post

I have 6.3.5

tried to install 6.4  RC16b   

 

How can I install an earlier RC release?  not the last one ? ex. RC8

I want to see if the bellow behaviour is something to do with RC16 or 6.4 in general

 

 RC16b booted but issued a system call and also shows the Array starting message continuously, though if I login via ssh I can see the disks mounted and accessible.

 no possibility to downgrade or install stable version. WEBUI starts the process with a script window showing nothing.

 

 

 

Share this post


Link to post
15 minutes ago, dadarara said:

How can I install an earlier RC release?  not the last one ? ex. RC8

rc8 is no longer available to download, at the moment rc10 is the oldest rc available:

https://s3.amazonaws.com/dnld.lime-technology.com/next/unRAIDServer-6.4.0_rc10b-x86_64.zip

 

16 minutes ago, dadarara said:

no possibility to downgrade or install stable version.

To downgrade to v6.3.5 you just need to copy to the root of the flash drive the files on the /previous folder.

Share this post


Link to post

thanks

to go back I just restore the USB flash from backup I have done before anything...

 

so there is no simple way to install the rc10 like  install plugin command ... ?!

Share this post


Link to post
7 minutes ago, dadarara said:

so there is no simple way to install the rc10 like  install plugin command ... ?!

No, plugin only installs latest, you just need to extract the bz* files to your flash drive root.

Share this post


Link to post

You can install earlier versions using the DVB plugin, I keep the stock files on our server.

Wouldn't recommend using it to switch between unstable/stable though.

Sent from my LG-H815 using Tapatalk

Share this post


Link to post
28 minutes ago, CHBMB said:

You can install earlier versions using the DVB plugin, I keep the stock files on our server.

Wouldn't recommend using it to switch between unstable/stable though.

Sent from my LG-H815 using Tapatalk
 

I tried actually. but while in the 6.4 16b I get a script empty windows doing nothing.

its related to the crash not to the DVB plugin I am sure

Share this post


Link to post
4 hours ago, dadarara said:

I tried actually. but while in the 6.4 16b I get a script empty windows doing nothing.

its related to the crash not to the DVB plugin I am sure

 

Can always download the files manually from here to get yourself out of a mess.....

Share this post


Link to post

Downloaded fresh 6.4.0 create USB out of it , started working and want to upgrade via Tools - update OS , but when i change from "Stable" to "Next" says "please wait recieving...."

 

Then it return back to this state and no way how can i upgrade to RC :(

 

 

I'm doing this as the "old" usd with Unraid 6.4.0 rc21 wont passthrough my GPU and on the fresh USB is working...so no clue about this mess, Any clue how i can upgrade and test if is on last RC also working before i switch whole unraid to "fresh" version? thanks

image.png

Edited by killeriq

Share this post


Link to post
56 minutes ago, killeriq said:

Then it return back to this state and no way how can i upgrade to RC

 

You can't. RC release is not an upgrade for the official release.

 

Share this post


Link to post
1 minute ago, bonienl said:

 

You can't. RC release is not an upgrade for the official release.

 

 

So how to get onto RC version then? there is just 2 links for upgrade the "updater" and it says im on higher version already...

 

Cant find how to jump on RC then...bit a mess , if im not able to switch to RC why is the "Next" option there without any explanation?

Share this post


Link to post
1 minute ago, killeriq said:

 

So how to get onto RC version then? there is just 2 links for upgrade the "updater" and it says im on higher version already...

 

Cant find how to jump on RC then...bit a mess , if im not able to switch to RC why is the "Next" option there without any explanation?

 

Why do you want to go back to  rc21?

If any issues with the official release please report in the appropriate topic.

 

Share this post


Link to post
1 minute ago, bonienl said:

 

Why do you want to go back to  rc21?

If any issues with the official release please report in the appropriate topic.

 

 

didnt want to roll back just didnt realise that 6.4.0 i newer and was released :)

 

Will try to upgrade my current rc21 then...thanks ;)

Share this post


Link to post

I'm on 6.4.1 and wanted to see if there is a new "next" release available, so i went to tools > update OS and changed (again?) from stable to next, and the system appeared to process, then came back showing I'm on the stable release.  i tried twice more, but cannot seem to set the next branch option.

 

is it still the way to do this, or am I doing it wrong?

Share this post


Link to post

You got it right.  There is no "next" branch at the moment, so the system will revert back to stable.  Once there's a next available, it will stay on next until the next stable is released

Share this post


Link to post

Interesting.  I find this somewhat non-user friendly.  I understand there is no "next" branch right now, but that's still the path I'd prefer, so allowing me to choose it should stick, and if/when another next branch is started, I'd like to just automatically be made aware.

 

As it sits now, I have to either follow the forums to learn when it's available again, or just try changing to Next every so often and see if it sticks.  This seems to require too much user participation for a decision I've already made.

 

I'll still have to decide if I want to do the actual upgrade, so it's not like this is the one/only time I need to/can make the decision to install 'beta' builds.

 

I'd suggest this setting be made to stick no matter the availability of a next branch.

Share this post


Link to post

I noticed on both Unraid server i have when i use tools and Update OS then go to Next in the drop down it just goes back to stable....am i missing something? (currently running 6.4.1 on both)

 

 

Edited by Can0nfan

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.