Jump to content
fanningert

[Support] Virt-Manager

27 posts in this topic Last Reply

Recommended Posts

Application Name: Virt-Manager

Application Site: https://virt-manager.org/

Docker Hub: https://hub.docker.com/r/fanningert/docker-virtmanager

Github: https://github.com/fanningert/docker-virtmanager

Template-Repository: https://github.com/fanningert/unraid-docker-templates

 

Answer for connection over SSH:

  1. Install "netcat-openbsd" via Nerd Tools
  2. Select SSH in Virt-Manager, add as user "root", add as server the IP or server name and click Connect.
  3. If you don't use a ssh key file, you need to enter the ssh password in the console.

 

Answer for connection over TCP (More details in the video):

When you like to connect to the unRaid libvirt-System over TCP, you need change one setting of libVirt.

A good start is the video from @gridrunner: Link to post with video

  1. Install "Nerd Tools"
  2. Go to the Nerd Tools and install "nc".
  3. Change the listen address ("listen_addr") of libVirt daemon from 127.0.0.1 to 0.0.0.0 .
    "nano /etc/libvirt/libvirtd.conf"
  4. Stop and start the array. With this, the libVirt daemon will be also restarted.

 

ToDos/Bugs:

  • Some times noVNC reconnect. I think the problem is that the websocket connection is currently only HTTP. It's looks like Virt-Manager is the problem. This bug is coming sometime by clicking on the menu entry "File", but when the reconnection is finished the menu is visible.
  • The only problem know is that the libVirt daemon is listen know on the network. So, this docker container also support SSH for Virt-Manager. The only problem is that I get currently this error message after login on unRaid over SSH throw Virt-Manager.
    libvirtError: Cannot recv data: Value too large for data type
  • The previous error is coming from Virt-Manager, because the app is not possible to ask for the ssh password. The solution for this is to start Virt-Manager via terminal. Know it is possible to enter the password into the terminal window. But after that I get a error message that the current nc version of the Nerd Tools don't support the "U" parameter. Install "netcat-openbsd" via Nerd Tools.
  • Run noVNC under HTTPS

 

Edited by fanningert

Share this post


Link to post

@disruptorx I don't know your system. But is libvirt running? This container is only usable with a running libvirt on the unraid server or a other libvirt server.

I tested the docker container on 6.3.5 and 6.4rc* and on all of this releases the libvirtd.conf file is in this directory. 

 

Here a screenshot from my current unRaid 6.4rc21.

image.png.9aecc19fe4a8a818bd4d7f5762fea126.png

Edited by fanningert

Share this post


Link to post
35 minutes ago, L0rdRaiden said:

Does the container path has to be in "/dev/urandom" or it can be in my usual Docker folder?

Leave it as is. It doesn't use the path for files like your usual Docker.

Share this post


Link to post

I am always failing on the password part. 

It also has an error message for fontconfig  warning: ignoring C.UTF-8: not a valid language tag

where do I set that and to what?

 

Share this post


Link to post

what is the advantage of using this instead the unraid interface?

Is there any incompatibility or issue?

 

BTW I am getting this error, I have ssh enable in unraid, and I have installed netcat

 

 

image.png.2fd2526fb6097b5d0bcb681b0bac72c4.pngimage.png.15d301eabd8a5cfc607b46d5817a5e22.pngimage.thumb.png.a384e0150a8cbb092d9e0c0c063f93fa.png

Edited by L0rdRaiden

Share this post


Link to post

Installed it. Didn't like it. The fact that you can see how much memory is the VM using and that allows you to change preferences while the guest OS is on is pretty sweet. But then it screws up on the unraid side. On the virt manager Vmdk were supported, but it never started so. 

Share this post


Link to post
6 hours ago, gacpac said:

But then it screws up on the unraid side.

Which version of unraid? Some versions have issues keeping track of the status of VM's.

Share this post


Link to post
On 10/21/2018 at 6:06 PM, jonathanm said:

Which version of unraid? Some versions have issues keeping track of the status of VM's.

I'm using the latest version. I thought it was like the Hyper-V manager or the Vsphere used to monitor in ESXI. But the docker it's funny. I created a new network, host only. Then it wouldn't show up in unraid. Then it showed up, but the machine wouldn't start. It's nice that I can see how much memory is the VM using but that's about it. I tried opening a vmdk like it said it would, then the VM wouldn't start. 

And even though I'm not too good with the command line. I think I rather use the command line to convert VMs and then assigning devices there. 

 

It's cool, but it's not perfect. At least not for me I guess. 

 

My unraid version is 6.6.2

Share this post


Link to post
20 minutes ago, gacpac said:

I'm using the latest version.

 

20 minutes ago, gacpac said:

My unraid version is 6.6.2

The VM errors were fixed in 6.6.3

Share this post


Link to post
Posted (edited)
On 1/10/2018 at 6:49 PM, disruptorx said:

Hi @fanningert , I can't seem to find /etc/libvirt/libvirtd.conf to edit . 5a55ef8b86c26_ScreenShot2018-01-10at9_47_41PM.thumb.png.374776fe60996fe3aa5706de5ea66e21.pngany ideas why ?

I have the same problem of not having the file /etc/libvirt/libvirtd.conf.

 

A brief history: I have four VMs, which were working fine under 6.5.3. I tried to install virt-manager on a Linux VM following SpaceInvader One's video, which also requires editing libvirtd.conf. While following the video I was able to edit the file, which was in the expected /etc/libvirt folder. (I also enabled nc-1.10 from NerdPack, as set out in the video.) But after rebooting unRAID, my VM tab was blank. Sometimes it takes a few minutes for the VMs to show up, but after a long wait there were still no VMs listed. (I've checked the paths in VMSettings, and I'm sure they're correct - and everything was working previously.)

 

I thought I had messed up the editing of libvirtd.conf, but when I looked for it, I found that the /etc/libvirt folder was empty. I saw that there was also a /etc/libvirt- folder (note the minus sign) and inside that folder there is a libvirtd.conf file (without any change to the "listen_addr" line). I have no idea why the file is in this other folder and whether this is expected behaviour.

On 1/24/2018 at 4:55 AM, disruptorx said:

@fanningert thanks it's working now

So @disruptorx, how did you get it working?

tower-diagnostics-20190110-1722.zip

Edited by sonofdbn
Added diagnostics file

Share this post


Link to post

@fanningert do you mind if I post an updated Virt-Manager container? this one keeps disconnecting when you go to click connect, the included Virt-Manager is out of date 

Edited by dee31797

Share this post


Link to post

Discussion for the new container moved here

 

 

according to @fanningert's profile he hasn't visited the forum while logged in since June 3, 2018.  I had issues with this container and it hasn't been updated in quite some time.  Fanningert if you want to take this over from me or want me to delete this just let me know.

 

Updated container here: https://hub.docker.com/r/djaydev/docker-virt-manager

Updates include:

Remembers previous connections through updates/restarts

Fix disconnect issue with newer base image

Added VNC connection along side WebGUI

Virt-Manager updated from github to lastest 2.0.0 version

 

Unraid template: https://github.com/djaydev/docker-virt-manager/tree/master/UnRaid/template

 

Edited by dee31797

Share this post


Link to post
17 minutes ago, dee31797 said:

I had issues with this container and it hasn't been updated in quite some time. 

Fair to say then that the existing container does not work with updated unRaid versions?

18 minutes ago, dee31797 said:

Why not just PM @Squid and create a new repository for CA.  Then we can deprecate fannigert's and replace it with yours.

Share this post


Link to post
12 minutes ago, dockerPolice said:

Fair to say then that the existing container does not work with updated unRaid versions?

The existing container does startup on my server running 6.6.6 and it's accessible.  I just had issues with disconnects, it didn't remember the previously connect KVM servers, and it being out of date.

Edited by dee31797

Share this post


Link to post
35 minutes ago, dee31797 said:

he hasn't visited the forum while logged in since June 3, 2018.

 

6 minutes ago, dee31797 said:

it being out of date.

Seems to me that your container is the better choice.  Especially considering the first item, and the fact that you were last on 5 minutes ago :)   I try and look for abandoned projects, hence my suggestion to get in touch with Squid

Share this post


Link to post
3 hours ago, dockerPolice said:

my suggestion to get in touch with Squid

This never fails to amuse me. I would love to be in the room when @Squid, @dockerPolice, and @pluginCop meet in person for the first time. 🤣

 

I crack myself up sometimes.

Share this post


Link to post
3 minutes ago, jonathanm said:

This never fails to amuse me. I would love to be in the room when @Squid, @dockerPolice, and @pluginCop meet in person for the first time. 🤣

 

I crack myself up sometimes.

They just bitched and complained to me, and was forced to add them to CA's Credit's popup.

Share this post


Link to post
1 minute ago, Squid said:

They just bitched and complained to me, and was forced to add them to CA's Credit's popup.

STOP, Your killin' me! 🤣

Share this post


Link to post
Posted (edited)

Hi, thanks for this docker, it works great. However the web VNC isn't the best i find. Is there some way i can VNC into it using an application?

 

Edit: i tried mapping a docker internal port 5900 to an external port then connecting via vnc on that but the connection is actively refused. I checked for a config folder in appdata and there isn't one so i'm guessing i'd have to edit the vnc server settings in the docker itself which then wouldn't be persistent across updates which i'm not that keen on.  Is there a way to get an appdata config like most other dockers have?

Edited by dgwharrison
further information

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.