Jump to content
realies

[Plugin] Corsair PSU Statistics

22 posts in this topic Last Reply

Recommended Posts

In the spirit of badly written things, here is a plugin that reads Corsair power supply statistics and displays them in the dashboard. GPU load is the value from the output0 PSU lane. It is a wrapper for the corsairmi binary which reads out monitoring information for Corsair RMi and HXi power supplies. Works cool in conjunction with an UPS plugin.

 

Screenshot

 

To install, go to Plugins > Install Plugin and paste

https://raw.githubusercontent.com/realies/corsairpsu-unraid/master/corsairpsu.plg

 

Edited by realies
  • Upvote 1

Share this post


Link to post
14 minutes ago, wgstarks said:

Are you planning to add this to CA?

 

Prolly not. Assuming there isn't much Corsair RMi/HXi unRAID users out there, but who knows...

Share this post


Link to post

As previously stated, this currently only works with Corsair RMi and HXi. The i stands for "intelligent" which is their digital control and monitoring feature over USB.

Share this post


Link to post
As previously stated, this currently only works with Corsair RMi and HXi. The i stands for "intelligent" which is their digital control and monitoring feature over USB.


Thanks for the clarification.

Share this post


Link to post

Thanks for the development. Unfortunately, I failed to install the plugin. Error message below.

 

 

plugin: installing: https://raw.githubusercontent.com/realies/corsairpsu-unraid/master/corsairpsu.plg
plugin: downloading https://raw.githubusercontent.com/realies/corsairpsu-unraid/master/corsairpsu.plg
plugin: downloading: https://raw.githubusercontent.com/realies/corsairpsu-unraid/master/corsairpsu.plg ... failed (Invalid URL / Server error response)
plugin: wget: https://raw.githubusercontent.com/realies/corsairpsu-unraid/master/corsairpsu.plg download failure (Invalid URL / Server error response)

Share this post


Link to post

Awkward... I tried again and it now works. No idea what I was doing wrong. You see from my copy & paste that it was not a typo... Anyhow, it is what it is and fortunately succeeded to install the plugin.

 

Unfortunately, the plugin is not working yet (though installed without errors).

 

I have a Corsair RM1000i. After successful install, it doesn't show anything. See copy&paste below:

Uptime Temp1 / Temp2 Fan RPM Supply Volts Nominal Power GPU Load PSU Load PSU Load %
null            

Share this post


Link to post

Any thoughts why the plugin doesn’t show any info?


Sent from my iPhone using Tapatalk

Share this post


Link to post

Mmh.. Thanks for your note. Could it be related to you having a HX1000i vs. my RM1000i? Is there some other way in Unraid to see whether it is it is working besides a docker? Maybe within a Windows VM or command line? Did you need to activate it in the bios or something else that is required to get it running. I bought the RM1000i for this feature, but never actually tried it out.

Share this post


Link to post
On 8/18/2018 at 9:31 AM, steve1977 said:

Any thoughts why the plugin doesn’t show any info?

 

Forgive me for stating the obvious, but did you plug the USB cable in?

 

Share this post


Link to post

Oh well.... Seems that I wasn't aware of the obvious. What USB cable are you referring to?

Share this post


Link to post

Got it, but still not working.

 

I now connected the cable from the PSU via UBS to the on-board USB port of my Asus X299-A.

 

I thought this was the obvious mistake, but unfortunately, this is still not working. Still shows "null".

 

Any idea whether I can test this from command line in Unraid? Do I somehow need to passthrough the USB port to Unraid?

Share this post


Link to post

It seems that I connected the cable correctly (see below), but I am still not seeing anything with the plugin. Any thoughts?

 

USB Devices

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 125f:c92a A-DATA Technology Co., Ltd.
Bus 001 Device 003: ID 1b1c:1c0d Corsair
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

Share this post


Link to post

I passed the USB through to a VM and can confirm that Corsair Link works inside a Windows VM providing me with PSU data. So, the PSU and cabling are not the issue,


Any idea what I can do to get this working with Unraid / Unraid plugin?

 

Thanks in advance for your help!

Share this post


Link to post

@steve1977, sorry for the lack of communication, I did not receive any notification for posts in this thread. I'll make sure I'm subscribed to it.

 

It seems that your Corsair PSU shows up as 1b1c:1c0d. Interestingly, while I was able to source the device IDs for the rest of the Corsair smart PSU lineup by decompiling the Windows client, I did not have any confirmation about the device ID of the RM1000i until now (only an assumption).

 

With this information, I have updated the plugin, which now supports RM1000i and displays meaningful errors on any potential failure (instead of "null").

 

 

Share this post


Link to post

Fantastic, thanks! Let me try shortly and report back. Would be great to have this working. I really like the idea of the plugin!

Share this post


Link to post

You are a star!!! It is working now, thanks!

 

GPU load is 138 watts and PSU load 170 watts. What is GPU load? Do I need to add both of them add to understand how much power my server is consuming? I.e., 308 watts in my case?

Share this post


Link to post

The "GPU Load" label is hardcoded to say that and it outputs the "output0 watts" value that the "corsairmi" command responds with (type "corsairmi" in the terminal for more). The name is hardcoded to say that only because this was my use-case at the time I wrote the plugin and configuration with other systems might differ. If there is demand, future versions might allow for custom labels. "PSU Load" is the "total watts" value from the same "corsairmi" command.

Share this post


Link to post

Thanks. What is the difference between "output0 watts" and "total watts"? Are there also other "output1/2/3/4/5"?

Share this post


Link to post

My understanding is that different outputs are different rails coming out of the power supply. You can use Corsair Link to figure this out better. As mentioned above, type "corsairmi" in the terminal of Unraid to see all output options and more.

Edited by realies

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now