Jump to content
tucansam

6.6.0 GUI

63 posts in this topic Last Reply

Recommended Posts

2 minutes ago, cmer said:

Give this a shot: https://github.com/cmer/unraid-sanity

I think it's an improvement over the "stock" 6.6 UI.

I'm not at home right now, but to me that looks exactly like what I have now.  Either way, I'm not sure how to load new skins or GUIs or whatever you would call it.

Share this post


Link to post
Just now, tucansam said:

I'm not at home right now, but to me that looks exactly like what I have now.  Either way, I'm not sure how to load new skins or GUIs or whatever you would call it.

It's based on White but I made many changes. Changes and how to install are in the README.

Share this post


Link to post

Sweet, I'll give this a shot.  Thanks!!!  

 

Last time I did anything with HTML it was still called "HTML 2.0" but I assume reworking the GUI isn't the easiest thing in the world to do?

Share this post


Link to post

@cmer, a few comments. First, looks good! Second, is there any way for you to add a GUI element to allow changing the font size without manual editing and reloading? I would love to be able to have a small, medium, large font size slider.

 

Regarding your guinea pig server's screenshot, I'm guessing you are fully aware you are running with only single parity protection since disk11 is disabled? Seeing as you don't appear to have any data on that drive slot, I'd recommend rebuilding parity without it, assuming all your other drives are healthy.

Share this post


Link to post
2 hours ago, cmer said:

Font size has been changed. If you want to make it smaller, it's easy. Just change the font size here: https://github.com/cmer/unraid-sanity/blob/master/default-sanity.css#L4

 

All font sizes are now proportional so changing it once there will change ALL the other sizes as well.

Have you considered doing this as a PR against our webGUI github repo?

https://github.com/limetech/webgui

Share this post


Link to post
47 minutes ago, tucansam said:

I followed the instructions in the readme and this is what happened:

 

 

unraid_big.jpg

That's actually the new look. You don't like it? 😂

 

Make sure the CSS is not broken. It looks like something is wrong with it. Or try clearing your browser history.

 

Share this post


Link to post
42 minutes ago, cmer said:

That's actually the new look. You don't like it? 😂

 

Make sure the CSS is not broken. It looks like something is wrong with it. Or try clearing your browser history.

 

Cleared browser cache, no effect.

 

As far as broken CSS goes, I downloaded the sheets from the site and copied them to the location specified in the readme.  I verified them with the "more" command to examine the text, and they look just like they do on the site (ie, no corruption etc as far as I can tell).

 

I am running a plugin or two in my browser (privacy stuff, anti tracking etc).  Would that have any effect?

 

 

Share this post


Link to post
27 minutes ago, tucansam said:

Cleared browser cache, no effect.

 

As far as broken CSS goes, I downloaded the sheets from the site and copied them to the location specified in the readme.  I verified them with the "more" command to examine the text, and they look just like they do on the site (ie, no corruption etc as far as I can tell).

 

I am running a plugin or two in my browser (privacy stuff, anti tracking etc).  Would that have any effect?

 

 

They might.. anytime I see something like that it means a resource was not loaded or got blocked.
If you load up the debug console in the browser (F12 in chrome) then refresh under the console tab it might tell you what is missing

Share this post


Link to post

F12 yielded nothing that was obvious.  I opened it in IE (I never use IE, ever, there is nothing added, just bone stock IE) and got the same issue.  

 

I'll disable some plugins in chrome and firefox and see what happens.  IE is a browser that was possibly coded by second graders, so its no surprise it doesn't work there.

Share this post


Link to post

Disabling all extensions had no effect.

 

I am running a pi-hole, and generally like to clobber all domains, and then only allow what's needed.  So, question, is your CSS drawing something specifically from outside my network, perhaps from 'id.google.com'?

 

Share this post


Link to post

Disregard.  Whitelisted 'id.google.com' and unraid is still broken.  No other domains are showing as blocked when I refresh the GUI.

Share this post


Link to post

I didn't see that, thanks.  Interesting.  Well at least I'm not alone.  I banged my head into my desk for a little while troubleshooting (see above posts) and decided I would sleep on it.  But now I'm not so sure its me.

Share this post


Link to post
4 hours ago, tucansam said:

I didn't see that, thanks.  Interesting.  Well at least I'm not alone.  I banged my head into my desk for a little while troubleshooting (see above posts) and decided I would sleep on it.  But now I'm not so sure its me.

What browser are you using? It works perfectly fine here in Safari, Chrome and Firefox.

Share this post


Link to post
10 minutes ago, cmer said:

What browser are you using? It works perfectly fine here in Safari, Chrome and Firefox.

Tested with Chrome and Firefox, clearing cache didn't help.

Share this post


Link to post
17 minutes ago, johnnie.black said:

Tested with Chrome and Firefox, clearing cache didn't help.

Look in the developer console to see what's happening.

 

Also try running this on your unraid box:

 

curl https://raw.githubusercontent.com/cmer/unraid-sanity/master/dynamix-sanity.css -o /usr/local/emhttp/plugins/dynamix/styles/dynamix-sanity.css
curl https://raw.githubusercontent.com/cmer/unraid-sanity/master/default-sanity.css -o /usr/local/emhttp/plugins/dynamix/styles/default-sanity.css

 

Share this post


Link to post
2 hours ago, cmer said:

What browser are you using? It works perfectly fine here in Safari, Chrome and Firefox.

Chrome, Firefox, IE, tried on two different systems.  And Chrome and Firefox, tried on two different android phones.  Neither android is running any kind of ad block, anti-track, etc.  

Share this post


Link to post
2 hours ago, cmer said:

Look in the developer console to see what's happening.

 

Also try running this on your unraid box:

 


curl https://raw.githubusercontent.com/cmer/unraid-sanity/master/dynamix-sanity.css -o /usr/local/emhttp/plugins/dynamix/styles/dynamix-sanity.css
curl https://raw.githubusercontent.com/cmer/unraid-sanity/master/default-sanity.css -o /usr/local/emhttp/plugins/dynamix/styles/default-sanity.css

 

This fixed it.  That was weird.  Something in how I copied the files from my desktop to unraid?!

 

Its an improvement, if slightly (I'm not complaining, thank you for this).  I am going to tweak font sizes and see how much better I can get it.  

 

For the unraid developers reading, this is an improvement.  But the orange buttons are still way too big (wasted space) and the black toolbar at the top is way too big (wasted space).

Edited by tucansam

Share this post


Link to post

Weird I had the same issue. Downloading it via curl seem to fixed that.

I have another issue though, my drop down boxes are all black

image.png.d3e7714e4df333db36183eb139da9963.png

Share this post


Link to post
7 minutes ago, gsayer said:

Why is 'Lime' technology now orange based in color?

 

(just asking)

 

Same reason this is a thing.

yello.jpg

 

 

  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now