Jump to content
limetech

Unraid OS version 6.6.4 available

67 posts in this topic Last Reply

Recommended Posts

To upgrade:

If you are running any 6.4 or later release, click 'Check for Updates' on the Tools/Update OS page.

If you are running a pre-6.4 release, click 'Check for Updates' on the Plugins page.

If the above doesn't work, navigate to Plugins/Install Plugin, select/copy/paste this plugin URL and click Install:

https://s3.amazonaws.com/dnld.lime-technology.com/stable/unRAIDServer.plg

 

Refer also to @ljm42 excellent 6.4 Update Notes which are helpful especially if you are upgrading from a pre-6.4 release.

 

BIOS: Especially if using Virtual Machines, we highly recommend keeping your motherboard bios up-to-date.

 

Bugs: If you discover a bug or other issue new to this release, please open a Stable Releases Bug Report.

 

Version 6.6.4 2018-11-07

Base distro:

  • curl: version 7.62.0 (CVE-2018-16839, CVE-2018-16840, CVE-2018-16842)
  • dcron: version 4.5 (rev 5) (reversion)
  • openssh: version 7.9p1
  • openssl: version 1.1.1
  • openssl-solibs: version 1.1.1

Linux kernel:

  • version 4.18.17

Management:

  • bug fix: desktop gui 'home page' not honoring user defined http port number
  • update smartmontools drivedb and hwdata/{pci.ids,usb.ids,oui.txt,manuf.txt}
  • webgui: Docker: changed LOG file size reading to prevent HTTP time-outs
  • webgui: improve usb device detection/parsing for vm usb list
  • webgui: Added warning when Flash device is set as public share
  • webgui: Black and White theme: simplified input & select boxes
  • webgui: VM edit: fixed overflow in cpu pinning
  • webgui: GUI: make header scrollable with floating menu
  • webgui: Add viewport meta setting for Safari
  • webgui: Viewport minimum width is 1280px
  • webgui: Hide select arrow across all browsers
  • webgui: Improved Docker and VM settings consistency
  • webgui: css correction for input & select element
  • webgui: Scroll menu: change hardcoded height to dynamic value
  • webgui: Docker styling corrections
  • webgui: jquery ui style corrections
  • webgui: Use viewport for mobile and tablet devices
  • webgui: Fixed: warning on docker container page when array is stopped
  • webgui: Diagnostics Add share storage location
  • webgui: VM manager: fixed: set memballoon model='none' if any PCI device passthrough configured
  • Like 2

Share this post


Link to post

I get the same error:

 

plugin: updating: unRAIDServer.plg
plugin: downloading: https://s3.amazonaws.com/dnld.lime-technology.com/stable/unRAIDServer-6.6.4-x86_64.zip ... done
plugin: downloading: https://s3.amazonaws.com/dnld.lime-technology.com/stable/unRAIDServer-6.6.4-x86_64.md5 ... done
wrong md5
plugin: run failed: /bin/bash retval: 

 

Share this post


Link to post

huh, let me check this...

 

should be fixed, sorry about that.

  • Like 1

Share this post


Link to post
12 minutes ago, limetech said:

should be fixed, sorry about that.

It's working for me.

Share this post


Link to post

Whats up with the strange "spinup of all disks" and not working Cache-Dirs? Is this fixed in this release?

Edited by Zonediver

Share this post


Link to post
10 minutes ago, Zonediver said:

Whats up with the strange "spinup of all disks" and not working Cache-Dirs? Is this fixed in this release?

1. See release notes which state all changes

2. Cache-dirs is a plugin not part of Unraid itself

3. What "strange" spin-ups? I don't have them

Share this post


Link to post
2 minutes ago, bonienl said:

1. See release notes which state all changes

2. Cache-dirs is a plugin not part of Unraid itself

3. What "strange" spin-ups? I don't have them

...but i have it - thats why i reverted to 6.6.2...

@strange spinups: It happens random - thats why i said "strange"...

Edited by Zonediver

Share this post


Link to post
2 minutes ago, Zonediver said:

...but i have it

You have what?

 

At the moment the dynamix cache-dirs plugin has an issue with autostarting after a system reboot.

@Alex R. Bergis improving the script here and this can be used for the moment as an alternative solution.

Eventually the dynamix cache-dirs plugin will be updated.

Share this post


Link to post
25 minutes ago, Zonediver said:

Whats up with the strange "spinup of all disks" and not working Cache-Dirs? Is this fixed in this release?

If you are referring to this bug report, it is still open.

Share this post


Link to post

Upgrade to 6.6.4 from 6.6.3 and all works fine.

In 6.6.3 i had the strange "spinup of all disks" 

After some file copy tests, for me In 6.6.4 the strange "spinup of all disks" disappeared (i haven't plugin, docker or vm).

 

Share this post


Link to post

I'm having an odd issue since upgrading to 6.6.4. For some reasons the drop down combo boxes are not entirely visible in the White and Black theme. I can see them on the Grey and Azure theme. I'm using Chromium. I cleared the cache and cookies. I also used Firefox and had the same problem.

 

Black theme:

1.png

 

White theme:

2.png

 

Grey theme:

3.png

Edited by Katherine

Share this post


Link to post
7 minutes ago, Katherine said:

For some reasons the drop down combo boxes are not entirely visible

I think thats the new style

 

5 hours ago, limetech said:

webgui: Black and White theme: simplified input & select boxes

 

Share this post


Link to post
23 minutes ago, Squid said:

I think thats the new style

Correct.

Share this post


Link to post
13 minutes ago, limetech said:

Correct.

You saw that question coming :) 

Share this post


Link to post

Updated from V6.6.3, have this new error in my system log:

 

Quote

root: error: /webGui/include/ProcessStatus.php: wrong csrf_token

 

Share this post


Link to post

So this new theming, we see no difference between text field and drop down? (before clicking it, like... surprise!)

I don't remember if that was the case before this change, but still. ;)

Edited by Niklas

Share this post


Link to post
26 minutes ago, highdefinitely said:

Updated from V6.6.3, have this new error in my system log:

 

 

A single error though of this is expected to be in the syslog when rebooting.

Share this post


Link to post

No errors updating from version 6.6.3.

Thank you for everyone's hard work.

Share this post


Link to post
5 hours ago, limetech said:

Correct.

Is that helpful from a usability standpoint?  To me it seems confusing and unintuitive, perhaps I'm in the minority on that.

 

Aside from that the upgrade was successful

Edited by sureguy
  • Upvote 1

Share this post


Link to post

When are we going to see WiFi support for times when there is no Ethernet socket. For example where I'm staying there is no wps on the router ao I can't use a Ethernet to WiFi adapter, my router doesn't support bridge mode and the only option is to unreliably bridge my connection with a computer

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now