Jump to content
Josh.5

[Support] Josh5 - Unmanic - Library Optimiser

258 posts in this topic Last Reply

Recommended Posts

Yea. Its not feature complete yet

Sent from my ONE E1003 using Tapatalk

Thanks, I will wait.

Sent from my SM-N960U using Tapatalk

Share this post


Link to post
4 hours ago, ijuarez said:

Thanks, I will wait.

Sent from my SM-N960U using Tapatalk
 

It still works, and does is fantastically. Don't be overly scared of beta stuff just be a bit more careful

Share this post


Link to post
On 4/24/2019 at 4:51 PM, DrAg0n141 said:

Hi, i have the problem that my HEVC converted Files are now again in the queue. I Have removed the many Audio Tracks and i think after that he want convert them new. What can i do that he now dont convert them new?

And the Remove Button is not working.

also encountering this issue.

Share this post


Link to post

Unmanic 0.0.1-beta4 is now available. This fixes the issue that you all were having regarding files that were already processed being re-added to the queue.

The major change with this release is the following:

 

Improved job pipeline.

Prior to this, the workers handled everything including the file copies and post-processing after a conversion. This was not ideal. The new pipeline works as follows:

  1. File added to job queue as a "task" object
  2. Worker picks up task object
  3. Worker configures ffmpeg
  4. Worker inits ffmpeg (monitor output)
  5. On conversion complete task object is updated by the worker
  6. Worker places update task object into a new "processed" queue
  7. New "PostProcessor" class picks up task object from "processed" queue
  8. PostProcessor tests all files and carries out the file move
  9. PostProcessor adds task object data to history

This now opens doors for things like modular post-processing configurations and improved logging on historical tasks (needed for upcoming "See all records" screen).

 

Further in the background this also enables the automated build CI server that I've setup. This build server will automatically execute regression tests which should help with my development.

 

The next milestone on my task list is 0.0.1-beta5 (https://github.com/Josh5/unmanic/milestone/3). This will include some more bugfixes and a new "See all records" screen. I set a release date for this for next Monday, but that my end up pushing out to the following week. We'll see how things go.

 

If you have opened issues on github, please check if I have closed them. If they are now closed, could you please test that your reported bug/enhancement now works as expected.

 

Ta

Share this post


Link to post
On 1/27/2019 at 11:57 AM, trekkiedj said:

yeah that doesn't work unfortunately.

 

Untitled.png

where's the icon located at for the list of dockers

Share this post


Link to post
13 hours ago, ijuarez said:

where's the icon located at for the list of dockers

icon-clear_bg.pngoh...

https://github.com/Josh5/unmanic/raw/master/webserver/assets/icon-clear_bg.png

in the Icon URL with advanced view turned on

Share this post


Link to post
icon-clear_bg.png&key=358227b026c8f8ebec1c3055908f44b08a1d409aff58a3bfd0b185e25c47e354oh...
https://github.com/Josh5/unmanic/raw/master/webserver/assets/icon-clear_bg.png

in the Icon URL with advanced view turned on

Got it thanks

Sent from my SM-N960U using Tapatalk

Share this post


Link to post
Posted (edited)

Correct conversion of multichannel audio streams?

Did anyone ever check the correct conversion of multichannel streams with files containing more than one audio stream?

 

This is the original:

 

843610424_Bildschirmfoto2019-05-10um11_07_14.thumb.png.083a54866d60e68bd798e2c596e676ca.png

 

After conversion:

 

994546840_Bildschirmfoto2019-05-09um11_18_39.thumb.png.8f4a9c616c8ef7e9b39b061dd9d110a8.png1613310764_Bildschirmfoto2019-05-09um11_18_30.thumb.png.f3a569226e393a09a805c31e076dc0af.png

 

The German stream seems to be untouched + the added stereo steam both as DTS, while the englisch stream changes in to ACC stereo and vorb with no indication about channels.

 

 

Edited by jaddel

Share this post


Link to post

Just wanted to show my support for this docker, really fantastic work. I have it setup on my 2nd Unraid machine, processing my main media shares which I pass into the docker using the unassigned devices plugin and NFS. Works beautifully. Keep up the good work.

Share this post


Link to post
Posted (edited)

so i believe i did everything right. i can see all the movie folders in docker console in library folder, but nothing shows up on the gui, and no options to convert anything. what did i miss or do wrong?

 

edit: ok so i just left it on and after a couple hours it started showing shows, its pegging all my cpu's 100%. i only have one worker. and dual 8 core processors. all are pegged at 100% on each cpu and its been 4 hours and its at 50% of one tv show file.... is this normal??

Edited by letrain

Share this post


Link to post
Posted (edited)

image.thumb.png.dcd71a25124e0e600bdc414354c3f9a2.png

Here is mine. Yours should look roughly the same bar the excessive libraries i have haha

---------------------

I just realise how this maybe unhelpful heres whats in some of them

image.thumb.png.0ed984df139a434a653c1ab52eb5b78f.png

image.thumb.png.1454d499b4e75dea03da6a53882e141b.png

image.thumb.png.8c68ceeaa90b6e452565b0554df1f7b1.png

image.thumb.png.7475104cf9c5fe499a1101726518f160.png

 

Make sure you have advanced view on.

 

3rd addon to this. the UI (for me atleast) is slow as shit I doubt that's the container and more that my server is almost pegged 247 because I'm not a nice sysadmin. Just give it some time to load things up

 

don't forget this option either

image.thumb.png.19d4ef642e40148b1dfe51c91c71cd30.png

Edited by BomB191
spellings hard

Share this post


Link to post
6 hours ago, MJ008 said:

Is there H265 transcode support?

Yeap, that's kinda the entire point. There's no hardware transcode support at the moment, but it's in the development plan.

Share this post


Link to post

Any chance this can convert from say AAC to AC3? I use FFMPEG to do that a lot. 

 

Basically I take a mp4 typically encoded to h.264 mp4 AAC and I use FFMPEG to change the audio from AAC to AC3 and copy the video to a MKV. 

Share this post


Link to post
Posted (edited)

Hey guys. I'm completely new to this, and have looked over this thread, but may have missed the answer. I have pulled and installed Unmanic and it's running. However, I can't seem at access the web ui? Portainer reports that the container is running but there's no announced port? 

 

Any help would be much appreciated. 

 

Thanks. 

Edited by Night_Fury

Share this post


Link to post
49 minutes ago, Night_Fury said:

Hey guys. I'm completely new to this, and have looked over this thread, but may have missed the answer. I have pulled and installed Unmanic and it's running. However, I can't seem at access the web ui? Portainer reports that the container is running but there's no announced port? 

 

Any help would be much appreciated. 

 

Thanks. 

@Night_Fury Make sure you Edit the container and click the advanced switch in the upper right. Make sure this line is filled in:

 

image.png.1aaa8eb7eb6f2358d04515304cfd9ed6.png

 

Then save the container and you should be able to get tot he web UI

Share this post


Link to post
9 minutes ago, mwoods98 said:

@Night_Fury Make sure you Edit the container and click the advanced switch in the upper right. Make sure this line is filled in:

 

image.png.1aaa8eb7eb6f2358d04515304cfd9ed6.png

 

Then save the container and you should be able to get tot he web UI

Sorry for my complete greenness in this, edit the container in Portainer, you mean?

Share this post


Link to post
9 minutes ago, Night_Fury said:

Sorry for my complete greenness in this, edit the container in Portainer, you mean?

Here is where I'm getting it:

 

I'm also on 6.7.0

 

image.png.481800146c771ef05df61f8af9d8576a.png

Share this post


Link to post

I'm completely missing something then. I don't have this at all 

Just now, mwoods98 said:

Here is where I'm getting it:

 

I'm also on 6.7.0

 

image.png.481800146c771ef05df61f8af9d8576a.png

 

Share this post


Link to post
33 minutes ago, mwoods98 said:

Here is where I'm getting it:

 

I'm also on 6.7.0

 

image.png.481800146c771ef05df61f8af9d8576a.png

How exactly did you come to that menu?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.