New unraid user install


26 posts in this topic Last Reply

Recommended Posts

Howdy folks! Pleasure to be on the forum...Although, I'm in need of a little help. So, I tried for about 3 hours last night to install unraid on one of my servers and was unsuccessful. I did make a lot of drastic changes last night to my system so I'm curious if I potentially missed something. Little history...Machine is a Dell R720XD LFF with dual Xeon E5-2680 v2 processors 256GB memory 12 x 3.5" 3TB SAS and 2 2.5" SAS in the flex bay. Raid card WAS an H710 mini and I ordered and swapped it last night with the passthrough H310 mini. I went in the config and cleared the current raid config and switched ALL the drives to non-raid. Previous to the swap, I transferred all the data from the 12 front drives that were running in RAID 6 on the H710 to another network attached storage, but I left the two rear drives data intact but cleared the RAID 1 config they were in. I also went into the system config and made the internal USB the first and prioritized boot device in the UEFI boot manager. I ran the unraid USB creator tool, customized, correct network info, UEFI bootable, ran the make_bootable as administrator and I get nothing but an install that won't start or initialize. This machine will install and boot ESXi no problem on the internal USB port. I am getting the following attached error, see picture. I have tried 2 different thumb drives, both of them are identical in make and model 16GB imation nano. I will try a different brand but I'm just not sure what to order on Amazon. Any help would be greatly appreciated as I really want to see what this unraid is all about...TIA

IMG_0319.jpg

Edited by rocky_mtn
Link to post

I am booting from the same port on the board that I was able to successfully boot ESXi from. It's internal, right on the board in front of the flex bay backplane. I'm going to try a different brand USB drive tonight. The imation nano's I used were identical and they did have a unique serial number attached to them, which unraid says is a prerequisite.

Link to post
56 minutes ago, trurl said:

Are you booting from a USB2 port?

The reason I asked is because many people have problems booting or maintaining a connection to the flash drive in a USB3 port. So what is the answer?

Link to post

Which makes me think of another question...Once I get it up and running, assuming I figure this out, should I swap out the rear 147GB SAS drives for 480GB SSD's or would there be no performance benefits there? Also, my apologies @trurl, somehow my eyes glazed right over the "2" after you asked if it was a USB2 port.

Link to post

Tried 3 different USB flash drives of multiple manufacturers and even different USB ports like the ones on the front and the back, not the problem. I'm thinking it has to have something to do with my servers config that I haven't figured out. I must have missed something in the settings. Hate to say it, but after 2 nights of this I'm about to throw in the towel...

Link to post
24 minutes ago, rocky_mtn said:

Could it be because I have zero vitrual disks setup, only physical?

I am not following you there, unless this question has something to do with ESXi.

 

I didn't get the impression that you were actually trying to run Unraid under ESXi. Is that what this is all about?

Link to post

Negative, I am trying to run it on a machine that all the drive data has been wiped from. I just don't know anything about any of this so I'm just spitballing. I did just figure out a setting I missed so we are about to see if legacy mode was the answer this whole time...shortly

Edited by rocky_mtn
Link to post
1 minute ago, rocky_mtn said:

Now the web UI isn't accessible by firefox, but I can get it in chrome...lol, never ends

I'm accessing the GUI on my unRAID server right now via Firefox.  What version of Firefox are you using?  There were a couple of older versions (about a year ago, I believe) that had some issues and did not display the GUI properly. 

 

There is no general incompatibility between Firefox and the GUI.

Link to post
  • 2 weeks later...

What type of information would you guys need from me to help me figure out why it takes 45 minutes to stop my array? I'm trying to transfer data and it works for 15-20 minutes at 1 Gbps then it drops abysmally slow down to 11 MB/s. I noticed it was when the fix common problems message pops up is when the speeds drag, so that's prompted me to do a couple stoppages of the array today and it literally takes 45 minutes to stop it and actually execute the powerdown -r command. I don't wanna give up on this, but something tells me you guys don't wait 45 minutes for your array to stop...TIA

Link to post

Thanks @jpowell8672 I’m just wondering if it’s because this is my first time, or it’s a brand new setup, or what...but I can’t imagine this is normal behavior. Opened files plugin shows 1873 PID running with 4 files open but if I kill it, I have to do so in the terminal, the plugin button opens a blank window and does nothing...the terminal kills it, but it doesn’t seem to change anything. Still 45 minutes to stop the array and reboot. I’ve since rebooted and disabled parity so I can get the media transferred and then I’ll re-enable it. I would LOVE to get to the bottom of this and not give up ha!

Link to post

Alright, here you go. Priority is obviously what's wrong with it taking so long to shutdown and stop the array, but figuring out why it goes from 111 MB/s down to 11 MB/s on the transfer sure would be a sweet bonus. Anything else would be much appreciated, seriously.

 

Edited by rocky_mtn
clarification
Link to post

Well the drive write cache is disabled by default. Found this thread

thanks @Vexorg and it worked perfectly...back to 111 MB/s transfer speeds writing to Unraid. You my friend, saved my Unraid install...As for the severe delay on stopping the array, it seemed to resolve itself with a fresh install on another USB drive. Hope this helps someone else...

Link to post
  • 3 weeks later...

So I’ve got this all up and running and have purchased my pro license. Very happy so far. I’ve recently started messing with a couple VM’s and instantly realized 3 problems I need help solving. I’ve been reading for 3 evenings straight on GPU install in this server and I’m more confused now than ever. The 3 problems are my graphics look like garbage, not full screen even when remote accessed with proper software...mouse has tracers, icons look grainy. Problem 2, I have zero sound. 3rd, and possibly the most annoying, my mouse scroller doesn’t work in my VM’s. I don’t do any gaming or need any extreme performance, I just want my VM’s resolutions to look proper on a 27” monitor, nice and crispy and my sound and mouse roller to work. Can someone please help me cut through the trauma and point me towards a solution for these 3 problems? Please 😂 TIA

Link to post

For accessing Windows VMs without GPU passthrough I use Microsoft's built in RDP (remote desktop protocol). My daily workstation is a Mac so I use the free Microsoft Remote Desktop client from the App Store. If you want to do the same using a Windows workstation there's a remote desktop client built in. It's much better than the web-based noVNC client and it passes sound. You set the required resolution in the client - I set the same as my screen and choose fullscreen and the scaling is 1:1. I use a trackpad, rather than a mouse, but scrolling works as expected. Some people recommend third party remote desktop tools but I prefer to use the built-in protocols if they work and RDP works very well for me.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.