Windows issues with unRAID


RobJ

Recommended Posts

@trurl I mounted a "master" share like that to avoid slow moves between different shares on the array. I haven't even considered that would bypass the security which is completely logical as thats how that was written.

 

After disconnecting the share and browsing \\localIP eveything works as intended.

 

@Frank1940 I was careful to not fall into that windows trap, following spaceinvaders videos.

 

Thank you guys!

Edited by Ver7o
Link to comment
  • 3 weeks later...
  • 1 month later...
On 7/25/2020 at 5:12 PM, DoleWhip said:

 

TL;DR: 

1. If Computer Configuration > Administrative Templates > Network > Lanman Workstation > Enable insecure guest logons shows "Enabled" but it isn't working, continue

2. Open the registry editor and go to Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

3. Double-click on AllowInsecureGuestAuth

4. Under "Value data:", change it from 0 to 1 

 

Describing what I did troubleshooting-wise (not that it matters, but maybe it'll help someone):

 

I updated my Windows 10 Education to version 2004 yesterday and was no longer able to access my SMB shares (was working fine before Windows update).

 

I could see them, but double-clicking on my server name in Windows Explorer under Network gave me the generic can't access error. Luckily (because it helped me google my problem) I had pinned some folders in it, and trying to access those gave me the popup pictured in that preview/thread saying:

"You can't access this shared folder because your organization's security policies block unauthenticated guest access. These policies help protect your PC from unsafe or malicious devices on the network."

 

I was confused because my group policy under: 

Computer Configuration > Administrative Templates > Network > Lanman Workstation > Enable insecure guest logons

showed "Enabled". Toggling this back and forth and restarting my PC didn't fix anything.

 

My unRAID server SMB settings had enabled for workgroup, enable NetBIOS to yes, and enable WSD to yes. My workgroup under those SMB settings matched with my PC, I even retyped them in holding down shift to capitalize just in case. Local master was set to yes, and I also downloaded the Dynamix Local Master plugin to check for me and it verified that yes, my unRAID server was indeed the current local master. Still not working.

 

I added:

log level=2

syslog=3

to SMB Extras and saw in my syslog that my PC was trying to send my local user to access the SMB shares (which are set to public) with errors along the lines of:

FAILED with error NT_STATUS_NO_SUCH_USER, authoritative=1

and that I was trying to use SMBv2

 

In the end, I found the solution in the linked thread to do this:

 

1. Open the registry editor and go to Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

2. Double-click on AllowInsecureGuestAuth

3. Under "Value data:", change it from 0 to 1 

 

This information is GOLD:

1. Open the registry editor and go to Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

2. Double-click on AllowInsecureGuestAuth

3. Under "Value data:", change it from 0 to 1 

 

Helped me solve a two week issue trying to access my network shares.

 

Thank you

  • Like 1
Link to comment

All, I encountered this problem for the first time today across most of my PCs, and the fixes in this thread did not work. What did work was adding a line to the [global] section of my unRAID smb extra configuration settings:

client min protocol = SMB2

To be clear for those who are less versed in smb settings, this is in addition to a line I already had in there for the server, which is simply min protocol = SMB2.

 

Note, I assume this change will break any SMB1 clients trying to connect, but hopefully those are increasingly few and far between. That said, I have not turned off the SMB1 client in my Windows features, though I assume it will no longer be necessary for accessing unRAID. I might test that later this week and report back with an update.

  • Thanks 2
Link to comment
  • 1 month later...
On 9/16/2020 at 2:23 PM, UnBeastRaid said:

 

This information is GOLD:

1. Open the registry editor and go to Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

2. Double-click on AllowInsecureGuestAuth

3. Under "Value data:", change it from 0 to 1 

 

Helped me solve a two week issue trying to access my network shares.

 

Thank you

I don't have the setting AllowInnsecureGuestAuth.   It won't break if I manually add it in or... I don't want to change to much because it works fine from my laptop.  I just want to be able to do stuff on my new desktop.  Is it because this version of Windows isn't registered (yet?)   

Link to comment
1 hour ago, cbr600ds2 said:

I don't have the setting AllowInnsecureGuestAuth.   It won't break if I manually add it in or... I don't want to change to much because it works fine from my laptop.  I just want to be able to do stuff on my new desktop.  Is it because this version of Windows isn't registered (yet?)   

First before you start editing the Registry, read this post and see if you have things setup this way:

 

https://forums.unraid.net/topic/43381-unraid-keeps-not-showing-up-in-the-network-folder-on-windows-10/?tab=comments#comment-906336

 

Notice the setting for Network discovery.  I suspect that this has to be on.  The default was changed from 'on' to 'off' when I got one of the MS security updates a number of months back!

 

Editing the Registry is is something nobody likes to recommend since doing is definitely not idiot-proof!!!   So I doubt if anyone is simply going to say "go ahead, nothing bad can happen..."

 

You might want to make a backup of the Registry before you start.  You want to be sure you go down the right path and triple check that path to verify you are at the proper point.  You have to type accurately (You made a mistake in your reply when you typed "AllowInnsecureGuestAuth" by adding an extra 'n').  (Cut-and-paste is probably a better way to go.  But avoid copying the 'line feed' at the end of the instruction---  Those things can really screw things up!)   I actually have the feeling that this entry was added to 'turn off' insecure access in one of the Windows updates. 

 

I would also bet you have different versions (1909, 2004, etc.)  and variety (Home, Pro, Edu) on your two computers.  If they differ in any way, the two Windows installations can and often do behave differently!  Unfortunately, I have been dealing with Windows SMB issues for so long and made so many teaks that I have no ideal of which ones are now truly necessary.

Link to comment
7 hours ago, Frank1940 said:

First before you start editing the Registry, read this post and see if you have things setup this way:

 

https://forums.unraid.net/topic/43381-unraid-keeps-not-showing-up-in-the-network-folder-on-windows-10/?tab=comments#comment-906336

 

Notice the setting for Network discovery.  I suspect that this has to be on.  The default was changed from 'on' to 'off' when I got one of the MS security updates a number of months back!

 

Editing the Registry is is something nobody likes to recommend since doing is definitely not idiot-proof!!!   So I doubt if anyone is simply going to say "go ahead, nothing bad can happen..."

 

You might want to make a backup of the Registry before you start.  You want to be sure you go down the right path and triple check that path to verify you are at the proper point.  You have to type accurately (You made a mistake in your reply when you typed "AllowInnsecureGuestAuth" by adding an extra 'n').  (Cut-and-paste is probably a better way to go.  But avoid copying the 'line feed' at the end of the instruction---  Those things can really screw things up!)   I actually have the feeling that this entry was added to 'turn off' insecure access in one of the Windows updates. 

 

I would also bet you have different versions (1909, 2004, etc.)  and variety (Home, Pro, Edu) on your two computers.  If they differ in any way, the two Windows installations can and often do behave differently!  Unfortunately, I have been dealing with Windows SMB issues for so long and made so many teaks that I have no ideal of which ones are now truly necessary.

Thanks Frank... I'll check it out but it shows up on windows explorer network but when you double click to get to see the shares then it gives me the error that it can't be found which I think is a bit weird.  I'll try these this week.  I thought it was the Samba 1 setting but that didn't fix.  *shrug* 

Link to comment

I've read so many topics, tried so many things but still cannot access my private shared folders. If I set them to public everything is OK. I'm lost and also wondering why everything just works with Synology and Openmediavault, but not with unRAID. I'm more and more certain it's on unRAID side and not Windows.

Link to comment
12 minutes ago, yogy said:

tried so many things

Go to Windows Control Panel, Credential Manager, and delete any Unraid credentials so they can be renegotiated. Then, be sure to try to access the private share before trying to access any other share. With Windows, you only get one login per network resource and you must make sure that one login is the one needed for the private share. Windows won't use another login even if it prompts you.

  • Like 1
Link to comment

And did you try this?

11 minutes ago, trurl said:

Go to Windows Control Panel, Credential Manager, and delete any Unraid credentials so they can be renegotiated. Then, be sure to try to access the private share before trying to access any other share. With Windows, you only get one login per network resource and you must make sure that one login is the one needed for the private share. Windows won't use another login even if it prompts you.

 

Link to comment
12 hours ago, Frank1940 said:

Any 'mapped' drives?

I have 2 SMB shares mapped to unRAID.

12 hours ago, Frank1940 said:

Also try from a Command Prompt on your Windows computer, type:


net use * /delete

This will force a disconnect of your Windows computer from all Network share connections.

I also tried this, but still doesn't work.

Link to comment

Since you can access these shares when they are public, you have one of several SMB 'user' problems.  Please read the balance of this thread from this post forward very carefully.  It discusses the  many SMB pitfalls that people encountered.  Many of the problems are very subtle.  Plus, Windows (yes Windows) will do things in the background to confuse things even more.

 

      https://forums.unraid.net/topic/25064-user-share-problem/?tab=comments#comment-228392

 

You have to be very careful about the first SMB access to your Unraid server from the Windows client.  With that first access, Unraid's SMB process will setup a user for that Windows computer client.  That is the only user that SMB will allow from your Windows client.

 

SMB is a Kludge.  It is controlled by Microsoft and has evolved out of Windows for Workgroups 3.1 introduced back in the early 1990's.  It was originally intended to connect a few computers together so that people working on a project could share files with the group.  There was zero security!!!   The Internet (as we know it) was in its initial deployment. 

 

You have to play by the SMB rules and they are confusing to say the least.  You are on the wrong side of one of them...

 

47 minutes ago, yogy said:

Where? On Windows 10? I have my NAS shares already mounted.

The SMB server I was referring to is the Unraid server.  The mapped drives are on your Windows client computer.   (Mapping to is the Windows process by which you assign an Unraid share to a drive letter (i.e., "Z:\") on your Windows client.)

Edited by Frank1940
Link to comment

After 2 hours of searching on the internet I finnaly found 2 solutions. Both worked for me in resolving my issue with unRAID shared folders mapped in Windows 10.

1. If you cannot mount SMB share to windows 10 use NFS share client in Windows. It works great.

  • enable NFS in your unRAID server
  • follow this tutorial on your Windows 10 (only Pro and Enterprise versions) computer

2. I tried and read every single tutorial here and couldn't mount SMB share in my Windows 10 computer. I finnaly realized that I have a special character "€" in my password and that caused SMB shares never worked for me. I change the password in unRAID server and Windows 10 PC and BOOOOOOOOM it worked straight away.

 

Maybe this will help others.

 

Thank you @trurl and @Frank1940 for trying to provide some help.

  • Thanks 1
Link to comment
1 hour ago, yogy said:

I finnaly realized that I have a special character "€" in my password and that caused SMB shares never worked for me. I change the password in unRAID server and Windows 10 PC and BOOOOOOOOM it worked straight away.

Another one of those special 'rules' that are so common with SMB.   Coupled with the error messages/codes that usually provide no clue as to what the problem is.  I am a bit curious as your special character was displayed in Firefox in the USA as being the Euro currency symbol.  If it is the Euro symbol, is it on your keyboard or did you enter it some other way? 

 

Piece of General information to everyone.  As I google this issue, it appears that there might well be issues with the use of special symbols and punctuation marks in SMB passwords.  It would probably be best to use only letters and numbers when setting up users who will be using the password to log into SMB to eliminate any potential for an issue.   If you are worried about the slight loss of security, consider making the password longer.

Edited by Frank1940
Link to comment
1 hour ago, Frank1940 said:

If it is the Euro symbol, is it on your keyboard or did you enter it some other way? 

Yes this is a Euro currency symbol. You won't see this symbol on any keyboard (even on EU countries one). I can access it by Alt+e.

 

1 hour ago, Frank1940 said:

Piece of General information to everyone.  As I google this issue, it appears that there might well be issues with the use of special symbols and punctuation marks in SMB passwords.  It would probably be best to use only letters and numbers when setting up users who will be using the password to log into SMB to eliminate any potential for an issue.   If you are worried about the slight loss of security, consider making the password longer.

I couldn't agree more

Link to comment

Hi im new 2 weeks a go my server disappeared from my network folder and i have bin reading all of this on and off the  strange thing is everything else was working previously mapped folder in explorer history an my mapped network drives but could not access shares that were not mapped as a network drives like appdata and flash drive etc..   long story

 

But this solved my problem for now open powershell as admin and put in "Enable-WindowsOptionalFeature -Online -FeatureName smb1protocol"

 

Win10pro v.2004

Edited by Diddmaster
win info
Link to comment
On 10/30/2020 at 6:09 PM, yogy said:

Yes this is a Euro currency symbol. You won't see this symbol on any keyboard (even on EU countries one). I can access it by Alt+e.

 

Just for info - there are many keyboards with the Euro symbol - even my UK layout Logitech keyboard (over 10 years old) has it.  In my case it's on the 4 key, along with the dollar sign.  Control-Alt-4 gives € in this case.  It's the same on my Dell laptop too.  Or if don't have the key marked but you have a numeric keypad, press and hold Alt while pressing 0 1 2 8 - that would be the way that many less common characters can be entered (and that method goes right back to the days of using DOS for some of us).

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.