• Unraid OS version 6.8.0-rc1 available


    New in Unraid OS 6.8 release:


    The unRAIDServer.plg file (update OS) still downloads the new release zip file to RAM but then extracts directly to USB flash boot device.  You will probably notice a slight difference in speed of extract messages.  There is still a 'sync' command at the end, which causes each device to spin up serially as Linux kernel syncs each device (why does kernel do this serially? I have no idea).  I am tempted to remove this because a Reboot of course spins everything up in parallel, but I'm concerned about users out there who might just hit Reset button and USB flash write data is not fully written. 


    Forms based authentication
    If you have set a root password for your server, upon boot you'll now see a nice login form.  There still is only one user for Unraid so for username enter root.  This form should be compatible with all major password managers out there.  We always recommend using a strong password.  We have auto-logout set to 1 hour.


    Linux kernel 5.3

    • default scheduler now 'mq-deadline'
    • enabled Huge Page support, though no UI control yet
    • binfmt_misc support
    • added "Vega 10 Reset bug" patch
    • more device drivers


    Some out-of-tree (oot) drivers are currently omitted either because the source code doesn't compile or driver doesn't work with the 5.3 kernel:

    • Intel ixgbe [does not build] (using in-tree driver)
    • Highpoint r750 [does not work]
    • Highpoint rr3740a [does not build]


    This is always the risk with including vendor-supplied drivers.  Until the vendor fixes their code we must omit their driver.


    md/unraid driver
    Introduced "multi-stream" support:

    • Reads on devices which are not being written should run at full speed.  In addition, if you have set the md_write_method tunable to "reconstruct write", then while writing, if any read streams are detected, the write method is switched to "read/modifywrite".
    • Parity sync/check should run at full speed by default.
    • Parity sync/check can be throttled back in presence of other active streams.
    • The "stripe pool" resource is automatically shared evenly between all active streams.


    As a result got rid of some Tunables:

    • md_sync_window
    • md_sync_thresh

    and added some tunables:

    • md_queue_limit
    • md_sync_limit


    Please refer to Settings/Disk Settings help text for description of these settings.


    Remaining issue: some users have reported slower parity sync/check rates for very wide arrays (20+ devices) vs. 6.7 and earlier releases - we are still studying this problem.

    WireGuard support - available as a plugin via Community Apps.  Our WireGuard implementation and UI is still a work-in-process; for this reason we have made this available as a plugin, though the latest WireGuard module is included in our Linux kernel.  Full WireGuard implementation will be merged into Unraid OS itself in a future release.  I want to give special thanks to @bonienl who wrote the plugin with lots of guidance from @ljm42 - thank you!  I also should give a shout out to @NAS who got us rolling on this.  If you don't know about WireGuard it's something to look into!


    Guide here:

    WS-Discovery support - Finally you can get rid of SMBv1 and get reliable Windows network discovery.  This feature is configured on the Settings/SMB Settings page and enabled by default.

    • Also on same settings page is Enable NetBIOS setting.  This is enabled by default, however if you no longer have need for NetBIOS discovery you can turn it off.  When turned off, Samba is configured to accept only SMBv2 protocol and higher.
    • Added mDNS client support in Unraid OS.  This means, for example, from an Unraid OS terminal session to ping another Unraid OS server on your network you can use (e.g., 'tower'):
      ping tower.local
      instead of
      ping tower
      Note the latter will still work if you have NetBIOS enabled.


    User Share File System (shfs) changes:

    • Integrated FUSE-3 - This should increase performance of User Share File System somewhat.
    • Fixed bug with hard link support.  Previously a 'stat' on two directory entries referring to same file would return different i-node numbers, thus making it look like two independent files.  This has been fixed however there is a config setting on Settings/Global Share Settings called "Tunable (support hard links)".  The default is Yes, but with certain very old media and DVD players which access shares via NFS, you may need to set this to No.
    • Note: if you have custom config/extra.cfg file, get rid of it.

    Other improvements/bug fixes:

    • Format - during Format any running parity sync/check is automatically Paused and then resumed upon Format completion.
    • Encryption - an entered passphrase is not saved to any file.  Also included an API for Unassigned devices plugin to open encrypted volumes.
    • Fixed bug where multi-device btrfs pool was leaving metadata set to dup instead of raid1.
    • Several other small bug fixes and improvements.
    • Numerous base package updates.


    Finally - please note that AFP is now deprecated and we plan to remove in Unraid 6.9 release.


    Version 6.8.0-rc1 2019-10-11

    Base distro:

    • aaa_elflibs: version 15.0 build 11
    • acpid: version 2.0.32
    • at-spi2-atk: version 2.34.0
    • at-spi2-core: version 2.34.0
    • atk: version 2.34.1
    • bash: version 5.0.011
    • btrfs-progs: version 5.2.2
    • bzip2: version 1.0.8
    • ca-certificates: version 20190826
    • cifs-utils: version 6.9
    • cryptsetup: version 2.2.1
    • curl: version 7.66.0
    • dbus: version 1.12.16
    • dbus-glib: version 0.110
    • dhcpcd: version 8.0.6
    • docker: version 19.03.3
    • e2fsprogs: version 1.45.4
    • encodings: version 1.0.5
    • etc: version 15.0
    • ethtool: version 5.3
    • expat: version 2.2.9
    • file: version 5.37
    • findutils: version 4.7.0
    • freetype: version 2.10.1
    • fuse3: version 3.6.2
    • gdbm: version 1.18.1
    • gdk-pixbuf2: version 2.38.2
    • git: version 2.23.0
    • glib2: version 2.62.0
    • glibc-solibs: version 2.30
    • glibc-zoneinfo: version 2019c
    • glibc: version 2.30
    • glu: version 9.0.1
    • gnutls: version 3.6.10
    • gtk+3: version 3.24.10
    • harfbuzz: version 2.6.0
    • haveged: version 1.9.8
    • hostname: version 3.22
    • hwloc: version 1.11.13
    • icu4c: version 64.2
    • intel-microcode: version 20190918
    • iproute2: version 5.3.0
    • iptables: version 1.8.3
    • iputils: version 20190709
    • irqbalance: version 1.6.0
    • less: version 551
    • libICE: version 1.0.10
    • libX11: version 1.6.8
    • libXi: version 1.7.10
    • libXt: version 1.2.0
    • libarchive: version 3.4.0
    • libcap-ng: version 0.7.10
    • libcroco: version 0.6.13
    • libdrm: version 2.4.99
    • libedit: version 20190324_3.1
    • libevdev: version 1.7.0
    • libevent: version 2.1.11
    • libgcrypt: version 1.8.5
    • libgudev: version 233
    • libjpeg-turbo: version 2.0.3
    • libnftnl: version 1.1.4
    • libnl3: version 3.5.0
    • libpcap: version 1.9.1
    • libpciaccess: version 0.16
    • libpng: version 1.6.37
    • libpsl: version 0.21.0
    • librsvg: version 2.44.14
    • libseccomp: version 2.4.1
    • libssh2: version 1.9.0
    • libtasn1: version 4.14
    • libusb: version 1.0.23
    • libvirt-php: version 0.5.5
    • libvirt: version 5.7.0 (CVE-2019-10161, CVE-2019-10166, CVE-2019-10167, CVE-2019-10168)
    • libwebp: version 1.0.3
    • libzip: version 1.5.2
    • logrotate: version 3.15.1
    • lsof: version 4.93.2
    • lsscsi: version 0.30
    • lvm2: version 2.03.05
    • lz4: version 1.9.1
    • mkfontscale: version 1.2.1
    • mozilla-firefox: version 68.0.2 (CVE-2019-11751, CVE-2019-11746, CVE-2019-11744, CVE-2019-11742, CVE-2019-11736, CVE-2019-11753, CVE-2019-11752, CVE-2019-9812, CVE-2019-11741, CVE-2019-11743, CVE-2019-11748, CVE-2019-11749, CVE-2019-5849, CVE-2019-11750, CVE-2019-11737, CVE-2019-11738, CVE-2019-11747, CVE-2019-11734, CVE-2019-11735, CVE-2019-11740, CVE-2019-11754, CVE-2019-9811, CVE-2019-11711, CVE-2019-11712, CVE-2019-11713, CVE-2019-11714, CVE-2019-11729, CVE-2019-11715, CVE-2019-11716, CVE-2019-11717, CVE-2019-1 1718, CVE-2019-11719, CVE-2019-11720, CVE-2019-11721, CVE-2019-11730, CVE-2019-11723, CVE-2019-11724, CVE-2019-11725, CVE-2019-11727, CVE-2019-11728, CVE-2019-11710, CVE-2019-11709)
    • nano: version 4.5
    • ncurses: version 6.1_20190720
    • net-tools: version 20181103_0eebece
    • nettle: version 3.5.1
    • nghttp2: version 1.39.2
    • nginx: version 1.16.1 (CVE-2019-9511, CVE-2019-9513, CVE-2019-9516)
    • nodejs: version 10.16.3
    • nss-mdns: version 0.14.1
    • ntp: version 4.2.8p13
    • openldap-client: version 2.4.48
    • openssh: version 8.0p1
    • openssl-solibs: version 1.1.1d
    • openssl: version 1.1.1d
    • p11-kit: version
    • pcre2: version 10.33
    • php: version 7.2.23 (CVE-2019-11042, CVE-2019-11041)
    • pixman: version 0.38.4
    • pkgtools: version 15.0
    • procps-ng: version 3.3.15
    • qemu: version 4.1.0 (CVE-2018-12126, CVE-2018-12127, CVE-2018-12130, CVE-2019-11091)
    • qrencode: version 4.0.2
    • rpcbind: version 1.2.5
    • rsyslog: version 8.1908.0
    • samba: version 4.10.8 (CVE-2019-10197)
    • sdparm: version 1.10
    • sessreg: version 1.1.2
    • setxkbmap: version 1.3.2
    • sg3_utils: version 1.44
    • shadow: version 4.7
    • shared-mime-info: version 1.12
    • sqlite: version 3.29.0
    • sysvinit-scripts: version 2.1
    • sysvinit: version 2.96
    • talloc: version 2.3.0
    • tdb: version 1.4.2
    • tevent: version 0.10.1
    • ttyd: version 1.5.2
    • usbutils: version 012
    • util-linux: version 2.34
    • wget: version 1.20.3
    • wireguard: version 0.0.20190913
    • wsdd: version 20180618 build 2
    • xauth: version 1.1
    • xclock: version 1.0.9
    • xfsprogs: version 5.2.1
    • xkeyboard-config: version 2.27
    • xorg-server: version 1.20.5
    • xrandr: version 1.5.1
    • xterm: version 348
    • xwininfo: version 1.1.5
    • zstd: version 1.4.3

    Linux kernel:

    • version 5.3.6
    • default scheduler now mq-deadline
    • CONFIG_BINFMT_MISC: Kernel support for MISC binaries
    • CONFIG_DEBUG_FS: Debug Filesystem
    • CONFIG_HUGETLBFS: HugeTLB file system support
    • CONFIG_ICE: Intel(R) Ethernet Connection E800 Series Support
    • CONFIG_IGC: Intel(R) Ethernet Controller I225-LM/I225-V support
    • CONFIG_MLX5_CORE_IPOIB: Mellanox 5th generation network adapters (connectX series) IPoIB offloads support
    • CONFIG_SCSI_SMARTPQI: Microsemi PQI Driver
    • CONFIG_WIREGUARD: IP: WireGuard secure network tunnel
    • patch: fix_vega_reset (user request)
    • patch: increase BLK_MAX_REQUEST_COUNT from 16 to 32
    • oot: LimeTech md/unraid: version 2.9.10 (multi-stream support)
    • oot: Highpoint rsnvme: version v1.2.16_19_05_06
    • oot: Tehuti tn40xx: version
    • oot: omitted: Intel ixgbe [does not build] (using in-tree driver)
    • oot: omitted: Highpoint r750 [does not work]
    • oot: omitted: Highpoint rr3740a [does not build]


    • fix btrfs bug where converting from single to multiple pool did not balance metadata to raid1, and converting from multiple to single did not balance metadata back to single.
    • auto-mount hugetlbfs to support kernel huge pages
    • emhttpd: do not write /root/keyfile if encryption passphrase provided via webGUI
    • fstab: mount USB flash boot device with root-only access
    • nginx.conf: configure all nginx worker threads to run as 'root'.
    • start/stop WireGuard upon server start/shutdown
    • support forms-based authentication
    • shfs: support FUSE3 API changes; hard links report same st_ino; hard link support configurable
    • support disabling NetBIOS, and set Samba 'min server procotol' and 'min client protocol' to SMB2 if disabled
    • support WS-Discovery method
    • support mDNS local name resolution via avahi
    • extract OS upgrade directly to USB flash
    • webgui: Revamp Banner Warning System
    • webgui: Fix custom case png not surviving reboot
    • webgui: Enhanced display of network settings
    • webgui: Open banner system to 3rd party apps
    • webgui: Modified notify script to allow overriding email recipients in notification settings
    • webgui: Allow Safari to use websockets
    • webgui: Select case correction + replace MD1510 for AVS-10/4
    • webgui: Font, Icon and image cleanup
    • webgui: Added AFP deprecated notice
    • webgui: Changed config folder of TELEGRAM
    • webgui: Add share access to user edit
    • webgui: Added cache and disk type to shares page
    • webgui: Aligned management page layout
    • webgui: Added conditional UPnP setting on Management page
    • webgui: Support wireguard plugin in download.php
    • webgui: Added UPnP to access script (to support WireGuard plugin)
    • webgui: Made notify script compatible with 6.8 new security scheme
    • webgui: Fixed misalignment of absent disk on Main page
    • webgui: Update ArrayDevices.page help text
    • webgui: show warning on login page when browser cookies are disabled
    • webgui: Fixed docker container update state
    • webgui: Added VM XML files to diagnostics
    • webgui: Telegram notification agent: enable group chat IDs, update helper description
    • webgui: Integrate CAs Plugin Helper
    • webgui: Switch download routine to be PHP Curl
    • webgui: Change PluginHelpers download to be PHP Curl
    • webgui: dockerMan - Deprecate TemplateURL
    • webgui: Fixed: footer always on foreground
    • webgui: Plugin Helpers: Follow redirects on downloads
    • webgui: dockerMan: Redownload Icon if URL changes
    • webgui: If a page is loaded via https, prevent it from loading resources via http (ie, block mixed content)
    • webgui: Ensure spinner always ontop
    • webgui: Allow outside click to close popups
    • webgui: Use complete HTML documents in popups
    • webgui: Standardize on lang="en"
    • webgui: Added 'F1' key to toggle help text
    • webgui: Main page: consolidate spin up/down action and device status into one
    • webgui: support changed tunables on Disk Settings page

    Edited by limetech

    • Like 6
    • Thanks 4

    User Feedback

    Recommended Comments

    14 hours ago, ljm42 said:

    Settings -> Network Settings -> Network protocol -> IPv4 only


    EDIT - OK, I see this in my IPv4 system log once also:

    Oct 11 20:38:14 Tower ntpd[1876]: bind(19) AF_INET6 fe80::7462:deff:fe79:8567%12#123 flags 0x11 failed: Cannot assign requested address
    Oct 11 20:38:14 Tower ntpd[1876]: unable to create socket on br0 (3) for fe80::7462:deff:fe79:8567%12#123
    Oct 11 20:38:14 Tower ntpd[1876]: failed to init interface for address fe80::7462:deff:fe79:8567%12

    Is it causing a problem or just don't like seeing it in the log? 


    (Just trying to help triage ;) )


    Link to comment
    4 hours ago, limetech said:

    Seriously how big of an issue is this really?  What scripts are you storing on the flash?

    It's small. As you say, there are workarounds. I was thinking about the principle of least surprise, or "how many things will break with alt A vs. alt B.".

    For me its some logic for setting up /root/keyfile ; for others it might be something else. Anyway - minor annoyance at most, easy to resolve.


    Link to comment
    8 minutes ago, Darqfallen said:

    No I didn't.

    Don't worry. I don't see anything incriminating in there. What I do see is that sdb (a MyPassport drive - connected by USB?) is causing a few problems by not responding when it's expected to. Unplugging it might help. Other than that random restarts could be caused by overheating, power supply problems or bad hardware.

    Edited by John_M
    Link to comment
    1 hour ago, Darqfallen said:

    Having problems with the server just restarting for no reason that I can see. Random intervals, nothing in the syslog.

    Please open a separate bug report for this. thx

    Link to comment
    3 minutes ago, Darqfallen said:

    I unplugged it, server still randomly restarts.

    Have you checked that all fans are working.   Random restarts can happen if the CPU is overheating.    Other common causes are power supply and RAM issues.

    Link to comment

    Just installed 6.8-rc1. Holy cow was the load tiem for the array slower than normal (diags attached.)


    Wireguard is super slick and was very easy to setup, however, I'm not sure it's routing properly as I cannot get to local assets within my primary subnet, such as pihole and my unraid box. I'm using the "Remote Access to LAN" setting. 


    Will trouble shoot throughout the day as I get time.



    Link to comment
    2 minutes ago, itimpi said:

    Have you checked that all fans are working.   Random restarts can happen if the CPU is overheating.    Other common causes are power supply and RAM issues.

    Fans are working great, all fans reporting >5000rpm, ambient temp in the room is 25C, System Ambient is 30C, CPU1 36C, CPU2 40C. Didn't have this issue in 6.7.0, had a similar issue in 3.7.2. But didn't have the time to work on it so I had downgraded to 6.7.0 again.


    Link to comment
    16 minutes ago, eagle470 said:

    the load tiem for the array slower than normal

    What do you mean by "load time"?

    Link to comment

    Can you please fix the issue where the SAS drives are not spun down ?

    I have a Netapp DS4243 enclosure and it's consuming a lot of power, I would like to be able to spin down the drives, why is this not implemented in UnRAID yet ?

    Link to comment

    On my 2990wx my upgraded to the latest QEMU version and lost a ton of performance.. Trying to figure out what is going on but so far can't see anything wrong. Went from 400 points on CPUZ single threaded to barely 250..


    Also this happened on 6.7.2 as well but when I boot in UEFI mode it takes forever to ever get a webpage.. talking like nearly 5 minutes at times.

    Edited by Jerky_san
    Link to comment

    In 6.7.2 when powering on the system, I have the array set to auto start. It always took less than 30 seconds for the array to auto start, I had to wait for more than a minute after upgrading to 6.8-rc1 for everything to come online. It's not a HUGE issue per say, but I thought the change was worth noting. Let me know what trouble shooting steps you'd like to see.

    Link to comment
    22 minutes ago, eagle470 said:

    In 6.7.2 when powering on the system, I have the array set to auto start. It always took less than 30 seconds for the array to auto start, I had to wait for more than a minute after upgrading to 6.8-rc1 for everything to come online. It's not a HUGE issue per say, but I thought the change was worth noting. Let me know what trouble shooting steps you'd like to see.

    It wouldn't surprise me if the first start-up immediately after an upgrade takes a little longer. Are subsequent start-ups the same or faster?

    Link to comment
    1 hour ago, eagle470 said:

    In 6.7.2 when powering on the system, I have the array set to auto start. It always took less than 30 seconds for the array to auto start, I had to wait for more than a minute after upgrading to 6.8-rc1 for everything to come online. It's not a HUGE issue per say, but I thought the change was worth noting. Let me know what trouble shooting steps you'd like to see.


    36 minutes ago, John_M said:

    It wouldn't surprise me if the first start-up immediately after an upgrade takes a little longer.

    Assuming that the "landing" page for the WebGUI is the dashboard, it will indeed take a hair longer the very first reboot  (And if its not the landing page, then the first access to either the docker tab or the dashboard will take longer)


    This is due to a change in how the icons are now handled for docker.  (They must redownload on the very first access after the upgrade).  After that, there should be no noticeable difference in speed AFAIK

    Link to comment
    7 hours ago, Hawkie said:

    Can you please fix the issue where the SAS drives are not spun down ?

    I have a Netapp DS4243 enclosure and it's consuming a lot of power, I would like to be able to spin down the drives, why is this not implemented in UnRAID yet ?

    It's a fairly extensive code change for a relatively few number of users and the only SAS h/w I have laying around seems to have some issues - whenever I use 'sdparm' command it hangs.

    Link to comment
    1 hour ago, limetech said:

    Have to say, was skeptical, but what do you know, it did build against our kernel.  You'll have to test in next -rc.

    Should be linking to realtek's site for latest versions...


    Not some shady unofficial realtek site.




    GBE Ethernet LINUX driver r8168 for kernel up to 4.158.047 version 8.047


    Edited by Dazog
    Link to comment
    13 minutes ago, Dazog said:

    Should be linking to realtek's site for latest versions...

    Noted.  But I'm only adding r8125 driver which has no in-tree support.  The r8168 (oot) vs. r8169 (in-tree) has been nothing but nightmare over the years.

    Link to comment

    Crossposting from Reddit - upgrade failed for me :(


    Some additional info: I have all disks encrypted including the disk with my containers on it using Unassigned drives. This is X570 hardware, 3700X. 6.7.2 (NVIDIA) ran fine for me other than issues we had all seen. When I boot the RC I see it seem to hang as mounting drives but I can SSH in and see everything except my flash and my unassigned SSD. There are two other SSD I don't automount but I don't think they're causing issues and could pull for troubleshooting if requested. Working my way back to 6.7.2 right now but from the looks of it I can test versions freely without trashing things and am willing to do so. If you need more info holler as I'd love to help, not sure what logs are best or safe to post!


    Edit: am on 6.73 RC4 running fine (so far) now. Let me know how I can help!



    Just a heads up - this is NOT going well for my system so far. System is a TaiChi 3700X build. Docker isn't starting for some reason - NVIDIA build. I use encrypted disks but those seem to have mounted fine. Still troubleshooting and the logs look fine but no shares are showing despite mount showing a list and my being able to go into the shares via SSH. No containers are starting, VMs are down too. Screen says "mounting disks" and there it hangs. Am about to grab the standard version of this release and see if it does any better - bummer for me and I'll update as I learn more. u/sittingmongoose cross your fingers lol. Tempted to try a straight reboot first but I'll do the standard build and then try for NVIDIA. Hope I don't end up doing a parity!

    Edit: Doing a straight reboot first from the UI. Looks like it had to force shutdown - grr! coming up it says dirty and won't give the start button as it's waiting on Mounting disks :( Looks like I'll drop to the standard RC1 and if that fails back to 6.7.2 NVIDIA. Noticed it's not automounting my XFS encrypted drive for containers. Tried the Mount button and it's hanging. This disk isn't showing as mounted from SSH but the others are. Maybe this is the issue?

    Edit2: fun fact, cannot download another unRAID version to my USB while things won't mount. I may have to pull this from the rack. I'll try SFTP and hope I have a handy backup around :( SFTP gets me in at least but my share for Flash isn't showing dammit.

    Edit3: Normal unRAID upgrade tool had a backup version of 6.7.0 RC6 in it, guess it's been awhile since I used that :) Managed to boot it! For science sake I'll try the normal unRAID 6.8 RC1 and see if it works better using that tool. If not I at least have a working go-back and we'll know if this was NVIDIA or not.

    Edit4: nope same issue with normal 6.8 RC1 for me. It looks like my use of encrypted disks could be an issue? Possibly because I have an encrypted secondary disk using Unassigned devices - it's not clear to me but it looks like I can get back to 6.7.0 RC6. I will then use normal tool to get to 5.7.2 and then NVIDIA 6.7.2. Bummer, I really wanted this to work :)

    This is what I see when I try to manually mount my Lux encrypted container disk:

    Oct 14 01:28:59 Minion unassigned.devices: Adding disk '/dev/mapper/docker_vm'...

    Oct 14 01:28:59 Minion unassigned.devices: luksOpen: key file not found - using emcmd to mount.

    Edited by BLKMGK
    Link to comment
    9 minutes ago, BLKMGK said:

    Crossposting from Reddit - upgrade failed for me :(

    Please, you've been around here long enough to know:

    • Please post diagnstics.
    • Please put this in a separate bug report.
    Link to comment
    2 hours ago, limetech said:

    Have to say, was skeptical, but what do you know, it did build against our kernel.  You'll have to test in next -rc.

    Nice!I compiled driver by my self for 6.8.0-rc1 for now. It is a good news for us.

    • Like 1
    Link to comment

    This is now closed for further comments

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.