"SimpleFeatures" Plugin - Version 1.0.11



2848 posts in this topic Last Reply

Recommended Posts

Hi

 

The new Log feature looks nice! Some small points from me too:

 

1) I agree that the font used for the log is very small and with quite much whitespace. Must a "courier" type font be used? Could you use a sans-serif font instead?

2) I also agree that I would like to see an option to sort both ways

3) If you search for something with the search box, the only way to reset it is to clear the text in the box and "go" again. Maybe a clear icon?

4) Maybe an option to filter only Info messages as well?

5) What about an option to filter on process? Aka "show only emhttp" or "show only kernel"?

6) Is there a reason that the window is fixed in height and not using the whole screen?

 

Keep up the good work!

 

New version will have decreased the size of the padding, and increased font size. I'm using the <pre> tag, which means that each character is a set width. I have no control over the font used, but presume that log integrity and visibility is more important than a nicer looking font?

 

I'll look into dynamic window heights and additional filters at a later stage  :)

Link to post
  • Replies 2.8k
  • Created
  • Last Reply

Top Posters In This Topic

Hey all,

 

New version of the log viewer. Added a few features that were suggested here, and Bergware converted it to PLG format. This is the way all of the SimpleFeatures plugins will go - very shortly might I add!

 

  • Added log direction sorting

  • Added start/stop for log refreshing

  • CSS fixes to make log text bigger

  • Fixed download issues with log files with no content

  • Fixed issue with archived log file not removing itself

  • Fixed some gui continuity issues

 

Install Instructions:

Remove existing version

Copy PLG file to the folder: /boot/config/plugins

Either telnet in and type 'installplg /boot/config/plugins/simpleFeatures.log.viewer-1.0.4-noarch-1.plg' or restart your server

simpleFeatures.log.viewer-1.0.4-noarch-1.plg.zip

Screen_Shot_2012-06-14_at_10_12.29_PM.png.167dc502c946e1fa1dc6bcd24131b205.png

Link to post

Just tried your log plugin. Installed and loaded okay.  When I try and view any log it tells me "Log Empty".  I suspect this is because as part of the GO file I move the location to a new mount point with the following:

 

# Make the mount points I desire in my system and mount the devices

logger -t "GOSCRIPT"  "Make mount points and mount devices"

echo ">>>>> Make mount points and mount devices"

# first we make the mount points (directories we need) for unRaid. if they already exist command will not execute

mkdir /mnt/scratch

# now we mount what needs to be mounted

mount -w -t vfat /dev/disk/by-label/SCRATCH /mnt/scratch

sleep 5

 

# Move the syslogs to the scratch drive logs folder keeping all syslogs

logger -t "GOSCRIPT" "Move the syslog to the scratch/log folder"

echo ">>>>> Move the syslog to the scratch/logs folder"

logdir="/mnt/scratch/logs" # <-- modify this if you want the logs elsewhere.

mkdir -p $logdir

logfile="$logdir/syslog.`date +%Y-%m-%d_%H.%M.%S`.log"

cat /var/log/syslog > $logfile

echo "*.debug $logfile" >> /etc/syslog.conf

echo "*.*  -/dev/tty12" >> /etc/syslog.conf

/etc/rc.d/rc.syslog restart

sleep 5

 

I could just leave the log file where it normally is, but I prefer it the way I have it.

 

Could you add a Log Viewer setting to allow one to define where the Log Files are located?

Link to post

The sleep button on the mnain menu puts my system to sleep.  I then send it a WOL.  The system comes out of sleep.  The process I use to wake it up is to send a magic packet and then probe port 23 until a connection is accepted.

 

What I see is a system that is up but the web system is not available and the console is not working.  I am pretty sure I have the g option on the eth0 configuration.  How can I check that.

 

Any advice ideas appreciated or should I move the query to the Sleep thread?

Link to post

Possible Bug?: Filter syslog by clicking "warnings" , clear warnings...hangs for 45s - 3 minutes, then syslog is refreshed.

System: XP, Chrome Beta

Repeatable: Yes

 

Minor Format Bug: Overlay of the Activity Monitor Columns. See attached.

 

 

ScreenHunter_140_Jun._14_19_07.jpg.3d890b959bfcc828b0c49c5cbd08563a.jpg

Link to post

Possible Bug?: Filter syslog by clicking "warnings" , clear warnings...hangs for 45s - 3 minutes, then syslog is refreshed.

System: XP, Chrome Beta

Repeatable: Yes

 

Depends on how big the syslog file is - it can take a while to process it at the front end (think 20,000 lines, each line needs processing by the browser). I found Chrome was terrible at dealing with lots of entries, Firefox is extremely quick.

 

Next version will have a filter for an "Amount of lines" dropdown menu. This should speed up the front end (by limiting the results), but will be ignored as soon as you filter.

Link to post

Just tried installing the latest and got this

 

root@Tower:~# installplg /boot/config/plugins/simpleFeatures.log.viewer-1.0.5-noarch-1.plg                                                                                       
installing plugin: simpleFeatures.log.viewer-1.0.5-noarch-1                                                                                                                      
                                                                                                                                                                                 
Warning: simplexml_load_file(): /boot/config/plugins/simpleFeatures.log.viewer-1.0.5-noarch-1.plg:1: parser error : Start tag expected, '<' not found in /usr/local/sbin/installp
lg on line 13                                                                                                                                                                    
                                                                                                                                                                                 
Warning: simplexml_load_file(): PK in /usr/local/sbin/installplg on line 13                                                                                                      
                                                                                                                                                                                 
Warning: simplexml_load_file(): ^ in /usr/local/sbin/installplg on line 13                                                                                                       
xml parse error 

Link to post

speeding_ant

 

what is the difference between the plg and the tar ?

in the thread here you have a link to the PLG and on your google code page you have the tar ?

 

simpleFeatures.log.viewer-1.0.5-i486-1.tgz SimpleFeatures - Logs

 

was just thinking to keep all simple feature in the extra folder ... but if there is a reason not to ?

Link to post

Yep - all of the SimpleFeatures will be adopting the standard package format of unRAID 5.0. Eventually there will be a package manager that SimpleFeatures will support, therefore making it easy to enable/disable individual plugins.

 

PLG will download and install certain files required for the package to run.

Link to post

I just installed v 1.05 of the log viewer.  I set my go file not to move the log file destination.  In utilities I can see the syslog just fine by touching the syslog icon.  If I open the log viewer and try and look at sys log, I get not found.  I get the same not found message when I attempt to look at any log file with log viewer.

 

What am I missing?

Link to post

Yes.  I made the changes to the flash drive, stopped the array, and did a reboot.

 

Question: Is it necessary to remove the old tgz and png files from config/plugins/simplefeatures (which I did) or do you handle that when you install the new png files?

 

When I try to look at the sys log file with log viewer it states where it is looking as

var/log/sys log - 86kb

But the text area does not show the log but says " Log Empty"

 

[sOLVED] what I stated above happens with IE 9.  Chrome works correctly!

 

It would be very convenient, at least for me, if SimpleFeatures and it's plugins worked identically in all browsers. I have come across the following where IE 9 differs from Chrome. IE 9 running in compatibility mode:

 

Log viewer as stated above

 

The page header date wher title info and the green bar follows lime technology logotype and values flushed right

 

Status page shows all status, not just the selected one until you select one and then it shows the selected one only until that page is left. Looks like a page initialization issue

 

The health page shows each disk logo on a separate line

 

In either browser, when the Shares page is showing before selecting a share the free column shows 2.55 TB free for each share. After compute is pressed it seems to show correct value. All my drives are 2TB

 

Great job,  I really like what you have done. MAKES unRaid a professional looking system. Keep it up

 

Barry

 

P.S. I think you have convinced me to make Chrome my default browser

Link to post
  • Squid locked this topic
Guest
This topic is now closed to further replies.