unRAID 6 NerdPack - CLI tools (iftop, iotop, screen, kbd, etc.)


jonp

1580 posts in this topic Last Reply

Recommended Posts

1 hour ago, dmacias said:
1 hour ago, johnwhicker said:
BORG:
 
is this normal? Installed version 1.1.3
 
root@NAS-UNRAID-BKP:~# borg
Traceback (most recent call last):
  File "/usr/lib64/python3.8/site-packages/borg/archiver.py", line 41, in
    from .archive import Archive, ArchiveChecker, ArchiveRecreater, Statistics, is_special
  File "/usr/lib64/python3.8/site-packages/borg/archive.py", line 20, in
    from . import xattr
  File "/usr/lib64/python3.8/site-packages/borg/xattr.py", line 9, in
    from ctypes import CDLL, create_string_buffer, c_ssize_t, c_size_t, c_char_p, c_int, c_uint32, get_errno
  File "/usr/lib64/python3.8/ctypes/__init__.py", line 7, in
    from _ctypes import Union, Structure, Array
ImportError: libffi.so.7: cannot open shared object file: No such file or directory
 
 

On Unraid 6.8 you have to install libffi also. 6.9 you don't.

 

That did the trick. MANY thanks partner :)

Link to post
  • 2 weeks later...
  • Replies 1.6k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

From discussion that start in this thread, we decided to create a simple plugin that installs a set of additional command line tools onto your unRAID server.   WARNING:  These tools are for

Lol, are we going to petition the willy wonka company to change the name of their candy too?  I guess its not a big deal to change the name, I just have to laugh at the thought of someone honestly bei

I had the same issue... re-linking/aliasing to the existing libraries (libssl.so.1.1 and libcrypto.so.1.1) fixed the issue. A simple `ls -la` helped me figure out what libraries I had... root@Towe

Posted Images

  • 2 weeks later...

Hi dmacias,

 

Can you please add the newest (2.10) version of rmlint?  We're using it to get CoW convergence on our caches

 

Edit:  It looks like the other option for this, jdupes, was built without btrfs support.  For those who need it, can you please enable that flag in the makefile and republish?

 

I'm not sure if it's in the works to configure where Nerdpack is pointed, but if it is, I'd be willing to open my own packages to lend a hand.  I imagine most others feel similarly.

Edited by thenonsense
Added jdupes
Link to post

We have tcl package, but no option for tcllib, often accompanying tcl runtimes.
Any possibility to get it added in?

https://slackware.pkgs.org/14.2/slackonly-x86_64/tcllib-1.20-x86_64-1_slonly.txz.html

Quote

Tcllib is a collection of utility modules for Tcl. These modules provide a wide variety of functionality, from implementations of standard data structures to implementations of common networking protocols. The intent is to collect commonly used function into a single library, which users can rely on to be available and stable.

 

Edited by tuxbass
Link to post



@dmaciasFor some reason I'm still showing 2019.12.31 and "up-to-date" after Removing and re-installing from Community Apps. When looking at the list, I don't see Neofetch which you say you've added on my behalf.
 
Ideas to fix?


That's the latest version for the plugin. The packages are updated independently. There were actually 2 neofetch packages. I'm guessing your on an earlier version of unraid than 6.8 or 6.9
Link to post
2 minutes ago, dmacias said:


That's the latest version for the plugin. The packages are updated independently. There were actually 2 neofetch packages. I'm guessing your on an earlier version of unraid than 6.8 or 6.9

 

6.7.2, yeah. So how do I get Neofetch to show in the Nerd Pack list?

Link to post
22 minutes ago, dmacias said:
23 minutes ago, ksignorini said:
6.7.2, yeah. So how do I get Neofetch to show in the Nerd Pack list?

I'll add it but may not work

So I upgraded UnRAID to 6.8.3 and rebooted. I now see neofetch in the list. I chose to install it and hit Apply. It shows it being installed in the scrolling log. When it returns to the Nerd Pack setting page, it says uninstalled.

 

I've never had this happen with a Nerd Pack item before.

 

Ideas?

Link to post
So I upgraded UnRAID to 6.8.3 and rebooted. I now see neofetch in the list. I chose to install it and hit Apply. It shows it being installed in the scrolling log. When it returns to the Nerd Pack setting page, it says uninstalled.
 
I've never had this happen with a Nerd Pack item before.
 
Ideas?
Yes. It's the package name. Renamed it. Click check for updates and install again
Link to post
8 minutes ago, dmacias said:
22 minutes ago, ksignorini said:
So I upgraded UnRAID to 6.8.3 and rebooted. I now see neofetch in the list. I chose to install it and hit Apply. It shows it being installed in the scrolling log. When it returns to the Nerd Pack setting page, it says uninstalled.
 
I've never had this happen with a Nerd Pack item before.
 
Ideas?

Yes. It's the package name. Renamed it. Click check for updates and install again

Yes! Thank you!

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.