[Support] binhex - DelugeVPN


8722 posts in this topic Last Reply

Recommended Posts

  • Replies 8.7k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

OK guys, multi remote endpoint support is now in for this image please pull down the new image (this change will be rolled out to all my vpn images shortly).   What this means is that the im

There has been an issue raised on GitHub related to tracker announce request IP leakage under certain circumstances, after careful review of iptables i have tightened up the rules to prevent this. A n

I wanted to summarize how I got Mullvad working with DelugeVPN as I had to piece together several "solutions" from different comments in this thread and there was some incorrect info; likely old.

Posted Images

13 hours ago, jonathanm said:

Yes I did get a chance to review the port forwarding information there which does state port forwarding is supported. I get the impression all ports must be manually forwarded. I am not sure which port needs to be forwarded though?

Do I need to forward all container ports? or the ports shown as incoming and outgoing under preferences > network from within deluge?

Link to post
10 minutes ago, ozzyc said:

Yes I did get a chance to review the port forwarding information there which does state port forwarding is supported. I get the impression all ports must be manually forwarded. I am not sure which port needs to be forwarded though?

Do I need to forward all container ports? or the ports shown as incoming and outgoing under preferences > network from within deluge?

None of the above. All port forwarding has to be done inside the VPN. You must figure out how to get a port open using the torguard settings, then set that port in deluge's settings. Nothing should be forwarded from the container.

Link to post
On 9/30/2019 at 1:56 AM, binhex said:

possible the old certificate from your vpn provider was using a weak cipher which is no longer permitted with the later version of openvpn, thus when you updated you couldnt connect, that would be my guess.

Windscribe confirmed that their implementation of OpenVPN is the AES-256-CBC cipher. Is this the issue?

Link to post
39 minutes ago, BBLV said:

Windscribe confirmed that their implementation of OpenVPN is the AES-256-CBC cipher. Is this the issue?

no, i use that cipher with PIA and have done for several months.

Link to post

OK so I have an update to the issue I've been having...

 

To be clear as well, the VPN itself works fine, just privoxy/web connections are where I'm having problems.

 

So within the container itself, I can't curl properly to most sites. Let me explain, I can curl the url google.com, which responds with a 301. I can't however, curl www.google.com (different IP). I can't curl example.com. I can curl unraid.net (responds with 301). I can't curl https://unraid.net... It gets as far as trying to establish the TLS handshake and will eventually timeout.

 

So that's weird right? I've checked the iptables, these requests are not being blocked by those rules. Interestingly, if I remove the rules, I can make any request over the eth0 interface. So only when trying to connect over the vpn tunnel will it not work. I'm running out of ideas :$

 

 

EDIT:

SO I've fixed the problem. If I use TCP openvpn configs, the problem disappears... That's really odd and I can't explain it. I wonder if my ISP or router is doing something funky with my packets. I will have to investigate, but maybe this will be useful to someone else.

 

EDIT 2:

After further investigations, it does appear to be a problem somewhere in my ISPs infrastructure. If I connect to the VPN using UDP from within my network using on my phone, it doesn't work; if I connect through TCP it does. UDP works on 4G though, so problem either with router or ISP. Hey-ho, at least I can get it to work.

Edited by mrfrogydog
Link to post

I've been runing binhex-delugevpn for years, and it has been working flawlessly.  Just recently, I notice that once the file is downloaded, it is no longer moved.  In fact, I can't find the file at all.  It's no longer in the complete or incomplete folders (like it use to be).  Doing a file search of the entire raid can't seem to find it.  I've tried redownloading multiple small files as a test, and they all exhibit the same problem.  Download is completed but nowhere to be found.  HELP!

Link to post
7 hours ago, vdtruong said:

I've been runing binhex-delugevpn for years, and it has been working flawlessly.  Just recently, I notice that once the file is downloaded, it is no longer moved.  In fact, I can't find the file at all.  It's no longer in the complete or incomplete folders (like it use to be).  Doing a file search of the entire raid can't seem to find it.  I've tried redownloading multiple small files as a test, and they all exhibit the same problem.  Download is completed but nowhere to be found.  HELP!

Reckon it is within the docker image itself. Check in the docker console if it is in /home/nobody/downloads/ or something to that affect. Make sure you know what folder you are passing to the docker image.

Link to post
1 hour ago, mrfrogydog said:

Reckon it is within the docker image itself. Check in the docker console if it is in /home/nobody/downloads/ or something to that affect. Make sure you know what folder you are passing to the docker image.

If so, the files will vanish if you stop/restart the image.

Link to post
6 hours ago, mrfrogydog said:

Reckon it is within the docker image itself. Check in the docker console if it is in /home/nobody/downloads/ or something to that affect. Make sure you know what folder you are passing to the docker image.

Aside from upgrading it when it becomes available, I haven't touched any of the settings.  It has been working flawlessly for years. 

 

That is indeed the folder that it is supposed to be downloaded to.  I've tried changing it to something else as an experiment, and it kills the download completely.  So I changed it back to /home/nobody/downloads.  Again it completes the download, but the file is MIA.

 

EDIT: Fixed

Edited by vdtruong
Link to post

Firstly, Binhex thank you for all your hard work! 

 

I'm attempting to set this up on a fresh install of Ubuntu Server 18.04LTS. I am using Torguard as my VPN provider.

 

I have the latest delugevpn image up and running, connecting successfully to a Torguard server. I can access the WebUI and I have connected to a thin client session with Deluge 2.0.3.

 

I have forwarded the ports for the particular server I'm connecting to in the Torguard client portal, and the correct ports appear to be open when checked on https://www.portcheckers.com/ for that server.

 

In Deluge webui I've changed the incoming port to one of the forwarded ports (58946). The thin client identifies that this is the Active Port.

 

I've installed the itconfig plugin and disabled the options as recommended in the FAQ.

 

I think a port issue still exists. My download speeds are ~10% of my theoretical max and the Deluge thin client identifies a 'port issue' in the bottom right hand corner of the window.

 

Has anyone managed to get this working successfully with Torguard? What am I missing? I've been beating my head against the wall for a couple of days trying to find the solution to this, so any help is appreciated!

 

Logs: 

Docker settings - https://pastebin.com/gujS2HTQ

Supervisord - https://pastebin.com/ptdCphtz

Deluge logs - https://pastebin.com/nEH1STcw

Link to post
8 hours ago, yeahokay said:

In Deluge webui I've changed the incoming port to one of the forwarded ports (58946)

58946 is only supposed to be used when you have the vpn switched off, when the vpn is enabled you HAVE to use the vpn provider assigned port, set deluge to use that port for incoming connections and you should be good.

 

see q14. for clarification:-

https://github.com/binhex/documentation/blob/master/docker/faq/vpn.md

Edited by binhex
Link to post
9 hours ago, binhex said:

58946 is only supposed to be used when you have the vpn switched off, when the vpn is enabled you HAVE to use the vpn provider assigned port, set deluge to use that port for incoming connections and you should be good.

 

see q14. for clarification:-

https://github.com/binhex/documentation/blob/master/docker/faq/vpn.md

I guess I'm confused.. what port # and where am I supposed to set it in the container? I still haven't been able to connect to the webui since updating to Deluge 2.0, so I'm troubleshooting everything I can think of.

 

Here is a screenshot of my port forward creation for Windscribe. I can pick my own internal IP, should this not be 58946? That's what I used prior to Deluge 2.0 and it worked, but not after updating to 2.0. Nothing else was changed and my webui is still broken.

windscribe port forward.jpg

Link to post
8 hours ago, BBLV said:

Here is a screenshot of my port forward creation for Windscribe. I can pick my own internal IP, should this not be 58946?

err 58946 is not an ip address, thats a port, and no you cant pick your own port you need to use the port that is assigned to you.

 

the screenshot you posted shows port number 42059, assuming thats a static port assignment and doesnt change (right?) then go to deluge web ui, go to settings and set the incoming port to 42059, you do not and should not set any port forwarding on your home router/firewall.

Link to post
41 minutes ago, binhex said:

err 58946 is not an ip address, thats a port, and no you cant pick your own port you need to use the port that is assigned to you.

 

the screenshot you posted shows port number 42059, assuming thats a static port assignment and doesnt change (right?) then go to deluge web ui, go to settings and set the incoming port to 42059, you do not and should not set any port forwarding on your home router/firewall.

Port not IP of course. I can select my own internal port when creating the port forward via windscribe (per that screenshot), but I cannot access the Deluge webui so no way to change that within the Deluge settings...

Link to post
38 minutes ago, BBLV said:

Port not IP of course. I can select my own internal port when creating the port forward via windscribe (per that screenshot), but I cannot access the Deluge webui so no way to change that within the Deluge settings...

assuming this is still the issue (taken from your previous post):-

 

Sat Sep 28 15:18:49 2019 AUTH: Received control message: AUTH_FAILED

then its due to incorrect username and/or password, double check your vpn_user and vpn_pass are correct, do NOT copy and paste the details, type them in manually, as you can sometimes get non ascii characters or whitespace in there.

Link to post
1 hour ago, binhex said:

assuming this is still the issue (taken from your previous post):-

 


Sat Sep 28 15:18:49 2019 AUTH: Received control message: AUTH_FAILED

then its due to incorrect username and/or password, double check your vpn_user and vpn_pass are correct, do NOT copy and paste the details, type them in manually, as you can sometimes get non ascii characters or whitespace in there.

Manually re-entered my VPN's user/pass and no change. Still can't connect to webui.

Link to post
1 minute ago, BBLV said:

My VPN-provided username has a hyphen in it. Could that be causing an issue with Deluge 2.0?

certain characters can cause an issue, you SHOULD be ok with hyphens, but i dont know for sure, the safe characters are:-

 

0-9, a-z, A-Z

does your password contain any characters as well that might cause issues?

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.