[Support] binhex - DelugeVPN


8745 posts in this topic Last Reply

Recommended Posts

Alright, did that and here it is: 
supervisord.log

Nothing wing with that, that's a successful start, so you can't connect to he webui? What URL are you attempting to connect on?

Sent from my SM-G900F using Tapatalk

Link to post
  • Replies 8.7k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

OK guys, multi remote endpoint support is now in for this image please pull down the new image (this change will be rolled out to all my vpn images shortly).   What this means is that the im

There has been an issue raised on GitHub related to tracker announce request IP leakage under certain circumstances, after careful review of iptables i have tightened up the rules to prevent this. A n

I wanted to summarize how I got Mullvad working with DelugeVPN as I had to piece together several "solutions" from different comments in this thread and there was some incorrect info; likely old.

Posted Images

I tried http://<host ip>:8112 and http://<host ip>:8118.

 

I do have to notice that it's a dedicated server directly exposed to the internet. For this reason I changed the IP address in the log. Not sure if that makes any difference.

Link to post
5 hours ago, Rourke said:

I tried http://<host ip>:8112 and http://<host ip>:8118.

 

I do have to notice that it's a dedicated server directly exposed to the internet. For this reason I changed the IP address in the log. Not sure if that makes any difference.

are you sure the dedicated server allows incoming connections?. by  default i can well imagine a internet connected host would not allow anything incoming.

 

what you could try if the host has a gui is remote onto the box, fire up the local browser and try connecting to the deluge webui using that, if that works then you know your issue is purely connectivity inbound for the dedicated server ,f it has no gui then try executing this directly on the dedicated server via ssh:-

 

curl http://localhost:8112

 

Link to post
7 hours ago, binhex said:

are you sure the dedicated server allows incoming connections?. by  default i can well imagine a internet connected host would not allow anything incoming.

Honestly I don't know, but other docker containers like sonarr or Plex run just fine.

 

7 hours ago, binhex said:

what you could try if the host has a gui is remote onto the box, fire up the local browser and try connecting to the deluge webui using that, if that works then you know your issue is purely connectivity inbound for the dedicated server ,f it has no gui then try executing this directly on the dedicated server via ssh:-

This is interesting. My server is stored in a data center and I'm running it headless. Running your curl command returns the Deluge Web UI HTML which suggests it's indeed something purely connectivity inbound.

 

However just like other containers the ports should be open:

                  Name                                       Command                                      State                                       Ports
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------
deluge                                      /usr/bin/tini -- /bin/bash ...              Up                                          0.0.0.0:44690->44690/tcp,
                                                                                                                                    0.0.0.0:58846->58846/tcp,
                                                                                                                                    0.0.0.0:58946->58946/tcp, 58946/udp,
                                                                                                                                    0.0.0.0:8112->8112/tcp,
                                                                                                                                    0.0.0.0:8118->8118/tcp
jackett                                     /init                                       Up                                          0.0.0.0:9117->9117/tcp
ombi                                        /init                                       Up                                          0.0.0.0:3579->3579/tcp
plex                                        /init                                       Up                                          0.0.0.0:1900->1900/udp,
                                                                                                                                    0.0.0.0:3005->3005/tcp,
                                                                                                                                    0.0.0.0:32400->32400/tcp,
                                                                                                                                    0.0.0.0:32410->32410/udp,
                                                                                                                                    0.0.0.0:32412->32412/udp,
                                                                                                                                    0.0.0.0:32413->32413/udp,
                                                                                                                                    0.0.0.0:32414->32414/udp,
                                                                                                                                    0.0.0.0:32469->32469/tcp,
                                                                                                                                    0.0.0.0:8324->8324/tcp
plexpy                                      /init                                       Up                                          0.0.0.0:8181->8181/tcp
radarr                                      /init                                       Up                                          0.0.0.0:7878->7878/tcp
sonarr                                      /init                                       Up                                          0.0.0.0:8989->8989/tcp

 

Link to post

Do you have a guide on configuring privoxy (or even how to get to the webadmin page)?

 

I have it working ok, but think it's blocking certain sites / content from applications using it as a proxy to the vpn.

 

Thanks

 

Edit: Ok, I sort of know where I'm looking: config.privoxy.org lets me identify which rules are being triggered.

 

I've tried adding it to the trusted site site (trust file), using ~thetvdb.com, but it's still blocked.

I think I need to do something in the user.action file, but a little lost as to what/where!

 

Edit2: Right, so using the trust file didn't work because you have to enable it - but turns out if you use the trust file, *only* those sites are allowed.

 

Instead, i edited the config file, and removed the default actions file. Probably not the best idea, but it'll do until I work out how to properly whitelist sites!

Edited by extrobe
Link to post

Tapatalk was messing with me.  I don't see anything wrong in the logs before openvpn starts complaining of local UDP.  Is it possible your VPN provider issued updated .ovpn files?

 

Are you running the docker in bridge mode?

Link to post
3 hours ago, Gog said:
Tapatalk was messing with me.  I don't see anything wrong in the logs before openvpn starts complaining of local UDP.  Is it possible your VPN provider issued updated .ovpn files?

 

Are you running the docker in bridge mode?

I checked .ovpn, updated everything accordingly, regenerated key, etc. I actually run binhex-sabnzbdvpn with the sane VPN settings just fine. Can't say for sure, but looks like it started after the last delugevpn update. @binhex, any thoughts?

 

Sent from my LEX727 using Tapatalk

 

 

 

Edited by izarkhin
Link to post
1 hour ago, izarkhin said:

Mystery continues.... I removed the docker and re-installed from scratch. Now I'm getting TLS handshake error. I have a binhex-sabnzbdvpn docker running with EXACT SAME SETTINGS and it handshakes just fine! Updated log is attached. Please help!

supervisord.log

it looks like the certificate used by your vpn provider is too weak for openssl 1.1.x, extract from your last log:-

 

Quote

Sun May  7 10:17:52 2017 VERIFY ERROR: depth=0, error=CA signature digest algorithm too weak: C=US, ST=NY, L=New York, O=vpnsecure.me, OU=Office, CN=vpnsecure-server, emailAddress=support@vpnsecure.me
Sun May  7 10:17:52 2017 OpenSSL: error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed

 

this is probably due to the switch in using the newer openssl version, which removes some of the weaker known vulnerable ciphers, my advise is to contact your vpn provider and ask them about a certificate that is openssl 1.1.x compatible, openssl 1.1.x is what everybody is moving to due to vulnerabilities, there will be no roll back im afraid.

 

another option is move to a vpn provider that does provide correct stronger ciphers, i know PIA works out of the box, and im pretty confident AirVPN also has full support for the stronger cipher types too.

Link to post
44 minutes ago, binhex said:

it looks like the certificate used by your vpn provider is too weak for openssl 1.1.x, extract from your last log:-

 

 

this is probably due to the switch in using the newer openssl version, which removes some of the weaker known vulnerable ciphers, my advise is to contact your vpn provider and ask them about a certificate that is openssl 1.1.x compatible, openssl 1.1.x is what everybody is moving to due to vulnerabilities, there will be no roll back im afraid.

 

another option is move to a vpn provider that does provide correct stronger ciphers, i know PIA works out of the box, and im pretty confident AirVPN also has full support for the stronger cipher types too.

@binhex, how come it works fine with binhex-sabnzbdvpn docker? Do you use a lower openssl version there? Ah, nevermind! I see that binhex-sabnzbdvpn docker has OpenSSL 1.0.2j vs. OpenSSL 1.1.0e here.

Edited by izarkhin
Link to post
15 minutes ago, izarkhin said:

@binhex, how come it works fine with binhex-sabnzbdvpn docker? Do you use a lower openssl version there? Ah, nevermind! I see that binhex-sabnzbdvpn docker has OpenSSL 1.0.2j vs. OpenSSL 1.1.0e here.

sabnzbdvpn, will also be rebuilt shortly, so expect that also to stop working for you, and yep as you have correctly identified this is using the older openssl version 1.0.x

Link to post

I'm attempting to follow the instructions outlined in the video tutorial here.

 

I'm running into problems at about the 5 minute mark.

 

After I fill out all the information in the "Update Container" section of unRAID, I click on "Create" at the bottom. Everything seems to complete successfully, however, when I go to the "Docker" section of unRAID, I do not see the binhex-delugeVPN as an option as should be.

 

I'm fairly new to this and a little over my head.

 

Would anyone be able to assist?

 

Below is the command result from the docker installation (UN/PW removed obviously).

 

Command: root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="binhex-delugevpn" --net="bridge" --privileged="true" -e VPN_ENABLED="yes" -e VPN_USER="xxxxxxxxx" -e VPN_PASS="xxxxxxxxx" -e VPN_REMOTE="ca-toronto.privateinternetaccess.com" -e VPN_PORT="1198" -e VPN_PROTOCOL="udp" -e VPN_DEVICE_TYPE="tun" -e VPN_PROV="pia" -e VPN_OPTIONS="000" -e STRONG_CERTS="no|yes" -e ENABLE_PRIVOXY="no|yes" -e LAN_NETWORK="192.168.1.0/24" -e NAME_SERVERS="8.8.8.8,37.235.1.174,8.8.4.4,37.235.1.177" -e DEBUG="false|true" -e UMASK="000" -e PUID="99" -e PGID="100" -e TZ="America/New_York" -p 8112:8112/tcp -p 58846:58846/tcp -p 58946:58946/tcp -p 58946:58946/udp -p 8118:8118/tcp -v "/mnt/cache/appdata/config":"/config":rw -v "/mnt/user/Downloads/":"/data":rw binhex/arch-delugevpn

yes: invalid option -- 'e'
Try 'yes --help' for more information.
yes: invalid option -- 'e'
Try 'yes --help' for more information.
docker: "run" requires a minimum of 1 argument.
See '/usr/bin/docker run --help'.

Usage: docker run [OPTIONS] IMAGE [COMMAND] [ARG...]

Run a command in a new container

The command finished successfully!

Link to post

Hi there
Spent the last few hours trying to get this to work. Eventually got there however I noticed something odd along the way. I narrowed down the error to a Vpn auth error. Upon checking the credentials file I noticed my password was wrong. It had cut the part after the ! off. There was also a $ directly after the ! I changed my password removing both symbols and now it works fine. Not sure which character was the problem. Didn't test it but it works without them.

Sent from my SM-G920F using Tapatalk

Link to post
Just now, cheesemarathon said:

Hi there
Spent the last few hours trying to get this to work. Eventually got there however I noticed something odd along the way. I narrowed down the error to a Vpn auth error. Upon checking the credentials file I noticed my password was wrong. It had cut the part after the ! off. There was also a $ directly after the ! I changed my password removing both symbols and now it works fine. Not sure which character was the problem. Didn't test it but it works without them.

Sent from my SM-G920F using Tapatalk
 

yes special chars for username and/or password is a problem for openvpn when passing through via credentials file, i did at one time try to escape the special characters but that failed miserably, so no way around it as far as i know.

Link to post
yes special chars for username and/or password is a problem for openvpn when passing through via credentials file, i did at one time try to escape the special characters but that failed miserably, so no way around it as far as i know.

Not a problem, works great now that I've found the problem. Maybe stick it in the read me on github? Would have saved me a couple hours.

Sent from my SM-G920F using Tapatalk

Link to post

DelugeVPN seems to have stopped working. I think the latest update did it. Running unRAID v6.2.4

Have checked the vpn address and user/pass so it's not them

 

I noticed when nothing was downloading, restarted the docker and now Chrome says "refuses to connect"

Link to post
2 hours ago, richardsim7 said:

DelugeVPN seems to have stopped working. I think the latest update did it. Running unRAID v6.2.4

Have checked the vpn address and user/pass so it's not them

 

I noticed when nothing was downloading, restarted the docker and now Chrome says "refuses to connect"

my sig, click on help link

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.