[Support] binhex - Plex Pass


1107 posts in this topic Last Reply

Recommended Posts

  • Replies 1.1k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

its currently queued to build, you should see a new image available in the next hour or two that should get things back on track.  

just change your repository to "binhex/arch-plexpass:1.12.0.4829-1-01" without the quotes. you can do this with any repositories, just add a colon and then the specific tag you want to use. 

Be patient young Jedi everything comes to those who wait, it's automated, as soon as it can be built it will be built. Sent from my EML-L29 using Tapatalk

Posted Images

  • 1 month later...

Running 6.2.0-beta23 and updating to the latest version of this plugin, it no longer starts with the following error:

 

usermod: no changes
[info] Env var PUID defined as 99
[info] Env var PGID defined as 100
[info] Permissions already set for /config
chown: cannot access '/var/lib/plex': No such file or directory

 

I SSH'd into my server and confirmed that '/var/lib/plex' doesn't exist, but why is it looking for that folder?

 

Edit: Removed the container, deleted the /plex folder from appdata & reinstalled it - same error.

Edit2: I removed it again & installed the linuxserver plex docker and it works. :/

Link to post

Same issue reported in my logs  :(

 

I hope our pal binhex can take a look see and push out a bug fix update.

 

this should now be fixed (untested, im not a plex pass user), please pull down the latest image and let me know if it fixes the issue.

Link to post

Same issue reported in my logs  :(

 

I hope our pal binhex can take a look see and push out a bug fix update.

 

this should now be fixed (untested, im not a plex pass user), please pull down the latest image and let me know if it fixes the issue.

 

Thanks Binhex, so far it's working for me.  I'm a bit confused however due to all the containers I use from you since updating to the latest beta are showing "update ready" - even after updating.

Link to post

any reason i cant get the docket to show that it needs an update?

 

I can tell from git-hub that there is a new version out...

 

root@Tower:~# docker pull binhex/arch-plexpass

latest: Pulling from binhex/arch-plexpass

 

ef9dce18c134: Pull complete

4d65b3715530: Pull complete

d8ae627c19db: Pull complete

f9351fdd03b0: Pull complete

1dc4c896bee1: Pull complete

ca7ab442b0d9: Download complete

09c7e884c149: Download complete

c6796f6667c7: Download complete

ca7ab442b0d9: Pull complete

09c7e884c149: Pull complete

c6796f6667c7: Pull complete

1a1d7c58a991: Pull complete

3dee3dbe29f0: Pull complete

10d960fa795b: Download complete

042d939f522a: Download complete

bbe50559617a: Pull complete

3bfb0b145fdb: Pull complete

62952e5e2d02: Pull complete

10d960fa795b: Pull complete

042d939f522a: Pull complete

0ac37ebe7edc: Pull complete

6b39352c1c21: Pull complete

7c969363fd2d: Pull complete

2a06449ad561: Pull complete

ee4ed4d2b4a5: Pull complete

28b8bbf7aa97: Pull complete

9da5c53ea8c6: Pull complete

 

Digest: sha256:3d8cb034bbd798e66ad8764f845c1b00bd2a5fd16b42b82f2185388835aaf15c

Status: Downloaded newer image for binhex/arch-plexpass:latest

root@Tower:~#

 

 

but in the web-ui (unraid) it always says up to date?

 

plex also states it needs an update. Thanks ???

Link to post
  • 2 weeks later...

Any idea when it will show the version 1 update they released a few days ago?

 

its already there, the update not showing is an unraid bug, left click, edit, dont change anything, click save, this forces the update

Link to post

I tried to install this docker, I was using needos previously but noticed your states plex pass so I tried it. Now it doesn't see my media anymore saying that plex is unreachable, I changed /media to /mnt/user and pointed that to /mnt/user but still no joy I have also deleted the container and images and tried from scratch and still won't see my media. Any idea what might have gone wrong.

Link to post

I tried to install this docker, I was using needos previously but noticed your states plex pass so I tried it. Now it doesn't see my media anymore saying that plex is unreachable, I changed /media to /mnt/user and pointed that to /mnt/user but still no joy I have also deleted the container and images and tried from scratch and still won't see my media. Any idea what might have gone wrong.

 

ok so the location of the metadata will most probably be different to needo's docker, so unless your REALLY keen on keeping your metadata then i would probably go from scratch and let it rebuild all the metadata. so to achieve this either create a new /config folder on the host or delete everything in the /config folder (obviously with all plex dockers stopped). once you have done this then start the docker container and on your lan (not remotely) open your web browser and go to http://<your unraid ip address>:32400/web

 

once you got this ui showing start adding in your media, this bit worries me a little:-

 

I changed /media to /mnt/user and pointed that to /mnt/user

 

so this is a fundamental understanding of docker volumes that you need to have clear (please forgive me if you do know how this works), basically its split into two, the unraid host side, as in /mnt/user/blahblah and the container side, which will look more like /media or /config or /data (but can be any name), so for example:-

 

/mnt/user:/media = this means that a container folder off the root file system INSIDE the container called "media" will be "mapped" to /mnt/user fuser on the unraid host, its that simple, so if you were able to do a directory listing INSIDE the container of /media it would be identical to doing the same directory listing on /mnt/user.

 

so now that is straight once you have /media as above you can then tell plex to start indexing media from /media/<name of sub folder> e.g. /media/movies

 

i hope this helps.

Link to post

Helo binhex

 

Im using your default Plex container and I recently bought my plex pass and so Id like to swap the container. Is there any way I can do that without loosing the library?

 

Thanks+

 

from memory the folder structure SHOULD be the same so it should simply be a case of stopping plex, configuring plex pass the same way as plex, and then starting it, but if i were you if your metadata is precious to you then i would personally copy the entire /config/plex folder, call it plex-backup or something and then you can always get back to a running plex instance if things go bad.

 

backing up /config folder for ALL dockers IMHO is a must, dont worry about the docker.img file its the loss of config that will be a kicker.

Link to post

I tried to install this docker, I was using needos previously but noticed your states plex pass so I tried it. Now it doesn't see my media anymore saying that plex is unreachable, I changed /media to /mnt/user and pointed that to /mnt/user but still no joy I have also deleted the container and images and tried from scratch and still won't see my media. Any idea what might have gone wrong.

 

ok so the location of the metadata will most probably be different to needo's docker, so unless your REALLY keen on keeping your metadata then i would probably go from scratch and let it rebuild all the metadata. so to achieve this either create a new /config folder on the host or delete everything in the /config folder (obviously with all plex dockers stopped). once you have done this then start the docker container and on your lan (not remotely) open your web browser and go to http://<your unraid ip address>:32400/web

 

once you got this ui showing start adding in your media, this bit worries me a little:-

 

I changed /media to /mnt/user and pointed that to /mnt/user

 

so this is a fundamental understanding of docker volumes that you need to have clear (please forgive me if you do know how this works), basically its split into two, the unraid host side, as in /mnt/user/blahblah and the container side, which will look more like /media or /config or /data (but can be any name), so for example:-

 

/mnt/user:/media = this means that a container folder off the root file system INSIDE the container called "media" will be "mapped" to /mnt/user fuser on the unraid host, its that simple, so if you were able to do a directory listing INSIDE the container of /media it would be identical to doing the same directory listing on /mnt/user.

 

so now that is straight once you have /media as above you can then tell plex to start indexing media from /media/<name of sub folder> e.g. /media/movies

 

i hope this helps.

 

Thanks for enlightening me, I did not understand and you explained it well and the fogs cleared more. I'm a suing the colon is a typo ? "/mnt/user:/media"  and I should enter that without colon on the left side and right side map it to /mnt/user / ? If my understanding is correct.

 

As for not doing it remotley, I access via vpn so it's like being there as I access it via the up address over vpn ?

 

Thanks for your docker.

 

Link to post

Thanks for enlightening me, I did not understand and you explained it well and the fogs cleared more. I'm a suing the colon is a typo ? "/mnt/user:/media"  and I should enter that without colon on the left side and right side map it to /mnt/user / ? If my understanding is correct.

 

As for not doing it remotley, I access via vpn so it's like being there as I access it via the up address over vpn ?

 

Thanks for your docker.

 

nope no typo, the colon is in there as that is for the format when specifying volume mappings via the command line for docker, but in your case your using the slightly more friendly unraid docker ui, so yes in your case just specify the host side as /mnt/user (or a more specific path if you want) and set the container side to be /media.

Link to post

Then it is how it was set and is now...container set /media and path to host is /mnt/user/ and I have also tried setting that as /mnt/user/movies

 

I'm still getting the plex gui but it's not seeing anything and no way of adding. Accessing via vpn is by using ip address as you stated previously so I assume that's the same as being within the local network ?. I'm not concerned with having to completely rebuild metadata but more concerned of upsetting any of my other dockers which work all ok with the same path settings. Scratching my head a bit.

Link to post

Well turned out that doing it via VPN is not like being in the house, however, teamviewer let me do it remotley persay and all is working now...im going to buy you a beer...its not a lot and will only buy me one in the UK but im sure youll get a couple there. thanks again buddy.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.