Jump to content
gfjardim

Preclear plugin

2816 posts in this topic Last Reply

Recommended Posts

I just ran and completed running PreClear with this plugin and it is great.

My only question is where do I find the Smart History that is associated with each disk that I ran the Preclear on ?

I do find a Smart Hstory (Printed in Red) in the System Log.

If I go to the Smart History Button I get the following message.

 

"Sorry: cannot run smarthistory. "

"The /boot/smarthistory/smarthistory.php file does not exist."

flash/preclear_reports/

That's where all the preclear reports are on mine anyway.

Share this post


Link to post

Thanks!  Saved lots of command stuff.  Just install, push a button and watch the progress! :)  Love it!

Share this post


Link to post

Trying to use this on a new 4TB drive and nothing happens.

 

I used it about a month ago and it ran fine. I have the scripts in the correct location as well.

-----

 

Update:

 

Delete and reinstalled plugin and it works.

 

Share this post


Link to post

Trying to use this on a new 4TB drive and nothing happens.

 

I used it about a month ago and it ran fine. I have the scripts in the correct location as well.

-----

 

Update:

 

Delete and reinstalled plugin and it works.

 

JUst update it to be compliant with unRAID 6.1

Share this post


Link to post

I'm just having a problem with installing this one via telnet...

 

I get the 'bad download, deleting' error :(

 

I'm in root@... /boot/config/plugins

 

I can download fine with wget https://raw.githubusercontent.com/gfjardim/unRAID-plugins/master/plugins/preclear.disk.plg --no-check-certificate

 

Then running this line errors:

installplg /boot/config/plugins/preclear.disk.plg

 

installing plugin: preclear.disk

file /boot/config/plugins/preclear.disk/preclear.disk-2015.07.23.txz: downloading from https://raw.githubusercontent.com/gfjardim/unRAID-plugins/master/archive/preclear.disk-2015.07.23.txz ... ERROR: cannot verify raw.githubusercontent.com's certificate, issued by `/C=US/O=DigiCert Inc/OU=www.digicert.com/CN=DigiCert SHA2 High Assurance Server CA':

  Unable to locally verify the issuer's authority.

ERROR: certificate common name `www.github.com' doesn't match requested host name `raw.githubusercontent.com'.

To connect to raw.githubusercontent.com insecurely, use `--no-check-certificate'.

bad download, deleting

Share this post


Link to post

I'm just having a problem with installing this one via telnet...

 

I get the 'bad download, deleting' error :(

 

I'm in root@... /boot/config/plugins

 

I can download fine with wget https://raw.githubusercontent.com/gfjardim/unRAID-plugins/master/plugins/preclear.disk.plg --no-check-certificate

 

Then running this line errors:

installplg /boot/config/plugins/preclear.disk.plg

 

installing plugin: preclear.disk

file /boot/config/plugins/preclear.disk/preclear.disk-2015.07.23.txz: downloading from https://raw.githubusercontent.com/gfjardim/unRAID-plugins/master/archive/preclear.disk-2015.07.23.txz ... ERROR: cannot verify raw.githubusercontent.com's certificate, issued by `/C=US/O=DigiCert Inc/OU=www.digicert.com/CN=DigiCert SHA2 High Assurance Server CA':

  Unable to locally verify the issuer's authority.

ERROR: certificate common name `www.github.com' doesn't match requested host name `raw.githubusercontent.com'.

To connect to raw.githubusercontent.com insecurely, use `--no-check-certificate'.

bad download, deleting

Why aren't you installing it from the GUI Install Plugins page?

Share this post


Link to post

Why aren't you installing it from the GUI Install Plugins page?

 

I'm still running V5

Somebody will correct me if I'm wrong but I don't think v6 plugins are backwards compatible with v5.

Share this post


Link to post

Why aren't you installing it from the GUI Install Plugins page?

 

I'm still running V5

Somebody will correct me if I'm wrong but I don't think v6 plugins are backwards compatible with v5.

 

I decided to go the old school preclear_disk.sh script route via telnet.

Once it's all done I'll update unraid to V6 and try the plugin install again :)

Share this post


Link to post

Rather than Preclear Successful, it should have told me that Preclear was successful, but your disk is starting to fail.

 

The plugin reports

 

ST3000DM001-9YN166_W1F0MED2

Preclear Successful

... Total time 24:27:20

... Pre-Read time 7:06:20 (117 MB/s)

... Zeroing time 5:11:10 (160 MB/s)

... Post-Read time 12:08:51 (68 MB/s)

 

But it doesn't note that the disk is beginning to fail (the number of reallocated sectors is not zero and increasing ) :

 

0 sectors were pending re-allocation before the start of the preclear.

0 sectors were pending re-allocation after pre-read in cycle 1 of 1.

0 sectors were pending re-allocation after zero of disk in cycle 1 of 1.

0 sectors are pending re-allocation at the end of the preclear,

    the number of sectors pending re-allocation did not change.

384 sectors had been re-allocated before the start of the preclear.

400 sectors are re-allocated at the end of the preclear,

    a change of 16 in the number of sectors re-allocated.

 

Share this post


Link to post

Rather than Preclear Successful, it should have told me that Preclear was successful, but your disk is starting to fail.

 

The plugin reports

 

ST3000DM001-9YN166_W1F0MED2

Preclear Successful

... Total time 24:27:20

... Pre-Read time 7:06:20 (117 MB/s)

... Zeroing time 5:11:10 (160 MB/s)

... Post-Read time 12:08:51 (68 MB/s)

 

But it doesn't note that the disk is beginning to fail (the number of reallocated sectors is not zero and increasing ) :

 

0 sectors were pending re-allocation before the start of the preclear.

0 sectors were pending re-allocation after pre-read in cycle 1 of 1.

0 sectors were pending re-allocation after zero of disk in cycle 1 of 1.

0 sectors are pending re-allocation at the end of the preclear,

    the number of sectors pending re-allocation did not change.

384 sectors had been re-allocated before the start of the preclear.

400 sectors are re-allocated at the end of the preclear,

    a change of 16 in the number of sectors re-allocated.

 

This is exported by the preclear script since bjp999 added support for myMain. I'll make some mods and submit to Joe L. again.

 

Thanks for reporting.

Share this post


Link to post

Thanks for reporting.

 

I'm not reporting a bug, but more wanting to start a debate about what should this plugin report in cases where the number of reallocated sectors is not zero and actually is increasing.  We need Joe L and the other drive experts to weigh in...

 

1. Case where the number of reallocated sectors is zero before and zero after - no debate.  Drive is good

 

2. Some reallocated sectors, but they are stable and not increasing. - Some debate, should the plugin report this??

 

3. Some reallocated sectors and more are found during the preclear.  - The drive is not healthy.  Should it be used?  Is it dying??

 

Share this post


Link to post

2. Some reallocated sectors, but they are stable and not increasing. - Some debate, should the plugin report this??

 

Without a doubt.  People need to know the status of the drive they are going to trust to reliably store data.

 

3. Some reallocated sectors and more are found during the preclear.  - The drive is not healthy.  Should it be used?  Is it dying??

 

Again, it should be reported.  I don't know if it should say the drive is not healthy unless there is a FAILING attribute.

If there are 'still' pending sectors, that would be an indication the drive is not reliable for unRAID.

Share this post


Link to post

I would not be at all in favor of equating a single small increase in reallocated sectors with drive failure (although it could be for that specific drive model ST3000DM001!).  A continuous increase is certainly a bad sign, but not a single small increase.  There are thousands more spares available.  It's more like a symptom of aging, we're all failing a bit each day that passes, once we pass our teen age years.

 

What I WOULD agree with, after any increase in reallocated sectors or any change (even for the better) in Current Pending sectors and of course any non-zero Current Pending sectors, is a statement that another Preclear or two is recommended.  You want to detect whether it's stable now, or continuing to reallocate (which WOULD be bad).

Share this post


Link to post

 

 

I'm not reporting a bug, but more wanting to start a debate about what should this plugin report in cases where the number of reallocated sectors is not zero and actually is increasing.  We need Joe L and the other drive experts to weigh in...

 

1. Case where the number of reallocated sectors is zero before and zero after - no debate.  Drive is good

 

2. Some reallocated sectors, but they are stable and not increasing. - Some debate, should the plugin report this??

 

I think that is should be noted as      'Advisory-- This drive is currently stable and could be used.'

 

3. Some reallocated sectors and more are found during the preclear.  - The drive is not healthy.  Should it be used?  Is it dying??

 

I think this condition should be noted as      'Warning-- This drive is not currently stable and additional testing is warranted before using in an array!.'

Share this post


Link to post

Notifications from this plugin seem to be broken on rc5. I know there was a change to the path for notify on rc3. See here

 

Using the faster preclear script I got from here, which looks like a modification you made to bjp999 script and it does indeed have the old path for notify.

Share this post


Link to post

Not working at all for me on RC6. Going to reboot and invoke from command line :(

Not 6.1 compliant

Share this post


Link to post

Not working at all for me on RC6. Going to reboot and invoke from command line :(

Not 6.1 compliant

 

at least the webgui still can read its progress ;)

 

Pre-Read. 0% @ 133 MB/s (0:01:34)

Share this post


Link to post

I"m using a fresh version of unraid 6.1 with the latest plugin and version 1.15 of the script.

 

Everything is working like a champ for me.

 

Share this post


Link to post

Now that 6.1 has been released, are there any plans to bring this plugin into compliance?

 

It is compliant. It doesn't use exec.php or any executables outside /plugins/<plugin>/scripts .

 

 

Share this post


Link to post

Now that 6.1 has been released, are there any plans to bring this plugin into compliance?

 

It is compliant. It doesn't use exec.php or any executables outside /plugins/<plugin>/scripts .

 

Thank you!  I have a new 3TB WD Red on order and will be using it to preclear that drive.  (Otherwise, I was planning to roll back to 6.0.1)

 

EDIT:  You should see about getting this thread moved from the 'Unverified' to 'Verified' section of Plugins (V6)!

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.