Jump to content
linuxserver.io

[Support] Linuxserver.io - OpenVPN AS

1603 posts in this topic Last Reply

Recommended Posts

I managed to get it, however i cannot find where to get the openvpn files for the user that i added? I mean the profile config files so i can use them on another machine to login via VPN.

Share this post


Link to post

Thank you, i figured that out however i am trying all the various network interfaces under 'server setting' but on all of them the 'connectivity test' fails. I have done port forwarding on my router. So i dont know what could be wrong.

Share this post


Link to post

Dunno HKR, I don't use this container. 

 

If the container is up and running, then may be worth looking at the OpenVPN forums for configuration problems..

Share this post


Link to post

Can i rule this out to be a port forwarding issue? As when i am in the same wifi network i can connect via VPN on my iPhone just fine, but when i switch off the wifi and try to connect it wont connect...

Share this post


Link to post

Can i rule this out to be a port forwarding issue? As when i am in the same wifi network i can connect via VPN on my iPhone just fine, but when i switch off the wifi and try to connect it wont connect...

 

No idea HKR...  I haven't seen your setup.  But we've not had any reports of the port management in docker being problematic, so I can only assume it's a config issue your end.

Share this post


Link to post

I understand that, i can connect to the webui just fine, i did not play around with any setting in the webui, i tried switching the network adapter setting in the 'server settings' however the connectivity test fails no matter what network host i select and i cannot connect to the server via VPN.

Share this post


Link to post

HKR, we're completely unable to help, without at least some more info, like screenshots etc. 

Share this post


Link to post

I have attached 2 screenshots, please take a look.

 

Under server setting no matter what Interface i select i cannot connect to the server.

Untitled.png.3d896c11c1c757382a256e3b313fae4f.png

Untitled1.png.cabec52343b4656530418d557e5a2d56.png

Share this post


Link to post

I have attached 2 screenshots, please take a look.

 

Under server setting no matter what Interface i select i cannot connect to the server.

I'm going to assume you have tried connecting from outside your home network and have setup port forwarding on your router/firewall?

 

Once thing you could test is try connecting locally to the openvpn instance just as a proof of concept that the docker is running correctly.

Share this post


Link to post

just diving into this docker and I must send a big thanks! This thing is great. After a bit of stumbling I managed to get it up and running and even configured it to take a google authenticator. I'm quite amazed at how quickly I was able to configure it.

 

One thing I would like to lock down and haven't figured out is better securing the admin web interface. Is there anyway to prevent that from being accessible from the outside network? Or force google authenticator for it as well? I'm a huge fan of two factor authentication, but it is rather pointless if the admin interface where you can disable it is accessible with just a name and password. For now I've settled for a ridiculously complex admin password.

 

Ideally you could block the admin interface entirely from outside the network and if you wanted to play with it remotely you could VPN first. But I'm guessing that is going off the same ports/webserver as the interface which lets you download the clients? Am I guessing correctly.

 

On an unrelated note, but in reference to HKR's questions I get the same thing on my self test even now, but actually trying from outside my network I can connect in just fine so you may not want to rely entirely on that for verifying you have things configured correctly.

Share this post


Link to post

We just produce the docker container not the application within so it may be better to direct some of the queries to the openvpn-as forum...

 

But I'll be interested to know if HKR's problem is solved by the above suggestion..

Share this post


Link to post

One thing I would like to lock down and haven't figured out is better securing the admin web interface. Is there anyway to prevent that from being accessible from the outside network? Or force google authenticator for it as well? I'm a huge fan of two factor authentication, but it is rather pointless if the admin interface where you can disable it is accessible with just a name and password. For now I've settled for a ridiculously complex admin password.

 

In case anyone comes up with this in search I wanted to follow up with what I ended up doing. I added a new user with a google authenticator as an admin. Once signed in with that account you can delete the default account named "admin". At that point you're left with an admin account that requires an authenticator to get in.

 

Also there is an option under "Server Network Settings" for Service Forwarding When TCP or Multi-daemon mode is chosen for the VPN Server protocol, the VPN Server can optionally provide access to these services through its IP address and port: and then two options Admin Web Server and Client Web Server. I've unchecked the admin option which I think may cover what I actually wanted but I don't have access to an external connection currently to verify that. Either way I'm happy with admin needing 2 factor at least.

Share this post


Link to post

Just installed docker. Tried to launch webui received the error: connection refused. Docker setup is all defaults, as shown in screen shot.

 

http://hydra/mnt/user/DockerApps/openvpn//log/openvpn.log reports: ...

 

2016-01-14 21:10:29-0800 [-] Server agent initialization failed (6/6 attempts) because the following network resources are unavailable: set(['eth0'])

2016-01-14 21:10:29-0800 [-] Server Agent is inactive due to the following errors: {'errors': {'admin_ui.https.ip_address': [('error', "LOCAL_ADDR eth0 : bad local address name or interface is not up; must be 'all', 'localhost', a local IP address, or an interface name:

 

What do I need to change to fix this? Thank you for your help

 

###EDIT###  Resolved. See reply #45 for fix..

/closed ticket/

docker_setup.PNG.e6ad86801ae1436dc2277cb8c6dfbcd5.PNG

Share this post


Link to post

Instead of using /mnt/user/..... use /mnt/cache/.... or /mnt/disk1/.... (or whatever disk you're storing this on)

 

Some containers don't play well with user shares, but be sure to delete the container and the /mnt/user/... first.

Share this post


Link to post

Instead of using /mnt/user/..... use /mnt/cache/.... or /mnt/disk1/.... (or whatever disk you're storing this on)

 

Some containers don't play well with user shares, but be sure to delete the container and the /mnt/user/... first.

 

I deleted my container in webUI; ssh and deleted the folder I was using on the user share. Made a new Docker Container, pointed /mnt/disk1/FOO per suggestion.

 

Same issue as before, error connection refused. Tried https://192.168.0.101:943/  (correct IP) and https://localhost:943/

Also have the same error in openvpn.log.

 

What else should I try? Thanks.

Share this post


Link to post

What's the output of ifconfig from a terminal?

 

root@HYDRA:/mnt/disk1/DockerApps# ifconfig
bond0: flags=5443<UP,BROADCAST,RUNNING,PROMISC,MASTER,MULTICAST>  mtu 1500
        ether 10:c3:7b:6f:43:ae  txqueuelen 0  (Ethernet)
        RX packets 376918292  bytes 545599728025 (508.1 GiB)
        RX errors 0  dropped 213548  overruns 0  frame 0
        TX packets 35516033  bytes 6243595662 (5.8 GiB)
        TX errors 0  dropped 12 overruns 0  carrier 0  collisions 0

br0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.101  netmask 255.255.255.0  broadcast 192.168.0.255
        ether 10:c3:7b:6f:43:ae  txqueuelen 0  (Ethernet)
        RX packets 85104066  bytes 554801007870 (516.6 GiB)
        RX errors 0  dropped 13916  overruns 0  frame 0
        TX packets 39609148  bytes 126332393253 (117.6 GiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

docker0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 172.17.42.1  netmask 255.255.0.0  broadcast 0.0.0.0
        ether 46:e0:a9:09:01:15  txqueuelen 0  (Ethernet)
        RX packets 52898  bytes 14164401 (13.5 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 53867  bytes 30521239 (29.1 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

eth0: flags=6211<UP,BROADCAST,RUNNING,SLAVE,MULTICAST>  mtu 1500
        ether 10:c3:7b:6f:43:ae  txqueuelen 1000  (Ethernet)
        RX packets 376704744  bytes 545585615783 (508.1 GiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 35516033  bytes 6243595662 (5.8 GiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

eth1: flags=6211<UP,BROADCAST,RUNNING,SLAVE,MULTICAST>  mtu 1500
        ether 10:c3:7b:6f:43:ae  txqueuelen 1000  (Ethernet)
        RX packets 213548  bytes 14112242 (13.4 MiB)
        RX errors 0  dropped 213548  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 18  memory 0xfbf00000-fbf20000

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        loop  txqueuelen 0  (Local Loopback)
        RX packets 137464  bytes 25960421 (24.7 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 137464  bytes 25960421 (24.7 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

veth17b05fb: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether 8e:b6:70:ea:a8:35  txqueuelen 0  (Ethernet)
        RX packets 2115  bytes 859529 (839.3 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1924  bytes 1218400 (1.1 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

veth638c205: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether a6:2a:88:78:4c:66  txqueuelen 0  (Ethernet)
        RX packets 19556  bytes 2062340 (1.9 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 21441  bytes 9256959 (8.8 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

vetha052b41: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether 46:e0:a9:09:01:15  txqueuelen 0  (Ethernet)
        RX packets 699  bytes 548224 (535.3 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 897  bytes 705751 (689.2 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

virbr0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 192.168.122.1  netmask 255.255.255.0  broadcast 192.168.122.255
        ether 52:54:00:fb:a4:f1  txqueuelen 0  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

vnet0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether fe:54:00:7c:e6:b8  txqueuelen 500  (Ethernet)
        RX packets 12455171  bytes 31394587093 (29.2 GiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 89716902  bytes 129283508307 (120.4 GiB)
        TX errors 0  dropped 5018 overruns 0  carrier 0  collisions 0

 

I'm a noob, but guessing from the ifconfig my docker needs to be pointed at br0 and not eth0 (default)? And if correct, I don't know how to go about doing that but I guess I can keep digging.

Share this post


Link to post

What's the output of ifconfig from a terminal?

 

root@HYDRA:/mnt/disk1/DockerApps# ifconfig
bond0: flags=5443<UP,BROADCAST,RUNNING,PROMISC,MASTER,MULTICAST>  mtu 1500
        ether 10:c3:7b:6f:43:ae  txqueuelen 0  (Ethernet)
        RX packets 376918292  bytes 545599728025 (508.1 GiB)
        RX errors 0  dropped 213548  overruns 0  frame 0
        TX packets 35516033  bytes 6243595662 (5.8 GiB)
        TX errors 0  dropped 12 overruns 0  carrier 0  collisions 0

br0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.101  netmask 255.255.255.0  broadcast 192.168.0.255
        ether 10:c3:7b:6f:43:ae  txqueuelen 0  (Ethernet)
        RX packets 85104066  bytes 554801007870 (516.6 GiB)
        RX errors 0  dropped 13916  overruns 0  frame 0
        TX packets 39609148  bytes 126332393253 (117.6 GiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

docker0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 172.17.42.1  netmask 255.255.0.0  broadcast 0.0.0.0
        ether 46:e0:a9:09:01:15  txqueuelen 0  (Ethernet)
        RX packets 52898  bytes 14164401 (13.5 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 53867  bytes 30521239 (29.1 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

eth0: flags=6211<UP,BROADCAST,RUNNING,SLAVE,MULTICAST>  mtu 1500
        ether 10:c3:7b:6f:43:ae  txqueuelen 1000  (Ethernet)
        RX packets 376704744  bytes 545585615783 (508.1 GiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 35516033  bytes 6243595662 (5.8 GiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

eth1: flags=6211<UP,BROADCAST,RUNNING,SLAVE,MULTICAST>  mtu 1500
        ether 10:c3:7b:6f:43:ae  txqueuelen 1000  (Ethernet)
        RX packets 213548  bytes 14112242 (13.4 MiB)
        RX errors 0  dropped 213548  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 18  memory 0xfbf00000-fbf20000

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        loop  txqueuelen 0  (Local Loopback)
        RX packets 137464  bytes 25960421 (24.7 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 137464  bytes 25960421 (24.7 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

veth17b05fb: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether 8e:b6:70:ea:a8:35  txqueuelen 0  (Ethernet)
        RX packets 2115  bytes 859529 (839.3 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1924  bytes 1218400 (1.1 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

veth638c205: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether a6:2a:88:78:4c:66  txqueuelen 0  (Ethernet)
        RX packets 19556  bytes 2062340 (1.9 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 21441  bytes 9256959 (8.8 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

vetha052b41: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether 46:e0:a9:09:01:15  txqueuelen 0  (Ethernet)
        RX packets 699  bytes 548224 (535.3 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 897  bytes 705751 (689.2 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

virbr0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 192.168.122.1  netmask 255.255.255.0  broadcast 192.168.122.255
        ether 52:54:00:fb:a4:f1  txqueuelen 0  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

vnet0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether fe:54:00:7c:e6:b8  txqueuelen 500  (Ethernet)
        RX packets 12455171  bytes 31394587093 (29.2 GiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 89716902  bytes 129283508307 (120.4 GiB)
        TX errors 0  dropped 5018 overruns 0  carrier 0  collisions 0

 

I'm a noob, but guessing from the ifconfig my docker needs to be pointed at br0 and not eth0 (default)? And if correct, I don't know how to go about doing that but I guess I can keep digging.

 

I suspect it's down to the fact you've got bonding enabled on your Unraid machine as that's the only difference I see between my setup and yours.

Share this post


Link to post

What's the output of ifconfig from a terminal?

 

root@HYDRA:/mnt/disk1/DockerApps# ifconfig
bond0: flags=5443<UP,BROADCAST,RUNNING,PROMISC,MASTER,MULTICAST>  mtu 1500
        ether 10:c3:7b:6f:43:ae  txqueuelen 0  (Ethernet)
        RX packets 376918292  bytes 545599728025 (508.1 GiB)
        RX errors 0  dropped 213548  overruns 0  frame 0
        TX packets 35516033  bytes 6243595662 (5.8 GiB)
        TX errors 0  dropped 12 overruns 0  carrier 0  collisions 0

br0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.101  netmask 255.255.255.0  broadcast 192.168.0.255
        ether 10:c3:7b:6f:43:ae  txqueuelen 0  (Ethernet)
        RX packets 85104066  bytes 554801007870 (516.6 GiB)
        RX errors 0  dropped 13916  overruns 0  frame 0
        TX packets 39609148  bytes 126332393253 (117.6 GiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

docker0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 172.17.42.1  netmask 255.255.0.0  broadcast 0.0.0.0
        ether 46:e0:a9:09:01:15  txqueuelen 0  (Ethernet)
        RX packets 52898  bytes 14164401 (13.5 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 53867  bytes 30521239 (29.1 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

eth0: flags=6211<UP,BROADCAST,RUNNING,SLAVE,MULTICAST>  mtu 1500
        ether 10:c3:7b:6f:43:ae  txqueuelen 1000  (Ethernet)
        RX packets 376704744  bytes 545585615783 (508.1 GiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 35516033  bytes 6243595662 (5.8 GiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

eth1: flags=6211<UP,BROADCAST,RUNNING,SLAVE,MULTICAST>  mtu 1500
        ether 10:c3:7b:6f:43:ae  txqueuelen 1000  (Ethernet)
        RX packets 213548  bytes 14112242 (13.4 MiB)
        RX errors 0  dropped 213548  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 18  memory 0xfbf00000-fbf20000

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        loop  txqueuelen 0  (Local Loopback)
        RX packets 137464  bytes 25960421 (24.7 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 137464  bytes 25960421 (24.7 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

veth17b05fb: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether 8e:b6:70:ea:a8:35  txqueuelen 0  (Ethernet)
        RX packets 2115  bytes 859529 (839.3 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1924  bytes 1218400 (1.1 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

veth638c205: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether a6:2a:88:78:4c:66  txqueuelen 0  (Ethernet)
        RX packets 19556  bytes 2062340 (1.9 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 21441  bytes 9256959 (8.8 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

vetha052b41: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether 46:e0:a9:09:01:15  txqueuelen 0  (Ethernet)
        RX packets 699  bytes 548224 (535.3 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 897  bytes 705751 (689.2 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

virbr0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 192.168.122.1  netmask 255.255.255.0  broadcast 192.168.122.255
        ether 52:54:00:fb:a4:f1  txqueuelen 0  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

vnet0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether fe:54:00:7c:e6:b8  txqueuelen 500  (Ethernet)
        RX packets 12455171  bytes 31394587093 (29.2 GiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 89716902  bytes 129283508307 (120.4 GiB)
        TX errors 0  dropped 5018 overruns 0  carrier 0  collisions 0

 

I'm a noob, but guessing from the ifconfig my docker needs to be pointed at br0 and not eth0 (default)? And if correct, I don't know how to go about doing that but I guess I can keep digging.

 

I suspect it's down to the fact you've got bonding enabled on your Unraid machine as that's the only difference I see between my setup and yours.

 

I went into webUI - edit page for docker; added a variable INTERFACE with a value of bond0 -- I can now access port 943. So I think my issue is resolved, but before I get too comfortable I just want to ask is this fix kosher? Also before this, I didn't realize I could do this. I.e. is there a technical reason it's mapped to eth0, or it's just default (you have to start somewhere)?

 

Again, thank you for your assistance and time (not to mention patience to deal with this noob).

Share this post


Link to post

 

I went into webUI - edit page for docker; added a variable INTERFACE with a value of bond0 -- I can now access port 943. So I think my issue is resolved, but before I get too comfortable I just want to ask is this fix kosher? Also before this, I didn't realize I could do this. I.e. is there a technical reason it's mapped to eth0, or it's just default (you have to start somewhere)?

 

Again, thank you for your assistance and time (not to mention patience to deal with this noob).

 

Looks good to me, most of us don't use bonding so eth0 would be a logical place to map it to, given that as far as I know, it's a fairly standard description for an ethernet interface in Linux.  I can't see any reason why you can't use bond0 as that is what your Unraid box is using.

 

No problem on the help front.

Share this post


Link to post

I have mine all set up finally and am able to connect locally, but can anyone direct me where to figure out how to get the certificates working right?  No matter where I try to connect from, or even the web client tells me the site is not signed and give me certificate errors.

 

In order to use this docker, do I need to download openssl and go through all that to generate a certificate?  Isn't there a newb guide to this?  I have gone through all the openvpn docs and it all seems like so much just to get a simple tunnel going.

openvpn.jpg.49914b9b5dace95443cadfc36423544a.jpg

Share this post


Link to post

I have mine all set up finally and am able to connect locally, but can anyone direct me where to figure out how to get the certificates working right?  No matter where I try to connect from, or even the web client tells me the site is not signed and give me certificate errors.

 

In order to use this docker, do I need to download openssl and go through all that to generate a certificate?  Isn't there a newb guide to this?  I have gone through all the openvpn docs and it all seems like so much just to get a simple tunnel going.

 

You'll need to create your own certificates I would imagine.  I used StartSSL.  Guide here...  Can't help you anymore than that though as I don't use this container.  But unless you own a domain name and can validate it, then you will get a warning regarding unsigned certificates.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.