My Servers Early Access Plugin


Recommended Posts

Hello Unraid Community!

 

Today we're excited to give you a sneak peak at something we've been working on for quite some time.  A new feature we like to call My Servers.

 

"My Servers" is designed to extend the value of your investment in Unraid by enabling you to more easily connect, share, monitor, and access your systems. For the initial beta launch, we are focusing on the following key features:

 

Secure Remote Access

Whether you need to add a share, container, or virtual machine, do it all from the webGui from anywhere and at any time using using HTTPS. Best of all, all SSL certificates are verified by Let's Encrypt, so no browser security warnings.

 

Online Flash Backup

When your Unraid configuration changes, the new settings on the flash drive will automatically be backed up to Unraid.net, enabling easy recovery in the event of a device failure. Never self-manage/host your flash backups again!

 

Real-time Monitoring

Get quick real-time info on the status of your servers such as storage, container, and VM usage. And not just for one server, but all the servers in your Unraid fleet!

 

License Management

Download any registration key linked to your account. Upgrade keys to higher editions. In addition, Trial keys are now downloaded automatically. Simply sign-in!

 

Installing

For the full details on how to install and configure, check out the wiki.

 

  • Like 14
  • Thanks 2
Link to comment
  • jonp pinned this topic

I followed the guide and ran into some errors. Port forwarding is working and showing it is accessible from internet but get Guest doesn't have permission to access "servers". I am logged in as root and root has a password. I have a Let's Encrypt cert. Not sure what else to check. Here are some screenshots. Let me know what additional info you need or any ideas how to fix this. Thanks, Jason

 

551459144_Screenshot2021-03-12200141.thumb.png.b01a368c431f9f509b17c5ee9879a9bf.png1105595026_Screenshot2021-03-12195455.png.d14d06fa92edb519d740e51e9722a18e.pngUntitled.png.8d2f6019688e04f912150cc7140f18ac.png

  • Like 2
Link to comment

Oh, and one thing that @jonp always forgets to mention about MyServers is that you can also actually use any of your VM's (that are set up with VNC) directly over the internet anywhere in the world by logging into your server and displaying the VNC page.

  • Like 3
  • Thanks 2
Link to comment
14 minutes ago, JasonP said:

I followed the guide and ran into some errors. Port forwarding is working and showing it is accessible from internet but get Guest doesn't have permission to access "servers". I am logged in as root and root has a password. I have a Let's Encrypt cert. Not sure what else to check. Here are some screenshots. Let me know what additional info you need or any ideas how to fix this. Thanks, Jason

 

551459144_Screenshot2021-03-12200141.thumb.png.b01a368c431f9f509b17c5ee9879a9bf.png1105595026_Screenshot2021-03-12195455.png.d14d06fa92edb519d740e51e9722a18e.pngUntitled.png.8d2f6019688e04f912150cc7140f18ac.png

Would you mind running `unraid-api restart` in a terminal and let me know if that sorts it. I’ve added this to our bug tracker. 

  • Like 4
  • Thanks 9
Link to comment
2 minutes ago, OmgImAlexis said:

Would you mind running `unraid-api restart` in a terminal and let me know if that sorts it. I’ve added this to our bug tracker. 

I had the same problem here, but this solved it, thanks!

  • Like 2
Link to comment

I had the same problem that JasonP had, and running "unraid-api restart" in a terminal fixed it also. But mine is still showing "Access unavailable" in the my server list... it says it is online and shows all my stats...

 

EDIT:
It figures it would change to "Remote access" right after i posted this.

Edited by GCS
  • Like 3
Link to comment

Hmm well I tried this and didn't really care for the need to expose port forwarding... Now I'm stuck with the cryptic Unraid.net DNS hostname even when I've signed out and remove the plugin.

 

How can I go back to local hostname and that's sufficient?

 

Edit: Figured it I could go into Management Access and set Use SSL / TLS to No and it set local DNS names back into effect.

Edited by xaositek
  • Like 1
Link to comment
13 minutes ago, xaositek said:

Hmm well I tried this and didn't really care for the need to expose port forwarding... Now I'm stuck with the cryptic Unraid.net DNS hostname even when I've signed out and remove the plugin.

 

How can I go back to local hostname and that's sufficient?

 

Edit: Figured it I could go into Management Access and set Use SSL / TLS to No and it set local DNS names back into effect.

 

Keep in mind you only need to do port forwarding for remote access. Local network access secured by ssl does not require port forwarding. 

Link to comment

Can't reach my server any longer after issuing the first steps. Even local access via IP doee not work any longer ecuase access to local IP tries to access a cryptic URL.

 

Some year ago I tried to certificate and use SSL when this feature was introduced. It ended the same. I was locked out. I remember that now.

 

I can't remember what I did to get access again.

 

Any help is highly appreciated.

 

Edit: Missing or empty GUID is shown now on registration page. What a €%*@

 

Edited by hawihoney
  • Like 1
Link to comment

Puh, have access to my server again. Had to call https://<localip>. Chrome complains, let Chrome call http://<localip> and I'm back in again. Calling http://<localip> directly ended in a rewrite to the cryptic https URL.

 

This time I threw out my unraid.net account completely, changed back to ssl=no and removed unraid.net plugin. Had to remove parts from the flash manually.

 

Everythings working now again.

 

Puh.

 

Edited by hawihoney
  • Thanks 2
Link to comment

I have a different problem - after switching SSL/TLS from Yes to auto I need to logon again with http:// but after i enter root password and hit login nothing happends - entered data dissapear, no information about invalid username/password.

 

I can ssh to server with this password :| 

Link to comment
46 minutes ago, cobhc said:

Hi,

 

I get the error "Graphql is offline" on my server using this plug-in, any ideas?

 

Also I get an error during the flash backup, I guess this is because I'm using a custom kernel?

 

Thanks.

Does running `unraid-api restart` fix the graphql offline issue?

Link to comment
11 minutes ago, OmgImAlexis said:

Does running `unraid-api restart` fix the graphql offline issue?

Strangely, I get "unraid-api: command not found" when I run that command in a terminal.

 

Is it something I need to install separately? It wasn't mentioned as a prerequisite on the wiki.

 

Edit: Second reboot fixed it. All good now, thanks.

Edited by cobhc
  • Like 1
Link to comment

So everything seems to work well! 
now i have a stupid question....what’s the best way to get access to the system other than browsing to the forums, going to our profile and clicking the link? 
 

i mean i guess i could bookmark the profile page....but a simple app would be pretty sweet lol

Link to comment
1 hour ago, bluesky509 said:

Any plans to add 2FA to the Secure Remote Access feature? I really like this feature.

It seems the only way to access the remote feature is through the unraid forums my servers page....thus if you 2FA your unraid forums account you will effectively 2FA the remote access feature.

  • Like 2
Link to comment

Hi @jonp

I'm really like this plugin but before I dive into it would it work behind the one of the nginx proxy containers within different vlans (which includes custom docker networks)?  I would like to like to leverage this new feature from the unraid team but put the following behind nginx proxy
 

- unraid server (no vlan)

- plexmedia server (container) (external vlan / custom docker network)

- homeassistant (VM) (external vlan)

thanks!

Edited by repomanz
Link to comment
8 hours ago, hawihoney said:

Puh, have access to my server again. Had to call https://<localip>. Chrome complains, let Chrome call http://<localip> and I'm back in again. Calling http://<localip> directly ended in a rewrite to the cryptic https URL.

 

This time I threw out my unraid.net account completely, changed back to ssl=no and removed unraid.net plugin. Had to remove parts from the flash manually.

 

Everythings working now again.

 

Puh.

 

 

Sorry you had trouble accessing your system via SSL. As you mentioned, this is functionality has been in Unraid for several years, it isn't actually related to My Servers (although it is required to configure Remote Access). 

 

Changing ssl to no should have been enough to disable SSL and get you back to a normal url. Everything in My Servers other than Remote Access works fine with a normal http url if you would like to try the other features.

Link to comment
3 hours ago, air360jg said:

what’s the best way to get access to the system other than browsing to the forums, going to our profile and clicking the link? 

Couple of options... what I usually do is type "tower" (the name of my server) in my browser and it redirects to https://myhash.unraid.net.  You could also type http://<ip address> and it will redirect. 

 

This is a good page to bookmark:
  https://forums.unraid.net/my-servers/ 
(or you can navigate there from the forums). It detects whether you are on the same network as the server and displays either the Local Access or Remote Access url (if that is configured)

 

3 hours ago, air360jg said:

It seems the only way to access the remote feature is through the unraid forums my servers page.

 

The Remote Access url is the same as Local Access, but with "www." up front.

Link to comment
4 hours ago, bluesky509 said:

Any plans to add 2FA to the Secure Remote Access feature? I really like this feature.

 

Safe to say there is more coming in this area :) For now please do ensure you are using a complex root password.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.