VirtualBox compiled for unRAID

Recommended Posts

  • Replies 256
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

I did not upgrade unraid. It is still on 5.00 final. I upgraded the virualbox and virtualboxphp.

I tried on the old php.config file and hs the same problems with making 2 changes in the sample. one for authencation and the other for server address. I can start the virtual machines in the simple features gui but on the the dedicated webpage.


Link to comment

thank you sir.


Would you mind posting a screenshot of your virtualbox settings page? (the one under plugins)


I'm trying to figure some things out.

I will do that after work tonight.  Might be late however.  I believe I left everything default on that page except for:  All yes/no's are YES but autostart I have set to none.  I might have changed the IP as well but I don't think that was necessary so if I did I may set it back to the default 


One thing I did do outside the plugin was to change the default directory for VMs by using a vboxmanage setproperty command:

"vboxmanage setproperty machinefolder <path of default VM folder>"



Edit added configuration graphic for my setup.

Uploaded the graphic to previous post.  Note am posting this from within the Online VM shown on that screen.


Also added my script that I used to create and attach the RDM'd drives to my HomeSrv VM with the device IDs instead of drive letters.  I did change some of the serial numbers to ____.


Link to comment

VirtualBox 4.3.2 package now available for the new unRAID (5.01 & 5.02) kernel 3.9.11p.


Sorry for the delay. This was released on a Monday... I am working longer hours during the week and there is not enough free time to compile this until the weekends. Thank you to those that message or post to let me know when there are new versions.


As always, let me know if there are any issues with the compile. I saw no errors when making it & I started a test download (so it appears I did not typo the name this time).



Link to comment
  • 2 weeks later...

I think it's strange that realtek could be the cause of the problem as actually when we compile kernel (and I guess lainie uses similar procedures to mine, based on wiki ones, etc.. though I will soon post my exact procedures) we don't actually include realtek drivers at all... then how could that make any difference? ... did you ever tried my package I posted on other topic? no problems with it?


btw, lainie note that vbox changed udev rules filename on latest versions, you are not including it at all on your last package (but I don't think this is related to the panic issue at all), also it seems not the first time they change it from version to version, I did myself added a workaround for that .new suffix to the packaged file and then ensuring on install script that any old rules riles are removed and only then renaming it to normal filename.

Link to comment

Well as a security measure you could just stop the array, then manually mount just the cache disk as you need it for the VM virtual disks and try it... but if you do it you need to take care that you mount really the cache disk, as if you directly mount any data disk you will surely bring parity errors... so only do it if you are really sure you know what you are doing.


Other than that I can just assure you mine doesn't crash with similar realtek (despite that makes no sense to me).

Link to comment

As I said above I'm just posting the exact steps (and scripts) I use to create my own vbox packages, over the time I did made for myself a few changes/improvements on instructions (based on wiki ones) to compile vbox package, trying to get it as simple (i.e. automated) as possible, to easily compile it for every new kernel/vbox versions.


mkdir /boot/dev; cd /boot/dev

(the steps above are just to get my scripts to a dev folder on then flash drive... obviously only needed once... scripts should not need any changes for future kernel/vbox versions - unless something changes a lot :) )


cd ~
/boot/dev/ make
mkdir /tmpfs && mount -t tmpfs -o rw,size=1G tmpfs /tmpfs && export TMPDIR=/tmpfs
cp vbox-4.3.4-unRAID-3.9.11p.tgz /boot/config/plugins/virtualbox

(on the last line you need to adjust path where you want to copy package file to...)


Please note that my procedures store all temp files, kernel source, etc on ram based filesystem, it is faster and doesn't require any permanent storage, but better don't try it (without some some changes) on a system with less than 4GB ram!


@lainie: note the workaround on my script for the rules file I told you above, also you will notice I did some other changes on the package install script, I did just changed it to mimic exactly what is done on vbox, incl. the code to properly build usb device tree. Also you will be wondering why I do try to start all these vbox services, same reason: that's exactly what is done on vbox then I did just copied it, though actually only rc.vboxdrv will do something (load the modules), others will do nothing unless there is proper settings on vbox config files - for eg. rc.vboxweb-service will actually load vboxwebsrv if proper VBOXWEB_USER entry on config file.


Link to comment

I see there is a Virtualbox 4.3.4 out now as well. I will look at the info nars has posted along with attempt to try to get this new version compiled tomorrow (Sunday). I am not sure if changes to the patching of the kernel in unRAID 5.03 will make a difference since when I compile the headers, install VirtualBox & make the package, I use the kernel from Willing to try using 5.0.3 with this kernel to see if it helps.

Link to comment

Yes, exactly that's why I also don't think it can be Realtek driver related at all, maybe related to some other kernel config changes though but not really sure.


Btw, I did noticed now that steps on wiki are now also a lot updated since last time I did see them, mainly by Gfjardim, he added mainly steps to get updated headers properly linked on /usr/include, that is a question I also have for some time now, why this? any advantage over just using the old ones that glibc was compiled with, i.e. from slackware headers package (despite not matching kernel, but from my understanding some sites recommend just that - the ones glibc was compiled with), so far I use old ones and never needed to update them to compile anything, but I still have this question hammering on my head as I see some people doing that :)

Link to comment

VirtualBox 4.3.4 is up for unRAID 5.0 - i386 (kernel 3.9.6p) & 5.03 (kernels 3.9.11p).


I saw the changes Gfjardim made to the wiki and I attempted to use his new links, but compiling headers failed for me. I pulled up an older version of the page that listed using "bc-1.06.95-i486-1.txz" and "kernel-headers-" which is what I have been using since unRAID 5 RC13... and that compiled with no errors. As Gfjardim created the wiki page & it is still over 90% his work, I do not want to undo his changes... just stating they did not work for me.


I created this page (which is still mostly from Gfjardim), but includes the directions that work for me on unRAID since 5 RC 13 (but does not include 4.7 instructions or his scripts):


I may move the info to somewhere on my website once I get some time... having multiple wiki pages with just slightly different names in the same place may be confusing.


It appears I can no longer edit my first post on this thread... I know someone recently deleted their thread which contained some useful guide... but did not realize that we could no longer edit older posts... I was keeping my first post to this thread updated with the latest files. Can't do that now >:(

Link to comment

log excert


Dec  1 09:43:39 Tower s3_sleep: s3_sleep process ID 13884 started, To terminate it, type: s3_sleep -qDec  1 09:43:42 Tower rc.virtualbox[13953]: Local plugin is the same version as on hosting server (v0.5.2) (System)Dec  1 09:43:42 Tower rc.virtualbox[13954]: Checking for VirtualBox packages update during array mount ...Dec  1 09:43:47 Tower apcupsd[14183]: apcupsd 3.14.10 (13 September 2011) slackware startup succeededDec  1 09:43:49 Tower apcupsd[14183]: NIS server startup succeededDec  1 09:43:50 Tower kernel: wget[15007]: segfault at c ip 4060f2eb sp bf9f41cc error 4 in[40608000+13000] (Errors)Dec  1 09:43:50 Tower rc.virtualbox[15655]: Latest VirtualBox (v4.3.4)/(k3.9.11p) exists locally - no need to downloadDec  1 09:43:50 Tower rc.virtualbox[15659]: Latest VirtualBox Extension (v4.3.4) exists locally - no need to downloadDec  1 09:43:50 Tower rc.virtualbox[15662]: Installing VirtualBox packages during array mount ...Dec  1 09:43:50 Tower rc.virtualbox[15714]: Installing Virtualbox package (v4.3.4)...Dec  1 09:43:52 Tower useradd[16644]: failed adding user 'istat', data deleted (Minor Issues)Dec  1 09:43:52 Tower groupadd[16645]: group added to /etc/group: name=istat, GID=1000Dec  1 09:43:52 Tower groupadd[16645]: group added to /etc/gshadow: name=istatDec  1 09:43:52 Tower groupadd[16645]: new group: name=istat, GID=1000Dec  1 09:43:59 Tower rc.virtualbox[16986]: Symbolically linked /boot/custom/vbox to /root/.VirtualBoxDec  1 09:43:59 Tower rc.virtualbox[16987]: Installing Virtualbox Extension package (v4.3.4)...Dec  1 09:43:59 Tower emhttp: shcmd (41): :>/etc/samba/smb-shares.conf (Other emhttp)Dec  1 09:43:59 Tower avahi-daemon[13730]: Files changed, reloading.Dec  1 09:43:59 Tower emhttp: get_config_idx: fopen /boot/config/shares/_www.cfg: No such file or directory - assigning defaults (Other emhttp)Dec  1 09:43:59 Tower emhttp: get_config_idx: fopen /boot/config/shares/lost+found.cfg: No such file or directory - assigning defaults (Other emhttp)Dec  1 09:43:59 Tower emhttp: Restart SMB... (Other emhttp)Dec  1 09:43:59 Tower emhttp: shcmd (42): killall -HUP smbd (Minor Issues)Dec  1 09:43:59 Tower emhttp: shcmd (43): cp /etc/avahi/services/smb.service- /etc/avahi/services/smb.service (Other emhttp)Dec  1 09:43:59 Tower avahi-daemon[13730]: Files changed, reloading.Dec  1 09:43:59 Tower avahi-daemon[13730]: Service group file /services/smb.service changed, reloading.Dec  1 09:43:59 Tower emhttp: shcmd (44): ps axc | grep -q rpc.mountd (Other emhttp)Dec  1 09:43:59 Tower emhttp: _shcmd: shcmd (44): exit status: 1 (Other emhttp)Dec  1 09:43:59 Tower emhttp: shcmd (45): /usr/local/sbin/emhttp_event svcs_restarted (Other emhttp)Dec  1 09:43:59 Tower emhttp_event: svcs_restarted (Other emhttp)Dec  1 09:43:59 Tower emhttp: shcmd (46): /usr/local/sbin/emhttp_event started (Other emhttp)Dec  1 09:43:59 Tower emhttp_event: started (Other emhttp)Dec  1 09:44:00 Tower avahi-daemon[13730]: Service "Tower" (/services/smb.service) successfully established.Dec  1 09:44:05 Tower init: Re-reading inittabDec  1 09:45:44 Tower rc.virtualbox[19342]: Installing Virtualbox package (v4.3.4)...Dec  1 09:45:44 Tower rc.virtualbox[19423]: Symbolically linked /boot/custom/vbox to /root/.VirtualBoxDec  1 09:45:44 Tower rc.virtualbox[19424]: Installing Virtualbox Extension package (v4.3.4)...Dec  1 09:46:53 Tower sSMTP[20614]: Sent mail for [email protected] (221 2.0.0 bizsmtp closing connection) uid=0 username=root outbytes=2047Dec  1 09:46:57 Tower rc.virtualbox[20704]: No Virtual Machines running - nothing to saveDec  1 09:46:57 Tower rc.virtualbox[20705]: vboxwebsrv not running - nothing to stop

Link to comment
I saw the changes Gfjardim made to the wiki and I attempted to use his new links, but compiling headers failed for me. I pulled up an older version of the page that listed using "bc-1.06.95-i486-1.txz" and "kernel-headers-" which is what I have been using since unRAID 5 RC13... and that compiled with no errors. As Gfjardim created the wiki page & it is still over 90% his work, I do not want to undo his changes... just stating they did not work for me.


Then you use similar procedures to the ones I used really. And yes, I didn't updated anything on wiki exactly for the same reason :)


Btw, re the recent forum changes that don't allow editing our posts I did already missed it too :(

Link to comment

jpimlott, I think we are talking about slightly different things.


A web server and phpvirtualbox are not part of installing VirtualBox or using the VIrtualBox plugin. You can have a completely functioning VirtualBox without a web server or phpvirtualbox. The web server and phpvirtualbox give a nice graphical interface and make managing your virtual machines easier... and for that reason, many people add them. There is also the possibility to run the web server on a different system and point it to your unRAID box.


I asked if you were using the VirtualBox plugin because it uses the compiled files that I post, but allows you to start and stop your VMs from the plugin.



Link to comment

@lainie: just for curiosity I did downloaded your 3.9.11p package and looked at files on it and there is really a problem with it (not with 3.9.6p one though), it is missing the 'install/' script, the 'install' dir is actually there, but empty, that's the reason for jpimlott problem. Also note that you are also still missing the udev rules file (at /etc/udev/rules.d/) on your packages, as I told you before, note that vbox changed that file name on the latest versions, from 10-... to 60-..., and you may have your script still trying to copy the old file name, that doesn't exist anymore.

Link to comment

@nars: Thank you for finding the issue. I thought I included the install/, but as I do everything by hand and have made 2 today, it is possible I missed it. I will try to redo it to include install/ as soon as I can... unfortunately tomorrow is a work day so I won't have much free time (if any).


I ended up having to take care of some other issues at home today and did not read your notes as well as I should have... hence the udev rules missing.


This does seem to be getting more complicated than when I originally started making the vbox package.

Link to comment

It's an hard task to do it by hand really :(  I would suggest when you get some free time try to look at my scripts (some changes required to compile to other kernels though...), feel free and use them or adapt to your needs, you will find things get a LOT easier :)

Link to comment

I missed some necessary steps when making the latest package. I'm at work now & not sure when I will get home today or what else I will have to do once there.


gshlomi: If you can wait until I can redo the package (or use the one nars linked that he created a few posts back that is working for him and peter_sm), then you should be able to use unRAID 5.03 and VirtualBox. If you don't want to use the one from nars or wait, then yes, downgrading should help.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.