[support] gfjardim's Docker Repository


343 posts in this topic Last Reply

Recommended Posts

  • Replies 342
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Updated DropBox and ownCloud, both with invaluable contribution of HurricaneHernandez!    

For those having issues getting Cloud Print to work in the CUPS docker... Here's how I got it all going: Add your printer in the WebUI ssh into your unRAID box run the following c

so after finding, sharing etc the USB printer (in CUPS), i can no longer find it on my windows 7 computer connected to the same router as the unraid NAS!   this is getting frustrating as it was w

Posted Images

Schar, I'll be very sincere, I don't have any Logitech player arround, so for me it's difficult to debug it.

 

I'll take a look into it, and see if there's anything I can do, ok?

 

I'll be happy to test as well!

Me too. I was probably the first to request LMS docker that gfjardim provided. Thanks again.
Link to post

When using dropbox, it will work if I reinstall it.  However, if I stop it and restart it, I receive the following in the log

 

** Running /etc/my_init.d/config.sh...

Continous console status not requested

*** /etc/my_init.d/config.sh failed with status 1

Link to post

When using dropbox, it will work if I reinstall it.  However, if I stop it and restart it, I receive the following in the log

 

** Running /etc/my_init.d/config.sh...

Continous console status not requested

*** /etc/my_init.d/config.sh failed with status 1

 

I'm having the same problem. I did a "docker attach $containerId" to get the url (didn't think to look in the logs) to do oauth with and then restarted the container after I got it linked and now all I can get is that message.

 

 

EDIT:

 

It would appear this is the issue it's a pull request on gfjardim's github for the dropbox container. It was post 15 days ago and it's a 1 line (ok technically 2 line) fix and hopefully gfjardim will merge it soon and trigger a rebuild of the container so we can update.

 

 

EDIT 2:

 

Ok if you are getting the error above causing your container to die 2 seconds after starting then until gfjardim accepts the pull request you can just edit the docker container (from web UI), toggle Advanced View, and change the repository to "joshstrange/unraid-dropbox", then press Save.

 

I am not planning on providing any support whatsoever and offer no guarantees it will work for you but it works for me. Know that this is only a stopgap until the pull request is merged then you can go back to using gfjardim's repo.

Link to post

Was tryng to reinstall plexwatch today - and some files it tries to grab are no longer available.....

 

*** Running /etc/my_init.d/00_regen_ssh_host_keys.sh...
No SSH host key available. Generating one...
Creating SSH2 RSA key; this may take some time ...
Creating SSH2 DSA key; this may take some time ...
Creating SSH2 ECDSA key; this may take some time ...
Creating SSH2 ED25519 key; this may take some time ...
invoke-rc.d: policy-rc.d denied execution of restart.
*** Running /etc/my_init.d/edge.sh...
Reading package lists...
Building dependency tree...
Reading state information...
The following extra packages will be installed:
git-man liberror-perl patch rsync
Suggested packages:
gettext-base git-daemon-run git-daemon-sysvinit git-doc git-el git-email
git-gui gitk gitweb git-arch git-bzr git-cvs git-mediawiki git-svn ed
diffutils-doc
The following NEW packages will be installed:
git git-man liberror-perl patch rsync
0 upgraded, 5 newly installed, 0 to remove and 77 not upgraded.
Need to get 3713 kB of archives.
After this operation, 22.5 MB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu/ trusty-updates/main rsync amd64 3.1.0-2ubuntu0.1 [283 kB]
Get:2 http://archive.ubuntu.com/ubuntu/ trusty/main liberror-perl all 0.17-1.1 [21.1 kB]
Get:3 http://archive.ubuntu.com/ubuntu/ trusty-updates/main git-man all 1:1.9.1-1ubuntu0.1 [698 kB]
Get:4 http://archive.ubuntu.com/ubuntu/ trusty-updates/main git amd64 1:1.9.1-1ubuntu0.1 [2627 kB]
Err http://archive.ubuntu.com/ubuntu/ trusty-updates/main patch amd64 2.7.1-4ubuntu2
404 Not Found [iP: 91.189.92.201 80]
Fetched 3629 kB in 9s (376 kB/s)
E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/p/patch/patch_2.7.1-4ubuntu2_amd64.deb 404 Not Found [iP: 91.189.92.201 80]

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
/etc/my_init.d/edge.sh: line 9: git: command not found
chown: cannot access '/var/www/html/plexWatch': No such file or directory
ln: failed to create symbolic link '/var/www/html/plexWatch/config/config.php': No such file or directory
*** /etc/my_init.d/edge.sh failed with status 1

*** Killing all processes...

 

Myk

 

Link to post

Was tryng to reinstall plexwatch today - and some files it tries to grab are no longer available.....

 

*** Running /etc/my_init.d/00_regen_ssh_host_keys.sh...
No SSH host key available. Generating one...
Creating SSH2 RSA key; this may take some time ...
Creating SSH2 DSA key; this may take some time ...
Creating SSH2 ECDSA key; this may take some time ...
Creating SSH2 ED25519 key; this may take some time ...
invoke-rc.d: policy-rc.d denied execution of restart.
*** Running /etc/my_init.d/edge.sh...
Reading package lists...
Building dependency tree...
Reading state information...
The following extra packages will be installed:
git-man liberror-perl patch rsync
Suggested packages:
gettext-base git-daemon-run git-daemon-sysvinit git-doc git-el git-email
git-gui gitk gitweb git-arch git-bzr git-cvs git-mediawiki git-svn ed
diffutils-doc
The following NEW packages will be installed:
git git-man liberror-perl patch rsync
0 upgraded, 5 newly installed, 0 to remove and 77 not upgraded.
Need to get 3713 kB of archives.
After this operation, 22.5 MB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu/ trusty-updates/main rsync amd64 3.1.0-2ubuntu0.1 [283 kB]
Get:2 http://archive.ubuntu.com/ubuntu/ trusty/main liberror-perl all 0.17-1.1 [21.1 kB]
Get:3 http://archive.ubuntu.com/ubuntu/ trusty-updates/main git-man all 1:1.9.1-1ubuntu0.1 [698 kB]
Get:4 http://archive.ubuntu.com/ubuntu/ trusty-updates/main git amd64 1:1.9.1-1ubuntu0.1 [2627 kB]
Err http://archive.ubuntu.com/ubuntu/ trusty-updates/main patch amd64 2.7.1-4ubuntu2
404 Not Found [iP: 91.189.92.201 80]
Fetched 3629 kB in 9s (376 kB/s)
E: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/p/patch/patch_2.7.1-4ubuntu2_amd64.deb 404 Not Found [iP: 91.189.92.201 80]

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
/etc/my_init.d/edge.sh: line 9: git: command not found
chown: cannot access '/var/www/html/plexWatch': No such file or directory
ln: failed to create symbolic link '/var/www/html/plexWatch/config/config.php': No such file or directory
*** /etc/my_init.d/edge.sh failed with status 1

*** Killing all processes...

 

Myk

 

This is needo's container.

Link to post

Schar, I'll be very sincere, I don't have any Logitech player arround, so for me it's difficult to debug it.

 

I'll take a look into it, and see if there's anything I can do, ok?

Ah, understood. Even more thanks are in order then!

 

I invested into the ecosystem over a Roku box way back with the original Squeezebox. The deciding factor back then was Squeeze supporting WPA wireless and the Roku only WEP (with a "promise" for firmware updates, and we all know how that works). The only thing that has almost tempted me since is the Sonos kit, but now that I am invested these devices work a treat and are kid friendly.

 

It is a shame that Logitech have basically killed off the hardware side, so whenever I see well priced second hand units I grab them. I have three booms, a duet and four radios. For those that want units, the Logitech Smartradio can be "downgraded" using built in functionality to the SqeezeRadio functionality.

 

If you are looking to experiment at all, you can grab the headless player SqueezeLite (https://code.google.com/p/squeezelite/) that will play out via your PC speakers. Fully controllable from the WebUI. The only issue I have with that is it tends to turn off with power settings, limiting the use on the media centre (shame as that is the primary user of my main hifi gear). It also isn't overly friendly it seems in sharing the channel, if I play a video it doesn't want to start playing again. I'm going to try and port a copy to .NET and deal to play with this (and ignore or demand a no-hibernate run mode via the appropriate APIs).

 

If you want to take any testing offline, drop me a PM and I'll flick you an email address.

 

Cheers!

 

Link to post

Schar, I'll be very sincere, I don't have any Logitech player arround, so for me it's difficult to debug it.

 

I'll take a look into it, and see if there's anything I can do, ok?

Ah, understood. Even more thanks are in order then!

 

I invested into the ecosystem over a Roku box way back with the original Squeezebox. The deciding factor back then was Squeeze supporting WPA wireless and the Roku only WEP (with a "promise" for firmware updates, and we all know how that works). The only thing that has almost tempted me since is the Sonos kit, but now that I am invested these devices work a treat and are kid friendly.

 

It is a shame that Logitech have basically killed off the hardware side, so whenever I see well priced second hand units I grab them. I have three booms, a duet and four radios. For those that want units, the Logitech Smartradio can be "downgraded" using built in functionality to the SqeezeRadio functionality.

 

If you are looking to experiment at all, you can grab the headless player SqueezeLite (https://code.google.com/p/squeezelite/) that will play out via your PC speakers. Fully controllable from the WebUI. The only issue I have with that is it tends to turn off with power settings, limiting the use on the media centre (shame as that is the primary user of my main hifi gear). It also isn't overly friendly it seems in sharing the channel, if I play a video it doesn't want to start playing again. I'm going to try and port a copy to .NET and deal to play with this (and ignore or demand a no-hibernate run mode via the appropriate APIs).

 

If you want to take any testing offline, drop me a PM and I'll flick you an email address.

 

Cheers!

 

Have you looked into using a Raspberry Pi B+ with either a USB DAC or one of the GPIO DACs? I currently use a Model B (no plus, so USB DAC) to play off the LMS, so I have no Squeeze hardware in my apartment. Bonus points for being controllable from my Crestron system via a module.

Link to post

Not yet, but that is on my list of things to do.

 

Since I'm hardware based apart from the MCE, I've not really played with software versions. The Boom has great sound for a small device, and the duet upstairs is through a lovely old Pioneer A-400 amplifier. They just don't make them like that any more!

 

Link to post

Not yet, but that is on my list of things to do.

 

Since I'm hardware based apart from the MCE, I've not really played with software versions. The Boom has great sound for a small device, and the duet upstairs is through a lovely old Pioneer A-400 amplifier. They just don't make them like that any more!

 

 

Mine is specifically running to a pair of Tascam VL-S5 Studio Monitors with a $10 USB DAC, sounds pretty amazing for my common space (living room/dining room/kitchen).

Link to post

@gfjardim :  Any reason why NZBget docker can't run Updates since a while?? always give error :

 

Currently installed: 15.0
Check failed. Please try again later.

 

The latest is 15.0 , and the new method of installation is not yet well proven. Eventually, I'll fix the update routine.

Link to post

@gfjardim: I am hoping that there may be a way for the Transmission docker to stop overwriting parts of the settings.json file... or for there to be an environment variable to set the bind address... I need to have transmission operate from an alternative IP address, and though I edited the line in the json file, it resets and I'm losing my mind here...  Thanks?

Link to post

@gfjardim: I am hoping that there may be a way for the Transmission docker to stop overwriting parts of the settings.json file... or for there to be an environment variable to set the bind address... I need to have transmission operate from an alternative IP address, and though I edited the line in the json file, it resets and I'm losing my mind here...  Thanks?

 

You have to edit the settings.json file while Transmission isn't running. The container will copy a settings.json file to /config only if it's absent.

Link to post

@gfjardim: I am hoping that there may be a way for the Transmission docker to stop overwriting parts of the settings.json file... or for there to be an environment variable to set the bind address... I need to have transmission operate from an alternative IP address, and though I edited the line in the json file, it resets and I'm losing my mind here...  Thanks?

 

You have to edit the settings.json file while Transmission isn't running. The container will copy a settings.json file to /config only if it's absent.

 

Weird... I swear I tried that... Thanks, totally worked that time I tried it... /sheepishgrin

Link to post

My printer isn't listed when adding it to CUPS.

Is there a way to install the necessary driver?

 

Its a Brother DCP-7065DN.

 

*Edit*

Found the proper PPD file.

Now how do I get google cloud print working?  After adding the appropriate variables CUPS fails to start and does not start if I manually do it.  Any ideas?

 

*EDIT 2*

Seems like this is the culprit "Google authentication failed."

Don't understand why as I've triple checked login and password.  Any ideas?  I have some documents I need to print ASAP.

 

Link to post

My printer isn't listed when adding it to CUPS.

Is there a way to install the necessary driver?

 

Its a Brother DCP-7065DN.

 

*Edit*

Found the proper PPD file.

Now how do I get google cloud print working?  After adding the appropriate variables CUPS fails to start and does not start if I manually do it.  Any ideas?

 

I have the same problem

Link to post

My printer isn't listed when adding it to CUPS.

Is there a way to install the necessary driver?

 

Its a Brother DCP-7065DN.

 

*Edit*

Found the proper PPD file.

Now how do I get google cloud print working?  After adding the appropriate variables CUPS fails to start and does not start if I manually do it.  Any ideas?

 

I have the same problem

 

Check your log under Docker.

I'm getting "Google authentication failed."  Which doesn't make sense because with my RPi it worked fine...

Link to post

My printer isn't listed when adding it to CUPS.

Is there a way to install the necessary driver?

 

Its a Brother DCP-7065DN.

 

*Edit*

Found the proper PPD file.

Now how do I get google cloud print working?  After adding the appropriate variables CUPS fails to start and does not start if I manually do it.  Any ideas?

 

I have the same problem

 

Check your log under Docker.

I'm getting "Google authentication failed."  Which doesn't make sense because with my RPi it worked fine...

 

Exactly the same - I also created 2 app specific passwords which dont work either.

Link to post

My printer isn't listed when adding it to CUPS.

Is there a way to install the necessary driver?

 

Its a Brother DCP-7065DN.

 

*Edit*

Found the proper PPD file.

Now how do I get google cloud print working?  After adding the appropriate variables CUPS fails to start and does not start if I manually do it.  Any ideas?

 

I have the same problem

 

Check your log under Docker.

I'm getting "Google authentication failed."  Which doesn't make sense because with my RPi it worked fine...

 

Exactly the same - I also created 2 app specific passwords which dont work either.

 

I have 2 emails.  A personal one and a "family" which we use for family stuff etc.  It worked under my personal one, but when I switched to the family email it gave me that error, reverted back and same issue.  Don't know wtf is wrong.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.