[Support] Linuxserver.io - SABnzbd


664 posts in this topic Last Reply

Recommended Posts

One little quirk:

 

I left the container port at 8080 but changed the hostport to 8090. I get to sabnzb gui at ip-address:8090, but when I need to restart sabnzb it tries to load it at ip-adres:8080 and I need to enter 8090 manually.

Link to post
  • Replies 663
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I'm seeing the same thing as well.  Found this when searching around:   https://forums.sabnzbd.org/viewtopic.php?t=23364   Started up normally after doing the following:  

It's fixed now. Update the container.

Bumped a new build to pick up 2.2.0 which was released to the sabnzbd ppa about 45 minutes ago (at time of this post). 

Posted Images

One little quirk:

 

I left the container port at 8080 but changed the hostport to 8090. I get to sabnzb gui at ip-address:8090, but when I need to restart sabnzb it tries to load it at ip-adres:8080 and I need to enter 8090 manually.

 

it will always do that, as far as sabnzbd is concerned it's running on port 8080.

Link to post

One little quirk:

 

I left the container port at 8080 but changed the hostport to 8090. I get to sabnzb gui at ip-address:8090, but when I need to restart sabnzb it tries to load it at ip-adres:8080 and I need to enter 8090 manually.

You mean when you click "WebUI" on the docker at unraid?

Link to post

One little quirk:

 

I left the container port at 8080 but changed the hostport to 8090. I get to sabnzb gui at ip-address:8090, but when I need to restart sabnzb it tries to load it at ip-adres:8080 and I need to enter 8090 manually.

 

Not sure what you mean exactly, but if you edit the container, switch the advanced tab on, you should be able to edit which port the webui loads on.

 

u0DNfNp.png

Link to post

One little quirk:

 

I left the container port at 8080 but changed the hostport to 8090. I get to sabnzb gui at ip-address:8090, but when I need to restart sabnzb it tries to load it at ip-adres:8080 and I need to enter 8090 manually.

 

Not sure what you mean exactly, but if you edit the container, switch the advanced tab on, you should be able to edit which port the webui loads on.

 

u0DNfNp.png

Very common misconception

 

You should NEVER actually touch the webUI setting on the template.  Its not a placeholder or anything

 

From your example, http://[ip]:[PORT:2202]/admin, if you leave it alone, unRaid will always display the UI correctly

 

It will parse that line to be:

 

http://whatever_the_ip_of_the_server_is:whatever_host_port_is_mapped_to_container_port2202/admin

 

You only run into trouble when you edit that line. (not to mention that certain versions of Dynamix webUI have an issue with not picking up changes correctly to that entry)

Link to post

Well in that case I'm really confused as to what issue dikkie is having....

 

Sent from my LG-H815 using Tapatalk

The only caveat is the long standing issue with dockerMan where if the webUI entry ever gets changed, it tends not to pick up changes to it, in which case the only solution is to actually start the docker.img file over again from scratch.

 

I have yet to see any container that there is ever a valid reason to change it the entry.  IMO, the webUI entry should only show up on add/edit template if docker is in developer mode.

 

Here's why you should never change it.

 

#1 - The subnet your server is on changes because you grabbed a new router.  Now you have to go and update all of the webUI entries if you changed [iP]

#2 - For whatever reason you decide to change the host port of the applicable webUI port.  Now you have to go and update the webUI entry to account for that.

 

Leaving it alone means that any and all changes to your network will still allow you to hit the webUI.

 

(Side Note: Fix Common Problems will pick up and issue warnings when that entry has been changed)

 

 

Link to post

Well in that case I'm really confused as to what issue dikkie is having....

 

Sent from my LG-H815 using Tapatalk

I have yet to see any container that there is ever a valid reason to change it the entry.

 

There actually is one use case, that's when you modfiy a config to put a weburl on the end.  So http://192.168.1.100:3456 becomes http://192.168.1.1:3456/application 

 

But other than that agree with you completely

Link to post

Well in that case I'm really confused as to what issue dikkie is having....

 

Sent from my LG-H815 using Tapatalk

I have yet to see any container that there is ever a valid reason to change it the entry.

 

There actually is one use case, that's when you modfiy a config to put a weburl on the end.  So http://192.168.1.100:3456 becomes http://192.168.1.1:3456/application 

 

But other than that agree with you completely

Then the maintainer should have done it correctly in the first place  ;)

 

Actually, TBH I never use the webUI to get to any application.  I find bookmarks to be so much easier...

Link to post

Well in that case I'm really confused as to what issue dikkie is having....

 

Sent from my LG-H815 using Tapatalk

I have yet to see any container that there is ever a valid reason to change it the entry.

 

There actually is one use case, that's when you modfiy a config to put a weburl on the end.  So http://192.168.1.100:3456 becomes http://192.168.1.1:3456/application 

 

But other than that agree with you completely

Also another use case. If the container is using the "host" method and there are no ports forwarded, and you change the port for the gui inside the container, then you have to change the webui link manually

Link to post

Well in that case I'm really confused as to what issue dikkie is having....

 

Sent from my LG-H815 using Tapatalk

I have yet to see any container that there is ever a valid reason to change it the entry.

 

There actually is one use case, that's when you modfiy a config to put a weburl on the end.  So http://192.168.1.100:3456 becomes http://192.168.1.1:3456/application 

 

But other than that agree with you completely

Also another use case. If the container is using the "host" method and there are no ports forwarded, and you change the port for the gui inside the container, then you have to change the webui link manually

I guess its gang up on Squid day again  >:(
Link to post

Is anyone else having issues with the container after the new sab update this morning? I had restarted UnRAID to put a new disk in for preclearing and it looks like sab downloaded an update and now I can't get it to come up in the web interface at all, I just get can't connect to server. If I view the docker log outside of the UnRAID logger directly using docker logs -f sabnzbd:

 

EDIT: here is the full log after a restart,

 

-------------------------------------
          _     _ _
         | |___| (_) ___
         | / __| | |/ _ \
         | \__ \ | | (_) |
         |_|___/ |_|\___/
               |_|

Brought to you by linuxserver.io
We do accept donations at:
https://www.linuxserver.io/donations
-------------------------------------
GID/UID
-------------------------------------
User uid:    99
User gid:    100
-------------------------------------

*** Running /etc/my_init.d/20_apt_update.sh...
finding fastest mirror
Getting list of mirrors...done.
Testing latency to mirror(s)
[72/72] 100%
Getting list of launchpad URLs...done.
Looking up 3 status(es)
[3/3] 100%
1. ubuntu.mirrors.tds.net (current)
    Latency: 10.00 ms
    Org:     TDS Internet Services
    Status:  Up to date
    Speed:   1 Gbps
2. mirrors.gigenet.com
    Latency: 11.00 ms
    Org:     GigeNet
    Status:  Up to date
    Speed:   1 Gbps
3. cosmos.cites.illinois.edu
    Latency: 12.99 ms
    Org:     University of Illinois
    Status:  Up to date
    Speed:   100 Mbps
ubuntu.mirrors.tds.net (current) is the currently used mirror.
Skipping file generation
We are now refreshing packages from apt repositories, this *may* take a while
Ign http://ubuntu.mirrors.tds.net trusty InRelease
Hit http://ubuntu.mirrors.tds.net trusty-updates InRelease
Hit http://ubuntu.mirrors.tds.net trusty-security InRelease
Hit http://ubuntu.mirrors.tds.net trusty Release.gpg
Hit http://ubuntu.mirrors.tds.net trusty-updates/main Sources
Hit http://ubuntu.mirrors.tds.net trusty-updates/restricted Sources
Hit http://ubuntu.mirrors.tds.net trusty-updates/universe Sources
Hit http://ubuntu.mirrors.tds.net trusty-updates/multiverse Sources
Hit http://ppa.launchpad.net trusty InRelease
Hit http://ubuntu.mirrors.tds.net trusty-updates/main amd64 Packages
Hit http://ubuntu.mirrors.tds.net trusty-updates/restricted amd64 Packages
Hit http://ubuntu.mirrors.tds.net trusty-updates/universe amd64 Packages
Hit http://ubuntu.mirrors.tds.net trusty-updates/multiverse amd64 Packages
Hit http://ppa.launchpad.net trusty/main amd64 Packages
Hit http://ubuntu.mirrors.tds.net trusty-security/main Sources
Hit http://ubuntu.mirrors.tds.net trusty-security/restricted Sources
Hit http://ubuntu.mirrors.tds.net trusty-security/universe Sources
Hit http://ubuntu.mirrors.tds.net trusty-security/multiverse Sources
Hit http://ubuntu.mirrors.tds.net trusty-security/main amd64 Packages
Hit http://ubuntu.mirrors.tds.net trusty-security/restricted amd64 Packages
Hit http://ubuntu.mirrors.tds.net trusty-security/universe amd64 Packages
Hit http://ubuntu.mirrors.tds.net trusty-security/multiverse amd64 Packages
Hit http://ubuntu.mirrors.tds.net trusty Release
Hit http://ubuntu.mirrors.tds.net trusty/main Sources
Hit http://ubuntu.mirrors.tds.net trusty/restricted Sources
Hit http://ubuntu.mirrors.tds.net trusty/universe Sources
Hit http://ubuntu.mirrors.tds.net trusty/multiverse Sources
Hit http://ubuntu.mirrors.tds.net trusty/main amd64 Packages
Hit http://ubuntu.mirrors.tds.net trusty/restricted amd64 Packages
Hit http://ubuntu.mirrors.tds.net trusty/universe amd64 Packages
Hit http://ubuntu.mirrors.tds.net trusty/multiverse amd64 Packages
Reading package lists...
*** Running /etc/my_init.d/00_regen_ssh_host_keys.sh...
*** Running /etc/my_init.d/10_add_user_abc.sh...
*** Running /etc/my_init.d/20_apt_update.sh...
Getting list of mirrors...done.
Testing latency to mirror(s)
[72/72] 100%
Getting list of launchpad URLs...done.
Looking up 3 status(es)
[3/3] 100%
ubuntu.mirrors.tds.net (current) is the currently used mirror.
Skipping file generation
*** Running /etc/my_init.d/30_set_config.sh...
*** Running /etc/my_init.d/999_advanced_script.sh...
*** Running /etc/rc.local...
*** Booting runit daemon...
*** Runit started as PID 123
Jul  6 14:04:49 3bf6a4df3199 syslog-ng[132]: syslog-ng starting up; version='3.5.3'
Traceback (most recent call last):
  File "/usr/bin/sabnzbdplus", line 55, in <module>
    import cherrypy
  File "/usr/share/sabnzbdplus/cherrypy/__init__.py", line 64, in <module>
    from cherrypy._cperror import HTTPError, HTTPRedirect, InternalRedirect
  File "/usr/share/sabnzbdplus/cherrypy/_cperror.py", line 122, in <module>
    import six
ImportError: No module named six
Traceback (most recent call last):
  File "/usr/bin/sabnzbdplus", line 55, in <module>
    import cherrypy
  File "/usr/share/sabnzbdplus/cherrypy/__init__.py", line 64, in <module>
    from cherrypy._cperror import HTTPError, HTTPRedirect, InternalRedirect
  File "/usr/share/sabnzbdplus/cherrypy/_cperror.py", line 122, in <module>
    import six
ImportError: No module named six
Traceback (most recent call last):
  File "/usr/bin/sabnzbdplus", line 55, in <module>
    import cherrypy
  File "/usr/share/sabnzbdplus/cherrypy/__init__.py", line 64, in <module>
    from cherrypy._cperror import HTTPError, HTTPRedirect, InternalRedirect
  File "/usr/share/sabnzbdplus/cherrypy/_cperror.py", line 122, in <module>
    import six
ImportError: No module named six
Traceback (most recent call last):
  File "/usr/bin/sabnzbdplus", line 55, in <module>
    import cherrypy
  File "/usr/share/sabnzbdplus/cherrypy/__init__.py", line 64, in <module>
    from cherrypy._cperror import HTTPError, HTTPRedirect, InternalRedirect
  File "/usr/share/sabnzbdplus/cherrypy/_cperror.py", line 122, in <module>
    import six
ImportError: No module named six
Traceback (most recent call last):
  File "/usr/bin/sabnzbdplus", line 55, in <module>
    import cherrypy
  File "/usr/share/sabnzbdplus/cherrypy/__init__.py", line 64, in <module>
    from cherrypy._cperror import HTTPError, HTTPRedirect, InternalRedirect
  File "/usr/share/sabnzbdplus/cherrypy/_cperror.py", line 122, in <module>
    import six
ImportError: No module named six
Traceback (most recent call last):
  File "/usr/bin/sabnzbdplus", line 55, in <module>
    import cherrypy
  File "/usr/share/sabnzbdplus/cherrypy/__init__.py", line 64, in <module>
    from cherrypy._cperror import HTTPError, HTTPRedirect, InternalRedirect
  File "/usr/share/sabnzbdplus/cherrypy/_cperror.py", line 122, in <module>
    import six
ImportError: No module named six
Traceback (most recent call last):
  File "/usr/bin/sabnzbdplus", line 55, in <module>
    import cherrypy
  File "/usr/share/sabnzbdplus/cherrypy/__init__.py", line 64, in <module>
    from cherrypy._cperror import HTTPError, HTTPRedirect, InternalRedirect
  File "/usr/share/sabnzbdplus/cherrypy/_cperror.py", line 122, in <module>
    import six
ImportError: No module named six
Traceback (most recent call last):
  File "/usr/bin/sabnzbdplus", line 55, in <module>
    import cherrypy
  File "/usr/share/sabnzbdplus/cherrypy/__init__.py", line 64, in <module>
    from cherrypy._cperror import HTTPError, HTTPRedirect, InternalRedirect
  File "/usr/share/sabnzbdplus/cherrypy/_cperror.py", line 122, in <module>
    import six
ImportError: No module named six

 

I tried deleting and re-creating the container and there is no change, I can see the two ports setup and listening using netstat so it seems like the web server side of it is up? Could there be something wrong with my configuration?

 

In the meantime I have switched to NZBGet, so far I like what I see.

Link to post

Is anyone else having issues with the container after the new sab update this morning? I had restarted UnRAID to put a new disk in for preclearing and it looks like sab downloaded an update and now I can't get it to come up in the web interface at all, I just get can't connect to server. If I view the docker log outside of the UnRAID logger directly using docker logs -f sabnzbd:

 

EDIT: here is the full log after a restart,

 

-------------------------------------
          _     _ _
         | |___| (_) ___
         | / __| | |/ _ \
         | \__ \ | | (_) |
         |_|___/ |_|\___/
               |_|

Brought to you by linuxserver.io
We do accept donations at:
https://www.linuxserver.io/donations
-------------------------------------
GID/UID
-------------------------------------
User uid:    99
User gid:    100
-------------------------------------

*** Running /etc/my_init.d/20_apt_update.sh...
finding fastest mirror
Getting list of mirrors...done.
Testing latency to mirror(s)
[72/72] 100%
Getting list of launchpad URLs...done.
Looking up 3 status(es)
[3/3] 100%
1. ubuntu.mirrors.tds.net (current)
    Latency: 10.00 ms
    Org:     TDS Internet Services
    Status:  Up to date
    Speed:   1 Gbps
2. mirrors.gigenet.com
    Latency: 11.00 ms
    Org:     GigeNet
    Status:  Up to date
    Speed:   1 Gbps
3. cosmos.cites.illinois.edu
    Latency: 12.99 ms
    Org:     University of Illinois
    Status:  Up to date
    Speed:   100 Mbps
ubuntu.mirrors.tds.net (current) is the currently used mirror.
Skipping file generation
We are now refreshing packages from apt repositories, this *may* take a while
Ign http://ubuntu.mirrors.tds.net trusty InRelease
Hit http://ubuntu.mirrors.tds.net trusty-updates InRelease
Hit http://ubuntu.mirrors.tds.net trusty-security InRelease
Hit http://ubuntu.mirrors.tds.net trusty Release.gpg
Hit http://ubuntu.mirrors.tds.net trusty-updates/main Sources
Hit http://ubuntu.mirrors.tds.net trusty-updates/restricted Sources
Hit http://ubuntu.mirrors.tds.net trusty-updates/universe Sources
Hit http://ubuntu.mirrors.tds.net trusty-updates/multiverse Sources
Hit http://ppa.launchpad.net trusty InRelease
Hit http://ubuntu.mirrors.tds.net trusty-updates/main amd64 Packages
Hit http://ubuntu.mirrors.tds.net trusty-updates/restricted amd64 Packages
Hit http://ubuntu.mirrors.tds.net trusty-updates/universe amd64 Packages
Hit http://ubuntu.mirrors.tds.net trusty-updates/multiverse amd64 Packages
Hit http://ppa.launchpad.net trusty/main amd64 Packages
Hit http://ubuntu.mirrors.tds.net trusty-security/main Sources
Hit http://ubuntu.mirrors.tds.net trusty-security/restricted Sources
Hit http://ubuntu.mirrors.tds.net trusty-security/universe Sources
Hit http://ubuntu.mirrors.tds.net trusty-security/multiverse Sources
Hit http://ubuntu.mirrors.tds.net trusty-security/main amd64 Packages
Hit http://ubuntu.mirrors.tds.net trusty-security/restricted amd64 Packages
Hit http://ubuntu.mirrors.tds.net trusty-security/universe amd64 Packages
Hit http://ubuntu.mirrors.tds.net trusty-security/multiverse amd64 Packages
Hit http://ubuntu.mirrors.tds.net trusty Release
Hit http://ubuntu.mirrors.tds.net trusty/main Sources
Hit http://ubuntu.mirrors.tds.net trusty/restricted Sources
Hit http://ubuntu.mirrors.tds.net trusty/universe Sources
Hit http://ubuntu.mirrors.tds.net trusty/multiverse Sources
Hit http://ubuntu.mirrors.tds.net trusty/main amd64 Packages
Hit http://ubuntu.mirrors.tds.net trusty/restricted amd64 Packages
Hit http://ubuntu.mirrors.tds.net trusty/universe amd64 Packages
Hit http://ubuntu.mirrors.tds.net trusty/multiverse amd64 Packages
Reading package lists...
*** Running /etc/my_init.d/00_regen_ssh_host_keys.sh...
*** Running /etc/my_init.d/10_add_user_abc.sh...
*** Running /etc/my_init.d/20_apt_update.sh...
Getting list of mirrors...done.
Testing latency to mirror(s)
[72/72] 100%
Getting list of launchpad URLs...done.
Looking up 3 status(es)
[3/3] 100%
ubuntu.mirrors.tds.net (current) is the currently used mirror.
Skipping file generation
*** Running /etc/my_init.d/30_set_config.sh...
*** Running /etc/my_init.d/999_advanced_script.sh...
*** Running /etc/rc.local...
*** Booting runit daemon...
*** Runit started as PID 123
Jul  6 14:04:49 3bf6a4df3199 syslog-ng[132]: syslog-ng starting up; version='3.5.3'
Traceback (most recent call last):
  File "/usr/bin/sabnzbdplus", line 55, in <module>
    import cherrypy
  File "/usr/share/sabnzbdplus/cherrypy/__init__.py", line 64, in <module>
    from cherrypy._cperror import HTTPError, HTTPRedirect, InternalRedirect
  File "/usr/share/sabnzbdplus/cherrypy/_cperror.py", line 122, in <module>
    import six
ImportError: No module named six
Traceback (most recent call last):
  File "/usr/bin/sabnzbdplus", line 55, in <module>
    import cherrypy
  File "/usr/share/sabnzbdplus/cherrypy/__init__.py", line 64, in <module>
    from cherrypy._cperror import HTTPError, HTTPRedirect, InternalRedirect
  File "/usr/share/sabnzbdplus/cherrypy/_cperror.py", line 122, in <module>
    import six
ImportError: No module named six
Traceback (most recent call last):
  File "/usr/bin/sabnzbdplus", line 55, in <module>
    import cherrypy
  File "/usr/share/sabnzbdplus/cherrypy/__init__.py", line 64, in <module>
    from cherrypy._cperror import HTTPError, HTTPRedirect, InternalRedirect
  File "/usr/share/sabnzbdplus/cherrypy/_cperror.py", line 122, in <module>
    import six
ImportError: No module named six
Traceback (most recent call last):
  File "/usr/bin/sabnzbdplus", line 55, in <module>
    import cherrypy
  File "/usr/share/sabnzbdplus/cherrypy/__init__.py", line 64, in <module>
    from cherrypy._cperror import HTTPError, HTTPRedirect, InternalRedirect
  File "/usr/share/sabnzbdplus/cherrypy/_cperror.py", line 122, in <module>
    import six
ImportError: No module named six
Traceback (most recent call last):
  File "/usr/bin/sabnzbdplus", line 55, in <module>
    import cherrypy
  File "/usr/share/sabnzbdplus/cherrypy/__init__.py", line 64, in <module>
    from cherrypy._cperror import HTTPError, HTTPRedirect, InternalRedirect
  File "/usr/share/sabnzbdplus/cherrypy/_cperror.py", line 122, in <module>
    import six
ImportError: No module named six
Traceback (most recent call last):
  File "/usr/bin/sabnzbdplus", line 55, in <module>
    import cherrypy
  File "/usr/share/sabnzbdplus/cherrypy/__init__.py", line 64, in <module>
    from cherrypy._cperror import HTTPError, HTTPRedirect, InternalRedirect
  File "/usr/share/sabnzbdplus/cherrypy/_cperror.py", line 122, in <module>
    import six
ImportError: No module named six
Traceback (most recent call last):
  File "/usr/bin/sabnzbdplus", line 55, in <module>
    import cherrypy
  File "/usr/share/sabnzbdplus/cherrypy/__init__.py", line 64, in <module>
    from cherrypy._cperror import HTTPError, HTTPRedirect, InternalRedirect
  File "/usr/share/sabnzbdplus/cherrypy/_cperror.py", line 122, in <module>
    import six
ImportError: No module named six
Traceback (most recent call last):
  File "/usr/bin/sabnzbdplus", line 55, in <module>
    import cherrypy
  File "/usr/share/sabnzbdplus/cherrypy/__init__.py", line 64, in <module>
    from cherrypy._cperror import HTTPError, HTTPRedirect, InternalRedirect
  File "/usr/share/sabnzbdplus/cherrypy/_cperror.py", line 122, in <module>
    import six
ImportError: No module named six

 

I tried deleting and re-creating the container and there is no change, I can see the two ports setup and listening using netstat so it seems like the web server side of it is up? Could there be something wrong with my configuration?

 

In the meantime I have switched to NZBGet, so far I like what I see.

 

SABnzbd updated for me too. Can't reconnect to it either. Deleted the container also and there was no change. Posted on Reddit to the developers but no one has gotten back to me. There was mention of the folks over at qnap are having a similar problem.

Link to post

It's a problem with the PPA version of Sabnzbd.

 

In the meantime you can add a variable

 

ADVANCED_DISABLEUPDATES

 

and set it to

 

TRUE

 

which will disable the autoupdate.  When the PPA version is fixed then remove the variable.

 

*** Running /etc/my_init.d/00_regen_ssh_host_keys.sh...
*** Running /etc/my_init.d/10_add_user_abc.sh...

-------------------------------------
_ _ _
| |___| (_) ___
| / __| | |/ _ \
| \__ \ | | (_) |
|_|___/ |_|\___/
|_|

Brought to you by linuxserver.io
We do accept donations at:
https://www.linuxserver.io/donations
-------------------------------------
GID/UID
-------------------------------------
User uid: 99
User gid: 100
-------------------------------------

*** Running /etc/my_init.d/20_apt_update.sh...
*** Running /etc/my_init.d/30_set_config.sh...
*** Running /etc/my_init.d/999_advanced_script.sh...
*** Running /etc/rc.local...
*** Booting runit daemon...
*** Runit started as PID 32
Jul 7 00:20:04 cc7be5b0738c syslog-ng[40]: syslog-ng starting up; version='3.5.3'

2016-07-07 00:20:05,215::INFO::[sabnzbdplus:1231] --------------------------------
2016-07-07 00:20:05,215::INFO::[sabnzbdplus:1232] sabnzbdplus-1.0.2 (rev=b7e2bd96844d85623458ea5ad02432becdb199e5)
2016-07-07 00:20:05,216::INFO::[sabnzbdplus:1233] Full executable path = /usr/bin/sabnzbdplus
2016-07-07 00:20:05,216::INFO::[sabnzbdplus:1245] Platform = posix
2016-07-07 00:20:05,216::INFO::[sabnzbdplus:1246] Python-version = 2.7.6 (default, Jun 22 2015, 17:58:13)

[GCC 4.8.2]
2016-07-07 00:20:05,216::INFO::[sabnzbdplus:1247] Arguments = /usr/bin/sabnzbdplus --config-file /config --server 0.0.0.0:8080
2016-07-07 00:20:05,216::INFO::[sabnzbdplus:1249] Preferred encoding = UTF-8
2016-07-07 00:20:05,216::INFO::[sabnzbdplus:1297] Read INI file /config/sabnzbd.ini
2016-07-07 00:20:05,216::INFO::[misc:434] download_dir directory: /config/Downloads/incomplete does not exist, try to create it
2016-07-07 00:20:05,217::INFO::[__init__:965] Loading data for queue9.sab from /config/admin/queue9.sab
2016-07-07 00:20:05,217::INFO::[__init__:968] /config/admin/queue9.sab missing
2016-07-07 00:20:05,217::INFO::[__init__:965] Loading data for queue8.sab from /config/admin/queue8.sab
2016-07-07 00:20:05,217::INFO::[__init__:968] /config/admin/queue8.sab missing
2016-07-07 00:20:05,217::INFO::[__init__:965] Loading data for queue7.sab from /config/admin/queue7.sab
2016-07-07 00:20:05,217::INFO::[__init__:968] /config/admin/queue7.sab missing
2016-07-07 00:20:05,232::INFO::[__init__:965] Loading data for rss_data.sab from /config/admin/rss_data.sab
2016-07-07 00:20:05,233::INFO::[__init__:968] /config/admin/rss_data.sab missing
2016-07-07 00:20:05,233::INFO::[__init__:965] Loading data for totals10.sab from /config/admin/totals10.sab
2016-07-07 00:20:05,233::INFO::[__init__:968] /config/admin/totals10.sab missing
2016-07-07 00:20:05,233::INFO::[__init__:965] Loading data for totals9.sab from /config/admin/totals9.sab
2016-07-07 00:20:05,233::INFO::[__init__:968] /config/admin/totals9.sab missing
2016-07-07 00:20:05,611::INFO::[postproc:89] Loading postproc queue
2016-07-07 00:20:05,611::INFO::[__init__:965] Loading data for postproc2.sab from /config/admin/postproc2.sab
2016-07-07 00:20:05,611::INFO::[__init__:968] /config/admin/postproc2.sab missing
2016-07-07 00:20:05,612::INFO::[__init__:965] Loading data for queue10.sab from /config/admin/queue10.sab
2016-07-07 00:20:05,612::INFO::[__init__:968] /config/admin/queue10.sab missing
2016-07-07 00:20:05,612::INFO::[__init__:965] Loading data for queue9.sab from /config/admin/queue9.sab
2016-07-07 00:20:05,612::INFO::[__init__:968] /config/admin/queue9.sab missing
2016-07-07 00:20:05,613::INFO::[__init__:965] Loading data for watched_data2.sab from /config/admin/watched_data2.sab
2016-07-07 00:20:05,613::INFO::[__init__:968] /config/admin/watched_data2.sab missing
2016-07-07 00:20:05,613::INFO::[__init__:965] Loading data for Rating.sab from /config/admin/Rating.sab
2016-07-07 00:20:05,613::INFO::[__init__:968] /config/admin/Rating.sab missing
2016-07-07 00:20:05,614::INFO::[scheduler:180] Setting schedule for midnight BPS reset
2016-07-07 00:20:05,614::INFO::[downloader:241] Resuming
2016-07-07 00:20:05,623::INFO::[__init__:350] All processes started
2016-07-07 00:20:05,623::INFO::[sabnzbdplus:356] Web dir is /usr/share/sabnzbdplus/interfaces/Glitter
2016-07-07 00:20:05,623::INFO::[sabnzbdplus:356] Web dir is /usr/share/sabnzbdplus/interfaces/Config
2016-07-07 00:20:05,642::INFO::[sabnzbdplus:471] _yenc module... found!
2016-07-07 00:20:05,642::INFO::[sabnzbdplus:479] par2 binary... found (/usr/bin/par2)
2016-07-07 00:20:05,642::INFO::[sabnzbdplus:484] par2-classic binary... found (/usr/bin/par2)
2016-07-07 00:20:05,642::INFO::[sabnzbdplus:487] UNRAR binary... found (/usr/bin/unrar)
2016-07-07 00:20:05,643::INFO::[sabnzbdplus:493] unzip binary... found (/usr/bin/unzip)
2016-07-07 00:20:05,643::INFO::[sabnzbdplus:499] 7za binary... found (/usr/bin/7za)
2016-07-07 00:20:05,643::INFO::[sabnzbdplus:506] nice binary... found (/usr/bin/nice)
2016-07-07 00:20:05,643::INFO::[sabnzbdplus:510] ionice binary... found (/usr/bin/ionice)
2016-07-07 00:20:05,643::INFO::[sabnzbdplus:515] pyOpenSSL... found (True)
2016-07-07 00:20:05,643::INFO::[sabnzbdplus:1360] SSL version OpenSSL 1.0.1f 6 Jan 2014

2016-07-07 00:20:05,643::INFO::[sabnzbdplus:1361] pyOpenSSL version 0.13

2016-07-07 00:20:05,643::INFO::[sabnzbdplus:1362] SSL potentially supported protocols ['SSLv23', 'SSLv3', 'TLSv1']
2016-07-07 00:20:05,644::INFO::[sabnzbdplus:1363] SSL actually supported protocols ['t1', 'v23', 'v3']
2016-07-07 00:20:05,646::INFO::[sabnzbdplus:1510] Starting web-interface on 0.0.0.0:8080
2016-07-07 00:20:05,649::INFO::[_cplogging:216] [07/Jul/2016:00:20:05] ENGINE Bus STARTING
2016-07-07 00:20:05,651::INFO::[_cplogging:216] [07/Jul/2016:00:20:05] ENGINE Started monitor thread '_TimeoutMonitor'.
2016-07-07 00:20:05,753::INFO::[_cplogging:216] [07/Jul/2016:00:20:05] ENGINE Serving on http://0.0.0.0:8080
2016-07-07 00:20:05,753::INFO::[_cplogging:216] [07/Jul/2016:00:20:05] ENGINE Bus STARTED
2016-07-07 00:20:05,754::INFO::[panic:270] Launching browser with http://127.0.0.1:8080/sabnzbd
2016-07-07 00:20:05,754::INFO::[sabnzbdplus:1582] Starting sabnzbdplus-1.0.2
2016-07-07 00:20:05,755::INFO::[dirscanner:302] Dirscanner starting up
2016-07-07 00:20:05,756::INFO::[urlgrabber:69] URLGrabber starting up

Link to post

It's a problem with the PPA version of Sabnzbd.

 

In the meantime you can add a variable

 

ADVANCED_DISABLEUPDATES

 

and set it to

 

TRUE

 

which will disable the autoupdate.  When the PPA version is fixed then remove the variable.

 

*** Running /etc/my_init.d/00_regen_ssh_host_keys.sh...
*** Running /etc/my_init.d/10_add_user_abc.sh...

-------------------------------------
_ _ _
| |___| (_) ___
| / __| | |/ _ \
| \__ \ | | (_) |
|_|___/ |_|\___/
|_|

Brought to you by linuxserver.io
We do accept donations at:
https://www.linuxserver.io/donations
-------------------------------------
GID/UID
-------------------------------------
User uid: 99
User gid: 100
-------------------------------------

*** Running /etc/my_init.d/20_apt_update.sh...
*** Running /etc/my_init.d/30_set_config.sh...
*** Running /etc/my_init.d/999_advanced_script.sh...
*** Running /etc/rc.local...
*** Booting runit daemon...
*** Runit started as PID 32
Jul 7 00:20:04 cc7be5b0738c syslog-ng[40]: syslog-ng starting up; version='3.5.3'

2016-07-07 00:20:05,215::INFO::[sabnzbdplus:1231] --------------------------------
2016-07-07 00:20:05,215::INFO::[sabnzbdplus:1232] sabnzbdplus-1.0.2 (rev=b7e2bd96844d85623458ea5ad02432becdb199e5)
2016-07-07 00:20:05,216::INFO::[sabnzbdplus:1233] Full executable path = /usr/bin/sabnzbdplus
2016-07-07 00:20:05,216::INFO::[sabnzbdplus:1245] Platform = posix
2016-07-07 00:20:05,216::INFO::[sabnzbdplus:1246] Python-version = 2.7.6 (default, Jun 22 2015, 17:58:13)

[GCC 4.8.2]
2016-07-07 00:20:05,216::INFO::[sabnzbdplus:1247] Arguments = /usr/bin/sabnzbdplus --config-file /config --server 0.0.0.0:8080
2016-07-07 00:20:05,216::INFO::[sabnzbdplus:1249] Preferred encoding = UTF-8
2016-07-07 00:20:05,216::INFO::[sabnzbdplus:1297] Read INI file /config/sabnzbd.ini
2016-07-07 00:20:05,216::INFO::[misc:434] download_dir directory: /config/Downloads/incomplete does not exist, try to create it
2016-07-07 00:20:05,217::INFO::[__init__:965] Loading data for queue9.sab from /config/admin/queue9.sab
2016-07-07 00:20:05,217::INFO::[__init__:968] /config/admin/queue9.sab missing
2016-07-07 00:20:05,217::INFO::[__init__:965] Loading data for queue8.sab from /config/admin/queue8.sab
2016-07-07 00:20:05,217::INFO::[__init__:968] /config/admin/queue8.sab missing
2016-07-07 00:20:05,217::INFO::[__init__:965] Loading data for queue7.sab from /config/admin/queue7.sab
2016-07-07 00:20:05,217::INFO::[__init__:968] /config/admin/queue7.sab missing
2016-07-07 00:20:05,232::INFO::[__init__:965] Loading data for rss_data.sab from /config/admin/rss_data.sab
2016-07-07 00:20:05,233::INFO::[__init__:968] /config/admin/rss_data.sab missing
2016-07-07 00:20:05,233::INFO::[__init__:965] Loading data for totals10.sab from /config/admin/totals10.sab
2016-07-07 00:20:05,233::INFO::[__init__:968] /config/admin/totals10.sab missing
2016-07-07 00:20:05,233::INFO::[__init__:965] Loading data for totals9.sab from /config/admin/totals9.sab
2016-07-07 00:20:05,233::INFO::[__init__:968] /config/admin/totals9.sab missing
2016-07-07 00:20:05,611::INFO::[postproc:89] Loading postproc queue
2016-07-07 00:20:05,611::INFO::[__init__:965] Loading data for postproc2.sab from /config/admin/postproc2.sab
2016-07-07 00:20:05,611::INFO::[__init__:968] /config/admin/postproc2.sab missing
2016-07-07 00:20:05,612::INFO::[__init__:965] Loading data for queue10.sab from /config/admin/queue10.sab
2016-07-07 00:20:05,612::INFO::[__init__:968] /config/admin/queue10.sab missing
2016-07-07 00:20:05,612::INFO::[__init__:965] Loading data for queue9.sab from /config/admin/queue9.sab
2016-07-07 00:20:05,612::INFO::[__init__:968] /config/admin/queue9.sab missing
2016-07-07 00:20:05,613::INFO::[__init__:965] Loading data for watched_data2.sab from /config/admin/watched_data2.sab
2016-07-07 00:20:05,613::INFO::[__init__:968] /config/admin/watched_data2.sab missing
2016-07-07 00:20:05,613::INFO::[__init__:965] Loading data for Rating.sab from /config/admin/Rating.sab
2016-07-07 00:20:05,613::INFO::[__init__:968] /config/admin/Rating.sab missing
2016-07-07 00:20:05,614::INFO::[scheduler:180] Setting schedule for midnight BPS reset
2016-07-07 00:20:05,614::INFO::[downloader:241] Resuming
2016-07-07 00:20:05,623::INFO::[__init__:350] All processes started
2016-07-07 00:20:05,623::INFO::[sabnzbdplus:356] Web dir is /usr/share/sabnzbdplus/interfaces/Glitter
2016-07-07 00:20:05,623::INFO::[sabnzbdplus:356] Web dir is /usr/share/sabnzbdplus/interfaces/Config
2016-07-07 00:20:05,642::INFO::[sabnzbdplus:471] _yenc module... found!
2016-07-07 00:20:05,642::INFO::[sabnzbdplus:479] par2 binary... found (/usr/bin/par2)
2016-07-07 00:20:05,642::INFO::[sabnzbdplus:484] par2-classic binary... found (/usr/bin/par2)
2016-07-07 00:20:05,642::INFO::[sabnzbdplus:487] UNRAR binary... found (/usr/bin/unrar)
2016-07-07 00:20:05,643::INFO::[sabnzbdplus:493] unzip binary... found (/usr/bin/unzip)
2016-07-07 00:20:05,643::INFO::[sabnzbdplus:499] 7za binary... found (/usr/bin/7za)
2016-07-07 00:20:05,643::INFO::[sabnzbdplus:506] nice binary... found (/usr/bin/nice)
2016-07-07 00:20:05,643::INFO::[sabnzbdplus:510] ionice binary... found (/usr/bin/ionice)
2016-07-07 00:20:05,643::INFO::[sabnzbdplus:515] pyOpenSSL... found (True)
2016-07-07 00:20:05,643::INFO::[sabnzbdplus:1360] SSL version OpenSSL 1.0.1f 6 Jan 2014

2016-07-07 00:20:05,643::INFO::[sabnzbdplus:1361] pyOpenSSL version 0.13

2016-07-07 00:20:05,643::INFO::[sabnzbdplus:1362] SSL potentially supported protocols ['SSLv23', 'SSLv3', 'TLSv1']
2016-07-07 00:20:05,644::INFO::[sabnzbdplus:1363] SSL actually supported protocols ['t1', 'v23', 'v3']
2016-07-07 00:20:05,646::INFO::[sabnzbdplus:1510] Starting web-interface on 0.0.0.0:8080
2016-07-07 00:20:05,649::INFO::[_cplogging:216] [07/Jul/2016:00:20:05] ENGINE Bus STARTING
2016-07-07 00:20:05,651::INFO::[_cplogging:216] [07/Jul/2016:00:20:05] ENGINE Started monitor thread '_TimeoutMonitor'.
2016-07-07 00:20:05,753::INFO::[_cplogging:216] [07/Jul/2016:00:20:05] ENGINE Serving on http://0.0.0.0:8080
2016-07-07 00:20:05,753::INFO::[_cplogging:216] [07/Jul/2016:00:20:05] ENGINE Bus STARTED
2016-07-07 00:20:05,754::INFO::[panic:270] Launching browser with http://127.0.0.1:8080/sabnzbd
2016-07-07 00:20:05,754::INFO::[sabnzbdplus:1582] Starting sabnzbdplus-1.0.2
2016-07-07 00:20:05,755::INFO::[dirscanner:302] Dirscanner starting up
2016-07-07 00:20:05,756::INFO::[urlgrabber:69] URLGrabber starting up

 

Not sure how to do what you're saying. Tried searching around on "how to" edit variables in unRAID but didn't find anything I understood.

 

Edit: NM I was able to figure it out. On Docker page edit SABnzbd. Top right click Advanced View. Scroll down to Environment Variables and add it there. Thanks!

Link to post

Edit the container then,

 

If you're on 6.2, click on Add Another Port, Path, Or Variable and add an environment variable.

 

If you're on 6.1, click on advanced settings then add an environment variable

Link to post

Edit the container then,

 

If you're on 6.2, click on Add Another Port, Path, Or Variable and add an environment variable.

 

If you're on 6.1, click on advanced settings then add an environment variable

 

Got it! Thanks.

Link to post

Edit the container then,

 

If you're on 6.2, click on Add Another Port, Path, Or Variable and add an environment variable.

 

If you're on 6.1, click on advanced settings then add an environment variable

 

Got it! Thanks.

 

Setting the variable to false won't turn back on the autoupdate btw.  You need to remove the variable entirely.

Link to post

It's a problem with the PPA version of Sabnzbd.

So this has happened a few times now, but I never see anything about it in the sab forums.  Is this the same PPA that everyone else uses?  Does this problem only seem to become apparent when used within a Docker?  So confused why it affects us (unRAID users) but not the sab userbase as a whole.

 

Edit: Not sure if this can be circumvented on the container side by incorporating "six", but that's what QNAP users did apparently to solve their similar issue.

Link to post

Back up and running for me! Thank you if anything was done behind the scenes!

Fixed for me as well, looks like the missing python package was added to resolve the issue.

 

the maintainer of the sab PPA fixed their mess and added the missing package there.

 

 

Link to post

Back up and running for me! Thank you if anything was done behind the scenes!

Fixed for me as well, looks like the missing python package was added to resolve the issue.

 

can anyone confirm it's fixed? haven't restarted my unraid array in forever but had to do today and sab wouldn't work. only after i added ADVANCED_DISABLEUPDATES did it work.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.