Jump to content
binhex

[Support] binhex - rTorrentVPN

2313 posts in this topic Last Reply

Recommended Posts

? And I thought I was done....doing it via the browser on my phone.

But thanks one more time - I'll give it a try, hoping that the GUI will be somewhat more accommodating than your average browser interface on a phone.?

 

Edited by whauk

Share this post


Link to post

Where can I state a different port no. in Transdroid? So far it seems hardwired: Either 80 for http or 443 for https.

Share this post


Link to post
Where can I state a different port no. in Transdroid? So far it seems hardwired: Either 80 for http or 443 for https.
Settings/servers/click on your server/advanced settings/port

Sent from my SM-G935F using Tapatalk

Share this post


Link to post
15 hours ago, binhex said:

 

you are missing the two cert files, as shown in your log:-

 


Options error: --ca fails with 'ca.rsa.2048.crt': No such file or directory (errno=2)
Options error: --crl-verify fails with 'crl.rsa.2048.pem': No such file or directory (errno=2)

they are included in the zip you download from PIA, so you need the two certs and a single ovpn file in the /config/openvpn/ folder

 

Solved the issue; that was a simple one! and thanks for the quick answer binhex

Share this post


Link to post
On 5/1/2018 at 2:13 PM, binhex said:

Settings/servers/click on your server/advanced settings/port

Sent from my SM-G935F using Tapatalk
 

Hey binhex, whats the command to reboot "autodl plugin only" in rtorrent docker? Thanks in advance 

Share this post


Link to post
10 hours ago, pervin_1 said:

Hey binhex, whats the command to reboot "autodl plugin only" in rtorrent docker? Thanks in advance 

 

not sure what you mean by 'reboot autodl plugin' ? do you mean you want to just reload the plugin only and not the entire container?.

Share this post


Link to post
2 hours ago, binhex said:

I don't want to reload the entire container with 500+ Torrents, was wondering if there is a way to reload the AutoDL plugin itself? 

I used to have a seedbox and there was an option to reload the AutoDL from the webUI, it was a shared seedbox based on Ubuntu.  

2 hours ago, binhex said:

not sure what you mean by 'reboot autodl plugin' ? do you mean you want to just reload the plugin only and not the entire container?.

 

Share this post


Link to post
1 hour ago, pervin_1 said:

I don't want to reload the entire container with 500+ Torrents, was wondering if there is a way to reload the AutoDL plugin itself? 

I used to have a seedbox and there was an option to reload the AutoDL from the webUI, it was a shared seedbox based on Ubuntu.  

 

 

im not sure how you could achieve this, its currently marked as mandatory due to the way its loaded/unloaded depending on setting irssi to enabled or not as an env var.

 

That aside though, can i ask why you need to reload it?, if you simply want to 'reload trackers' or 'update' then you can do this from the web ui, look at the 'autodl-irssi' tab at the bottom of the main window for rutorrent.

Share this post


Link to post
4 hours ago, binhex said:

 

im not sure how you could achieve this, its currently marked as mandatory due to the way its loaded/unloaded depending on setting irssi to enabled or not as an env var.

 

That aside though, can i ask why you need to reload it?, if you simply want to 'reload trackers' or 'update' then you can do this from the web ui, look at the 'autodl-irssi' tab at the bottom of the main window for rutorrent.

True, I can do that too from the webUI, IDK how my seedbox provider does it through the web page, but after clicking the "restart" button on the webpage on my seedbox panel (BTW seedhost.eu) I can see the AutoDl starts with showing the version and loading trackers, maybe they somehow reload the IRSSI client, anyway, no worries, as you said, I can update the plugin and the settings from the webUI from now on!!!

 

Thank you!!!

Share this post


Link to post

I'd prefer to have this container accessible through my linuxserver/letsencrypt reverse proxy, has anyone got that working well and can post their config?  I've been trying it with various options and haven't gotten it quite right.  When I refresh the page it seems almost random what happens, sometimes it loads correctly, sometimes it times out, sometimes it takes a long time to load, sometimes it loads some of the interface but with an error.  

 

Seems similar to an issue kostecki was having but that was back in August and I didn't see any response to it.  

 

Reverse proxy on same local network as rtorrentvpn, using a subdomain, rtorrentvpn loads correctly when going directly to IP:9080, other sites using reverse proxy working normally.  

 

EDIT: Think I've got it working, will edit post again if I find an issue after a couple days of testing.

Commented out authorization in the rtorrentvpn container by editing nginx.conf

Used the below server and location block on the reverse proxy container.

 

#RTorrentVPN
server {
    listen 443 ssl http2;

    #root /config/www;
    #index index.html index.htm index.php;

    server_name rvpn.domain.com;

    include /config/nginx/ssl.conf;

    client_max_body_size 0;

location / {
     proxy_pass_header Authorization;
     proxy_pass http://192.168.1.XXX:9080;
     proxy_set_header Host $host;
     proxy_set_header X-Real-IP  $remote_addr;
     proxy_http_version 1.1;
     proxy_set_header Connection "";
     proxy_buffering off;
     proxy_request_buffering off;
     client_max_body_size 0;
     proxy_read_timeout  36000s;
     proxy_redirect off;
     proxy_ssl_session_reuse off;
     auth_basic "Restricted Content";
     auth_basic_user_file /config/nginx/.htpasswd;
   }
}

 

Edited by THF13

Share this post


Link to post
On ‎3‎/‎6‎/‎2018 at 7:20 PM, c0nfuzed said:

I just found a bug, it only appears to have started recently so I suspect something changed at my VPN provider.

 

The script that detects my public IP fails about 90% of the time because ... 


# from /root/getvpnextip.sh
$(dig -b ${vpn_ip} TXT +short o-o.myaddr.l.google.com @${pri_ns} 2> /dev/null | tr -d '"')

returns a IPv6 address rather than IPv4 as expected by the script.

 

Additionally, and I'm not sure why, but when it does return an IPV4 address it is always different than what I get from 


curl ipinfo.io/ip

by exactly 1... so if google's dns is reporting my IP is 1.1.1.1 then ipinfo.io/ip is reporting that it's 1.1.1.2... I don't fully understand why they would be different, but I fear that googles dns is wrong... might explain why I am not seeding as well as I would like.

 

Were you ever able to solve this issue? I'm also using Mullvad and I'm having the exact same issue...

Share this post


Link to post

Hi guys... I can't for the life of me figure out how to fix this error... any ideas?

Using PIA VPN, transferred the .ovpn (same as the deluge install this is replacing). This seems to be stopping any torrents from connecting to peers... 

 

018/05/13 07:54:24 [error] 941#941: *1 FastCGI sent in stderr: "PHP message: PHP Warning: fopen(/usr/share/webapps/rutorrent/share/settings/uisettings.json): failed to open stream: No such file or directory in /usr/share/webapps/rutorrent/php/getsettings.php on line 7" while reading response header from upstream, client: 192.168.1.24, server: localhost, request: "POST /php/getsettings.php HTTP/1.1", upstream: "fastcgi://127.0.0.1:7777", host: "192.168.1.17:9080", referrer: "http://192.168.1.17:9080/"

 

 

Edited by GoudaK

Share this post


Link to post

This is in my log file:

2018/05/16 09:50:52 [warn] 891#891: could not build optimal types_hash, you should increase either types_hash_max_size: 2048 or types_hash_bucket_size: 64; ignoring types_hash_bucket_size

Anything to be concerned about? Is there something I can do for this warning?

 

Thanks!

Share this post


Link to post
Thanks Binhex as always, beer coming your way brother.
Thanks, all donations to keep me hydrated very welcome

Sent from my SM-G935F using Tapatalk

Share this post


Link to post

Is there anyway to set this to point to another gateway for VPN VM I already have setup? As I think my VPN Provider only allows 1 connection so I was looking to setup Transmission on a VM and point it to the VPN server IP as the gateway.

 

ps.. Donation sent ?

Edited by witalit

Share this post


Link to post
Is there anyway to set this to point to another gateway for VPN VM I already have setup? As I think my VPN Provider only allows 1 connection so I was looking to setup Transmission on a VM and point it to the VPN server IP as the gateway.
 
ps.. Donation sent
No I'm afraid you can't do that, the gateway is defined by the tunnel.

Sent from my SM-G935F using Tapatalk

Share this post


Link to post

Ah no problem I first need to work out why I cant download the docker.. this Mikrotik router is great but super secure I need to do some port forwarding I think.

Sent from my Pixel 2 XL using Tapatalk

Share this post


Link to post

Is it possible to change to custom docker IP on br0? Only allows me to connect if i run as Bridge mode when I set custom I cannot connect to WebUI. 

 

Thanks

Share this post


Link to post
Is it possible to change to custom docker IP on br0? Only allows me to connect if i run as Bridge mode when I set custom I cannot connect to WebUI. 
 
Thanks
It's untested and thus currently unsupported, unlikely I will have time to look at it any time soon, so best bet is to stick with bridge mode on default settings.

Sent from my SM-G935F using Tapatalk

Share this post


Link to post

Honestly its fine, as long as I can browse to unraid from my VM VPN then its fine. 

 

Edit: Don't look like I can hmm need to look into this. 

 

Thanks dude. 

Edited by witalit

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.