[Support] Linuxserver.io - Nextcloud


Recommended Posts


Doesn’t appear to be working here unless I’ve broken something else. Just restarted Nextcloud and Collabora so will try again in a sec. just sits on connecting.

15c0afb0d6363348c4271c2a16002f50.jpg
77f72239a3f91b5f4d417f25f9764f2d.png
Use :6.4.10.6
Just in case it used a cached image.


Sent from my Mi 10 Pro using Tapatalk

Link to comment
Use :6.4.10.6
Just in case it used a cached image.


Sent from my Mi 10 Pro using Tapatalk


Will try in AM. On my way to bed at current. Maybe I broke something else; albeit I haven’t been muckin in things LOL

Thank you, Skois
  • Like 1
Link to comment
Use :6.4.10.6
Just in case it used a cached image.


Sent from my Mi 10 Pro using Tapatalk


Downgrade 6.4.9.3 and instantly works… log last night makes me wonder if it isn’t something with certificate verification box? Never had issue 6.4.9.3 before though or had to toggle that

I can’t get 6.4.10.6 to work though

feba8d647ad78a9edd3c95560d4f470b.png

a6a6e1fb3b3e19345043d0c055e1936f.png
Link to comment

Downgrade 6.4.9.3 and instantly works… log last night makes me wonder if it isn’t something with certificate verification box? Never had issue 6.4.9.3 before though or had to toggle that

I can’t get 6.4.10.6 to work though

feba8d647ad78a9edd3c95560d4f470b.png

085d72f6aec70435ea5c836584fecea4.png
Hmm try with incognito, maybe something in cache?
For me works very good, it's even faster

Sent from my Mi 10 Pro using Tapatalk

Link to comment
Hmm try with incognito, maybe something in cache?
For me works very good, it's even faster

Sent from my Mi 10 Pro using Tapatalk


Played with it more; still no dice . I’m sure it’s fail on my part just don’t know what
Link to comment
6 minutes ago, blaine07 said:


Played with it more; still no dice emoji22.png. I’m sure it’s fail on my part just don’t know what

I don't know what else might be :/ Maybe it's worth posting a bug report on Collabora's github.

Link to comment

Hi everyone,

i need your help

I'm on NextCloud 21.0.3

and, of course, i've these messeges:

 

nextcloud.thumb.png.e3e2c1ac68b39d1ef26efb8ce940ecd6.png

 

this is my DEFAULT file:

 

upstream php-handler {
    server 127.0.0.1:9000;
}
server {
    listen 80;
    listen [::]:80;
    server_name _;
    return 301 https://$host$request_uri;
}
server {
    listen 443 ssl http2;
    listen [::]:443 ssl http2;
    server_name _;
    ssl_certificate /config/keys/cert.crt;
    ssl_certificate_key /config/keys/cert.key;

    # Add headers to serve security related headers
    # Before enabling Strict-Transport-Security headers please read into this
    # topic first.
    add_header Strict-Transport-Security "max-age=15768000; includeSubDomains; preload;" always;
    #
    # WARNING: Only add the preload option once you read about
    # the consequences in https://hstspreload.org/. This option
    # will add the domain to a hardcoded list that is shipped
    # in all major browsers and getting removed from this list
    # could take several months.

    add_header X-Content-Type-Options nosniff;
    add_header X-XSS-Protection "1; mode=block";
    add_header X-Robots-Tag none;
    add_header X-Download-Options noopen;
    add_header X-Frame-Options "SAMEORIGIN";
    add_header X-Permitted-Cross-Domain-Policies none;
    add_header Referrer-Policy no-referrer;
    fastcgi_hide_header X-Powered-By;
    root /config/www/nextcloud/;
    # display real ip in nginx logs when connected through reverse proxy via docker network
    set_real_ip_from 172.0.0.0/8;
    real_ip_header X-Forwarded-For;
    location = /robots.txt {
        allow all;
        log_not_found off;
        access_log off;
    }
    location = /.well-known/carddav {
      return 301 $scheme://$host:444/remote.php/dav;
    }
    location = /.well-known/caldav {
      return 301 $scheme://$host:444/remote.php/dav;
    }
    location = /.well-known/webfinger {
      return 301 $scheme://$host:444/public.php?service=webfinger;
    }
    location = /.well-known/host-meta {
      return 301 $scheme://$host:444/public.php?service=host-meta;
    }
    location = /.well-known/host-meta.json {
      return 301 $scheme://$host:444/public.php?service=host-meta-json;
    }
    client_max_body_size 10G;
    fastcgi_buffers 64 4K;
    gzip on;
    gzip_vary on;
    gzip_comp_level 4;
    gzip_min_length 256;
    gzip_proxied expired no-cache no-store private no_last_modified no_etag auth;
    gzip_types application/atom+xml application/javascript application/json application/ld+json application/manifest+json application/rss+xml application/vnd.geo+json application/vnd.ms-fontobject application/x-font-ttf application/x-web-app-manifest+json application/xhtml+xml application/xml font/opentype image/bmp image/svg+xml image/x-icon text/cache-manifest text/css text/plain text/vcard text/vnd.rim.location.xloc text/vtt text/x-component text/x-cross-domain-policy;
    location / {
        rewrite ^ /index.php;
    }
    location ~ ^\/(?:build|tests|config|lib|3rdparty|templates|data)\/ {
        deny all;
    }
    location ~ ^\/(?:\.|autotest|occ|issue|indie|db_|console) {
        deny all;
    }
    location ~ ^\/(?:index|remote|public|cron|core\/ajax\/update|status|ocs\/v[12]|updater\/.+|oc[ms]-provider\/.+|.+\/richdocumentscode\/proxy)\.php(?:$|\/) {
        fastcgi_split_path_info ^(.+?\.php)(\/.*|)$;
        set $path_info $fastcgi_path_info;
        try_files $fastcgi_script_name =404;
        include /etc/nginx/fastcgi_params;
        fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
        fastcgi_param PATH_INFO $path_info;
        fastcgi_param HTTPS on;
        fastcgi_param modHeadersAvailable true;
        fastcgi_param front_controller_active true;
        fastcgi_pass php-handler;
        fastcgi_intercept_errors on;
        fastcgi_request_buffering off;
    }
    location ~ ^\/(?:updater|oc[ms]-provider)(?:$|\/) {
        try_files $uri/ =404;
        index index.php;
    }
    location ~ \.(?:css|js|woff2?|svg|gif|map)$ {
        try_files $uri /index.php$request_uri;
        add_header Cache-Control "public, max-age=15778463";
        # Add headers to serve security related headers
        # Before enabling Strict-Transport-Security headers please read into this
        # topic first.
        #add_header Strict-Transport-Security "max-age=15768000; includeSubDomains; preload;" always;
        #
        # WARNING: Only add the preload option once you read about
        # the consequences in
https://hstspreload.org/. This option
        # will add the domain to a hardcoded list that is shipped
        # in all major browsers and getting removed from this list
        # could take several months.
        add_header X-Content-Type-Options nosniff;
        add_header X-XSS-Protection "1; mode=block";
        add_header X-Robots-Tag none;
        add_header X-Download-Options noopen;
        add_header X-Frame-Options "SAMEORIGIN";
        add_header X-Permitted-Cross-Domain-Policies none;
        add_header Referrer-Policy no-referrer;
        access_log off;
    }
    location ~ \.(?:png|html|ttf|ico|jpg|jpeg|bcmap|mp4|webm)$ {
        try_files $uri /index.php$request_uri;
        access_log off;
    }
}

 

What i must do/modify to make this messages disappear?

 

i have already tried to add this but it doesn't work:

 

location ^~ /.well-known {

       location = /.well-known/carddav { return 301 /remote.php/dav/; }

       location = /.well-known/caldav { return 301 /remote.php/dav/; }

       location = /.well-known/webfinger { return 301 /index.php$uri; }

       location ^~ /.well-known { return 301 /index.php$uri; }

 

       try_files $uri $uri/ =404;

       }

 

Thanks in advance to anyone who wants to help me!

 

Zippi

 

Link to comment

Hi guys,

 

i performed an updated from v21.0.3 to v22.1.0 RC1 and when i wanted to finish the update with the web based updater, i got this message and i can't access NC anymore. Does anybody have an idea?

 

 

Bildschirmfoto 2021-08-07 um 14.22.49.png

Link to comment
44 minutes ago, parazit said:

Hi guys,

 

i performed an updated from v21.0.3 to v22.1.0 RC1 and when i wanted to finish the update with the web based updater, i got this message and i can't access NC anymore. Does anybody have an idea?

 

 

Bildschirmfoto 2021-08-07 um 14.22.49.png

Most of the time this error comes because of a broken or not started database.
Start there

Link to comment

I'm not sure what is going on. I have uninstalled and reinstalled many times. I'm getting this error when trying to complete the setup.

 

I'm new to this. I have followed all the directions and I can't seem to get around this. Please can someone help me out.

 

Thanks

Capture.PNG

Link to comment
I'm not sure what is going on. I have uninstalled and reinstalled many times. I'm getting this error when trying to complete the setup.
 
I'm new to this. I have followed all the directions and I can't seem to get around this. Please can someone help me out.
 
Thanks
Capture.PNG.3d8588c342e6bb790687f5282b2fafde.PNG
Well, as the message says,
It is cannot connect to the database,
the dburl is wrong and/or you didn't provide a password

Sent from my Mi 10 Pro using Tapatalk

Link to comment

I'm not sure what to do now. I have tried done everything in this video correct.
 

Login to your MariaDB:

mysql -u root -p

Create user:

CREATE USER ‘nextcloud’ IDENTIFIED BY 'lfco2659';

CREATE DATABASE IF NOT EXISTS nextcloud;

 

GRANT ALL PRIVILEGES ON nextcloud.* to ‘nextcloud’ IDENTIFIED BY 'lfco2659';

quit

 

 

Any ideas?

Capture.PNG

Link to comment
I'm not sure what to do now. I have tried done everything in this video correct.
 
Login to your MariaDB:
mysql -u root -p
Create user:
CREATE USER ‘nextcloud’ IDENTIFIED BY 'lfco2659';
CREATE DATABASE IF NOT EXISTS nextcloud;
 
GRANT ALL PRIVILEGES ON nextcloud.* to ‘nextcloud’ IDENTIFIED BY 'lfco2659';
quit
 
 
Any ideas?
Capture.PNG.9bd2409c1f0cc9173491ea2a0bc72a9f.PNG
How does the docker template looks for nextcloud and msriadb?

Sent from my Mi 10 Pro using Tapatalk

Link to comment
I'm not sure what to do now. I have tried done everything in this video correct.
 
Login to your MariaDB:
mysql -u root -p
Create user:
CREATE USER ‘nextcloud’ IDENTIFIED BY 'lfco2659';
CREATE DATABASE IF NOT EXISTS nextcloud;
 
GRANT ALL PRIVILEGES ON nextcloud.* to ‘nextcloud’ IDENTIFIED BY 'lfco2659';
quit
 
 
Any ideas?
Capture.PNG.9bd2409c1f0cc9173491ea2a0bc72a9f.PNG
Actually here shows that username or password is not correct, "access denied"

Send a photo when you fill the mysql form on nextcloud install wizard

Sent from my Mi 10 Pro using Tapatalk

Link to comment
4 minutes ago, skois said:

Actually here shows that username or password is not correct, "access denied"

Send a photo when you fill the mysql form on nextcloud install wizard

Sent from my Mi 10 Pro using Tapatalk
 

Here it is 

Capture.PNG

Link to comment
Here it is 
Capture.PNG.5b4a3c043512f0f07458765396436c2d.PNG
Ok, this looks fine, try continuing, if it fails again,
I THINK I saw somewhere, latest mariadb have some issues with nextcloud. So maybe trying an older mariadb docker tag, or use postgres

Sent from my Mi 10 Pro using Tapatalk

Link to comment
2 minutes ago, skois said:

Ok, this looks fine, try continuing, if it fails again,
I THINK I saw somewhere, latest mariadb have some issues with nextcloud. So maybe trying an older mariadb docker tag, or use postgres

Sent from my Mi 10 Pro using Tapatalk
 

Still no go.

 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.