Jump to content
Djoss

[Support] Djoss - MakeMKV

523 posts in this topic Last Reply

Recommended Posts

11 hours ago, Balpaugh said:

Thank you Djoss. I probably looked at it a hundred times and didn't notice that the output was defaulting to /storage and not /output. as soon as i changed it, it appears to work. Now the question is why does the output file location default to /storage and not /output?

It should default to /output.  Did you had the issue after a fresh install?

Share this post


Link to post
2 hours ago, Balpaugh said:

yes, a couple of fresh installs. Each time in defaults back to storage.

Screen Shot 2018-08-07 at 8.39.31 PM.png

 

What are your MakeMKV settings under the General tab?

Share this post


Link to post

I just can't seem to get this to work. Haven't been able to successfully read a create a backup from a dvd or bluray.

And, every time I stop the docker it won't restart. If I stop the container, I have to remove and reinstall.

 

2018-08-09.png

2018-08-09 (1).png

MakeMKV.log

Share this post


Link to post
20 hours ago, Encino Stan said:

I just can't seem to get this to work. Haven't been able to successfully read a create a backup from a dvd or bluray.

And, every time I stop the docker it won't restart. If I stop the container, I have to remove and reinstall.

 

2018-08-09.png

2018-08-09 (1).png

MakeMKV.log

When you get "Execution error" exactly?

Share this post


Link to post
3 hours ago, Djoss said:

Also, is your cache pool full?

Cache has 298 GB free. I do see the SSD drive lights flashing when running the program.

I was going to say that Execution Error occurs as soon as restarting container, but just now started fine.

I am going to try another DVD and report what it does...

 

.. OK. Read the DVD and selected just main title and only english audio and subtitles. 2018-08-10_1.png 

2018-08-10_1.thumb.png.16451aaa09f5fae5c5e660954134c5ca.png

 

.. click the Make MKV button and get error.  2018-08-10_2.png 

 

2018-08-10_2.thumb.png.c6c8b387b517079ed7685fc9816c83f6.png

Edited by Encino Stan

Share this post


Link to post

Thanks for this useful docker.  I've just realised after several rips that it wasn't defaulting to selecting all audiostreams so I've missed my TrueHD streams on several rips ?  Is there a way to to set this?

 

Thanks

Share this post


Link to post
3 hours ago, DZMM said:

Thanks for this useful docker.  I've just realised after several rips that it wasn't defaulting to selecting all audiostreams so I've missed my TrueHD streams on several rips ?  Is there a way to to set this?

 

Thanks

 

You set it in advanced settings under default settings rule, but you need to read a little bit about how it works. I'll post mine, but need to go on a computer first. 

 

 

Share this post


Link to post
On 8/10/2018 at 6:46 AM, Encino Stan said:

I just can't seem to get this to work. Haven't been able to successfully read a create a backup from a dvd or bluray.

And, every time I stop the docker it won't restart. If I stop the container, I have to remove and reinstall.

 

2018-08-09.png

2018-08-09 (1).png

MakeMKV.log

 

This usually happens when you have used a port that is already in use. 

Share this post


Link to post
1 hour ago, saarg said:

 

You set it in advanced settings under default settings rule, but you need to read a little bit about how it works. I'll post mine, but need to go on a computer first. 

 

 

Thanks - I've started googling but there seems to be a lot to it.  I'll wait to see your profile to see if there are other items in there.

Share this post


Link to post
5 hours ago, DZMM said:

Thanks - I've started googling but there seems to be a lot to it.  I'll wait to see your profile to see if there are other items in there.

 

This is what I have. This chooses the lossless tracks in English, MVC track if available, and subtitles in Norwegian and English.

Core is the DTS/Dolby x.1 tracks inside the HD tracks.

 

-sel:all,+sel:(lossless&eng|nor|core&eng|nor),-sel:(stereo|mono),+sel:mvcvideo,+sel:(subtitle&eng|nor)

 

Share this post


Link to post
On 8/5/2018 at 8:48 PM, Djoss said:

 

"--device /dev/sr0 --device /dev/sg3" are the correct parameters to use.  Do you have other containers/applications that see the content of disc with the same drive?

 

To check if the issue is related to the latest update, you can try to revert to the previous version of the container:  change the "Repository" in container's settings to "jlesage/makemkv:v1.9.0".

 

I passed through the drive to handbrake and it behaves exactly the same way. No title. I tried rolling back the version but it still reports using the new one, is there anything to do besides changing the repository line and restarting the container?

 

On 8/5/2018 at 7:57 PM, Balpaugh said:

Hello. It can see the drives without issue but when it goes to start the decryption, it errors because it cannot create the directories.

 

It certainly seems that way, although there is nothing in the logs that would indicate that. I don't recall having to grant special permissions during the install, where would one do that? 

Share this post


Link to post
15 minutes ago, Tergo247 said:

No title. I tried rolling back the version but it still reports using the new one

You are talking about the MakeMKV version?  Which version do you see?

 

15 minutes ago, Tergo247 said:

is there anything to do besides changing the repository line and restarting the container?

No, changing the repository and applying the settings are the only things required.  To container will be restarting during the process.

 

17 minutes ago, Tergo247 said:

It certainly seems that way, although there is nothing in the logs that would indicate that. I don't recall having to grant special permissions during the install, where would one do that? 

You just need to make sure that files are written under /output (not /storage, which is read-only).

 

Does your disc container only short titles?  Maybe it's the reason you see no one?  Check the "Minimum title length" option in MakeMKV preferences.

Share this post


Link to post

I see v1.12.2 in MakeMKV. If I add :v1.9.0 to the repository line and force the update, it seems to install that version but the about page in the gui shows otherwise. If I understand you correctly, I do have it set to only rip titles more than an hour and a half long, but in my experience it will still see all the titles on the disc regardless of that setting. It just won't bother to rip in the short ones. My output directory is definitely different from the storage directory.

 

Thanks for the snappy assistance Djoss. Hopefully we're nearing the cause, even if that means buying a new optical drive.

Edited by Tergo247
Clarification.

Share this post


Link to post
7 hours ago, Djoss said:

To customize the profile like you want, see https://www.makemkv.com/forum2/viewtopic.php?f=10&t=4386#p17399

Thanks @saarg for the example and @Djoss for the link. I've gone with

 

-sel:all,+sel:(favlang|nolang|single),-sel:mvcvideo,=100:all,-10:favlang

I didn't really understand what -sel:(havemulti|havecore) was doing, particularly havecore but I've removed it as I'm hoping plex will know which track to select if I'm say using a laptop rather than transcoding.  I'm ditching mvcvideo as I don't have any 3D content

Share this post


Link to post
1 hour ago, DZMM said:

Thanks @saarg for the example and @Djoss for the link. I've gone with

 


-sel:all,+sel:(favlang|nolang|single),-sel:mvcvideo,=100:all,-10:favlang

I didn't really understand what -sel:(havemulti|havecore) was doing, particularly havecore but I've removed it as I'm hoping plex will know which track to select if I'm say using a laptop rather than transcoding.  I'm ditching mvcvideo as I don't have any 3D content

 

Which audio tracks does that choose? Everything? 

 

Share this post


Link to post

it should select all the english, or when no language is set, or when just a single language (e.g. foreign disk) and not the mvcvideo - I haven't tested yet

Edited by DZMM

Share this post


Link to post
1 hour ago, DZMM said:

it should select all the english, or when no language is set, or when just a single language (e.g. foreign disk) and not the mvcvideo - I haven't tested yet

 

So you want all tracks in English. I thought you just wanted the True HD/ DTS HD-MA tracks.

Share this post


Link to post
35 minutes ago, saarg said:

 

So you want all tracks in English. I thought you just wanted the True HD/ DTS HD-MA tracks.

I'm playing it safe for now and letting Plex decide which one to use, as I have lots of different clients connecting.  HDD space isn't an issue for me

Share this post


Link to post
22 hours ago, Tergo247 said:

I see v1.12.2 in MakeMKV. If I add :v1.9.0 to the repository line and force the update, it seems to install that version but the about page in the gui shows otherwise

Note that there are 2 different versions: v1.12.2 is the version of MakeMKV while v1.9.0 is the version of the container image. The latest MakeMKV version is 1.12.3 and it has been introduced in container image v1.9.1.

 

22 hours ago, Tergo247 said:

If I understand you correctly, I do have it set to only rip titles more than an hour and a half long, but in my experience it will still see all the titles on the disc regardless of that setting.

I don't know if the behavior changed, but the setting had an impact on the displayed titles for a DVD I wanted to rip recently.  I would try to change the setting to 1 second just to see if some titles will appear.

Share this post


Link to post

Here is my MakeMKV settings. The output folder appears to be set correctly, however it continually defaults to the storage directly forcing me to manually change it to the output.

Screen Shot 2018-08-13 at 9.27.24 AM.png

Share this post


Link to post
4 minutes ago, Balpaugh said:

Here is my MakeMKV settings. The output folder appears to be set correctly, however it continually defaults to the storage directly forcing me to manually change it to the output.

Screen Shot 2018-08-13 at 9.27.24 AM.png

 

Sorry I meant the settings of MakeMKV itself (inside the UI), not the settings of the container.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.