6.7.0 Slow SMB Download Throughput

Recommended Posts

I recently upgraded to Unraid 6.7.0, and I'm suddenly seeing poor throughput when downloading files from the server through SMB from a Macbook Pro running Windows 10 and connected through 5 GHz WiFi. I usually get around 300-500 Mb/s, but on 6.7.0, it peaks at around 6 Mb/s. Connecting via Ethernet doesn't have this issue. Uploading files to the server through SMB doesn't have this issue. Downloading files via SFTP doesn't have this issue, either. Oddly enough, it works fine when booted into macOS and connecting through SMB.


Rolling back to 6.6.7 restores the fast SMB throughput I was seeing before the upgrade. Any idea why this is happening?


  • Like 2
Link to comment

Hi there,


This is a very weird issue you're having and not sure how we can go about recreating it or why this would be a problem in the first place or how Unraid would be causing it.  Just to confirm, this is the scenario:


 - You have Windows 10 installed on a Macbook Pro connected to your network via WiFi

 - Prior to 6.7, you would be able to copy files over the network to this device at 300-500 mbps

 - After 6.7, you are limited to 6 mbps

 - This behavior does exhibit itself on any other devices, wired or wireless, nor does it happen on the same device when booted into Mac OS


First question would be if you use another wireless device with Windows (on non-Mac hardware), what happens?

  • Like 1
Link to comment
On 5/31/2019 at 5:39 PM, Silverbolt said:

Any other thoughts on what's happening or ideas on how to troubleshoot this issue?

Long shot, but just curious.  If you right click on Windows icon and go to Settings -> Network & Internet -> Change Adapter Options and double click your Wifi connection, what is your speed listed as?


I lost power last week for a few days, and lost some router configs, and my channel width was all set back to 20 MHz and I was connecting in at 72 Mbps on some devices.


Link to comment

Adding my findings to the list as I think I'm having this same issue....

  1. Upload speed doesn't seem to be affected, my uploads are 3 x the speed of my downloads across the same network connection, which suggests it's not a network issue.
  2. From any VM (Windows 10 and lubuntu) on the unraid server there's no degradation in read performance from the unraid share
  3. If I read from a windows share inside the windows VM across the network there is no degradation of performance, which rules out a network issue

So that backs up the theory that it's an SMB issue, but doesn't seem to affect the "network adapter" being used by the VMs 🤨

Link to comment

There are some LAN speed testing programs out there.  I have used one of them is the distant past.  (  LAN speed test   on Google will find them for you. I believe I used the one from TutoSoft.)  You will want to bypass using your cache drive by setting up a special "test" share that does not use cache as a part of your testing.  Make sure that you generate a very large file (>10GB) when you test as you don't want to be measuring the transfer speed to and from the RAM buffer. 


Speaking from a personal experience, finding the solution to these types of problems is a tough nut to crack.  In my case, I found out that I was using an outdated RealTek NIC MB driver on a Win7 computer.  Updating the driver with the latest driver release from the MB manufacturer fixed the problem.  

Link to comment

It's not a network issue, I used LAN speed test for my initial investigations. I have no cache drive so no problems there. As a work around for my particular issue, I moved from using Plex on docker, which was giving me read speeds of 8Mbps, resulting in choppy playback, to putting it on a VM, which as I said above has no such performance issues, and now I am getting 40+Mbps and no more chop. Note that this is the exact same physical machine,  physical network card and physical network. As I said before, Windows and Linux VMs perform brilliantly, it's only trying to access the share from the unraid itself or from inside a docker that's got problems.

It's a fairly fundamental problem for anyone with this issue, I could get around it by mounting all my shares through a VM but I don't want to have to do that, so I hope it's being looked into

Link to comment

Similar experience with poor SMB performance, especially simultaneous read/write performance.

Does not appear to be network, as iperf and rsync run at gigabit.

Tested a Windows Server 2019 VM running on same Unraid server, get much better SMB performance.

See test details and results at the end of this post:




Link to comment
  • 3 weeks later...

So, I messed around with Windows networking settings, and I was able to get better throughput by enabling TCP timestamps with this PowerShell command: Set-NetTCPSetting -SettingName Internet -Timestamps Enabled

You probably need to reboot for it to take effect.


I have no idea why this worked or why I didn't need it enabled with 6.6.7, so I have no idea if it will work for anybody else. It would be nice if someone could find the real reason for this issue, but I'm at least glad that I have normal throughput on my Windows machines again.

  • Like 1
Link to comment
  • 1 month later...
  • 4 months later...


i have a very similar problem with a share over SMB. If i map a network drive in Windows 10, the speed is very slow when i download something from the share.

I had no problems on the same machine, running Windows 7 with network shares. I switched to Unraid and created some shares for SMB with the same files as i had in Windows 7, but the speed is mostly 10-20 times slower than before.

To check that everything is OK with the network, i've created a VM with Windows 7 on my Unraid server and created a network share where i copied all the files from the Unraid share into, and voila - the speed is the same as before!


Can anyone explain, why the speed of a network share is faster in a VM on Unraid than directly on the array?


Thank you!

Link to comment
  • 5 weeks later...

I was having the same problem but @Silverbolt's solution fixed it.  Thanks @Silverbolt!!  +10


UPDATE:  Argh, I was wrong.  May be a caching thing - I saw normal performance and assumed it was fixed and canceled the copy.  And posted the above.  Then I restarted the copy and it was normal until the cancel-point, when transfer rate dropped to the 5MB/s I'm seeing.  Which sucks.  Did anyone ever figure out a fix?  Do I need to roll back to 6.6.x?



Edited by Dav3
Link to comment

Yeah, I spent about three hours trying to troubleshoot the issue late last night.  Results were inconsistent and contradictory so I decided not to bring it up here, just live with it with the hope it resolves or roll-back to 6.7 in in desperation. 🤷‍♂️


Paying for those three hours of lost sleeep today.  Hope the gurus figure it out.  I'm kinda done losing sleep over the stuff.


Link to comment
  • 1 month later...

Any updates? SMB has been pretty useless for me since the update.  I have a windows vm doing background copies overnight and they havent worked since that update.  Times out it seems like, then reconnects and times out again, very odd.  Just checking this thread for updates as I have similar issues.

Link to comment
  • 1 month later...
  • 2 weeks later...

Just replying here to share that Silverbolt's Set-NetTCPSetting -SettingName Internet -Timestamps Enabled also fixed my slow transfer speed issue.


More info here: 



Anyone know why this is suddenly fixing transfer speed issues?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.