[Support] ich777 - Application Dockers


ich777

Recommended Posts

I've recently been getting the following error when I try to connect to Privado VPN.

 

Quote

Tue Dec 28 11:09:54 2021 Restart pause, 300 second(s)
Tue Dec 28 11:14:54 2021 TCP/UDP: Preserving recently used remote address: [AF_INET]23.19.225.111:1194
Tue Dec 28 11:14:54 2021 TCP/UDP: Preserving recently used remote address: [AF_INET]23.19.225.111:1194
Tue Dec 28 11:14:54 2021 Socket Buffers: R=[212992->212992] S=[212992->212992]
Tue Dec 28 11:14:54 2021 UDP link local: (not bound)
Tue Dec 28 11:14:54 2021 UDP link remote: [AF_INET]23.19.225.111:1194
Tue Dec 28 11:15:54 2021 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Tue Dec 28 11:15:54 2021 TLS Error: TLS handshake failed

Prior to this everything has been running fine.

 

I don't recall any changes I've made.

 

Ideas?

 

thanks

david

Link to comment
3 hours ago, MasterDraco said:

i have installed Enpass on my unraid server but when connecting to it, it asks for a master password ?

what is this password or how do i set it ?

I don't know your password... if you've installed it for the first time it should ask you to create one, if you've imported one you have to enter your password.

Link to comment
20 minutes ago, lovingHDTV said:

Tue Dec 28 11:15:54 2021 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Tue Dec 28 11:15:54 2021 TLS Error: TLS handshake failed

This seems like a network related issue...

 

Do you run PiHole somewhere in your network? Maybe specify a static DNS in the template at the Extra Parameters (with Advanced View turned on):

--dns=8.8.8.8

Or something similar.

Link to comment
26 minutes ago, lovingHDTV said:

I've recently been getting the following error when I try to connect to Privado VPN.

 

Prior to this everything has been running fine.

 

I don't recall any changes I've made.

 

Ideas?

 

thanks

david

Looks like this is a known issue.  Privado requires v2.5

 

Upgrade openvpn to 2.5.x to manage data-ciphers options · Issue #392 · dperson/openvpn-client (github.com)

 

david

Link to comment
7 minutes ago, ich777 said:

This seems like a network related issue...

 

Do you run PiHole somewhere in your network? Maybe specify a static DNS in the template at the Extra Parameters (with Advanced View turned on):

--dns=8.8.8.8

Or something similar.

I do have piHole, but already have the extra paramenters.

 

I think it is because data-ciphers are now required.  I commented those lines out, but think that is probably the issue.

 

thanks

Link to comment
28 minutes ago, lovingHDTV said:

I think it is because data-ciphers are now required.  I commented those lines out, but think that is probably the issue.

In your case I don't think so, this was already reported a few days back and there was actually the error with the cypher but in your case I don't think thats the issue here.

Link to comment

OK I'll start from the beginning.

 

When I load the opvn setup file from my VPN provider (Privado)  I get:

 

+ exec sg vpn -c 'openvpn --cd /vpn --config /vpn/jfk-032.ovpn --script-security 2 --redirect-gateway def1 --auth-user-pass /vpn/vpn.auth '
Options error: Unrecognized option or missing or extra parameter(s) in /vpn/jfk-032.ovpn:24: data-ciphers (2.4.9).  Here is the header part of the opvn file.  I added the vpn.auth portion only.

 

client
dev tun
#dev-node "PrivadoVPN (OpenVPN)"
proto udp
remote jfk-032.vpn.privado.io 1194
resolv-retry infinite
nobind
persist-key
persist-tun
persist-remote-ip

verify-x509-name jfk-032.vpn.privado.io name

tls-client

#block-outside-dns
route-ipv6 ::/0
route 0.0.0.0 0.0.0.0 vpn_gateway
tls-cipher TLS-DHE-RSA-WITH-AES-256-CBC-SHA:TLS-DHE-DSS-WITH-AES-256-CBC-SHA:TLS-RSA-WITH-AES-256-CBC-SHA
remote-cert-tls server
auth-user-pass vpn.auth
verb 3
auth SHA256
data-ciphers AES-256-CBC
data-ciphers-fallback AES-256-CBC
route-delay 3

 

From what I've read (not an expert at all), it means I have to run version 2.5 client.

Edited by lovingHDTV
Link to comment
1 hour ago, lovingHDTV said:

OK I'll start from the beginning.

All clear, I've also pointed another user to the Github issue that you've linked, if no one responds to the Github Issue feel free to contact me again next week and I will look into it, maybe I'll fork the container and see if I can get it running again with OpenVPN v2.5+

 

The strange thing to me is that when you changed nothing the container shouldn't stop to work.

 

Another user reported already after he changed the vpn.ovpn file that it won't work anymore:

Link to comment

I want to use Krusader to move files from a previous unRAID server to a new unRAID server.  I have the remote drives mounted under the web UI in unRAID and I can see them in a bash prompt at /mnt/remotes.  How do I get these to show  up in Krusader?

 

Or is there a better way to transfer large amounts of data?

Link to comment
37 minutes ago, wayner said:

How do I get these to show  up in Krusader?

Add a path like this in the template for Kursader:

grafik.thumb.png.d337099110ab563f2b16bf8b9726976a.png

 

You will then find it in the folder /mnt/remotes in Krusader.

 

38 minutes ago, wayner said:

Or is there a better way to transfer large amounts of data?

You can sync it with luckyBackup too but I think Krusader is way easier to do.

Link to comment

Having a little trouble getting the Thunderbird docker to work.  I have it setup like so:

 

I get the following output in the log:

 

---Checking if UID: 99 matches user---
usermod: no changes
---Checking if GID: 100 matches user---
usermod: no changes
---Setting umask to 000---
---Checking for optional scripts---
---No optional script found, continuing---
---Checking configuration for noVNC---
Nothing to do, noVNC resizing set to default
Nothing to do, noVNC qaulity set to default
Nothing to do, noVNC compression set to default
---Starting...---
---Version Check---
---Thunderbird v91.4.1 up-to-date---
---Preparing Server---
---Resolution check---
---Checking for old logfiles---
---Checking for old display lock files---
---Starting TurboVNC server---
---Starting Fluxbox---
---Starting noVNC server---
WebSocket server settings:
- Listen on :8080
- Web server. Web root: /usr/share/novnc
- No SSL/TLS support (no cert file)
- Backgrounding (daemon)
---Starting Thunderbird---
[GFX1-]: glxtest: libpci missing
[GFX1-]: glxtest: libEGL missing

(thunderbird:105): GLib-GIO-WARNING **: 17:30:21.927: Failed to execute child process “update-desktop-database” (No such file or directory)

 

image.png

Link to comment
6 hours ago, ColeBrodine said:

I get the following output in the log:

The log putput looks good.

These messages are just warnings since there is no HW acceleration in the container available and I doesn't ship the libraries for that to keep the container as small as possible, but that won't stop the container from working.

I use the Thunderbird container on a daily basis.

 

Do you get an error message when connecting to noVNC? If yes, please post a screenshot.

Have you yet tried to empty the browser cache?

Link to comment
On 12/30/2021 at 12:16 AM, ich777 said:

The log putput looks good.

These messages are just warnings since there is no HW acceleration in the container available and I doesn't ship the libraries for that to keep the container as small as possible, but that won't stop the container from working.

I use the Thunderbird container on a daily basis.

 

Do you get an error message when connecting to noVNC? If yes, please post a screenshot.

Have you yet tried to empty the browser cache?

 

I'm an idiot! I just tried the WebGUI and it worked. I was trying to connect with a VNC client.  Thanks!

  • Like 1
Link to comment
6 hours ago, wayner said:

Any suggestions on what tool to use to keep files on multiple machines synched?  I see both DirSyncPro and LuckyBackup are maintained by ich777.   Do they both do the same thing or are there differences?

They do the same things and have both a "schedule" engine where DirSyncPro is a little more advanced in managing everything through the GUI but is more resource hungry when syncing lots of data (sometimes 5 to 6 GB) where luckyBackup is not that far in terms of managing "everything" through the GUI but is a lot more efficient, uses very little resources has built in SSH support for SFTP file transfers but also comes with some caveats when using the "schedule" engine (only console mode is working properly and you have to restart the container to see the last synchronizations in the logs from luckyBackup).

Link to comment

Apologies, but I just installed DirSyncPro and when I tried to set the noVNC password using the process described in the Recommended Post at the beginning of this topic I get a "Cannot write password file /dirsyncpro/.vnc/passwd" error and a password never appears to get set.  Anyone have an idea as to why this is occuring, and how to allow that file to be created?

 

Edit: I figured out that you need to actually manually create a .vnc folder in the dirsyncpro folder in appdata for the file to be properly written, but for some reason there is still not a required password to use the WebGUI.  I made sure I had the TURBOVNC_PARAMS variable created and restarted the docker but nothing is showing up.

Edited by Vitreous Humour
Additional Information
Link to comment
15 hours ago, Vitreous Humour said:

Edit: I figured out that you need to actually manually create a .vnc folder in the dirsyncpro folder in appdata for the file to be properly written, but for some reason there is still not a required password to use the WebGUI.  I made sure I had the TURBOVNC_PARAMS variable created and restarted the docker but nothing is showing up.

Can you please tell me the exact steps/commands that you've done?

Do you run DirSyncPro as root?

Link to comment
45 minutes ago, ich777 said:

Can you please tell me the exact steps/commands that you've done?

Do you run DirSyncPro as root?

 

Literally the exact instructions in your post.  

1. Opened the terminal by clicking console under DirSyncPro on the docker tab

2. Enter root by typing "su $USER" in the opened terminal

3. Executed password creation by typing "vncpasswd"

4. Put in 8 character password, twice

5. Edited the DirSyncPro settings to add a blank variable with "TURBOVNC_PARAMS" as the key.

6. Pressed apply to restart the container.

 

The only additional step is I had to create a .vnc folder in the DirSyncPro appdata folder, so that I wouldn't get a " password file couldn't be created" error after inputing the passwords after the vncpasswd command.

 

I'm assuming I'm running DirSyncPro as root when typing "su $USER", is there another way I should be running DirSyncPro as root?  I'm on the latest version of your DirSyncPro docker, since I just installed it.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.